IRC channel logs

2017-11-17.log

back to list of logs

<vagrantcish>how would i specify a tmpfs for /tmp ? it seems to require the device parameter, but there is no device.
<vagrantcish> (file-system
<vagrantcish> (mount-point "/tmp")
<vagrantcish> (type "tmpfs"))
<vagrantcish>??
<wigust>vagrantcish: Device basicaly is a first field in fstab man page. There is a note about "tmpfs" and other file systems with no storage.
<vagrantcish>sure, i know how to configure it in fstab ... but how to i configure it using: guix system reconfigure /etc/config.scm ?
<wigust>vagrantcish: Yes, by specifing (device "tmpfs") you will set a first field of fstab to "tmpfs".
<vagrantcish>ah, reading the info page for guix configuration didn't make that clear.
<vagrantcish>couldn't find mention of tmpfs
<wigust>vagrantcish: It says that device is a source file system. I think it will be too noisy to mention all of possible file systems in Guix manual. But maybe a link to fstab manual about first field will be good.
<vagrantcish>sure, impossible to enumerate all possible values
<vagrantcish>This names the “source” of the file system. By default it is
<vagrantcish> the name of a node under ‘/dev’, but its meaning depends on
<vagrantcish> the ‘title’ field described below.
<vagrantcish>in my case, it doesn't depend on the title field ... and it's not the name of a /dev node
<wigust>vagrantcish: Good catch about /dev node. Seems wrong to me too.
<vagrantcish>mostly a catch through failing :)
<wigust>vagrantcish: Maybe you want to send a patch to improve a documentation? :-)
<vagrantcish>ACTION hasn't yet found the source that magically handles tmpfs or other arbitrary conditions
<vagrantcish>i could document that it also magically works with "tmpfs" specified... but i suspect that doesn't document the general case
<vagrantcish>though (device "tmpfs") is certainly used in numerous places in the code
<vagrantcish>hmmm... xscreensaver doesn't include /etc/pam.d/xscreensaver ... what magic do i need to invoke to get that?
<vagrantcish>ACTION wonders if this is the same basic issue ng0 was having getting i3lock working
<wigust>vagrantcish: It should work for all devices as on others distroes editing fstab manually. At the end Guix just produce a fstab guix/gnu/services/base.scm http://paste.debian.net/996178 So you could specify any source device as manual says in "The first field" https://manpages.debian.org/stretch/mount/fstab.5.en.html
<vagrantcish>something created /etc/pam.d/xlock ... no idea what
<vagrantcish>so, the documentation is overly specific about what it does when it's not 'uuid or 'label
<vagrantcish>pretty much just blindly copies whatever you put in the field in that case
<wigust>As I see yes, but didn't follow deep this though.
<vagrantcish>ACTION experiments
<vagrantcish>wahahasurelythisisnotvalid /tmp tmpfs defaults
<vagrantcish>well, it pretty much seems to do no sanitizing :)
<vagrantcish>which is consistant with mount
<vagrantcish>allows me to call the "device" whatever i want
<vagrantcish>well, i guess that gives me an idea of what to write in the documentation.
***ghostbsd_cfec is now known as rat_riot
<civodul>Hello Guix!
<catonano>hey civodul
<efraim>hi!
<efraim>i got my printer working but I forgot to enable the cups web browser so now i'm trying to connect to the remote CUPS server through the CLI
<efraim>Might need cups-browsed and not just cupsd to make it work
<brendyn>My geiser repl has became extremely laggy after evaluating package.scm
<brendyn>and guile is using up heaps of cpu i wonder what it's doing
<civodul>efraim: i suppose you could stop the cups service and reconfigure?
<civodul>brendyn: the compiler makes the heap grow significantly
<civodul>so if you compile large files from the REPL, then you're in trouble
<brendyn>Can I get things like M-. to work without evaluating the whole file then?
<brendyn>I think it may be compile other stuff from the git repo.
<mb[m]1>I wonder if we could make the CVE linter also check all dependencies. It should bring more visibility to security issues, at the expense of becoming much slower.
<civodul>hey mb[m]1!
<civodul>mb[m]1: i'm not sure it's a good idea
<mb[m]1>Good :)
<mb[m]1>I kind of like being able to run `guix lint -c cve` on everything in a few seconds.
<mb[m]1>But was inspired by GitHubs security scans.
<mb[m]1>I guess a recursive CVE check is better suited for a third-party tool.
<civodul>maybe
<civodul>i was thinking of 'guix health', which would work recursively on the installed packages
<civodul>so if you have libtiff in your profile, it would report not only libtiff CVEs but also glibc CVEs :-)
<mb[m]1>Ooh.
<civodul>what do the GitHub security scans do?
<mb[m]1>They compare dependency files with the CVE database. So if you have a vulnerable library in "requirements.txt" it will give you a notice.
<mb[m]1>Mainly I wanted to brag on HN that Guix can do much better :P
<mb[m]1>A `guix health` command that could act on profiles would be great.
<civodul>yep
<civodul>well you can still brag on HN somehow ;-)
<civodul>mb[m]1, efraim: in other news i've restarted the failed core-updates jobs now that hydra runs a newer kernel
<efraim>Yay
<civodul>it still seems to be failing though
<efraim>Boo
<civodul>:-)
<civodul>oh it's acl: https://hydra.gnu.org/build/2349333/nixlog/5/raw
<civodul>the thing you fixed recently, efraim
<civodul>well maybe we need a new evaluation?
<efraim>Gah that stray python file
<efraim>S/python/perl
<efraim>Probably, the fix wasn't too bad in the end
<mb[m]1>Great, I'll start building core-updates as well this weekend. Sorry for going AWOL, had to heal a damaged tendon.
<civodul>mb[m]1: oh, i hope your tendons are healing and getting better!
<kmicu>M-x guix-doctor
<brendyn>kmicu: Your Doctor here. How may I be of assistance.
<kmicu>Sorry Doctor, I have no issues anymore; Mark H Weaver fixed them all in 6a71fa and f1e321 ;)
<brendyn>I'm actually ill myself. When I try to adjust screen brightness in GNOME, it pops up Authentication is required to run gsd-backlight-helper as super user, but then it fails to work
<cehteh>isnt that normal because DDC and other ways control the backlight are clusterfuck?
<ng0>I know we do not limit on the technical side what we include. I have some tools here, some are still in WIP (https://c.n0.is/ng0_guix/pen_packages/tree/hack/thegibson) most of them could be included in master in my opinion.
<ng0>or am I wrong?
<ng0>SET (social engineering toolkit) is still heavy WIP because upstream build-system sucks.
<bavier>ng0: those would be fine in master, imho
<ng0>So as long as malicious intent is not the only application it's okay.
<ng0>some software included in KALI dist or Blackarch dist have a lack of copyright, so eventually more will follow
<quiliro>hello
<quiliro>i get an error when posting to bugs-guix@guix.org
<quiliro>is it bugs-guix@gnu.org ?
<ng0>quiliro: was it you who wrote an respond to my email the troll 'willi uebelherr' responded to? or just coincidence in names?
<ng0>my spanish is just good enough to get the content but nothing more
<vagrantc>ng0: regarding your i3lock packaging, did you configure /etc/pam.d/i3lock ?
<ng0>vagrantc: marius responded and I'll apply fixes when I have the time
<vagrantc>ng0: cool
<ng0>*to do so
<ng0>*an response
<ng0>actually: a reply
<vagrantc>ACTION gets the jist
<ng0>today in: goodbye grammar
<vagrantc>ACTION has yet to find a working screen locker in guixsd
<vagrantc>or at least, they require some non-obvious configuration
<ng0>slock, xlockmore
<ng0>also gnome screensaver
<ng0>and xfce
<ng0>etc
<vagrantc>i tried xscreensaver, which sounded like it had the same issue you had with i3lock
<quiliro>ng0: what is wrong with willi?
<vagrantc>s,sounded,seemed
<vagrantc>ACTION guesses gnome/xfce screensavers are embedded in some other package
<quiliro>ng0: willi is sometimes rude but presents good issues
<vagrantc>ACTION hasn't seen slock
<ng0>quiliro: many things. actually many things to the level that they are currently looking into kicking him off fsfe lists for good
<brendyn>if i set an environment variable in the 'configure phase, will it still be available afterwards in the 'build phase?
<ng0>I'm not interested in conversation with someone who keeps CC'ing half the world.
<quiliro>ng0: i do not believe in censorship..even for the most rude behaivior
<rekado>sneek: later tell civodul I’m going to move more of python.scm elsewhere.
<sneek>Will do.
<quiliro>gotta go....i will be given a closet for free!
<ng0>if I choose not to talk with someone that'S not censorship but rather saving some of my time. But aside from that, we issued an updated invitation on gnunet.org
<quiliro>ng0: i agree with that part
<quigonjinn>brendyn: yes, it will be available
<quiliro>see you tomorrow
<quiliro>have a good time
<dogetest>is there another mirror beside hydra?
<bavier>dogetest: berlin.guixsd.org
<rekado>dogetest: nitpick: hydra is not a mirror, but a substitute server.
<rekado>berlin.guixsd.org is another substitute server providing its own binaries that it built on its own.
<bavier>ACTION used fuzzy matching
<dogetest>rekado: cool. is there a list so I could choose or pick the better? hydra is too slow
<dogetest>rtfm, sorry
<vagrantc>is mirror.hydra.gnu.org is a mirror?
<rekado>vagrantc: yes, it’s just nginx with a cache.
<rekado>dogetest: no, there’s no list
<dogetest>Ill try berlin
<rekado>dogetest: hydra is slow, but you can get most binaries from mirror.hydra.gnu.org and berlin.guixsd.org
<rekado>I’d just add both to the list of substitute servers that should be tried.
<dogetest>sorry, could you point me out to help?
<vagrantc>ACTION noticed that hydra.gnu.org is in north america, whereas mirror.hydra.gnu.org is in europe (as well as berlin.guixsd.org)
<vagrantc>is hydra.gnu.org slow enough that downloading from europe will still be faster?
<dogetest>where is this config?
<vagrantc>(faster presuming cross-continent downloads)
<wigust>dogetest: https://www.gnu.org/software/guix/manual/html_node/Base-Services.html#Base-Services in guix-configuration
<rekado>dogetest: it’s an argument to either the “guix” commands or the “guix-daemon”
<dogetest>--substitute-url
<rekado>if you’re using GuixSD it’s best to do this using “guix-configuration” as wigust points out
<rekado>vagrantc: people shouldn’t really talk to hydra.gnu.org directly, because that machine is swamped and rather unresponsive.
<dogetest>there isnt guix-configuration
<rekado>dogetest: where?
<dogetest>guixsd
<dogetest>the manual doesnt talk about it too
<vagrantc>ACTION ponders what it would take to set up another mirror in north america
<dogetest>how should I pass more then one url to --subtitute-url=url1,url2 ?
<bavier>dogetest: whitespace-separated string
<rekado>vagrantc: it shouldn’t be hard. The configuration file used for mirror.hydra.gnu.org is part of the guix-maintenance.git repo.
<bavier>dogetest: i.e. --substitute-urls="url1 url2 ..."
<rekado>dogetest: the manual talks about it. Have you looked at the link wigust provided?
<vagrantc>or would it make more sense to mirror berlin.guixsd.org ?
<rekado>this is not like apt mirrors
<rekado>the mirrors are just HTTP caches
<vagrantc>so any sort of proxy ought to work well?
<rekado>if there’s a cache miss the mirror server fetches the thing from the server
<vagrantc>caching proxy
<rekado>yes
<vagrantc>nice and simple
<ng0>vagrantc: mostly bandwidth and diskspace
<dogetest>so, Ive no option beside mirror.hydra.gnu.org ?
<vagrantc>which brings up the question ... how much?
<vagrantc>diskspace and bandwidth ... obviously you can set cache policy to throw away some when it runs out of space, but how much would a useful cache size be?
<vagrantc>for a public proxy?
<vagrantc>ACTION has some underutilized machines with reasonable bandwidth
<wigust>dogetest: You have an option berlin.guixsd.org besides mirror.hydra.gnu.org
<dogetest>im testing, hydra.gnu.org is the better until now
<dogetest>berlin is the slowest
<dogetest>for me
<janneke>o/
<wigust>janneke: \\o/
<janneke>wigust: :-)
<dogetest>:'( 60KB/s...
<rekado>dogetest: from where are you connecting?
<dogetest>brazil
<rekado>berlin.guixsd.org is in Germany.
<dogetest>Im using mirror.hydra
<vagrantc>also in germany
<dogetest>hydra.gnu equal mirro.hydra
<dogetest>for me
<jonsger>where is mirror.hyrda.gnu.org locateted? or is it build with multiple servers around the world?
<ng0>how do I switch to the tty in qemu?
<ng0>ah, got it
<dogetest>downloading xorg, is it a end's signal? xD
<ng0>whoever wanted i3lock-color + i3lock-fancy: I'm sending a third revision later tonight, i3lock-color works now, and i3lock-fancy only needs one last adjustment
<rekado>vagrantc: ^
<ng0>I've sent it now, I've reconsidered some ideas I had.
<rekado>got python.scm down to 698 packages
<rekado>I hope all this moving around of packages won’t make the core-updates merge too difficult
<ng0>wow
<ng0>how many loc is python.scm now? I remember it had several 10thousand
<rekado>12.2k now
<ng0>that's at least 50% less than before
<rekado>ludo did most of the work on that module.
<rekado>I just shaved off about 100 more packages.
<vagrantc>ng0: thanks for the work on i3lock*
<vagrantc>being new here, when you say you've sent a revision, where did it get sent to that i might find it and test it?
<ng0>guix-patches@gnu.org, the guix-patches debbugs
<ng0>one moment
<vagrantc>cool
<ng0> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27083
<ng0> https://debbugs.gnu.org/cgi/pkgreport.cgi?package=guix-patches
<ng0>but you can also use the branch from my guix repo
<ng0>if you want to apply it somehow
<vagrantc>ACTION found it before checking irc :)
<ng0> https://c.n0.is/ng0_guix/guix/ there's a branch with i3lock in the name
<civodul>rekado: thanks for your work on python.scm!
<sneek>civodul, you have 1 message.
<sneek>civodul, rekado says: I’m going to move more of python.scm elsewhere.
<civodul>heh :-)
<jonsger[m]>ng0: are you going to the 34C3?
<ng0>yes