IRC channel logs

2017-08-23.log

back to list of logs

<cbaines>The procedure is called bundle-package-to-store https://github.com/alphagov/govuk-guix/blob/master/gds/packages/utils/bundler.scm#L155
<cbaines>it works kinda like download-to-store, but runs bundle package
<cbaines>This approach is made feasible by bundler providing a way to do all the network access up front, using the bundler package command
<davexunit>interesting
<davexunit>not suited for upstream guix, but a very clever solution to the bundler problem
<davexunit>thanks for sharing
<cbaines>you're welcome
<CharlieBrown>Riot is an ugly but working replacement for Skype. How am I going to run it on the GNU system if IceCat, its only version of Firefox, deliberately got rid of WebRTC support?
<kmicu>CharlieBrown: how did you check that WebRTC has been removed?
<CharlieBrown>kmicu: riot throws and error and i saw ruben's note about it in an https://savannah.gnu.org/forum/forum.php?forum_id=8747
<CharlieBrown>it works in abrowser but not icecat
<kmicu>Ah, yes, WebRTC is modified to prevent leaks, not disabled. I see how “Disabled antifeatures: … WebRTC tunned…’ phrasing could suggest that WebRTC was removed. You could file a 1734th issue on https://github.com/vector-im/riot-web/issues to notify them that their app is buggy :P
<CharlieBrown>kmicu: they already say: we only support firefox,chrome
<CharlieBrown>Do I need to run GH's nonfree JS to submit issue?
<efraim>CharlieBrown: probably
<CharlieBrown>searching packages on the https://www.gnu.org/software/guix/packages/ is awkward and difficult
<efraim>grrr libxml2 https://lists.debian.org/msgid-search/e1dkngm-0003ds-76@seger.debian.org
<CharlieBrown>trying to find sip client
<buenouanq>CharlieBrown: $ guix package -s sip
<CharlieBrown>i cant do that on the website, and i dont have guix rn
<buenouanq>ah
<buenouanq>well, it looks like there's 3 options
<buenouanq>sipwitch, osip, and exosip
<CharlieBrown>sipwitch is no client
<CharlieBrown>osip is just a lib
<CharlieBrown>exosip is also just a lib
<insommiack>Hi guix! I have some trouble installing postgis because it tried to install files in postgresql path in the store and the access is denied
<insommiack>And postgis option --prefix doesn't work so i do not know what to do..
<efraim>you might need to write a patch to change some of the install directories
<efraim>good news is python?-libxml2 only has 78 dependants so that doesn't need to be grafted
<insommiack>efraim : thanks! do you have some documentation to help me to create a patch?
<efraim>insommiack: for writing the patch, I normally grab the source with `guix build foo -S', unpack it, cd into the directory, `git init; git add .; git commit -m "start" '
<efraim>and then i start working the patch from there
<efraim>after I have a patch i run `git format-patch -1 -o ~/', and then move the patch from ~/ to gnu/packages/patches/patch-name.patch and add it to the package definition
<efraim>only at the end when it seems to work do I bother adding it to gnu/local.mk
<insommiack>efraim : thanks a lot! I will try
<efraim>i'm guessing there's a more straightforward way, but that's what I've ended up with
<roptat>hi, how would I remove old system generations on guixsd?
<rekado>roptat: you need to delete the /var/guix/profiles/system-*-link files corresponding to older versions.
<rekado>that frees them up for garbage collection
<roptat>ok, thanks
<Hiroteru>Hi. I'm trying to mount a 'sshfs' filesystem using a system configuration file. but this doesn't work. When the generated systed is launched, it says "waiting for partition 'user@hostname:/' to appear..." and doesn't boot. (the file system definition http://paste.lisp.org/+7L9J)
<Hiroteru>I have no way to see what's in the `/etc/fstab` file, it seems to be created after the first boot :/
<cbaines>Hiroteru, can you get the system to boot by using a previous system generation?
<Hiroteru>cbaines: if I delete the part of code that tries to mount a sshfs, I can boot. (not sure this answers yout question ?)
<cbaines>The "I can boot" bit does
<cbaines>You could try setting the mount? option to #f, that might mean that the system starts, and then you can mount the filesystem afterwards
<cbaines>I think I remember something about there being ordering issues with filesystems requiring the network, which might be what you are encountering here...
<Hiroteru>Oh, lucky me ...
<Hiroteru>I'll try the `mount? #f` anyway, i can't believe i didn't think of it, thanks :-)
<rekado>I’m wondering if we can express both grafts and Pjotr’s no-root HPC hack as ‘post-processing’ steps.
<rekado>it would be nice if a user could specify reference rewrite hooks.
<rekado>I can’t think of another use case for this, but it would be very handy for non-root HPC deployment to a user-owned prefix.
<thomasd>only tangentially related: if a package requires multiple grafts, is this properly taken care of? i.e. if 2 inputs of package A need to be grafted, do we graft A -> A' -> A''? Or are all grafts applied in a single go?
<thomasd>because i've sometimes seen the same store item get grafted twice, to different output store items. (“grafting A->A'..”, “grafting A->A''”), and wondered if that was suspicious or not :)
<efraim>ludo did work a while back to make sure propagated inputs also got grafted, iirc
<efraim>as for your actual question, commit d4da602e4c28d704ee04ec57887fa14b134c7ebb sounds like it should only graft everything once
<efraim>so that together with c22a1324e64d6906be5e9a8e64b8716ad763434a for recursive grafts should take care of it
<thomasd>efraim: thanks
<thomasd>I wonder how the different grafts from a single package came about, will try to take a closer look next time I see them
<insommiack>Hi! I need for a command in the scheme of my package, the directory where the package will be build. There is a variable to get it?
<mekeor>insommiack: maybe we can better help you if you explain your general goal, e.g. by showing us the code you got so far?
<efraim>i'm having a hard time with the libxml2 CVEs if anyone wants to help, i'm getting an error during the test suite of libxml2/fixed. https://paste.pound-python.org/raw/ldAw4TfsrxG9Alvww7pP/
<efraim>sneek you're killing me
<efraim>come back!
<ng0>Hiroteru: could be that you need the sshmount thing I've been sitting out..
<ng0>package name: sshfs. ... or did someone else merge that in the last months?
<ng0>my egrep in guix source says no
<ng0>ah well we have sshfs-fuse in there
<ng0>but not sshfs.
<Hiroteru>I added the package sshfs-fuse
<ng0>I'll see when I can find time to test my sshfs package
<ng0>packages.git is not intended as a permanent place for it ;)
<Hiroteru>ok thanks
<ng0>eh.. oh
<ng0> https://github.com/libfuse/sshfs that's the same sshfs.
<ng0>I'll take a look at the differences
<ng0>you also want to take a look at past discussions regarding the ssh-daemon
<ng0>there we discussed some changes for sshfs specifically
<ng0>guix diff would be great.. guix diff package1 package2 .. it is total bolocks as it would be yet another git-or-guix command, but maybe I'll write that for myself :)
<Hiroteru>sure i'll look into in. first i looked my "/etc/fstab" file (with the option mount? #f) but it looked correct :/
<ng0>I don't see much of a difference. My description is longer (, doesn't start with "This"), and "I have a dependency on "openssh"
<ng0>we should get LiquidFeedback 3.1 packaged. Apparently it doesn't suck anymore :)
<ng0>or, I'll look into it
<ng0> http://www.interaktive-demokratie.org/news/2015/20151214-LiquidFeedback-3_1-for-democratic-software-and-product-development.en.html
<ng0>I've read an article a long time ago expressing what I thought about its use in software projects and its potential, to some degree.
<ng0>I never wrote anything public about it so far because some ideas need time and discussion with friends to shape them into texts people can eventually understand.
<ng0>efraim: are you okay with me adding more MATE packages to the Mate patch series, or should I wait until it is reviewed? I want to apply some corrections aswell, so that you have less work.
<ng0>I think I'd add 2 or 3 more depending on how much is needed to make the basic desktop more complete
<efraim>go ahead and do it, AFAIK I have time today
<efraim>ng0: ^
<rekado>insommiack: in build phases you can get the target directory through the “outputs” variable.
<rekado>insommiack: you need to capture it with (lambda* (#:key outputs #:allow-other-keys) …)
<rekado>insommiack: then you can refer to it in the build phase with “(assoc-ref outputs "out")” or any other output name. "out" is the default output for a package.
<ng0>ok
<ng0>Oh, of course I meant adding as in I still need to work on that.
<ng0>first I'll take a break, then I have some business to do and then I can work on it.
<ng0>couple of hours
<ng0>In general it is functional, I've been using it for a while now :)
<efraim>no problem, i'll take a look at some of the other patches for a bit
<ng0>yeah, it even accepts my keyboards volume controls :)
<ng0>does someone know how Mate packages are compatible to each other? I picked the 1.18.x series as it is the current stable. I think that .x is patch-release and therefore compatible to all packages in this series
<ng0>But we'd notice if something would be incompatible
<ng0>So I'll update the software I added there
<efraim>i assume the 1.18.x is compatable
<ng0>I understand glib-or-gtk build-system in the way that all my "glib:bin" in inputs are not necessary as it is added by the build-system already
<ng0>but that is just "build-inputs", not "inputs".
<ng0>yeah, it's not necessary
<rekado>looks like sklearn is broken
<rekado>that’s not good
<rekado>ACTION tries to fix it
<zacts>hi guix
<rekado_>the fix is to upgrade :-/
<Apteryx> zacts hi!
<Apteryx>I'm bringing up a 2nd GuixSD machine :)
<Apteryx>With raid0 btrfs. Gotta juice those old drives.
<Apteryx>Hmm. Small glitch: cannot find my 'my-root' label
<Apteryx>Any idea how I could instruct GuixSD to run "btrfs device scan" before attempting to mount the "my-root" label?
<efraim>well there's an obvious spot to check, see if gentoo can give me hints about building GHC for aarch64
<ng0>efraim: I'll add 4 more applications now and then we'll have an almost feature-full MATE desktop
<ng0>12 commits or something
<efraim>sounds good
<ng0>in fact there's only 5 official addons and applications of MATE missing if I counted right
<efraim>can I use setenv to replace the shell used?
<Apteryx>Could we enable readline for our Guile in initrd? would be a plus for hackability!
<innova>in guixsd, how would one be able to start an x server manually after console login (a la 'startx') rather than with an X login greeter?
<innova>and is there any way to avoid installing a greeter while still installing xorg in config.scm?
<buenouanq>innova: the supported way of doing xorg right now is through slim. I believe some people have done things to get around it, but it's nontrivial.
<ng0>alezost had something about this
<ng0>3 more applications to go.. I watched one twin peaks episode. So MATE on my test system will hopefully work out so far that screensaver, applets and control center are added when I reconfigure it
<ng0>*are functional
<buenouanq>so we're going to officially offer full Mate now too? along with xfce and gnome
<buenouanq>awesome ng0, keep up the good work
<ng0>we have more aswell..
<buenouanq>things change so fast now~
<ng0>thanks :)
<ng0>surprisingly MATE is easier on some of my GPUs than XFCE, so you see the difference of GNOME2 and GNOME3 based WMs
<ng0>what is "upowerd"? "To work properly, mate-power-manager requires udevd and upowerd to be running."
<ng0>the daemon of upwer?
<ng0>I think I'm done for today. Power-saving is for later
<buenouanq>ACTION continues waiting for someone to adopt and rekindle guilewm
<efraim>ng0: according to apt-file, upowerd is a binary from upower
<efraim>upower seems to be in gnome.scm instead of freedeskop.scm
<ng0>Okay, thanks. I know we have upower. For a different part of MATE I was unable to fix this quickly, so I made a FIXME note
<ng0>also: argh. https://groups.google.com/forum/#!topic/mozilla.governance/81gMQeMEL0w
<jonsger>guix doesn't like fishshell that much :(
<ng0>what do you mean?
<ng0>as a user shell?
<ng0>I've been sitting on a collection of links to work on
<ng0>but mainly for addon paths
<ng0>jonsger: or: what has been crashing this time?
<ng0>efraim: Control Center seems to work :)
<ng0>I'll send the updated patches now
<jonsger>ng0: guix pull won't work with fish, no problem with bash
<ng0>ah yeah.. you have to setup fish the way you#d setup fish normally
<ng0>like the /etc/profile doesn't work currently with all shells
<ng0>I've been thinking about a more portable solution
<jonsger>so what do I have to do with my fish?
<ng0>something with PATH.. I read there's a bashrc addon for fish
<ng0>or something which reads bash into fish
<ng0>I didn't come very far into applying thoughts into experiments :)
<jonsger>I'm setting the env variables like it's written by guix pull
<ng0>I have some relevant nix issue links if you want to read them without knowing if they actually help your specific situation?
<jonsger>you could
<ng0> https://github.com/NixOS/nix/issues/440 https://github.com/NixOS/nixpkgs/pull/24314 https://github.com/NixOS/nixpkgs/issues/5331 I have some more. My motivation at the moment is just: introduce the ability to package zsh + fish addons and use them without symlinking into a known location. zsh is easier, fish needs some work. afterwards there's the problem you're possibily interested in aswell, improving at
<ng0>least the user experience of shells which are not bash in Guix (not changing the default supported shell, I know this will never happen but we should at least try to make it less akward to use the shells which can run into problems).
<ng0>efraim: 15 patches, with the last one included (mate, meta package used to test this all)
<ng0>not that I expect you to review them now, just to tell you the number increased a bit :)
<ng0>applets seem to work
<ng0>media aswell (sound applet is there)
<ng0>I'm not completely sure about the applets. I need to check what it should include.
<ng0>ACTION thinks "mate" is also missing consolekit or policykit