IRC channel logs

2017-08-09.log

back to list of logs

<lfam>It seems that ncurses is not available on the mirror :/
<tetero>Does guix use linux or mach?
<brendos>linux-libre
<tetero>Ah
<Hiroteru>I'm trying to build a guix package for postgis, but I got the following error:
<Hiroteru>make[2]: Entering directory '/tmp/guix-build-postgis-2.3.3.drv-0/postgis-2.3.3/doc' /gnu/store/6908gy3pws0ccys49ni98idwnicchlr2-coreutils-8.26/bin/mkdir -p '/gnu/store/my4ahdmqsrv3q6v6fm9ffv9fb42y5ssk-postgresql-9.6.3/share/contrib/postgis-2.3' /gnu/store/6908gy3pws0ccys49ni98idwnicchlr2-coreutils-8.26/bin/mkdir: cannot create directory ?/gnu/store/my4ahdmqsrv3q6v6fm9ffv9fb42y5ssk-postgresql-9.6.3/share/contrib?: Permission denied
<Hiroteru>Does anyone know how to deal with it ? I'm struggling right now
<wigust>Hello Hiroteru, are you trying to create a directory in input “/gnu/store/…-postgresql-9.6.3/share/contrib”, but you package “postgis”?
<Hiroteru>Hi ! I do not really understand your question ^^ But I could send you the guix scheme file that defines the guix package
<Hiroteru>Oh I think i understand, the "postgresql" directory
<Hiroteru>Could the cdause of the probleme be the propagated input postgresql ?
<cbaines>Hiroteru, I don't think so
<cbaines>it sounds like postgis is trying to install in to a sensible location, but that is not what you want for the Guix package
<cbaines>for the Guix package, you need it to install to the package output directory
<wigust>Hiroteru: I think it could, because somewhere in “postgis” Makefile (if gnu-build-system) maybe a “mkdir /gnu/store/…-postgresql-9.6.3” present.
<Hiroteru>I'll take a look at the postgis Makefile, and see if I can figure something out about the output directory
<Hiroteru>Thanks anyways guys
<solene>Would it be interesting to have the package module of a package when using "guix package -I" to display installed ?
<solene>Currently, I install some packages and sometimes I reconfigure my system to include then system wide, but the process is terrible. I add packages in the "packages" list and then, I need to find the package-module of each package by doing guix package -A | grep package_name and look at the scm file
<wigust>solene: “guix package -A” supports REGEXP. Why do you use “grep”?
<solene>wigust: bad habits I think
<solene>I didn't understand that -A supported regexp, It's far easier to use -A than -s and parse with grep to get only the package name
<solene>maybe, would it be a good idea that "guix package -I" add a column with the module ?
<wigust>solene: I think, packages just need to be named properly like emacs-* or dovecot-*.
<solene>wigust: I think I explained badly
<solene>when I want to add my packages to the system configuration, I'm looking at packages installed as my user and then I add them in the config file
<solene>but for each package, I have to dig out to find the module providing the package
<wigust>solene: Ah, I have this pain with “manifest”, too. But probably could use dirty way, like include all Guix packages Scheme modules :-)
<wigust>solene: I have this messy for me thing https://paste.pound-python.org/raw/Wtbtt63tUiZC3BXC9GGb/
<wigust>So probably need some auto-discovere use-package-modules for packages->manifest.
<rekado_>you can use specifications instead of package variables.
<rekado_>then use (packages->manifest (map (compose list specification->package+output) packages))
<solene>wigust: what's (packages-manifest (list )) ? I have (packages (cons* pkg1 pkg2 pkg3 etc...))
<solene>rekado_: that seems not intuitive at all
<rekado_>(define packages '("python@2" "r-minimal" "foo" "bar:lib"))
<rekado_>why not?
<rekado_>packages->manifest requires a list of packages.
<rekado_>you can get that list of packages from a list of strings with specification->package
<rekado_>(or specification->package+output)
<solene>rekado_: and then you use "guix system reconfigure -m yourfile.scm" ?
<wigust>solene: No, it's useful for user packages, “guix package -m packages.scm”. You probably could use this for system declaration, too. Check https://www.gnu.org/software/guix/manual/html_node/Invoking-guix-package.html
<wigust>rekado_: Yea, I didn't see this way last time I read documentation, thanks!
<solene>wigust: I found this page too from the code snipped of rekado_ :)
<wigust>solene: You don't want many packages in system declaration anyway, I think.
<solene>why ?
<reepca>Question, when parallel builds for makefiles are enabled, is the order in which certain stuff happens essentially random? I'm comparing the build log output I'm getting to what the C++ daemon is getting and seeing a lot of stuff in slightly different orderings, and it's making it tedious to sort through the diff
<wigust>solene: Because it's a feauture of Guix. You could have packages per user. And don't need to “system reconfigure” every time you add a package.
<solene>wigust: I had troubles with some packages, like a terminal. If root doesn't have the terminfo you can't use it when you go root inside
<wigust>solene: So you add this and only this to system declaration. Look at my manifest, it will be littleli odd to add all packages in system declaration, because I need them only for my user.
<fr33domlover>Hello
<fr33domlover>I just installed the transmission package, I can't find the gui app
<fr33domlover>Is there a chance it wasn't built?
<fr33domlover>How do I make it build?
<atheia>You gotta install the "gui" output.
<fr33domlover>atheia, thanks! I did `guix package -i transmission:gui` looks like it worked :)
<atheia>np :-)
<fr33domlover>atheia, the app fails to display icons. do i need some line in .bashrc to set the icon path correctly?
<atheia>Sorry, pass.
<atheia>Now that you mention it, doesn't display an icon for me either…
***dshin-california is now known as dshin
<wigust>I have the issue with icons in pavucontrol and icecat (files open window), too.
<efraim>sneek: later tell ng0 I see you have translate-shell and emacs, des translate-shell work for you from inside emacs? I wasn't able to test it before committing it
<sneek>Got it.
<efraim>sneek: botsnack
<sneek>:)
<janneke>guix package -I
<janneke>guix package: error: unsupported manifest format
<janneke>huh?
<wigust>efraim: works for me “M-x google-translate-mode” “C-c -” “C-c =”. Or did you push a new version?
<efraim>wigust: no, the same one, I don't use emacs and wasn't able to test that it actually worked after figuring out how to make that part of the package build
<wigust>efraim: it works in Emacs, thanks for amazing package :-)
<tetero>How mature is guix?
<tetero>Any occasional issues with the package management? Usually rollbacks are tricky to implement
<Apteryx>fr33domlover: I had the same problems with icons and transmission. Launch the app from a terminal, and see if it complains about any icon resources.
<Apteryx>In my case it was looking for arc-theme icons IIRC. I'm not sure why, but I did use a theme switcher at some point and attemted to use arc-theme; which I thought had undone and uninstalled arc-theme. My short term fix was to reinstall arc-theme-icons or something like that.
<rekado_>tetero: rollbacks are trivial in Guix. It’s just a matter of changing a single symlink.
<tetero>Neat
<rekado_>janneke: are you using an old version of Guix with a more recent profile?
<wigust>Apteryx: Ah, I had no icons because didn't install them. “guix package -i adwaita-icon-theme” does the job, thanks. :-)
<wigust>Like with fonts need to manually install them.
<tetero>Is there a rootfs tarball for guix?
<rekado_>we have a tarball for Guix that includes /gnu and /var/guix directories. You unpack those and with a little more configuration (creating user accounts and starting the daemon) are good to go.
<tetero>Right, but that's within my own distro.
<tetero>Is guixsd not its own distro?
<solene>guixsd is
<tetero>Ahh
<tetero>I was pretty confused.
<tetero>Is there a rootfs tarball for GuixSD then?
<solene>i think it stands for guix system distribution
<tetero>Yeah I just didn't really notice that the binary said Guix and not GuixSD. Or think about the difference
<solene>there is a vm-image maybe you could use it ?
<tetero>That sounds like a hassle
<solene>or use debootstrap to make a debian in a chroot and extrats guix inside
<tetero>Is that what guixSD is? debian+ guix?
<solene>no but it seems you want to chroot into a guix system ?
<tetero>No?
<solene>oh :)
<tetero>I just don't want to go through an installer
<tetero>I prefer configuring things from my working system and then just booting it
<solene>the usb install image is all manual installation
<wigust>tetero: You need to know how to start guix-daemon and shepherd if you wanna like debootstrap, I think.
<tetero>solene: Yes but using it would require me to configure it from a not-nice system, there's no reason for that
<ng0>debootstrap?
<sneek>ng0, you have 1 message.
<sneek>ng0, efraim says: I see you have translate-shell and emacs, des translate-shell work for you from inside emacs? I wasn't able to test it before committing it
<ng0>sneek: later tell efraim: I do? That's news for me..
<sneek>Okay.
<ng0>sneek: later tell efraim: I mean about translate-shell
<sneek>Okay.
<efraim>ng0: I saw it from the manifest you posted yesterday
<sneek>Welcome back efraim, you have 2 messages.
<sneek>efraim, ng0 says: I do? That's news for me..
<sneek>efraim, ng0 says: I mean about translate-shell
<ng0>what manifest?
<efraim> https://paste.pound-python.org/raw/Wtbtt63tUiZC3BXC9GGb/
<ng0>I really have no translate-shell or any shell interaction in emacs, I stay away from eshell for now.
<ng0>that's not mine, that's someone using one of my package repositories
<ng0>one of the module paths is named ng0/packages/ .. the later ones are like crash/burn or mystery/hack
<wigust>efraim: It's my manifest. :-)
<wigust>ng0: Yeah, I found a way to use ng0-packages in manifests.
<wigust>Also now via specification https://paste.pound-python.org/raw/PldDT2oog6vfSbNcVUHv/
<ng0>oh, I found a way for source code hosting, so just diregard the savannah question for now I've sent to the list ;D
<adfeno>ng0: Which savannah question?
<adfeno>(me feels lost not being able to login via email)
<ng0>subject "I can't find a good subject to summarize this" .. also it included some misunderstandings of savannah which I cleared up for myself now
<ng0>so yeah exactly "which question?" no question ;) no need to reply to it
<ng0>Oh, I found out Gitlab CE has no hooks, that's an Enterprise feature. In case you ever wanted to use Gitlab for something with mandatory checks: forget it.
<ng0>It took a while to grow on me, but reading/watching the "Maintainers don't scale" talk is really recommended. I wished I could've pointed to this when we had the last "savannah and email sucks" discussion
<ng0>with the links to the video inluded: http://blog.ffwll.ch/2017/01/maintainers-dont-scale.html http://blog.ffwll.ch/2017/08/github-why-cant-host-the-kernel.html
<adfeno>I don't know about your stance on this, but so far, I see GNU Savannah (and other instances of Savane, because anyone can host another one), is/are better than GitHub/GitLab.
<adfeno>I have yet to watch the talks, also.
<rekado_>tetero: wait, I don’t know why others suggest things like debootstrap here… There’s a disk image you can use to run and install GuixSD.
<rekado_>
<wigust>adfeno: You could host Gitlab, but it doesn't include all feautures I believe.
<rekado_>tetero: the disk image does not come with an installer. It boots into GuixSD from within which you can just set up your system.
<adfeno>Also... non-free Js for the visitor/guest/client :)
<wigust>rekado_: no debootstrap suggestions, tetero wants install GuixSD from another system like debootstrap as I understand.
<ng0>wait a moment, the talk is not about hosting. it is about accepting patches and workflow etc
<rekado_>tetero: if you don’t like that you can also just get Guix (e.g. from the guix-binary* release) onto your foreign distro and then run “guix system init /etc/config.scm /”
<ng0>the second link is a reply to questions there were on the first one
<solene>I have a problem with guile, it doesn't work : http://paste.lisp.org/display/352930
<rekado_>tetero: I’ve done this from old Ubuntu hosts a couple of times.
<rekado_>solene: are there Guile 2.0 things on your GUILE_LOAD_PATH?
<solene>rekado_: env | grep GUILE
<solene>GUILE_LOAD_COMPILED_PATH=/run/current-system/profile/lib/guile/2.2/site-ccache:/run/current-system/profile/share/guile/site/2.2
<solene>GUILE_LOAD_PATH=/run/current-system/profile/share/guile/site/2.2
<solene>I think no
<solene>but I was able to use "guix pull" and guix works on my user, so I assume that guile isn't entirely broken
<tetero>rekado_: I don't want to boot and configure from the installer, and I don't want to set up guix on my current distro. I want to dump GuixSD on a partition and configure it from my current distro, and then boot it
<tetero>This is typically something very elementary, I'm surprised there isn't a rootfs tarball
<adfeno>ng0: So, which one should I watch? first or second?
<ng0>1, 2
<rekado_>tetero: GuixSD builds complete system trees in the /gnu/store and then checks them out at boot.
<ng0>if you try readin 1 without 2 it works aswell, but is an entiurely different topic
<ng0>or angle
<rekado_>solene: which guile is this?
<solene>rekado_: guile 2.2.2
<tetero>Ugh.
<wigust>solene: I have the same /gnu/store/0kay0503aqwxx6rrhnqr1jmdlcwm9wy2-guile-2.2.2/ with no problems, hm.
<solene>I have the same hash wigust
<rekado_>tetero: I’m just telling you what alternatives there are. There is no rootfs tarball, so if you absolutely need it you have to work around the lack of it.
<wigust>solene: so, maybe “guix build --check guile”?
<solene>wigust: I was writing to ask if there was some command to check the installation of a package :)
<solene>i'll try
<solene>guix build --check guile@2.2.2 ?
<rekado_>no
<rekado_>that will just try to rebuild guile
<tetero>rekado_: Yeah, it's not a huge thing, but it's one of those annoyances that's unnecessary
<rekado_>solene: if you want to check that the store isn’t corrupt and repair it, use “sudo -E guix gc --verify=repair,contents”
<solene> guix build --check guile
<solene>guix build: error: build failed: some outputs of `/gnu/store/vrsxh21gh7rsisd4bx6c4qnwnhi56m8v-guile-2.2.2.drv' are not valid, so checking is not possible
<efraim>at almost 20000/2727193 for chromium on aarch64
<ng0>cool
<solene>rekado_: the command finished and didn't printed anything about checkin hashes, so I assumed everything was correct ?
<rekado_>solene: yes, if there were problems it should have printed something.
<tetero>rekado_: Is there a way, from guix, to install guixsd onto another partition? If so I can chroot into a temporary distro which I'll install guix onto and then go from there
<solene>tetero: that's exactly the same thing as using the guix usb image
<tetero>Except I don't have to reboot into it
<solene>true
<tetero>I don't want to quit what I'm doing until I'm ready to reboot a configured system, basically
<solene>you can use qemu or virtualbox to install on your hard drive, that's what I'm often doing
<tetero>I suppose I can qemu it aswell
<solene>qemu-system-x86_64 -hda /dev/sda -hdb guix.img -boot menu -m 512m
<tetero>aye
<wigust>solene: Maybe get configs from “/etc/skel” like “HOME=/etc/skel bash” and then “guile”?
<solene>wigust: same, and also I get this error as root
<wigust>Not sure if bash will start with /etc/skel/.bashrc though
<efraim>new curl release today
<tetero>is guix rolling release, by the way?
<efraim>tetero: yes
<tetero>nice
<ng0>efraim: oh. thanks for the reminder
<ng0>oh, today as in has just been made available
<ng0>then I can work on gnURL. Thought it would be much later
<efraim>I'm building the curl update on my x86_64 machine now
<ng0>does anyone want to provide our logo to the cURL download page?
<ng0>I passed it in the initial message, but it never happened to be added
<solene>what is the package to get java Jre ?
<snape>solene: icedtea
<solene>snape: ok ! I thought icededtea was firefox java plugin
<snape>not sure though
<snape>the browser plugin seems to be icedtea-web
<snape>look: https://www.reddit.com/r/linux/comments/1p8dd7/what_is_difference_between_icedtea_openjdk/
<snape>:)
<efraim>Curl failed at the end, no man3 it looks like
<efraim>I wonder what the grafting will do if I remove that output
<ng0>yeah, I think a7bbbb7c368c6096802007f61f19a02e9d75285b came after tag 7.55.0
<tetero>'herd start cow-store' lol
<solene>snape: interesting
<solene>tetero: what's fun ?
<tetero>solene: It's a herd that starts a cow store. ;) (yes I know, copy on write)
<tetero>I assume that if I uncomment the bootloader sexp, it will not install a bootloader? (I don't need grub, again)
<solene>I didn't know that herd had a meaning, english is not my native language and I didn't mind looking for a meaning. I'll check into a dictionary :)
<tetero>solene: Ah. A herd is a large group of animals :)
<tetero>kind of funny with cow-store in the same 'sentence'
<solene>indeed
<snape>tetero: I think you can't uncomment the bootloader, because there is no default for it
<snape>but you can tell it not to install
<tetero>snape: How do I do that?
<snape>with something along those lines: http://paste.lisp.org/display/352935
<tetero>snape: Why does (bootloader) appear three times there?
<snape>the first is a <operating-system> entry; the second is a <bootloader-configuration> entry, the third is the constructor of <bootloader>
<snape>see gnu/bootloader.scm and gnu/system.scm
<tetero>ah
<tetero>I assume I can just comment out the luks stuff to skip encryption?
<snape>the mapped-device part, yes
<tetero>Aye
<tetero>Does the installation require networking?
<snape>I think so
<snape>solene: see https://lists.gnu.org/archive/html/guix-devel/2016-01/msg00274.html for the origin of 'herd'
<ng0>a bunch / group of GNUS I'd guess without reading it
<snape>it's a vert, actually
<snape>to herd
<snape>a verb for a command :-)
<snape>s/vert/verb
<snape>"We might even rename ‘deco’ to ‘herd’ because it’s the very command that allows users to herd their daemons."
<solene>shepherd is a name too :O
<ijp>if we are doing cute names, can we use 'barn' instead of 'cow-store'
<ng0>well it is copy-on-write store :/ I have no problems with cow-store
<tetero>snape: bootloader-configuration, unbound variable
<rekado_>tetero: you need to load the module (gnu bootloader)
<snape>or (gnu), which loads a bunch of other things as well
<tetero>(gnu) is already in config.scm
<ng0>efraim: can confirm this.. I think I'll just apply a mixture of the 2 commits they made after they tagged 7.55.0
<ng0>the missing man3 in build I mean
<snape>tetero: maybe you are not up to date
<snape><bootloader-configuration> arrived on May
<ng0>efraim: read also this comment https://github.com/curl/curl/commit/f864bd8c880d5a916379aa4f26f1c45fe370b282
<ng0>and the commit afterwards
<tetero>snape: I'm using the latest installer image from alpha.gnu.org
<tetero>(13.0)
<efraim>ng0: thanks
<tetero>snape: It's got linux 4.11.0 which was released may 1st
<tetero>Either way, how do I make this -not- install grub?
<snape>tetero: oh it did not exist then
<snape>actually is it a big deal if it installs grub?
<snape>I mean, even if there is an error
<snape>it's usually not a problem
<tetero>Yes
<snape>ok... you see the whole bootloader thing has been reworked just after 0.13 was released :)
<tetero>Oh for crying out loud. You're telling me there's no way to not install grub?
<tetero>What if I replace grub with a script that exits successfully?
<snape>hmm, there is a --no-grub option
<snape>there *was
<snape>you should have a look at the documentation
<snape>and try to use it
<tetero>For what? There's no grub mentioned in the manpage to guix
<snape>hmm right
<snape>there is --no-bootloader though
<tetero>So, not only can I not install guixsd without the installer, I can't install it with the installer either.
<tetero>Oh, that does seem to exist
<snape>both should work I think
<snape>there is backward compatibility
<snape>but yes, use --no-bootloader
<tetero>Does guix only accept --no-bootloader after the other arg's? It's in the documentation, but it doesn't recognize it as the first arg
<ng0>first arg? you mean directly after "guix"?
<tetero>yeah
<snape>it's an option to guix init
<ng0>you can only pass (useful) arguments to guix subsystem, such as guix system --reconfigure , or guix package -s hello
<snape>and guix system too I guess, not sure
<tetero>So, guix system init --no-bootloader /mnt/etc/config.scm /mnt returns missing field initializer (bootloader), which I've commented out. It still needs those?
<solene>tetero: I think the config should be good / complete
<solene>but with --no-bootloader if will skip the bootloader part
<wingo>hoo, guix is hard to upgrade these days
<davexunit>yeah :(
<wigust>wingo: Why?
<snape>yes
<paroneayea>"down with guix pull"? :)
<snape>tetero: yes
<paroneayea>or "down with the current design"
<wingo>guile 2.0/2.2, libgit2, guile-git, gnutls with the right guile version, and all of these can have multiple versions around (profile, system, your guix git checkout)
<wingo>i don't use guix pull for better or for worse
<paroneayea>wingo: well that's for the better, at present
<paroneayea>wingo: but it should be good enough for even guix hackers to use and appreciate
<tetero>...
<snape>tetero: even if it doesn't install grub, it will still generate grub.cfg
<snape>which you might need, actually
<snape>depending on your setup
<tetero>snape: I can't not use encryption it seems. unbound variable mapped-devices when it's commented out
<davexunit>'guix pull' is a real nightmare right now
<snape>tetero: Ctrl-f 'mapped-devices'
<wigust>wingo: Ah, I use local guix checkout to pull. Like “guix pull --url=git://localhost/~natsu/src/guix --commit=7817b3181b9553478503c1c3c216d44f31a121f1”
<tetero>snape: ctrl-f? where?
<wingo>bytestructures wtf
<didi>Can I install guix locally, without root?
<davexunit>didi: you need root to run the daemon
<didi>davexunit: Oh, shucks.
<didi>davexunit: Thanks.
<davexunit>np
<wingo>too much dependencies on little libraries, not enough code copying :)
<davexunit>guix depends on bytestructures? that is a big wtf to me
<wingo>guile-git2 depends on bytestructures apparently
<wingo>not that it's listed in its readme :)
<davexunit>:/
<davexunit>not good
<paroneayea>I understand why it's a pain for guix but
<paroneayea>I also understand why guile-git2 would use bytestructures
<wingo>oh yay we depend on openssl *and* gnutls :)
<snape>tetero: on your config.scm file
<solene>tetero: guixsd is still in beta / not production ready, don't forget this
<snape>tetero: I think there is another occurence of 'mapped-device' in the file, that's why
<wingo>bytestructures has no makefile, that's also "fun"
<davexunit>I'm noticing an increasing number of guile libraries with poor development practices
<davexunit>but I've been so out of the loop I didn't realize that they were becoming guix dependencies
<tetero>snape: Ah. But what's ctrl-f? (I should probably mention I use zile and vim)
<tetero>Is that search?
<snape>'/'
<snape>:-D
<snape>yes, I should have said 'search' because every software has its own binding for this
<tetero>Yeah, I just was confused. I haven't used ctrl-f bindings in forever :)
<rekado_>solene: respectfully, “beta” has little to do with an incorrect configuration file.
<tetero>I kind of vaguely remembered it was search.. in web browsers
<snape>you use wget instead of web browsers?
<tetero>There was a dependency on mapped-devices that I missed
<paroneayea>davexunit: it probably doesn't help that we don't have a good way to get people up and running fast with "good" practices yet
<davexunit>that is true.
<tetero>snape: haha, what gives you that idea?
<paroneayea>it takes me about an hour to get a basic project structure in place
<tetero>snape: I use firefox+vimperator (for vim keybinds)
<solene>rekado_: I agree
<davexunit>I started writing a 'guild init' tool that would do this but it got complicated
<snape>tetero: ok :-) VimFX is excellent IMHO
<davexunit>mostly around licensing. I didn't want to generate a project skeleton and ignore the license, but there are so many licenses...
<tetero>snape: I haven't tried it in a while, last time I did it had issues of losing focus (and so keys would stop working until you clicked somewhere)
<snape>tetero: I see. I don't remember having this issue
<tetero>snape: It was some time ago, maybe it's been fixed
<tetero>solene: True. About the beta part. But there are some design decisions here that are odd.
<solene>tetero: I find guix very hard to use and understand if it's what you mean. I'm trying to write a little guide for day to day use because the manual is way to big when you are new and that you don't have time to read the 300 pages
<tetero>solene: No, that's not what I mean. I mean that commenting out the bootloader should just make it skip that part. I don't see any point in requiring elaborate functions to *not* do something
<tetero>Or set a *bootloader* symbol to nil, or whatever.
<solene>I think it prevents the system to be configured without the bootloader
<solene>by accident
<tetero>So use the latter approach
<tetero>Require a specific symbol to be set, *no-bootloader*
<wigust>tetero: by the way, you could contribute this change :-)
<tetero>wigust: If I like guix, I might actually do that
<tetero>I like some of the ideas
<snape>tetero: we hope you will like :)
<tetero>I hope so too. Minor implementation things aside, I like what it's trying to do
<tetero>And though I'm a Common Lisp guy, I'm looking forward to having a reason to mess with guile
<tetero>How many people are involved in the development?
<snape>159
<tetero>Of the actual system, or does that include package contributors?
<snape>it includes the package contributors
<tetero>Ah, and without those?
<snape>it's difficult to say
<ng0>done. patch for guix gnURL coming in a minute
<ng0>(wishing that this could be moved entirely into cURL..)
<snape>because they are on the same git repo
<tetero>snape: I like that of the two supported filesystems, btrfs is one of them.
<adfeno>ng0: About the speech/talk and also the reasons why Linux kernel project will probably not be moving to GitHub: I agree with the latter article. However, I don't necessarely understand how it relates to GNU Savannah, because GNU Savannah (or better: Savane, the software) supports Git hosting
<ng0>yes, thjat's what I told you it has nothing to do with hosting.
<ng0>only with a discussion we had last year
<adfeno>Oh, OK then :)
<tetero>Guix compiles from source?
<tetero>That's unexpected.
<ng0>patch sent
<janneke>guix package -i hello fails on building ca-certificate-bundle
<janneke>ERROR: no code for module (guix build utils)
<janneke>i'm now pretty stuck debugging this
<efraim>rm guix/build/utils.go ?
<janneke>hmm
<rekado_>tetero: yes. As an optimization, binaries (if available) can be downloaded from the build farm, as a substitute for the local build.
<janneke>efraim: i thought it's the builder that says this
<janneke>this works: guile -c (use-modules (guix build utils))
<janneke>and /tmp/guix-build-ca-certificate-bundle.drv-0/ is empty
<tetero>rekado_: Interesting, I don't have anything for or against it, I just didn't expect it. The trend seems to favor binary packaging these days
<bavier`>tetero: guix tries to make it easier for users to modify the source of their packages if they so desire
<tetero>bavier`: I like that
<wigust>Did you have a discussion about installing an old package version? If I need to have an old package version, I need to downgrade “guix”? Could we just have “guix package -i hello-VERSION” which will downgrade “guix“ temporarily and install it? Maybe somebody working on it?
<snape>wigust: you need to do a custom package that will inherit from the original one, except for the version
<rekado_>wigust: if there is a package definition for that version you can already do that
<rekado_>wigust: e.g. ‘guix package -i samtools@0.1’
<rekado_>it’s just that we choose not to keep more than one version of a package around unless there’s a good reason for it.
<paroneayea>davexunit: heh yeah
<wigust>rekado_: snape: Thanks, I just think that we could have a way to downgrade to any package version (without needing definition) via temporarily downgrade “guix”.
<wigust>Because we have all version definitions in guix git history.
<snape>wigust: that would work too
<snape>but it's usually better to have an up-to-date guix
<wigust>For example 1f0d47059d31bbbaf588a4ca2de38d2ded8678cc upgrades emacs-yasnippet from 0.11.0 to 0.12.0, and from this point I cannot install 0.11.0 easily.
<snape>doing a package that inherits from emacs-yasnippet is pretty easy
<snape>it's like 5 lines
<snape>or so
<wigust>snape: Yeah, but... :-) I think about ‘guix package -i emacs-yasnippet@0.11.0’
<janneke>efraim: tried all variations of `rm guix/build/utils.go' ...
<wigust>snape: Without manual inheritance of course.
<snape>manual inheritance is done once and for all :-) it's no big deal
<rekado_>wigust: going back in time is not so great. At an earlier point in time you may have a different default GCC, for example.
<rekado_>wigust: are you willing to build the old GCC to get an old Emacs, just to get an old emacs-yasnippet built?
<wigust>rekado_: Ouch, this is big.
<rekado_>wigust: each version of Guix describes a very large graph; to go back in time means that you’ll be instantiating a section of that graph.
<rekado_>it’s preferable to just create a new package definition and inherit from an existing definition
<snape>(plus, substitutes for this whole graph might not be available anymore and you would have to build them)
<wigust>I totally forgot about graph. What about autogenerate a new package definition and inherit?
<rekado_>(plus, source code for building the packages may have disappeared.)
<rekado_>wigust: the supporting code changes as well.
<rekado_>wigust: in the past we may have used Guix features that no longer exist.
<wigust>rekado_: Does it prevent from generate a new package definition automatically?
<rekado_>wigust: it might.
<rekado_>if you want to do things automatically, though, why bother with package definitions?
<rekado_>we already have --with-source
<wigust>I think about --with-version which just changes “version” in package definition. :-)
<snape>it would be unsafe since some packages have a 'http' source
<snape>and --with-version would not provide any checksum I guess
<wigust>snape: We have these checksums in guix git repository.
<snape>no, they would change is the source change
<janneke>could this be a problem: bind mounting `/dev/full' to `/gnu/store/3vq51mpsrkcpgh1x3l2fjmdz2j2mzcv3-ca-certificate-bundle.drv.chroot/dev/full'
<snape>version change => source change
<wigust>snape: And we back to --with-source, got it. Thanks for explain you and rekado_.
<snape>:)
<lfam>In practice, it's not really possible to go back and reproduce old graphs, because there are package test suites that fail or succeed based on the date :/
<lfam>We remove those tests when we find them, but we don't always find them
<janneke>sorry to ask again, any ideas here:? ERROR: no code for module (guix build utils)
<lfam>janneke: You could check recent Git history for changes involve module imports, or just do `make clean-go`
<janneke>lfam: this is while doing: guix package -i hello
<janneke>it fails on building ca-certificate-bundle
<lfam>Urgh, that's not good
<janneke>i'm on a stable 0.13 that works on other machines
<lfam>Are you using GUIX_PACKAGE_PATH?
<lfam>Unset it if so
<janneke>no
<janneke>when i do --keep-failed, there is an empty /tmp/guix-build-ca-certificate-bundle.drv-0/
<janneke>i could imagine there should be guix/build/utils.scm or something there, but i have no idea...
<janneke>i don't know in how to trigger a ca-certificate-bundle.drv build and have that fail to look
<rekado_>janneke: that’s a profile hook, isn’t it?
<janneke>rekado_: yes
<rekado_>janneke: do you get this same problem with a fresh profile?
<rekado_>guix package -p /tmp/somewhere -i hello
<janneke>nice idea...yes, same problem
<rekado_>hmm
<lfam>Is there a way to get the absolute path of the resulting profile when doing operations with `guix package`
<lfam>?
<bavier`>lfam: 'readlink -f ~/.guix-profile' ?
<rekado_>or do you mean before running “guix package”?
<lfam>Yes, but it seems like it could be unreliable if there are multiple clients
<lfam>That was to bavier`
<lfam>What I would really like is if `guix package` would print the path of the new profile at the end, like `guix build` prints the path of the store item(s)
<lfam>That way you could be sure you had the right path
<lfam>The idea is that you could save metadata related to profiles generated from a particular manifest
<janneke>rekado_: this *is* on top of an ubuntu VM and i've seen other weird things in a similar environment
<janneke>still, would be nice to debug it
<rekado_>janneke: and the only error message you get is that there’s no code for (guix build utils)?
<lfam>I wonder if there is actually no code for any module, but (guix build utils) is just the first thing it looks for?
<janneke>rekado_: it's a whole stack trace: http://paste.lisp.org/display/352958
<janneke>lfam: i would like to know which process & where reports this problem
<janneke>with --keep-failed, there is an empty directory in /tmp/guix-build-ca-certificate-bundle.drv-0/
<janneke>i can imagine that there should be something there
<rekado_>/gnu/store/9paf7m6kxi248pphvd0hppqpwyp7vf4r-ca-certificate-bundle-builder
<rekado_>that’s the build script it tries to run
<rekado_>and inside of that it will look for (guix build utils).
<rekado_>janneke: this is not guix from git or anything weird, right?
<janneke>rekado_: yes, it's from git, but a stable 0.13 branch that we've been using all the time
<rekado_>janneke: have you tried “make clean-go && make” yet?
<rekado_>janneke: is the Guile version the same as on other machines where this works?
<janneke>trying that now...
<janneke>yes, in fact the machine is a clone of a machine where this worked ~10 times
<efraim>I think the external hard drive I'm using as /gnu on my aarch64 build box got corrupted
<bavier`>lfam: you can do something like 'guix package -n ...', then use 'guix build' to build the profile derivation that's listed without actually updating the default profile
<lfam>bavier`: Hm, good idea :)
<bavier`>lfam: or you could do something like 'd=`mktemp`; guix package -p $d ... && readlink -f $d && rm $d'
<bavier`>but doing something with the store api might be nicer :P
<janneke>rekado_: rm -rf /gnu /var/guix; re-run script, all fine...
<tetero>Ugh. I am starting to regret not looking more carefully at the config before it started compiling gnome in qemu
<lfam>tetero: If you started QEMU with --enable-kvm and your host OS / hardware supports KVM, it should work at near-native speed
<tetero>lfam: This laptop isn't very fast
<tetero>and gnome is very big
<lfam>Yes, that's true
<tetero>Kind of stupid since I don't even use gnome :)
<lfam>I recommend you stop the build and change the system configuration :)
<tetero>I thought about it, but I've left it on for so many hours that I'm getting a bit OCD about having it finish ^^
<tetero>Very well, I cancelled and removed gnome
<jackhill>ls
<tetero>jackhill: . .. /etc /gnu
<jackhill>
<tetero>jackhill: I felt that it was sad that your command didn't work ;)
<ng0>lfam: https://github.com/curl/curl/commit/f864bd8c880d5a916379aa4f26f1c45fe370b282 https://github.com/curl/curl/commit/a7bbbb7c368c6096802007f61f19a02e9d75285b
<ng0>in addition to my email reply
<lfam>ng0: Oh, good catch!
<efraim>25640/27193 on chromium
<lfam>ng0: Do you have time to send a patch for the curl update?
<lfam>If not, I'll get to it later today
<ng0>too tired… and I'll be busy tomorrow
<ng0>maybe we'll get a new cURL release tomorrow, I don't know what FreeBSD did. I saw their bug report after I fixed it myself with the content of these commits
<efraim>using just the two commits I couldn't get curl to build
<ng0>oh
<ng0>what did I do with gnURL? I didn'tr invoke any special magic
<ng0>haha
<ng0>let me compare the receipes though
<ng0>efraim: does a test fail, or how does not build?
<efraim>it failed while moving man3 to the separate output, so I think it just didn't build it
<ng0>ah.. hm
<ng0>I wished I could help, but today I'm too tired to help
<ng0>btw.. is GNU always taking so long to make changes to who can upload to a project ftp folder?
<ng0>3 weeks.. not so bad, but maybe it's just 1 person or 2 persons dealing with these requests
<ng0>maybe https://github.com/curl/curl/issues/1745 helps you? sorry if I suggested this before
<ng0>or just wait until badger replies again, or open a separate issue
<ng0>gnURL is not in attic of GNU descriptions, or is it? I'd like to change the description maybe.. I think it's nowhere expressed that you are not supposed to use this in place for cURL and that it's just for GNUnet.. or at least using it in-place systemwide is experimental and not intended use. Dunno who actually would think that'S a good idea.
<ng0>attic is only official GNU projects as far as I understand it?
<lfam>Has anyone tried Guix on Alpine?
<lfam>I'm wondering if Alpine's musl libc will even work with Guix
***joshuaBPMan_ is now known as jbranso
<ng0>rain1 has been working on it, and documented it afaik
<ng0>no idea how far rain1 came
<ng0>Guile works with musl, I see no obvious problems, just optimiuations we'd have to make in code which compilation errors with musl could reveal
<fr33domlover>ng0: maybe you know, I installed Transmission GUI and it doesn't display icons - how can it be told where to find them?
<fr33domlover>Or maybe I need to install an icon theme?
<ng0>I can't tell out of the blue what it could be. I'm just sticking around reading a comic. What's your system config? if you use gnome or xfce you already have a icon set available
<fr33domlover>ng0: I started with minimal Devuan installation, just basic system. Then installed the deps for the Xmonad window manager, so I now have GUI. And installed some GUI apps with Guix such as IceCat and Transmission
<fr33domlover>So if I need anything else manually installed, I probably don't have it installed :P
<ng0>I assumed GuixSD.. ok.
<ng0>then you probably need one of the icon sets
<ng0>I don't know xmonad, but it's minimal aswell and has no dep. on icons
<fr33domlover>Yeah xmonad doesn't require any icons
<fr33domlover>ng0: by icon set you mean something like the Tango icon theme?
<ng0>I have "gnome-themes-standard" in case that helps
<fr33domlover>Thanks I'll try some things and see what happens :)
<ng0>that was an actual package name "gnome-themes-standard"
<ng0>just search for "icons" and go through the search results.. I don't have much experience with guix on other systems except for servers
<ng0>you might need to reboot and/or log out and back in