IRC channel logs

2017-06-16.log

back to list of logs

<ennoausberlin>ng0: I see
***kelsoo1 is now known as kelsoo
<reepca>Hey OriansJ, turns out when one enters a blank line it pushes a 0 on the stack.
<paroneayea>e
<paroneayea>oops
<janneke>morning guix!
<reepca>o/
<efraim>sneek: later tell ng0 you might have to pass --sysconfdir=/etc to configure; if you find more E21 oddities I'm happy to,push fixes
<sneek>Will do.
<efraim>sneek: botsnack
<sneek>:)
<civodul>Hello Guix!
<rekado>Hello!
<reepca>'lo
<balduin>how can I upgrade guix from v12 to v13?
<civodul>balduin: 'guix pull' should work, though there's a couple of gotchas
<civodul>heya reepca & rekado
<civodul>reepca: how's everything?
<reepca>I find myself a bit distracted improving OriansJ's forth, but I don't plan on spending much time on it after tonight... after I finally get displaying a number to work. Rather difficult to debug without that.
<balduin>@civodul: thanks
<balduin>how can I see which version of guix I use?
<balduin>okay, guix --version works, but it is not listed under help
<rekado>thomassgn: “I have nixbld in my groups” <– I don’t think you should.
<rekado>thomassgn: is “nixbld” the group your daemon uses to spawn build jobs?
<civodul>reepca: heheh, sounds fun :-)
<reepca>ahh, just got it to work. It even correctly displays negatives!
<rekado>I just noticed that the ld-wrapper’s behaviour isn’t documented.
<rekado>So I submitted a patch to document the GCC toolchain and the GUIX_LD_WRAPPER_ALLOW_IMPURITIES env var.
<rekado>it’s a commonly asked question
<civodul>good
<civodul>at one point i wonder about making 'gcc' a "hidden" package, to avoid problems
<civodul>*wondered
<civodul>79 pending entries in guix-patches
<rekado>oof
<rekado>gotta take some time on the weekend to review some of those
<reepca>OriansJ: turns out that issue with the parser putting 0s on the stack also happens with comments.
<reepca>By the time it's gone through my tape_01, it's got 29 of them sitting on the stack... which I know because I just finished implementing .S! \\o/
<balduin>how can I add packages I developed and build from source into my execution path?
<rekado>balduin: could you rephrase? I’m not sure I understand what you’re asking.
<balduin>sure, I created a package under /home/user/guix/gnu... Then I build the package to do that I added changed the GUIX package build path.
<rekado>okay
<rekado>instead of using “guix build” just use “guix package -i” to install the package to your profile
<balduin>okay, thanks now I have that in my profile.
<balduin>However, my question is how can I add the binaries in the /gnu/store.... location to my path. I installed guix in Fedora and if I try to execute the binary from the package I build I get the message program not found.
<rekado>The preferred way is to use profiles.
<rekado>a profile is the union of a bunch of packages from the store.
<rekado>when using “guix package -i the-package” it will be added to your default profile, which is linked from ~/.guix-profile.
<rekado>so you only need to run “source ~/.guix-profile/etc/profile” to set all environment variables that are required to use the software
<rekado>this also sets PATH such that ~/.guix-profile/bin is searched for executables.
<balduin>thanks that is what I wanted to know. Perfect, thanks a lot.
<rekado>glad it helped :)
<balduin>By the way is there a way to test if a package was build correctly? Like for example, can I write something like a small unit test for commandline applications?
<rekado>we run a package’s test suite by default.
<rekado>that’s often sufficient as a test.
<balduin>can I read somewhere how the package test suite works?
<rekado>we run “make check” for all packages.
<rekado>exactly what this entails depends on the package.
<rekado>we don’t do any extra testing
<balduin>okay, so this works only if the author of the software wrote a test and if it uses make. Is this correct?
<rekado>it doesn’t have to use make.
<rekado>that depends on the build system for the package.
<reepca>(see section 4.2 of the manual)
<rekado>for the gnu-build-system we run “make check” (or any other target)
<rekado>for other build systems it’s a different thing we run.
<balduin>ah, okay. Still the test depends on the author of the software and not on the author of the package (the scheme file).
<balduin>how to you handle packages which are based on electron? Electron is the chromium based framework/building block for applications developed by GitHub. The most well known application based on Electron is the Atom editor.
<rekado>I don’t think we have any Electron applications in Guix yet.
<rekado>Isn’t that a whole bunch of JavaScript?
<balduin>basically a browser engine + Javascript/CSS/HTML + other resources (images, audio files etc.)
<balduin>the App I am interested in is Pencil: https://github.com/evolus/pencil
<balduin>it is a GUI prototyping App under GPL2 license.
<thomassgn>rekado: I don't think the daemon uses it. It's only referenced twice in my config, one for creating the group, and then for adding my user to the group. The current config is here: https://notabug.org/thomassgn/guixsd-configuration/src/master/config.scm#L64
<reepca>OriansJ: Here's everything I've written for the bootstrap forth so far (let me say, being able to print numbers and show the stack feels GREAT): http://paste.lisp.org/display/348819. Hope it can be of use :-)
<catonano>balduin: my irc client disconnected so I'm not sure if there was further meaningul conversation about Electron. I'd suggest you to see this toot o mine https://mastodon.social/@catonano/9027490
<catonano>more generally there's the whole npm issue not still tackled, in Guix
<catonano>Personally I'd be more interested in the workflow to work on Gnome based solutions in Guix
<catonano>recently Gnome released a footage sowing off their solution for packaging and dependency management
<catonano>I didn't watced it
<catonano>But I'd like to be able to play with Gnome based GUI apps building
<catonano>apps to be packaged in Guuix, of course
<catonano>maybe some day I will ask on the mailing list about this
<ng0>If I had commit rights, I would push this https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26899 because 2 months without a comment would be enough to just go ahead. Instead I ask, is this on someones list of things to check?
<sneek>ng0, you have 1 message.
<sneek>ng0, efraim says: you might have to pass --sysconfdir=/etc to configure; if you find more E21 oddities I'm happy to,push fixes
<ng0>sneek: later tell efraim: I have more E21 odities (see open Enlightenment related bugs), I just had no time to push fixes for them, and for one I received no alternative solutions so I'll just prepare a patch for it.
<sneek>Will do.
<ng0>sneek: later tell efraim: I meant 'to create fixes for them'
<sneek>Will do.
<catonano>ng0: tere was a note by Ludo today about pending patches. There are about 70 of tem at the moment
<ng0>I know the webview list
<catonano>ah it's a bug, not a patch
<ng0>no it's a patch
<catonano>no, it's a patch
<catonano>right
<ng0>someone asked me if I wanted to ask again for commit rights to help reviewing… my time is limited, but if ludovic or ricardo think it would help: I have a savannah account again.
<ng0>have to go again… bye
<OriansJ>reepca: I promise to fix all of those bugs and thank you for everything
<catonano>sneek later tell ng0 you can review even without commit rights. Just reply to emails, give your lgtm if you deem that appropriate
<sneek>Okay.
<rekado>sneek: later tell ng0 Comments like “For possible past reviews search the guix-devel <at> gnu.org archive” make it less likely that a review will happen in time, because it takes extra time to find those past reviews.
<sneek>Okay.
<janneke>reepca: are you now also joining in our bootstrapping efforts? ;-)
<civodul>rekado: did you have a chance to test the profile collision patch?
<efraim>TeX 2017 massive tarballs are up on tug.org
<sneek>efraim, you have 2 messages.
<sneek>efraim, ng0 says: I have more E21 odities (see open Enlightenment related bugs), I just had no time to push fixes for them, and for one I received no alternative solutions so I'll just prepare a patch for it.
<sneek>efraim, ng0 says: I meant 'to create fixes for them'
<efraim>They really should have torrents for those
<civodul>efraim: but we don't need them anymore, do we? :-)
<janneke>what's with guix gc --help' saying PATHS instead of FILES/DIRECTORIES?
<janneke>oh and lower case paths too
<civodul>yeah there are some imperfections :-)
<janneke>ok, that's cool.
<janneke>hmm, can our `warning: arbitrarily choosing' handle circular symlinks?
<janneke>warning: collision encountered: /gnu/store/ck23z60hkp8rgryqfnhlhxr7bfzaagix-dezyne-system-test-feature-ast/client/node_modules/dzn/node_modules/dzn/node_modules/dzn/node_modules/dzn/node_modules/dzn/node_modules/...
<civodul>janneke: no idea, you'll tell us
<janneke>civodul: i'm currently at: "probably not, but do we want to?"
<civodul>also, what kind of "handling" are we talking about?
<janneke>"it seems" that when installing two packages with colliding circular symlinks, the collision checker starts to follow waay too deep into the circular symlink tree, finding more and more collisions until memory is exhausted
<janneke>but i would to create a proper test and possibly rather find a way to fix my package
<janneke>*would rather like to find a way
<janneke>as much as i like the young exwm and exwm-x, i cannot seem to get in touch with the developers or other users -- emacs at 29G/14G now brb
<civodul>janneke: oh, memory exhaustion is not good
<TopSekret_>Hey, I have a problem. Installing GuixSD lasts really long, and at some point it requires to use --fallback. I have been advised that this is because of outdated mirror. Is it true? If not, how can I avoid it?
<janneke>ehh
<janneke>i had two friends install guix for the first time, and they both missed
<janneke> 7. To use substitutes from ‘hydra.gnu.org’ or one of its mirrors
<paroneayea>what up #guix
<janneke>substitutes? dunno what that is, lets's skip this stage
<janneke>hey paroneayea
<paroneayea>janneke: heh re: exwm, that's what I was afraid of... I've had emacs take up a lot of memory here due to mu4e
<paroneayea>and if I had to shut down my emacs and restart it (which I don't do often) I didn't want it to mean restarting my WM :)
<janneke>paroneayea: it does have its upsides, but yeah -- it seems that all WMs suck
<janneke>i like exwm+x better than stumpwm, apart from the memory thing -- hard to choose
<paroneayea>janneke: time to build a guile wayland library, then write a new wm for guile built on top of wayland? :)
<paroneayea>my friend paultag has poisoned my brain with the vision of having a WM that looks like the big virus-tv-creature from https://www.youtube.com/watch?v=NhheiPTdZCw
<paroneayea>(which is maybe the greatest music video of all time)
<davexunit>figured I'd show y'all this lovely log I grabbed from #gnu just now http://paste.lisp.org/display/348854
<davexunit>and by lovely I mean not lovely at all
<catonano>davexunit: :-/
<davexunit>jmd has caused issues on the mailing list in the past, and now he is discouraging new users from talking to us.
<catonano>being te organier of the gnu hacker meeting I'd say that's concerning
<davexunit>yes, indeed.
<janneke>what's the nicest way to add an url to substitute-urls in the build daemon?
<janneke>this: (guix-service (guix-configuration (substitute-urls (cons* "http://dundal.local:8080" %default-substitute-urls))))
<janneke>is quite ok, but then i need to filter-out guix-service from %base-services again :9
<janneke>:(
<catonano>davexunit: both rekado and ludo aren't here, right now. It's saturday evening after all. I'll send them an email about this.
<catonano>I tink it's iportant they know this
<davexunit>they'll read the log eventually
<gazon>catonano: wait. it's saturday evening?
<catonano>gazon: no, it's ffriday evening. I was wrong
<gazon>catonano: i'm so glad not to have missed half of the weeken already!
<gazon>d
<bavier>davexunit: :(
<bavier>and how is #guix and "unofficial channel"?
<bavier>s/and/an/
<bavier>it's mentioned on the front page of gnu.org/s/guix after all
<catonano>gazon: :-)
<catonano>gazon: I touught so. Happy week end !
<reepca>janneke: I don't know if "joining" is the right word, but if I have spare time it'd be neat to put my forth hobbyist status to work. But for now, I have several thousands of lines of C++ to read through (or attempt to reverse-engineer by mostly guessing, whichever is easier).
<janneke>reepca: wow, is the builder so big?
<reepca>nix/libstore/build.cc is 3600 lines, but that's including comments and whitespace
<OriansJ>I'm more surprised that no one ever tried the stage0 knight.py (or atleast asked about it)
<OriansJ>speaking of which, reepca's bug reports are resulting in a couple fun improvements there too
<reepca>OriansJ: What all requirements are there besides python3 to run it? I get an error about lacking "cherrypy".
***in0rdr_ is now known as in0rdr
<OriansJ>reepca: just python3 and cherrypy
<OriansJ>reepca: then simply open your web browser of choice to http://127.0.0.1:8080
<reepca>What would cherrypy's package be named?
<OriansJ>in debian it is python3-cherrypy3
<reepca>Is it packaged for guix?
<OriansJ>reepca: I guess not yet
<bavier>reepca: there's no cherrypy package afaict
<OriansJ>reepca: although I am tempted to rewrite it in guile but I haven't found a light enough web framework to write it in
<jamesrichardson>Is there an ex
<jamesrichardson>Is there an example anywhere as to how to actually run nginx serving a webpage?
<jamesrichardson>I'm not able to grok enough info from the manual to define the proper service.
<OriansJ>reepca: found and solved the stack leak, patches will be up shortly
<rekado>sneek: later tell civodul Sorry, I haven’t been able to test the collision patches yet, but I’ll try this weekend.
<sneek>Got it.
<rekado>davexunit: hmm, that’s disappointing :(
<OriansJ>reepca: adding EXECUTE now
<janneke>rekado, davexunit: i'm pretty sure it's all tragic misunderstandings
<reepca>OriansJ: words that aren't found still leave a 0 on the stack. Not sure what the appropriate thing to do there is.
<quiliro>anyone know how to mount a hydra mirror?
<janneke>ah, me found modify-services, great!
<OriansJ>reepca: Honestly, if I knew I would have done that and anyone is free to tell me what the correct thing to do here is
<quiliro>does anyone know about a link to make a hydra mirror?
<rekado>janneke: I really hoped that our efforts at mediating during the conflict helped to clear up the misunderstandings.
<rekado>I suppose jmd’s comment is true for every channel. Could be that we have very intolerant people here, but I don’t know any of them :)
<reepca>well, I suppose the user-friendliest thing to do would be to emit some sort of warning.
<jamesrichardson>I have ngninx running now with a simple website. Still, I may be doing something wrong.
<OriansJ>reepca: you are probably right, oh and I just finished adding EXECUTE and patches are already up
<rekado>jamesrichardson: what exactly are you doing?
<bavier>OriansJ: usually an "unrecognized word" error. some forths will clear the stack in such a case too
<jamesrichardson>seems to work.
<jamesrichardson>probalby should post that to irc.
<OriansJ>jamesrichardson: please use http://paste.lisp.org or similar
<buenouanq>jamesrichardson: (nginx-service #:config-file "/etc/nginx/nginx.conf") is all I have
<jamesrichardson>OriansJ: sorry :(
<jamesrichardson>buenouanq: Well, that's much simpler. thanks.
<buenouanq>keeps unnecessary things out of your global config
<buenouanq>there is a balance between throwing everything to guix and letting things take care of themselves and I still don't feel I've found the sweetspot in everything yet
<jamesrichardson>I'm still trying to sort this out myself.
<OriansJ>bavier: I think I could do that in a reasonably clean manner
<OriansJ>reepca: Keyword ERROR work for you?
<reepca>OriansJ: What do you mean by "keyword"?
<OriansJ>reepca: think defined function like ; or :
<reepca>What does it do? Just print an error?
<OriansJ>reepca: print an error message with the string that caused the error and clears the stack
<catonano>is there a part of the guix web site made with Haunt ? Do I remember correctly ?
<reepca>OriansJ: yeah, that would work.
<bavier>OriansJ: abort" is a fairly standard word that does mostly that.
<OriansJ>bavier: works for me
<bavier>OriansJ: used like 'FOO IF ABORT" error" THEN'
<catonano>the news
<reepca>OriansJ: could EXECUTE be made so that instead of taking the address of a pointer to the assembly, it takes the address of the assembly itself? That way the stuff we compile with , and the stuff we EXECUTE directly are one and the same
<OriansJ>reepca: it does take the address of the assembly itself
<OriansJ>whatever is on top of the stack is the address that is directly jumped to
<reepca>Huh. That's weird. When I give it the address of a colon definition, it crashes.
<janneke>hmm, how do i set/override "--substitute-urls" in the repl?
<OriansJ>reepca: for example if you run EXECUTE with 0 on top of the stack it will jump to address 0
<janneke>i'm getting lost trying to read guix/scripts/build.scm
<reepca>Oh, I think I see now - I had it backwards. What I've been compiling with , is the address of a pointer to the assembly.
<OriansJ>reepca: easy mistake to make
<jlicht>hello guix
<OriansJ>with that abort is done and an oversight has been corrected
<OriansJ>reepca bavier patches are up