IRC channel logs

2017-05-21.log

back to list of logs

<destt_> http://paste.lisp.org/display/347173#1
<destt_>I've updated the neko package I am trying write
<destt_>now getting `guix build: error: #<unspecified>: not something we can build`
<destt_>when I run `guix build -f neko.scm`
<quiliro>there is an error on installation of guixsd
<civodul>destt_: that's because neko.scm does not return any value
<civodul>whereas "guix build -f" expects a file that returns a package object or similar
<civodul>instead you could drop neko.scm in GUIX_PACKAGE_PATH
<civodul>for "guix build -f", see https://www.gnu.org/software/guix/manual/html_node/Additional-Build-Options.html#Additional-Build-Options
<civodul>for GUIX_PACKAGE_PATH, see https://www.gnu.org/software/guix/manual/html_node/Package-Modules.html
<quiliro> guix system : error: build failed: build of /gnu/store/...-guix-0.12.0.drv failed
<quiliro>before that
<quiliro>phase 'check' failed after 10.1 seconds
<civodul>quiliro: could you paste the lines that start with "FAIL:"?
<civodul>above that one
<quiliro>civodul: i would have to retype them
<destt_>put neko.scm on the path
<quiliro>should i do that?
<destt_>tried running `guix package -i neko`
<destt_>getting this error: ERROR: no code for module (neko)
<civodul>destt_: take a look at the footnote on Package-Modules.html
<civodul>on module name vs. file name
<civodul>a module called (a b c) must be in a/b/c.scm
<quiliro>Make file:4400: tests/cpio.log] Error1
<quiliro>check-TESTS] Error 2
<quiliro>check-am ] Error 2
<quiliro>check-recursive ] Error 1
<quiliro>check] Error 2
<quiliro>builder for '/gnu/store....-guix-0.12.drv' failed with exit code 1
<civodul>there's no "FAIL:" here :-)
<destt_>civodul: alright, got that fixed, thanks! Now I need to figure out how input works, but I gotta go right now
<civodul>cool!
<destt_>thanks for the advice (lfam as well!)
<civodul>yw
<rain1>can I see the list of bootstrap binaries?
<quiliro>so what should i do about this failed build?
<quiliro>could it be because i included swap?
<retard>I'm consistently getting an error messgae for a faulty hash in /gnu/store/288vbaj26b5mijg1mlj6wail4v8fq2y1-libcap-2.24.tar.xz
<retard>and it's causing /gnu/store/pwkf255vaivs0jwsx42qzb3r79q3vww8-i3-wm-4.13.drv build to fail
<quiliro>retard: i am having probles too
<quiliro>did you try guix pull first?
<quiliro>my build fails
<quiliro>i will tryed last time with guix pull
<quiliro>and it was working
<retard>no, I dind't try that, i'll do it real quick
<quiliro>except that i had a power down
<quiliro>had to start again
<quiliro>and in a celeron D machine!
<quiliro>can you imagine?
<retard>Lol, I certainly wouldn't like to :-)
<retard>quiliro: how do I use pull command?
<quiliro>guix pull
<retard>just tried guix pull and crossing fingers
<retard>lol ok perfect
<quiliro>exactly
<quiliro>it is similar to aptitude update
<quiliro>or apt-get update
<quiliro>retard: have you used it?
<retard>yes, loads of text streaming currently
<retard>no entry for pull in man?
<retard>ok it says "updated GNU Guix successfully deployed under '/root/.config/guix/latest.. is my install done?
<quiliro>retard: alt F2 will show you the guix manual
<quiliro>it has guix pull somewhere
<retard>quiliro: ahh ty
<quiliro>retard: now resume your process....guix system init
<quiliro>etc
<retard>ok, perfect that's what I did.. Thank you
<quiliro>just press the up arrow twice
<quiliro>oh good
<retard>quiliro: And this should be used anytime --fallback fails?
<retard>as in with my sha256 hash error?
<quiliro>retard: i don't think so
<retard>Oh ok, well I didn't get a chance to read the man pages for it.. do you know what it does exactly?
<quiliro>--fallback is used to download the sources and not use the derivations
<quiliro>when the derivations are not avalable
<quiliro>the error message will tell you to use --fallback when you need it
<quiliro>but guix pull will update the package manager (guix) and the list of packages it handles
<quiliro>so guixsd can use those packages that guix will install
<quiliro>the new ones because you used guix pull
<quiliro>retard: is that clearer?
<retard>Oh ok, yes thank you, hopefully that works around my problem
<quiliro>retard: even if you don't understand it the first time, read the whole info guix
<quiliro>you will get the hang of it more and more with every pass
<quiliro>i think the problem is the time it takes
<quiliro>a very new machine is required
<quiliro>the newest machine i have is a core 2 duo
<quiliro>and it has efi
<quiliro>so guixsd usb installer does not support it yet
<quiliro>i have to install guix inside debian
<quiliro>as a package manager
<retard>how new is very new?
<retard>it does take awhile
<ng0>person with the r: there is a current memory leak, once that is fixed it will not require 'very new' machines
<retard>oh ok
<quiliro>ng0: that is good news
<quiliro>i was going to ask a university to lend me their servers
<quiliro>rekado_: since you work with clusters, do you think a libre server is possible? or is it necessary to make a cluster to make a real libre server
<quiliro>?
<ng0>clusters are servers
<gazon>ng0: do you still work on the gnunet package, and if so, what's the current state of the package?
<ng0>yes. well it is complete, outside of guix. Now I'm just learning more about services and debug my gnunet-service so that I can work on one of my roadmap items which is the -fs distribution. And life is also happening, so I have to make space for applications etc. but as it's central for my work, yes I am working on it
<gazon>yes, life does happen! thank you, i hope to get it running again some day. it's difficult on trisquel, but i have a guixsd in a qemu machine that i want to use.
<ng0>the state is also: depends on gnunet release (as 1 year ago ludovic did not want a pre-release) and that depends on Grothoff finding time to work on the 2 bugs between multiple jobs
<gazon>oh there's a thought: there's probably a difference between the guix-env.scm in the gnunet repo and the guix package. i have only looked at the former, but perhaps i should look at the latter.
<ng0>guix-env.scm in gnunet was initially maintained by myself but I just thought you meant the package in Guix.
<ng0>I have a developer collection in my guix package repo
<gazon>i will check that out! thank you.
<ng0>this is outside of gnunet.git as I haven't found a good solution yet for this mess
<ng0>the url should stay the same when I move the server next week, one moment
<quiliro>ng0: what i meant is that we could build a powerful server with ordinary machines or use a university server which is usually impossible to use with free drivers
<quiliro>or firmware
<quiliro>how to use untrusted keys?
<ng0>actually the sourcecode location will change. I will announce it somewhere when I do it, as I'm switching to include user style repos and also use different domains.
<quiliro>sorry wrong chatroom
<ng0>I will push my onion only changes to the public dns now
<ng0>gazon: git clone git://git.pragmatique.xyz/ng0-packages.git
<thomassgn>hi, I guess I've missed any messages about what I need to do when going from guile 2 to 2.2. I now got a bunch errors and warnings about 'load-thunk-from-memory' saying first a bunch of files are 'not an elf file' and then a bunch of other files saying 'no such file or directory'. How to proceed?
<gazon>ng0: "access denied or repository not exported: /ng0-packages.git"
<ng0>in that case the path is different.. one moment
<ng0>git://git.pragmatique.xyz/srv/git/ng0-packages.git ? It will be easier once the move to GuixSD is finished
<gazon>ng0: thank you, that worked. i see ng0/packages/gnunet.scm in there. lovely.
<ng0>there is a permanent mirror over at notbug.org/ng0/, it will also keep the path when I change the path on my server.
<gazon>ng0: noted.
<ng0>I will merge it back into gnunet once I had time to deal with the format problem. seems like some people really use it. good night
<ng0>the 'problem' is basically cross-repo dependencies and how I don't want to keep copies in gnurl, gnunet and gnunet-gtk etc repositories
<ng0>which is why the module in my package repo happened
<gazon>if only we could spend all our days working on important things instead of being slaves to the money-devil. it's good to see that progress is being made. i hope to be able to contribute some time soon.
<catern>hey #guix, I am not sure how to determine whether substitutes are being used when fetching source. does guix package print a message when it gets source code from hydra.gnu.org rather than downloading directly?
<quiliro>i have finally installed guix on debian
<quiliro>and installed ngnix with that guix
<quiliro>catern: check the chat log...i think it has been mentioned
<quiliro>or maybe in the forum
<quiliro>how can i configure a mirror?
<quiliro1>error: no se pudo realizar la operación (archivos en conflicto)
<quiliro1>openssl-1.0: /usr/lib/libcrypto.so.1.0.0 existe en el sistema de archivos
<quiliro1>openssl-1.0: /usr/lib/libssl.so.1.0.0 existe en el sistema de archivos
<quiliro1>Ocurrieron errores, por lo que no se actualizaron los paquetes
<quiliro1>pacman -Syu --force
<drakonis>oh boy
<drakonis>its a arch user
<drakonis>great!
<catern>hmm
<catern>I figured out my thing with substitutes
<catern>but here's an idea
<catern>is it possible for guix to do ./configure caching?
<quiliro>woops....wrong chatroom
<quiliro>parabola user
<catern>to generate a configure cache file and provide that as a build input
<catern>that would speed whole system builds quite a lot
<quiliro>my guix system build error was solved with guix pull
<quiliro>por qué se fue la electricidad?
<quiliro>sorry
<quiliro>again wrong chatroom
<quiliro> https://gitlab.com/rain1/guix-wiki/wikis/home
<quiliro>it is great
<bob___>any dual booters here?
<destt_>Not yet ;)
<destt_>I am getting an error saying `warning: failed to install locale: Invalid argument` whenever I run a guix command.
<destt_>This started after I ran this: `guix archive --authorize < ~root/.guix-profile/share/guix/hydra.gnu.org.pub`
<destt_>This command is straight from the documentation, so it is weird to me that that would happen
<destt_> https://www.gnu.org/software/guix/manual/html_node/Binary-Installation.html#Binary-Installation
<janneke>destt_: https://lists.gnu.org/archive/html/guix-devel/2015-07/msg00675.html
<janneke>does this help?
<destt_>jenneke: yeah! Only problem is I partitioned root too small on my machine, so I can't install anything without running out of room
<destt_>:/
<quiliro>hi
<quiliro>what packages are needed for this instalaltion? https://github.com/rowinggolfer/openmolar1/blob/master/INSTALL.txt
<pookleblinky>What is the cheapest computer that guixsd will run on?
<pookleblinky>* (arbitrarily, to the degree of useability of an rpi running raspbian)
<janneke>pookleblinky: the one someone donates? -- i don't really get the question
<efraim>quiliro: looks like pyqt@5, mysql or and xdg-utils
<quiliro>pookleblinky: i was running guixsd on a core duo computer (32 bits)
<quiliro>sorry...dual core
<efraim>pookleblinky: I'd arbitrarily put the minimum at 2GB of RAM, 4GB of swap and an ssd
<rekado_>pookleblinky: I’m running GuixSD on a T60, also core duo, 32 bits.
<quiliro>32 bit processor
<quiliro>guix package -i python-pyqt
<quiliro>mariadb
<quiliro>pookleblinky: but it took a week to install gnome
<quiliro>desktop
<quiliro>efraim: so i have to install python-pyqt, mariadb and xdg-utils
<quiliro>?
<efraim>i would put them in the inputs for your package definition, and probably pkg-config in native-inputs
<rekado_>quiliro: it’s very unusual to need a week to install gnome.
<efraim>building everything from source?
<quiliro>why do i get a bunch of mesages as theese when guix package -i ?
<quiliro>;;; WARNING: loading compiled file /home/quiliro/.config/guix/latest/gnu/packages/zile.go failed:
<quiliro>;;; ERROR: In procedure load-thunk-from-memory: not an ELF file
<quiliro>efraim: i do not know how to make a package definition
<rekado_>quiliro: this means that you’re using Guile 2.2 but you make it load Guile 2.0 modules
<quiliro>it takes such a long time to install guixsd for me
<rekado_>quiliro: it’s easy to learn how to make a package definition, and it’s much easier than having to manually build things repeatedly.
<quiliro>of course all my machines are old
<rekado_>mine too :)
<quiliro>my newest is macbook air core 2 duo 64 bit
<quiliro>my oldest core duo 32 bits
<quiliro>it is always needed to use fallback
<quiliro>when i install guixsd
<quiliro>so that is why i am trying to lift a nginx guix package mirror
<quiliro>guixsd system packages i mean
<quiliro>because i do not have a connection
<quiliro>i have to travel for 1 hour and a half
<quiliro>so sometimes i have to stay on a couch
<quiliro>i will wait for version 0.13 to install guixsd on my efi macbook air
<quiliro>because it is not ready for libreboot
<quiliro>perhaps i am doing something wrong that it takes so much time
<quiliro>i am installing bare-bones.scm now
<quiliro>and it has taken 24 hours
<quiliro>wait
<quiliro>from yesterday 15h -utc-5
<quiliro>up to now
<quiliro>on a celeron D machine
<quiliro>it is 64 bits
<quiliro>i could not pass a certain point on guix system init
<quiliro>until i decided to use guix pull
<quiliro>and then guix system init worked
<rekado_>but that’s because you’re compiling from source
<quiliro>i had no choice
<quiliro>when i installed on the core duo i had "network problems" and guix recommended --fallback
<quiliro>and today i had to guix pull
<quiliro>i don't remember if it suggested --fallback this time
<rekado_>yeah, it’s hard with poor network.
<quiliro>but it is not my network
<quiliro>it is ok here
<quiliro>on my place there is no network
<quiliro>or sometimes there is but is very poor
<quiliro>but here i get 1MB/s
<quiliro>would it be possible to wget hydra so i can go to sleep in abed?
<quiliro>(not on couch)
<quiliro>now i have debian with guix installed in it
<quiliro>i have guix package -i python-pyqt mariadb xdg-utils
<quiliro>will that be enough for installing openmolar?
<quiliro>as per the link i provided before?
<quiliro>be back in a minute
<quiliro>i do not get those long errors on my debian anymore
<quiliro>just
<quiliro>warning: failed to install locale: Invalid argument
<quiliro>one line!
<quiliro>with guix...i am talking about
<rekado_>this means that the locales are not set up properly in the daemon’s environment
<ng0>sneek: later tell gazon: I removed unused code in guix-env.scm in gnunet and added a note to the alternative repository location
<sneek>Got it.
<quiliro>rekado_: that is a problem of debian then?
<quiliro>locales
<rekado_>quiliro: no.
<rekado_>quiliro: the manual explains how to set up locales.
<rekado_>quiliro: you may need to change the systemd service file.
<quiliro>on making an scm package definition
<quiliro>how can i get
<quiliro>(sha256
<quiliro> (base32
<quiliro> "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9"))
<quiliro>replace the hashmark
<quiliro>how can i get the appropriate hashmark? is it described in the manual?
<ng0>yes, and also guix hash --help
<civodul>Hello Guix!
<rekado_>civodul: hello!
<civodul>hey rekado_!
<civodul>i'm doing a few sanity checks on version-0.13.0
<civodul>and then hopeing to run "make release" today
<rekado_>civodul: nice!
<rekado_>should we test something before that?
<efraim>civodul: did you get the guix binary to build on aarch64?
<pookleblinky>quiliro, efraim: Hm, still sounds a bit higher-end than I'd like.
<civodul>efraim: not yet!
<efraim>I was afraid of that
<civodul>rekado_: you could run "guix system image --image-size=1.2G' and try it out
<civodul>i just tried the x86_64 one, which is okay, modulo some missing substitutes
<civodul>you could try the i686 one
<rekado_>civodul: okay, will do!
<gazon>ng0: thank you. am looking forward to getting gnunet running again and you've made that easier now.
<sneek>gazon, you have 1 message.
<sneek>gazon, ng0 says: I removed unused code in guix-env.scm in gnunet and added a note to the alternative repository location
<rekado_>civodul: trying to compile on i686 now, but I fear I might not have enough memory
<civodul>:-(
<civodul>another one of these terrible bugs we'll have to address
<civodul>you could test on an x86_64 machine if you have one
<wingo>or if you want to delay, we can look into fixing in guile.
<civodul>wingo: i think we'd rather have a 0.13.1 with the fixed guile
<rekado_>or we could release 0.13.0, fix the problem with guile, and … what civodul said :)
<civodul>yay :-)
<wingo>:)
<catonano>ng0: are you here ? I sent you a couple of emails
<ng0>yes. I an answer emails in about 12 hours or so, still 200.000 to convert
<ng0>I'll look on my server to see what you asked
<ng0>Wow :) looks like you made some progress with gnunet-texi. I'll apply it as soon as I can get the mail safely.
<ng0>about pgg and tor, don't wory. I can sign the commits off.
<ng0>it would've made it easier to just give you commit access, but any way works
<felicien>Hi guys; is there a GuixSD forum somewhere ? Would it be a good idea to launch one ?
<catonano>ng0: ok, wonderful
<catonano>thanks !
<ng0>no, thanks to you :)
<felicien>To share issues, solutions, custom packages, configurations...
<rekado_>felicien: there is the mailing list help-guix@gnu.org where you can ask for help with your configuration or with packaging.
<rekado_>felicien: issues should be reported to bug-guix@gnu.org
<rekado_>felicien: and solutions would best be added to the manual.
<felicien>Yes, I know, but a forum permits to keep discussions online, easily accessible for everyone
<rekado_>felicien: the mailing lists have public archives
<rekado_>and the manual should be easily accessible for everyone
<rekado_>(even when there is no network connection)
<felicien>Ok, ok. And a place for sharing configurations/custom packages ?
<ng0>maybe codesearch.com could help here, otherwise some people use gitlab, github, notabug or self host their repositories
<felicien>So, no centralized place only for GuixSD users.
<ng0>a forum/bbs/additional list/format requires administration and moderation.
<ng0>it would be good to have an quasi up to date list of URLs for this, I only know of a handful of people. I will list them soon
<ng0>Idk if 'how to customize your suckless.org packages' makes sense in the manual. I do this for some of my packages
<ng0>all it requires is including patches and/or inherit and substitute
<felicien>do we know how much the community is big ?
<rekado_>we don’t collect stats
<rekado_>and since Guix does not require a central build farm they wouldn’t be accurate anyway
<felicien>if we were enough some would be able to maintain a community forum or sthg like that. I say that because I know it can be an obstacle for some new users (from other distributions where there are forums) who may not use mailing lists
<felicien>ng0: where would you put that list of URLs ?
<ng0>a link section on my website
<ng0>or something similar
<felicien>I guess the fact there is no forum/community place is also due to the fact we (guix) are hosted by gnu.org, and don't have a lot of space to waste
<ng0>gnu projects are not bound to gnu infrastructure.
<felicien>savannah, I meant
<rekado_>my experience with fora has always been pretty bad. They contain outdated conversations, poor recommendations, and often bad advice.
<rekado_>the Ubuntu forum, for example, was pretty bad and created more problems than it solved.
<rekado_>it would also be unlikely that those who know about the system would use the forum, so it would be even more likely to get bad advice there.
<rekado_>if there’s something that the manual is missing (e.g. examples or a tutorial), then it should be added
<felicien>I don't totally agree, this looks like elitism to me
<rekado_>quite the opposite
<felicien>Look at Gentoo's forum, it is not a bunch of bad practice
<rekado_>our goal is to make the manual easy to understand for everyone and to keep it up to date and matching the version of Guix that the user has installed.
<felicien>Yes, but a goal of a forum is to answer to specifics questions, which can after been seen easily by anyone
<felicien>[sorry for my bad English, it is not my mother tongue]
<rekado_>we already have help-guix@gnu.org for that purpose. It is archived and can be viewed with a web browser.
<felicien>I tried to find an answer to one of my problems on the archives, I spent a lot of hours, whithout finding anything at the end.
<felicien>It didn't seem "easy" to me..
<OriansJ>felicien: well what would seem "easy" to you?
<felicien>Discussions where all answers are on the same page, with a [Solved] header in the titled, and links to similar topics, for example.
<ng0>so ntp with just a few extras on top
<ng0>I meant newsnet
<OriansJ>felicien: sounds like what you want is a more expansive troubleshooting guide to be written
<rekado_>someone could write a web UI for help-guix@gnu.org, I suppose.
<OriansJ>probably with the error messages as keywords to enable faster discovery and solution
<ng0>I was wrong. nntp.perl.org doesn't list similar results in the thread view.
<felicien>and categories, filtered by [keyword headers]
<felicien>yes, a UI for help-guix would approach what I look for
<felicien>I will focus on the issue, and come again to you.
<OriansJ>felicien: I have an idea
<OriansJ>What if we create a guix troubleshooting manual and you can help us create our problem list and categories
<felicien>by quoting help-guix ? or by writting from scratch articles ?
<quiliro>i want to help with that!
<ng0>I think both
<OriansJ>why not both depending on the issue
<felicien>ok. I can create a public repository for it
<OriansJ>and the rest of us will try to supply you with the answers and help that we can provide
<OriansJ>felicien: I look forward to seeing your work :D
<quiliro>Name Service Switch is necessary on a foreign distro as 2.6.2 says.....this service has to be started from outside guix as if guix were not present?
<quiliro>the same way?
<rekado_>quiliro: yes.
<rekado_>(if you mean ‘nscd’)
<quiliro>yes
<quiliro>i am in debian......what package should i install? nscd?
<quiliro>/etc/nsswitch.conf
<quiliro>it does not mention nscd
<quiliro>only the above conf
<quiliro>i have no idea what to do
<efraim>do you have apt-file installed?
<rekado_>quiliro: actually, the manual just says that you should run ‘nscd’
<rekado_>you don’t need to edit /etc/nsswitch.conf to use Guix.
<rekado_>civodul: my i686 froze while trying to compile Guix.
<civodul>:-(
<rekado_>it has 3GB of RAM
<civodul>what would you suggest?
<quiliro>efraim: i don't know
<rekado_>I don’t know… this wouldn’t happen if there was a substitute.
<civodul>yeah
<quiliro>is there a way to configure guix such that each guix user that downloads the source uploads substitutes by default?
<quiliro>guix publish i think it is
<quiliro>or upload derivations is a more ample term...right?
<quiliro>efraim: i just installed it now
<quiliro>what do you suggest? 'apt-file nscd' ?
<quiliro>'apt-file search nscd'
<OriansJ>quiliro: how about something like debian's popularity contest. Where the users opt into always doing that whenever they build a package?
<quiliro>i am trying to make a scm package definition
<quiliro>wow this is emotional!
<quiliro>i am excited
<OriansJ>quiliro: I like the idea of letting people choose if they want to become part of the very important build audit infrastructure. and I look forward to seeing your work on it
<jlicht>hello guix
<quiliro>please tell me how to find the package url
<janneke>hi jlicht!
<quiliro>i have this git link for openmolar https://github.com/rowinggolfer/openmolar1.git
<quiliro>and this https://github.com/rowinggolfer/openmolar1/archive/master.zip
<quiliro>for a compressed archive
<quiliro>(method url-fetch)
<quiliro> (uri (string-append
<quiliro> "https://github.com/rowinggolfer/openmolar1/archive/master.zip"))
<quiliro>is correct?
<janneke>have a look at other github urls in gnu/packages/*.scm
<OriansJ>that reminds me, lightdm is still producing http://paste.lisp.org/display/347220
<janneke>you probably want something with a version in it, and probably a .tar.gz or something
<quiliro>where can i find a scm file sample?
<OriansJ>quiliro: for packages there are a collection here https://gitlab.com/rain1/guix-wiki/wikis/Packaging and the guixsd manual has a couple examples
<quiliro>i am still a long way from making a package definition
<quiliro>still have to read a lot
<quiliro>i do not want hand holding
<quiliro>i do not want to waste people's times when they have already documented it
<quiliro>so i will read and then ask questions about making the scm file
<quiliro>even so, i am really excited! this is like having a child
<quiliro>or being a creator!
<quiliro>or being an actor instead of a spectator
<quiliro>by the way...there is a public technical academy which i will be speaking with on tuesday
<quiliro>i told them i was a member of the board of free software foundation latin america
<quiliro>i would like the students to contribute guix
<quiliro>what are some easy tasks for them to do, considering they probably haven't even used GNU
<quiliro>?
<quiliro>for starters
<quiliro>translation to spanish i think would be a good one!
<jlicht>quiliro: package the software they use daily ;-)
<quiliro>jlicht: i cannot teach them that yet
<quiliro>i don't know how to do it....i am reading
<rain1>making a package isn't too hard
<quiliro>but a tutorial would be great
<ng0>you could look at past presentations, it was presented :)
<quiliro>oh...that is great
<quiliro>the only presentations i saw were the definitions were shown....not where they were constructed
<quiliro>does someone remember one that shows how'd they do it?
<quiliro>is there an ebook format of the guix manual?
<ng0>make doc/guix.pdf should be fixed now I think
<quiliro>pdf files do not show well on ebook readers
<quiliro>but i did download guix.pdf...thanks
<quiliro>xdot is necesary for using guix graph dot command, right? the example gave me an error
<catonano>quiliro: there are several presentations
<jlicht>quiliro: k2pdfopt might help to make pdfs a bit more usable on ebook readers! It is quite hard to build on linux though.
<quiliro>i saw several presentations...but non show _how_ to make a scm file...they showed the file and said it was easy to make
<catonano>I see
<quiliro>python 2.7.13 is not python3 or is it?
<catonano>python 2.7.x is python-2
<quiliro>oh
<catonano>python is python 3.x
<catonano>sorry
<catonano>I mean python3 is python .x
<catonano>ouch :-/
<quiliro>i installed python with no version but i see python 2.7.13...perhaps both are installed
<catonano>python3 is python 3.x
<quiliro>but i saw something about python 2.7.13 while installing xdot
<quiliro>and i cannot see another version of python installed with 'guix package -I python'
<quiliro>I= capital i
<quiliro>guix graph -e '(@@ (gnu packages commencement) glibc-final-with-bootstrap-bash)' | dot -Tps > t.ps
<quiliro>gives me an error
<quiliro>;;; ERROR: In procedure load-thunk-from-memory: No such file or directory
<quiliro>guix graph: error: fport_write: Broken pipe
<quiliro>even after installing xdot
<quiliro>could not fin dot command
<quiliro>what package should i install?
<quiliro>oh...i have to install graphviz
<quiliro>made my forst graph!
<quiliro>first
<quiliro>how can i include that in the manual (to install graphviz to be able to use the guix graph example)
<efraim>I think it might be a good time to introduce guix environment, 'guix environment --ad-hoc graphviz -- guix graph ...'
<quiliro>i get this message
<quiliro>;;; WARNING: loading compiled file /home/quiliro/.config/guix/latest/gnu/packages/zile.go failed:
<quiliro>;;; ERROR: In procedure load-thunk-from-memory: No such file or directory
<quiliro>weird...i closed the terminal and opened it again.....the same command gave me an error
<quiliro>the one that was successful before:
<quiliro>guix graph coreutils | dot -Tpdf > dag.pdf
<quiliro>i think the manual does mention graphviz
<quiliro>"By default, guix graph emits a DAG representation in the input format of Graphviz, so its output can be passed directly to the dot command of Graphviz"
<quiliro>but I did not read that part before haha
<quiliro>i don't quite understand the difference between package, bag-emerged and bag in guix graph.....i know they are inlcuding more dependencies....but i don't understand what defines to show them or not....aren't dependencies impossible to avoid mentioning?
<quiliro>i will have to read about impicit dependencies and
<quiliro>bootstrap dependencies
<quiliro>i don't get what they are
<quiliro>perhaps package shows the dependencies to run the package in question
<quiliro>and bag-emerge includes the packages needed to build it
<quiliro>and bag includes even the packages needed to build the packages which are needed to run and build the package in question
<quiliro>is that correct?
<quiliro>what do you call a definition made by making a scm file for a package? is it a guix package or a guixsd package or a GNU system package?
<rain1>I call it a guix package but that may not be the correct term...
<quiliro>the question really is: what do you call a definition made by making a scm file for a package? is it a guix package definition or a guixsd package definition or a GNU system package definition?
<quiliro>oh
<quiliro>it would be nice to make a tutorial for guix and guixsd
<rain1>quiliro: i made a wiki for my personal notes a long time ago
<rain1> https://gitlab.com/rain1/guix-wiki/wikis/Packaging
<quiliro>something that would be easy and that could be used offline in case of low bandwidth and with binaries in case of low resource machines
<rain1>maybe this needs updated a bit, but you can try ti
<quiliro>rain1: i saw the link some hours ago
<rain1>really ?
<quiliro>i will clone it so i can study it offline
<rain1>you can edit it if the instructions are out of date
<quiliro> https://gitlab.com/rain1/guix-wiki/wikis/Documentation
<quiliro>i think you sent it to the list....am i wrong?
<rain1>not recently
<quiliro>Fox sent it
<quiliro>about 14 hours ago to the help-guix mailing list
<rain1>oh
<solene>hello, I use guix on Ubuntu 17.04. I installed icecat with guix but it crashed pretty often. Does someone else encounter this ?
<m-o>hi solene, what's your version of icecat ?
<rain1>if anybody wants to edit the wiki i have for random guix notes, you can. just PM me your gitlab account name and I can add you
<rain1>and the best parts can of course be merged into the real guix documentation
<quiliro>rain1: "rain/unrar.scm: Added open source but NONFREE unrar package so I can..."
<quiliro>all open source software is free
<ecraven>quiliro: it is? even if I can't do anything but look at it?
<rain1>the source code has a condition on it: May not be used to reverse engineer the file format in order to create a compressor
<quiliro>just open source people think that open source is an option....libre people think that it is a need
<quiliro>then it is not open source
<ecraven>quiliro: well, it literally is :P
<ecraven>the source is open (to look at)
<quiliro>as of the definition by the OSI
<ecraven>yea, but do normal people actually know that definition?
<quiliro>then it is source open
<quiliro>normal....haha
<quiliro>normal people do!
<quiliro>you mean common
<quiliro>or rather
<quiliro>uninformed
<ecraven>I'd bet you that 99% of the world population have no idea of that definition
<quiliro>so the term open source is not a good guide to what that software conveys
<quiliro>ecraven: that i can agree with
<ecraven>yea, same as "free software" (which totally implies it is any software that doesn't cost me anything, like free beer)
<quiliro>so 99% of the population is abnormal?
<ecraven>"libre software", that sounds like a technical term
<ecraven>liro: I believe the usual definition is whatever >50% believe is "normal"
<quiliro>i think that libre is a great term
<quiliro>ecraven: i do not like the term normal
<ecraven>that I can agree with ;)
<quiliro>normal is that which adopts the norm
<quiliro>the norm is not necesarily the majority use
<quiliro>the norm is just a standard
<ecraven>it would probably help everyone but francophones (and spanish-speaking people?) if we used "libre software" more
<quiliro>software libre in spanish
<ecraven>sorry, afk ;)
<quiliro>i never use the term free software
<ecraven>yea, but libre is a normal word too in spanish, leading to the aforementioned problems
<ecraven>maybe we should use a lojban word, that'll be known to noone :P
<quiliro>libre in spanish refers to freedom
<quiliro>but some people in some circumstances use it as gratis
<quiliro>most know libre refers to freedom
<quiliro>livre in portuguese
<quiliro>librero in esperanto
<quiliro>libero
<quiliro>or as an adjective libera
<quiliro>it sounds like liberia
<quiliro>would someone please help me install openmolar on guix which is itself on debian
<quiliro> please
<quiliro>i have installed mariadb
<quiliro>on a guix which is running on debian
<quiliro>but i do not know how to start the service
<quiliro>maridb or mysql is required for openmolar1
<quiliro> https://github.com/rowinggolfer/openmolar1/blob/master/INSTALL.txt
<quiliro>i see that https://www.gnu.org/software/guix/manual/html_node/Database-Services.html
<quiliro>says how to do it in guixsd
<quiliro>but on debian?
<quiliro>my guixsd installation fails
<janneke`>quiliro: you can start it manually, or hook it up to debian's init service, systemd probably
<quiliro>oh
<janneke`>but you're reverting to debian because guixsd install fails?
<quiliro>how to start mariadb manually? just type mariadb?
<quiliro>janneke`: i am installing in two machines
<quiliro>one will be server and the other has debian because guixsd cannot install on efi
<janneke`>if i had to guess, it would be ....-mariadb-0.0/sbin/mariadbd ...or something
<janneke`>you'll probably have to give it some options: daemonize or not, config file/port, db directory.. dunno
<janneke`>ah, efi blegh
<quiliro>how about the mariadb admin password?
<quiliro>how do you think i should investigate about mariadb? #mariadb?
<janneke`>quiliro: indeed, password
<janneke`>it would be nice if you could use the shepherd to start your database on debian
<janneke`>otherwise, why not use debian's db until GuixSD installs on your efi?
<quiliro>janneke: because guix has mariadb...i want to use as much guix as possible
<quiliro>i would rather have the server (guixsd) machine up
<quiliro>because i plan to make it an offline mirror
<quiliro>because i do not have connection at home
<quiliro>Testsuite summary for GNU Guix
<quiliro>total 706
<quiliro>pass 672
<quiliro>skip 32
<quiliro>xfail 0
<quiliro>fail 2
<quiliro>xpass 0
<quiliro>error 0
<quiliro>see ./test-suite.log
<quiliro>please report to bug-guix@gnu.org
<quiliro>error 1 on test-suite.log
<quiliro>error 2 on check-TESTS
<quiliro>error 2 on check-am
<quiliro>error 1 on check-recursive
<quiliro>phase 'check' failed after 1271.6 seconds
<quiliro>bavier`: do you have any idea?
<quiliro>on /mnt/tmp/guix-inst i have 4451 files
<quiliro>and it is a celeron machine
<davidl>quiliro I have been trying to install for the last 7 days and ran into this a bunch of times. What program is it failing with or is that the guix package manager?
<quiliro>guix system init /mnt/etc/bare-bones.scm /mnt
<quiliro>another error happened with --fallback which i do not remember
<davidl>ok, but is there any info above "Testsuite summary.." indicating what package build that failed?
<quiliro>davidl: i cannot find the file
<davidl>I couldn't either.
<davidl>I just read in the mailing list that some of the packages that fail with "gzip crc error read pipe error" stuff are due to hydra being overloaded and that it can be fixed by using wget and gunzip manually.
<quiliro>i am running updatedb
<davidl>so from a working machine I think you can just cp $(which wget) /mnt/some_usb and same for gunzip and then use that on GuixSD computer you want to install on.
<quiliro>so i can 'locate test-suite.log'
<davidl>oh.
<davidl>then you shuld perhaps report it to bug-guix@gnu.org or whatever the address is.
<quiliro>i cannot copy...i have to retype everything
<davidl>that's a bummer.
<quiliro>as i did in this chatroom
<quiliro>unless you know how i can redirect the output to a file
<quiliro>and send it to a paste
<davidl>probably just "guix init ..." > log.txt will work.
<davidl>if you wanna rerun the whole process.
<quiliro>test-suite.log does not exist
<quiliro>i have run the whole proces like 10 times
<quiliro>1 more is no sweat
<davidl>it's probably about time to get that issue dealt with then.
<davidl>however, idk if the guix init command output is what is being asked for when it asks for ./test-suite.log.
<davidl>Anyone considered IPFS for serving guix substitutes?
<quiliro>what is IPFS
<davidl>Interplanetary Filesystem
<davidl>distributed version-controlled replacement of http.
<davidl>pretty cool stuff :-P
<davidl>it deduplicates content on the web.
<quiliro>davidl: sounds great...when will you implement it?
<davidl>hehe, I will not :)
<davidl>I don't have the knowledge for that.
<quiliro>you could investigate
<quiliro>you would do a great service to people like me
***jamesrichardson is now known as j-r
<buenouanq>davidl: IPFS is certainly really neat, but GNUnet offers more and more important things
<davidl>buenouang: such as?
<buenouanq>anonymity
<davidl>ok. Is it easy to start using?
<buenouanq> https://gnunet.org/ they will be able to describe much more and better than I can
<davidl>I managed to figure out how to start hosting IPFS content on cjdns in 1-2 hours.
<buenouanq>if you're on a distro that has it, it's pretty much plug and play
<davidl>cool.
<buenouanq>if not you'll have to figure out how to build it
<davidl>it always seemed complicated to me. I guess I should give it more of a try.
<buenouanq>we're still waiting for the next major release which fixes a bunch of things
<buenouanq>and it's not back compatible, so the network is kind of disjoined right now
<davidl>mhm.
<buenouanq>is still worth reading about and figure out right now I think though so that when they push it you're ready to go and help others
<buenouanq>I'm so stoked on GNUnet, it's going to be the future of the internet.
<davidl>buenouanq: if IPFS is used for hosting on CJDNS/Hyperboria, then what benefits would there be to using GNUnet instead?
<buenouanq>next release I think will see a explosion of users and dev help and it will hopefully finally take off
<buenouanq>read their site
<buenouanq>I have to leave right now though - Hope you can figure it all out.
<davidl>alright. here's a pretty neat comparison also: http://secushare.org/comparison
<davidl>thx.
<quiliro>mysqld_safe Fatal error Can't create database directory '/var/run/mysqld/mysqld.sock'
<quiliro>i mkdir all directories asked by mariadb
<quiliro>and chown to my user
<quiliro>$ mysqld
<quiliro>2017-05-21 14:42:06 140401988646848 [Note] Using unique option prefix 'key_buffer' is error-prone and can break in the future. Please use the full name 'key_buffer_size' instead.
<quiliro>2017-05-21 14:42:06 140401988646848 [Note] mysqld (mysqld 10.1.23-MariaDB) starting as process 10008 ...
<quiliro>2017-05-21 14:42:06 140401988646848 [ERROR] Incompatible header in messagefile '/usr/share/mysql/english/errmsg.sys'. Probably from another version of MariaDB
<quiliro>2017-05-21 14:42:06 140401988646848 [ERROR] Aborting
<quiliro>should i report it to bugs-guix?
<quiliro>i installed mariadb from debian aptitude
<quiliro>and it is up and running
<quiliro>but i get this error when running the python install script for openmolar1
<quiliro>UnicodeEncodeError: 'ascii' codec can't encode characters in position 93-94: ordinal not in range(128)
<quiliro>i think it is something related to python and unicode
***jamesrichardson is now known as j-r
<quiliro>anyway...i still have the problem with guix system init /mnt/etc/bare-bones.scm /mnt
<quiliro> i added
<quiliro>> install.log
<quiliro>at the end
<quiliro>but install.log file came out empty and at less install.log, everything disappeared
<quiliro>so i cannot see what the error was
<quiliro>i think it is the same as the other times
<quiliro>how can i send the output to a file?
<davidl>that's weird.
<davidl>installation seems basically broken.
<davidl>I have failed all but like 1 installation the last 7 days, and that installation I couldn't use either.
<quiliro>davidl: i have to disconnect.....would you please file the bug report?
<quiliro>to bug-guix@gnu.org
<quiliro>i do not have a connection at home and it takes me one hour and a half to get home
<davidl>quiliro, no. I filed one before and they asked for the test-suite.log
<quiliro>which is the bug report?
<davidl>uhm let me check the number
<quiliro>the thanks
<quiliro>davidl: maybe you reported to help-guix
<quiliro>not to bug-guix
<quiliro> https://debbugs.gnu.org/cgi/pkgreport.cgi?pkg=guix
<davidl>that one: https://lists.gnu.org/archive/html/bug-guix/2017-05/msg00108.html
<quiliro>davidl: you say it is working now?
<quiliro>so leo closes the bug
<quiliro>what happenned?
<davidl>I just reflashed my usb and restarted.
<davidl>possibly an unnoticed write error with dd.
<davidl>there have been lots of strange behaviour with this installation for me.
<davidl>my LUKS-partition have been malformed and not recognized after a reboot. Partition boot-flags disappearing after a reboot and other stuff I don't remember.
<davidl>and then lots of builds and failed builds which shouldn't be necessary but are probably due to hydra being overloaded.
<quiliro>so after reflashing it worked?
<davidl>yeah, mostly at least.
<catern>has anyone backported guile 2.0.7 (or higher) to Debian 7?
<catern>I would like to deploy Guix on some Wheezy systems
<catern>ugh, that's embarrassing to say :)