IRC channel logs

2017-05-12.log

back to list of logs

<quiliro>unknown command
<quiliro>guix-daemon --build-users-group=guixbuild
<rekado>quiliro: where is that command?
<rekado>how did you install things? Are you using GuixSD?
<quiliro>rekado: no
<quiliro>in debian
<rekado>what installation method are you using?
<reepca>quiliro: that part there just means "that's how it could be run". Later in the binary install process it shows how to actually set it up to automatically run.
<quiliro>step 4 on https://www.gnu.org/software/guix/manual/guix.html#Binary-Installation
<quiliro>and 5
<quiliro>i cannot run the daemon, and set it to automatically start on boot.
<quiliro>4 was no problem
<rekado>why not?
<rekado>what’s wrong with step 5?
<quiliro>guix-daemon --build-users-group=guixbuild
<quiliro>unknown command
<rekado>have you tried step 5?
<reepca>that command is in step 4, isn't it?
<rekado>no
<quiliro>isn't that step 5?
<rekado>“5. Run the daemon, and set it to automatically start on boot.”
<quiliro>i created users and groups
<rekado>what follows is installing the systemd unit and starting the service
<quiliro>so now i have to do step 5 which i do not know
<quiliro>ok
<quiliro>how
<rekado>what do you mean?
<rekado>it’s right there
<rekado>“If your host distro uses the systemd init system, this can be achieved with these commands:”
<rekado>
<rekado>“If your host distro uses the Upstart init system:”
<rekado>
<reepca>Perhaps he didn't know which init system debian uses
<rekado>“Otherwise, you can still start the daemon manually with:”
<rekado>
<quiliro>oh ...sorry ...my bad habit of sequentiality and not holisticality
<rekado>quiliro: no worries.
<rekado>Debian probably uses systemd these days
<rekado>so the first series of commands should be executed here
<rekado>ACTION —> zzZZ
<ng0>I have a motivation to learn assembler now. I am going to write a shell.
<ng0>among other things.. but the editor I use now is nice, and it's so small
<quiliro>systemctl enable guix-daemon
<quiliro>Failed to execute operation: No such file or directory
<quiliro>but it is started
<ng0>yes, this is a "bug".. you need to use the absolute filename
<ng0>it's not covered in the documentation though.. I just assumed that people search the mailinglist
<reepca>When I tried "systemctl enable guix-daemon" I got the message "too many levels of symbolic links"
<quiliro>what is the absolute filename?
<ng0>uh... let me search the mail archive
<ng0>it is a com bination of read the guix documentation and read the links here: https://lists.gnu.org/archive/html/guix-devel/2017-03/msg00810.html
<ng0>no, it is written in the email not the links. the links are just context.
<quiliro>systemctl enable /root/.guix-profile/lib/systemd/system/guix-daemon.service
<quiliro>i get
<quiliro># guix archive --authorize < ~root/.guix-profile/share/guix/hydra.gnu.org.pub
<quiliro>warning: failed to install locale: Invalid argument
<reepca>quiliro: that's an annoying warning that will be addressed in https://www.gnu.org/software/guix/manual/guix.html#Application-Setup
<reepca>if there wasn't any other output, then it seems safe to say it succeeded.
<quiliro>oh...i thought that was only on other users, not on root
<quiliro>no other outpet
<quiliro>ut
<quiliro>haha
<quiliro>so now i have guix on debian
<quiliro>how can i generate the uefi usb now
<quiliro>mbakke: ^
<quiliro>how can i configure the nginx server to mirror all guixsd packages?
<reepca>now you use the binary install of guix to set up the right environment for building the wip-uefi branch
<reepca>"guix environment guix"
<reepca>once that finishes, make sure you have the wip-uefi branch checked out ("git checkout wip-uefi"). Then follow the instructions at https://www.gnu.org/software/guix/manual/guix.html#Building-from-Git. Once you have the wip-uefi branch built, I think there's some command you can use to produce a bootable image.
<reepca>ah yes, see section 7.1.7 of the manual for information on building the installer image.
<quiliro>reepca: as root?
<reepca>doesn't have to be
<quiliro>i am confused
<quiliro>ok
<quiliro>but making the installer image for uefi is different from the manual
<reepca>Ah. Then I'm not sure how that's supposed to happen. Maybe mbakke left a note about how that differs in the repository...
<reepca>Oh there it is, back in the chat a bit - "./pre-inst-env guix system disk-image --image-size=1200M
<quiliro>mbakke said: you can fetch the branch here: https://github.com/mbakke/guix/tree/wip-uefi
<quiliro>use "./pre-inst-env guix system disk-image --image-size=1200M gnu/system/install.scm" to build the installation image
<quiliro>and then dd it onto a USB drive as usual
<mbakke>quiliro: i'm back!
<quiliro>but i don't quite see how to do that
<quiliro>mbakke: i did the installation
<quiliro>but i also have to make the mirror so i can make the offline install
<mbakke>yay! did you also do the steps to set up the git repository as in https://www.gnu.org/software/guix/manual/guix.html#Building-from-Git ?
<mbakke>basically, just "guix environment guix", and then "./bootstrap && ./configure --localstatedir=/var && make"
<mbakke>add make -j10 to make it build a little faster :)
<quiliro>how about your uefi version?
<quiliro>guix environment guix
<quiliro>as root?
<mbakke>quiliro: you don't have to be root
<mbakke>I recommend doing it with a normal user account
<mbakke>quiliro: you should do a "guix pull" for the user first, though, to get guile2.2 guix
<mbakke>before using "guix environment guix" and configuring the git repository
<quiliro>it is running guix environment guix
<quiliro>how can i make a mirror for offline install
<quiliro>?
<mbakke>quiliro: you can include more packages in the installation image by adding them to "gnu/system/install.scm"
<mbakke>you can copy it somewhere, modify it, and generate a uefi disk image from it with "./pre-inst-env guix system disk-image my-install.scm"
<mbakke>anyway, did you run the bootstrap and make steps?
<mbakke>also, make sure you are on the "wip-uefi" branch by running "git checkout wip-uefi"
<quiliro>mbakke: i would like to have an installation image and a mirror to install the packages from
<ashtioee>hello there i have a question re derivation flags: does guix have a meta.priority like nix? and what is the default value? (zero in nix)
<ashtioee>couldn't find it in the manual
<quiliro>mbakke: i am a little lost
<quiliro>mbakke: could you tell me what to do after "guix environment guix"?
<quiliro>it is not possible to have a temporary connection for installing guixsd...it is a long download process
<reepca>"./bootstrap && ./configure --localstatedir=/var && make" (assuming you have the wip-uefi branch checked out. If you don't, or if you're not sure, run "git checkout wip-uefi")
<quiliro>it is imperative to have a way to download all derivations or sources
<quiliro>reepca: where is ./ supposed to be?
<reepca>In the git repository you cloned
<quiliro>oh...i erased it
<quiliro>ok
<quiliro>guix environment guix
<quiliro>is taking too long and i get cut off the connection en a while
<quiliro>i will clone again now
<quiliro>"git clone https://github.com/mbakke/guix.git"
<quiliro>right?
<reepca>yep
<quiliro>mbakke:
<quiliro>ok
<quiliro>done
<quiliro>mbakke: ./bootstrap: 5: exec: autoreconf: not found
<reepca>is that after "guix environment guix" succeeded?
<quiliro>did not finish
<quiliro>reepca: so it will have to be another day
<quiliro>i do not have connection in a few minutes
<quiliro>reepca: will it work after "guix environment guix"?
<reepca>it should, if not follow the instructions in 8.1 of the manual
<quiliro>reepca: thank you
<quiliro>very much
<reepca>also make sure you run ./bootstrap and the other commands in the same session you ran guix environment guix in
<quiliro>ok... :-(
<quiliro>:-(
<quiliro>:-)
<quiliro>that is it!
<quiliro>haha
<mbakke>reepca: thanks for covering, lol. looking forward to their feedback :)
<mbakke>was on the phone :(
<Lambda>Hello, I need some assistance booting guix
***Lambda is now known as Guest10610
<Guest10610>I did, dd if=guix of=usb bs=4096, and it won't boot, the screen flashes black when I attempt to boot it from my USB and that's all that happens
<brendyn>g; o;i jkkg bd=4096?
<brendyn>ACTION changes his keybourd layout back...
<brendyn>ACTION just gives up
<Guest10610>I don't want to give up just yet
<brendyn>Do you need bs=4096?
<brendyn>Are you using the 0.12 GuixSD image?
<Guest10610>Yes
<brendyn>I did that, but without bs=4096
<Guest10610>I'll give that a try
<brendyn>Do you have BIOS or UEFI?
<brendyn>I don't really understand much how UEFI works but Guix might not work with it at the moment
<Guest10610>BIOS
<brendyn>You decompressed the .xz image?
<Guest10610>Yes
<brendyn>for me, I ran sudo dd if=guixsd-usb-install-0.12.0.x86_64-linux of=/dev/sde
<Guest10610>guixsd-usb-install-0.12.0.x86_64-linux
<brendyn>it should be sdX, not sdX1 or sdX2
<Guest10610>That's what I'm doing now
<Guest10610>It's /dev/sdb for me
<brendyn>sha256sum guixsd-usb-install-0.12.0.x86_64-linux => 3ad03a796d091c536f4d3c5658efeb75fd65f8f4a6233c615dca0a8cced81005
<brendyn>You're sure you don't need the i686 version?
<Guest10610>Yeah, my PC is 64bit
<brendyn>Not sure what else to try then.
<Guest10610>I'm about to reboot to see
<Guest10610>It's not even showing up......
<Guest10610>This is what I get for forgetting to wipe the previous dd
<brendyn>I wouldn't have thought that would matter?
<Guest10610>Apparently it does
<brendyn>Maybe mine worked because I overwrote a ubuntu image ha
<Guest10610>Haha Ubuntu broke on me that's why I'm going for guix
<Guest10610>And also my friend has reccomened it to me
<brendyn>It's quite a contrast
<Guest10610>Before that I was using arch
<Guest10610>I'm doing the dd now
<Guest10610>Not showing up still
<Guest10610>I think this is where I give up for now
<Guest10610>I maybe back eventually
<DoublePlusGood23>Couple of questions. 1. is it possible to use GDM over SLiM, it seems to be in the repos. 2. is there a reason why the new GNOME Night Light isn't available?
<DoublePlusGood23>sleepy after work tonight so didn't do much deving
<brendyn>DoublePlusGood23: I think so yes. I asked about display managers before and the Boss said he'd be happy with GDM
<DoublePlusGood23>brendyn: I think it's the reason why I can't logout of GNOME, though I could be missunderstanding
<brendyn>I've never used a display manager before anyway
<DoublePlusGood23>brendyn: I like having the ability to logout and lock my screen
<brendyn>I'd like to start using gnome or kde stuff, but still have a tiling window manager
<DoublePlusGood23>brendyn: tiling wm's are great to. I used i3wm for about a year, but I kept running into edge cases.
<brendyn>DoublePlusGood23: I've heard some people run them within gnome so they can use gnomes toolbar, suspend, networkmanager, etc..
***andreh1 is now known as andreh
<rekado>“systemctl enable guix-daemon” should be enough. An absolute file name does not need to be given when systemd has updated its registry
<efraim>mbakke: I got the following error from your branch on my x86_64 machine: ERROR: In procedure #<syntax-transformer bootloader-configuration-bootloader>:
<efraim>ERROR: Wrong type to apply: #<syntax-transformer bootloader-configuration-bootloader>
<CharlieBrown>GuixSD desktop: https://lut.im/uvkTMYivEn/bi71VnX8mfebgI2N.png
<rekado>the java bootstrap is coming along nicely, but the test errors in kaffe really are problematic
<rekado>27 regression tests fail and it’s hard for me to understand them.
<rekado>analyzing this requires reading Java… :)
<rekado>looks like they are all related, though. Something to do with serializing arrays.
<rekado>I ignored the failures and tried to just use jikes+kaffe+classpath 0.93 to build ant 1.8.1, but it fails setting attributes.
<rekado>that’s a big deal because ant reads lots of xml files where each tag contains attributes to set.
<brendyn>CharlieBrown: Yay
<slyfox>when building packages with --no-substitutes is there an easy way to disable tests in all packages when derivations are built?
<civodul>hey slyfox
<slyfox>hia civodul \\o/
<civodul>slyfox: no, that cannot be done without changing the derivation
<slyfox>aha, and '#:tests?' is really a keyword for a particular build system, so i could flip the default locally as guix/build-system/gnu.scm: s/(tests? #t)/(tests? #f)/
<civodul>you could do that, but you'd end up with different store file names than everyone else
<b11111000000>is there a general guix way for auto mount usb devices configuration? If I don't use The Gnome?
<davidl>I just let guix system init --fallback run for over 2 days and then the process hanged and now the command hangs right away. I don't know how to get this installed.
<brendyyn>davidl: I've been going for 3 days. compiling webkit at the moment
<davidl>brendyyn, yeah webkit really takes forever. I did that too 3 months ago.
<davidl>is gpt supported?
<davidl>or must I use dos?
<brendyyn>no idea
<brendyyn>Sleep_Walker: Yo, any updates on LVM support?
<rekado>I’m happy: I just built a bootstrap ant (1.6.0) without the OpenJDK
<rekado>I used the unmaintained sablevm with jikes
<rekado>kaffe had lots of problems that could not be resolved, unfortunately
<rekado>jamvm requires a later version of GNU classpath (which cannot be built).
<rekado>sablevm comes with it’s own version of GNU classpath, and it just works
<rekado>it hangs trying to compile ant 1.8.x, but 1.6 is totally fine.
<rekado>will try with 1.7.x and then move on to building ecj.
<civodul>rekado: woohoo, impressive
<Sleep_Walker>brendyyn: sorry, no
<Sleep_Walker>brendyyn: I hope I'll play with that again on holidays
<brendyyn>Sleep_Walker: Cool. I think I'll just go for plain old ext4 for now
<civodul>rekado: in other news, i just pushed "proot-static"
<civodul>combined with 'guix pack', it provides an easy way to run Guix stuff in hostile environments :-)
<rekado>civodul: excellent!
<rekado>how slow does it feel?
<efraim>Does proot build on anything other than x86_64?
<rekado>what is your opinion on better documenting environment variables
<rekado>?
<rekado>I see that R, for example, needs CURL_CA_BUNDLE in order to find certificates.
<rekado>Should I just add this to the X.509 Certificates section?
<civodul>rekado: dunno, i haven't measured
<civodul>rekado: but for purely computational code, it shouldn't be a problem, i suppose
<civodul>efraim: supposedly yes
<civodul>rekado: re CURL_CA_BUNDLE yes, feel free to add it to "X.509 Certificates"
<rekado>woohoo: ecj-3.2 has built! Now I wonder if that’s already enough for classpath 0.99.
<civodul>you're a hero :-)
<roelj>rekado: Wow, really cool! I'm preparing myself for reviewing the second batch of Java patches. Unfortunately, it seems I only have time on monday.
<rekado>roelj: thank you! The second batch is much more regular. Almost nothing had to be patched.
<rekado>when this is done I should write a blog post and publish it on bootstrappable.org
<roelj>Definitely. This is another leap for GNU Guix I think.
<roelj>Why did we change '_' to 'G_' in the guix code?
<roelj>It broke GWL.. and I'd like to avoid finding it broken again.. :)
<rekado>roelj: I think it was to avoid a conflict with match syntax.
<civodul>roelj: you shouldn't use it though, because it looks up translations in the "guix" gettext domain
<roelj>civodul: Aha
<roelj>Then I'll remove it
<civodul>or at least, you shouldn't use it yet ;-)
<civodul>you could define your own G_ though
<brendyyn>Some code is just so mysterious I start to come up with conspiracy theories about it.
<Petter>brendyyn: Like what?
<brendyyn>I'm trying to package Helio Worksation, but the header files for JUCE seem to be generated with this proprietary program, and all the C++ code is dual licensed proprietary & GPL3 and there is no actually build script or anything
<brendyyn>I was wondering what motivated them to suddenly make this program a libre version, and where it even came from
<brendyyn>So far the makefile doesn't even work for me
<brendyyn>But I talked got word from someone in #fsf that uses JUCE and it seems legit
<brendyyn>Gyah, I can't type English anymore.
<rekado>sneek: later tell brendyyn JUCE is quite hard to package. I gave it a try some months ago, but it isn’t straight-forward.
<sneek>Will do.
<brendyyn>rekado: I'm still here.
<sneek>Welcome back brendyyn, you have 1 message.
<sneek>brendyyn, rekado says: JUCE is quite hard to package. I gave it a try some months ago, but it isn’t straight-forward.
<rekado>weird, ERC doesn’t give me name completion for your name.
<brendyyn>do I come up in /names ?
<brendyyn>rekado: What do we need to do to package it?
<rekado>brendyyn: it’s been too long since I looked at it. I just remember that it took me longer than I had patience.
<Petter>Claws-Mail isn't very good. I didn't exit it cleanly, and now it doesn't find my configured e-mail accounts...
<Petter>And when I initially configured it, I deleted the first account. And then as well it didn't find my accounts any more.
<efraim>it seems python-graphene is more than just bumping the version number
<jlicht>hello guix!
<catonano>hey jlicht !
<jlicht>\\o/
<davidl>I tried to install using GPT and it went well except for grub which says this GPT partition contains no BIOS Boot partition. And apparently you are supposed to make a separate partition and write "(parted) set N bios_grub on". Is it possible to do this in the Guix declaration?
<jlicht>I am getting some segfaults when giving input to a simple guile repl. Something regarding SIGABRT and (probably) readline.
<jlicht>I put my gdb session here: http://paste.lisp.org/display/346440
<jlicht>Do other people also have their `guile-2.2` located in `/gnu/store/3kqj6adsk53h0zr4fhbh9qmaq2rl0qci-profile/bin/guile`?
<civodul>hmm "herd stop cuirass" doesn't seem to stop the process
<m-o`>hi civodul, maybe it's because of guile-2.2 switch ?
<civodul>davidl: the GuixSD declaration doesn't say anything about your partition table; you really need to set those flags when you partition your drive
<m-o`>i've been doing a lot of herd restart cuirass without problem
<civodul>hmm
<civodul>m-o`: maybe it's the new snapshot that has this problem
<civodul>jlicht: is it on GuixSD?
<jlicht>civodul: Yes, it is
<civodul>hmm!
<jlicht>after doing the guix pull thing twice ;-)
<civodul>jlicht: people are unlikely to have the same profile as you
<civodul>can you reproduce it in "guix environment" or something?
<civodul>is it on x86_64?
<jlicht>it is on x86_64, but I will have to do some more research regarding the ¨guix environment¨
<jlicht>hmm, in `guix environment --pure --container --ad-hoc guile -- guile`, I do not have this issue
<jlicht>could it have something to do with guile 2.2 trying to load some 2.0-related files?
<davidl>civodul: yeah I realized it was a stupid question and did that. but thanks.
<balduin>how can I cross-compile guix for arm64? My goal is to run guix as package manager on top of debian on a Raspberry PI 3
<civodul>jlicht: it could be "something" in your environment, maybe something in GUILE_LOAD_PATH
<civodul>you can also try: env -i $(type -P guile)
<civodul>and see if that segfaults
<civodul>if it doesn't, then it's something related to your env vars
<civodul>balduin: "guix build guix --target=aarch64-linux-gnu" might work
<civodul>efraim is the expert :-)
<civodul>hmm actually it doesn't
<efraim>i have to go, i'll be back tomorrow evening-ish :(
<civodul>because of cmake-build-system, which doesn't support cross-compilation
<civodul>ok!
<efraim>and I don't seem to have an already uploaded unofficial binary-install tarball
<civodul>balduin: ATM i think your best bet on aarch64 is to build Guix from source (git master)
<efraim>oh, i have one on my aarch64 board, I can upload it to flashner.co.il/~efraim
<civodul>m-o`: re "herd stop cuirass", it's just the 'evaluate' process that kept going; 'cuirass' itself was stopped as expected
<civodul>efraim: neat!
<efraim>give it a couple of minutes, it should be there
<efraim>ACTION heads off
<jlicht>civodul: Thanks! I found the culprit: export TERM=xterm-256color somehow lets *something* in readline and/or guile crash
<jlicht>I had this export in my bash profile so my emacs theme rendered properly on temrinals, but I guess I will have to use something else
<civodul>jlicht: i can't seem to reproduce it, even with guile-readline loaded
<civodul>could you try to find a way to reproduce it?
<civodul>i'm curious :-)
<civodul>ACTION has to go
<civodul>later!
<jlicht>civodul: I´m looking for a way. Thanks for the help
<civodul>yw!
<balduin>@efraim: thanks :-)
<jlicht>sneek: later tell civodul: The segfault is very hard to pinpoint, as it comes from libc, but I can reproduce it each time TERM is set to *anything* x-related. Both the xfce and st terminals let guile crash, but not the non-Xorg C-M-<f2> tty.
<sneek>Okay.
<jlicht>Is there any practical reason why guix could not fetch its substitutes via e.g. bittorrent?
<paroneayea>so, does anyone else experience this with icecat?
<paroneayea> - disconnect fron the internet
<paroneayea> - open icecat
<paroneayea> - try to visit something
<paroneayea> obviously it won't load
<paroneayea> - reconnect to the internet
<paroneayea> - now it loads
<paroneayea>er
<paroneayea>sorry!
<paroneayea> - it still won't load
<paroneayea> - restart icecat
<paroneayea> - *now* it loads
<paroneayea>I've noticed this for a while and I've found it kind of disturbing?
<paroneayea>it doesn't happen in epiphany
<paroneayea>I tried opening a new icecat profile, same thing
<paroneayea>why does icecat require internet access when opened in the first place to continue working correctly?
<paroneayea>it makes me nervous that maybe something strange is going on.
<avoine>paroneayea: sounds like the offline mode is on
<paroneayea>avoine: how would that affect it?
<avoine>paroneayea: maybe it's caching the error page
<paroneayea>avoine: it could be, but then it's for all webpages.
<paroneayea>hm
<rekado>paroneayea: next time this happens check if “work offline” in the File menu was automatically enabled.
<paroneayea>avoine: actually, it's only happening in this one profile.
<paroneayea>rekado: looks like it isn't.
<paroneayea>maybe I should ditch this profile and recreate it.
<catonano>paroneayea: yes, I experience this too
<catonano>paroneayea: what do yo mean with "profile" ? The Guix profile or an Icecat speciic thing ?
<paroneayea>catonano: try `icecat --ProfileManager'
<paroneayea>catonano: glad to hear it isn't just me!
<catonano>paroneayea: ah, thanks
<paroneayea>ok
<paroneayea>I created a totally new profile and this stopped happening
<paroneayea>... disturbing!
<jackhill>Hi, If I'm looking at a package description, and see in the location for where a package is defined (e.g. gnu/packages/haskell.scm:1684:2). Can I look somewhere on disk to see the package description?
<rekado>jackhill: you can use “guix edit package-name”
<jackhill>rekado: thanks
<balduin>jilicht: it would be awesome to have bittorrent support in Guix
<civodul>m-o: hey!
<sneek>civodul, you have 1 message.
<sneek>civodul, jlicht says: The segfault is very hard to pinpoint, as it comes from libc, but I can reproduce it each time TERM is set to *anything* x-related. Both the xfce and st terminals let guile crash, but not the non-Xorg C-M-<f2> tty.
<civodul>ok
<civodul>m-o: did you see the trick in build-aux/build-self.scm to handle guile-ssh?
<civodul>(used by 'guix pull')
<civodul>you could do something similar for guile-git
<civodul>and reinstate the (guix git) commit that was reverted recently