IRC channel logs

2017-04-17.log

back to list of logs

<Lijero>mbakke: Failing to do what you suggested, despite trying for some time, what I'm actually trying to do is run icecat 52, but I'd also like a solution that works for other programs.
<mbakke>Lijero: try running `guix environment icecat` and then `export LD_LIBRARY_PATH=$LIBRARY_PATH`. What errors are you getting from icecat after starting it from the same shell?
<Lijero>mbakke: working on it, but I'm waiting on the incredibly slow series of nss tests
<buenouanq>I'm getting an error when I try to reconfigure.
<buenouanq> https://rectilinear.xyz/p/7cf924f4fc
<buenouanq>reverted to known working config and got the same thing
<buenouanq>ran guix pull prior
<buenouanq> https://rectilinear.xyz/p/b831adb6c6 here is config.scm
<Lijero>mbakke: it wasn't nss, but it took ages nevertheless. I'd like to be clear I'm running the binary off of the GNU ftp. First off, there was no linker, so I manually set it to a glibc-2.25 one in the store using patchelf. LD_LIBRARY_PATH is now set as you told me to, and [...] libstdc++.so.6 [...] no such file or directory
<Lijero>this is with a fresh untar, none of my weird patchelf failures
<methalo_>it's posible an if condition under configure-flags?
<sneek>Welcome back methalo_, you have 1 message.
<sneek>methalo_, phant0mas says: can I see the code you are using?
<methalo_>:) sneek
<methalo_>sneek: later tell phant0mas this is my definition: http://paste.lisp.org/display/344284
<sneek>Got it.
<buenouanq>anyone?
<buenouanq>considering just doing a fresh install
<buenouanq>but it'd be nice to know what's going on regardless
***Lijero_ is now known as Lijero
<Apteryx>Hello Guix!
<marusich>Hello!
<Apteryx>Is there something in the debbugs emacs integration (i.e., a function) that allows to easily apply patches to a git checkout?
<marusich>buenouanq, I think I found your problem.
<marusich>buenouanq, You've invoked (cons* %base-file-systems (file-system ...))
<marusich>I think that invocation is incorrect.
<marusich>For cons*, you want to put the elements you wish to add at the front, and the list to which you want to add them at the end.
<marusich>try (cons* 1 (list 2 3)) and (cons* (list 2 3) 1) in a guile repel and you'll see what I mean.
<marusich>So, put the %base-file-systems as the last argument to cons*.
<marusich>For details, see Section 6.7.2.3 "List Constructors" in the Guile Reference manual.
<marusich>The error message "Wrong type argument in position 1 (expecting struct)" is basically saying that it expected to find a <file-system> record, but instead it found a list.
<buenouanq>oh, interesting
<buenouanq>thank you marusich
<marusich>No problem! :)
<buenouanq>one thing that bugs me, and I don't know how easy this would be to fix, is that guix system reconfigure path doesn't TAB complete path for me
<buenouanq>the words system and reconfigure both do, but not the final path to the config file
<buenouanq>what does --fallback actually do any why does it always tell me to use it?
<brendyn>buenouanq: guix build --help
<brendyn>`--fallback fall back to building when the substituter fails'
<buenouanq> https://lists.gnu.org/archive/html/guix-devel/2016-10/msg00929.html this thread seems to indicate that it was fixed, but I'm still getting the same error
<Petter>Someone on github produced a Guix patch to update Go to 1.8 (currently we have 1.7.4), but they have not submitted it to Guix as far as I can see.
<Petter>Now I'd like to submit a patch for Go 1.8.1, using their insight to solve the problem of building 1.8.
<Petter>How should I do this, should I add the github user's name to the Copyright section?
<Petter>Their patch, https://github.com/golang/go/issues/19132#issuecomment-285897612
***jonsger1 is now known as jonsger
<slyfox>Petter: i'd say you can completely ignore attribution of that comment (i wrote it). If you find explanation useful you can put a link to go's package definition. But it's a very generic problem for guix. I'd say debugging those is the hardest part here :)
<Petter>slyfox: Yeah, good job debugging this! I was clueless :)
<Petter>I've sent an e-mail to guix-devel already, maybe you can follow this and chime in when necessary. https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00349.html
<slyfox>yeah, i'll respond to it as well
<slyfox>will finish testiong your patch first :)
<Petter>Great! :)
<methalo_>i need to replace install phase to fix this? , http://paste.lisp.org/display/344459
<slyfox>looks like package tries to modify directory external to package being buil
<roptat>you should probably fix the Makefile rather than changing the whole install phase
<roptat>or maybe use the glib-or-gtk-build-system?
<methalo_>ok, i will try both
<marusich>buenouanq, regarding tab completion, if you are using bash, then perhaps that is a bug with the bash completions that ship with Guix.
<marusich>If you're interested in fixing it, I suggest you look into the source for stuff that mentions words like "completion"
<marusich>I don't know where it comes from exactly, but somewhere, there is code that implements some Guix-specific bash completions.
<marusich>It's probably either in the Guix source tree itself, or pulled in via some sort of completion package. With a bit of sleuthing, I'm sure you can find it.
<jmi2k>Hi Guix, I have a question. Sometimes audio doesn't work, because /run/user/1000 doesn't exist. I just create and chown it and it works. What could be the problem?
<Apteryx>I've got nss build failure caused by failing tests. Anyone else has that? While updating keepassx.
<bavier>exciting to see the icecat 52 release!
<jonsger>bavier: sadly e10s is deactivated
<bavier>jonsger: indeed, yes
<jmi2k>Where should I send package patches now? Last time I used guix-devel but that changed IIRC
<m-o>jmi2k: You shall send them to guix-patches@gnu.org
<m-o>See here : https://github.com/pjotrp/guix-notes/blob/master/HACKING.org
<jmi2k>m-o: ok done. Thanks
<SovereignBleak>Are there ideological reasons why GuixSD isn't represented on Patreon? I'd love to throw some bucks.
<jonsger>SovereignBleak: you just can donate here https://my.fsf.org/civicrm/contribute/transact?reset=1&id=50
<SovereignBleak>I guess I like the idea of monthly patronage that Patreon sets up for you.
<SovereignBleak>Tiny dollar amounts that add up over time.
***kelsoo1 is now known as kelsoo
<jlicht>hello guix!
<bavier>hello jlicht
<jlicht>Today I kind of appreciated being able to instantiate a vm of my os config to debug some arcane kernel module problems. Is there any way in which a bare-metal GuixSD can also drop me into a guile repl if it runs into some weird issues while booting?
<lfam>jlicht: My understanding is that you will get a Guile REPL if the boot fails, although I'm sure there are ways for even that to fail
<jlicht>lfam: I guess weird OOM errors are not conducive to debugging ;-)
<lfam>jlicht: Ah, that's a case where not much will work as expected :)
<lfam>Definitely something to debug in a VM
<jlicht>also, I noticed *things* are using guile-2.2 now. Is the guix-scheme code compatible with this release?
<jlicht>because I keep noticing some load-thunk-from-memory mishaps when trying to work with guix code
<nckx>lfam: does downloading https://www.netfilter.org/projects/iptables/files/iptables-1.6.1.tar.bz2 work for you? The connection times out here.
<nckx>...it does so from New York as well. Hm.
<nckx>OK. Looks like netfilter.org is just down. Great timing, but nothing to do about it.
<lfam>Darm
<lfam>I mean, darn
<lfam>Well, I bet it will be back soon
<nckx>We shall revert, and we shall rebuild.
<lfam>BTW nckx, are you using iptables on GuixSD?
<lfam>If so, how do you do it? Do you have a custom service or something?
<nckx>lfam: it's in my system packages, so I have to say yes. Let's see if I can remember when and why. Why?
<lfam>nckx: I've been thinking about an iptables-service for GuixSD. For now, we don't have a good way for users to set up firewalling on GuixSD
<lfam>Firewalls, NAT, anything like that
<nckx>Ah, here's why. I was mucking around with iodined and firewall-level DNS packet inspection (kids: don't). Nothing fancy like a real firewall.
<lfam>I'm not the person to write the service, however, because I don't have much experience with iptables
<nckx>lfam: That would certainly be a nice feature for those of us *cough* crazy enough to run GuixSD on their servers...
<lfam>I guess we should look at what NixOS does and think about copying it :)
<nckx>lfam: I'll put it on my to-do list, but that's suffering from serious bufferbloat at the mo'.
<nckx>lfam: My secret thoughts exactly.
<lfam>Yeah, I can't commit to doing it. I've got too much already
<nckx>mbakke: Ouch. Ninja'd. (Which is fine ☺
<nckx>dangit
<nckx>now I must
<nckx>)
<lfam>The NixOS configuration syntax looks like this: http://paste.lisp.org/+7DT4
<lfam>I haven't looked into more complex configuration
<lfam>I was thinking that we should offer something similar for basic use cases, and then let users write real iptables rules if they need something more complicated
<lfam>nckx: You can get the identical source code for iptables and its new dependencies from Debian
<lfam>If netfilter.org is still offline in a couple hours, I'll revert the changes
<nckx>lfam: Marius just pushed a mirror:// patch. I'm trying it... now.
<lfam>Oh, nice :)
<nckx>ACTION glares at their slow VPS — but hey, at least it's GuixSD on a VPS.
<lfam>Did you `guix system init` on another distro, nckx?
<nckx>lfam: From a Ubuntu ‘rescue image’ with a few bind-mount hacks, yes.
<nckx>My personality type would never let me convert an impure running system. Yech.
<lfam>Cool. I'm using NixOS for my VPS so I can at least have a declarative system. But, I don't understand how to use it properly, so it's only a little bit better than using any other distro :/
<lfam>Heh, I can sympathize. I'm even skeptical of `guix system reconfigure` trying to change the running system. I still reboot every time :)
<nckx> /meanwhile iptables builds happily here ☺
<lfam>Cool, much thanks to mbakke for this improvement! I love it when we can collaborate like this :)
<nckx>lfam: I usually reboot as well. I had trouble with nginx not loading its new configuration otherwise. I'm sure that was some misunderstanding on my part, but... I'm lazy.
<lfam>nckx: Implementing `nginx reload` is still in the TODO phase
<nckx>lfam: Oh! Excellent. So I'm not a complete idiot.
<lfam>I don't remember if there's anything holding it up. I'd expect it to be simple to implement since nginx already handles the complexity internally
<nckx>ACTION eyes his to-do list seductiv—NO.
<lfam>Heh
<nckx>I urgently need to learn to write services. I think I looked at one too early in my Guix days and now I'm irrationally scared of them. I suspect you're right that it's not hard to do if you know what you're doing.
<lfam>It's never too late to start banging your head against the wall ;)