IRC channel logs

2017-03-04.log

back to list of logs

***MatthewAllan93_ is now known as MatthewAllan93
<amz3>I have question regarding package dependencies resolver
<amz3>the algorithm that does resolve dependencies like aptitude does
<amz3>I guess I can try to have a look at the code
<amz3>:)
<amz3>ah... maybe there is not the algorithm I look for in guix
<amz3>so maybe there is no such algorithm in guix
<amz3>ACTION reading aptitude-0.8.3/src/generic/problemresolver/problemresolver.h
<amz3>I am looking at the same algorithm used in npmjs
<amz3>s/at/for/
<paroneayea>rekado: submitted an email to bug-guix that captures the issue I think
<paroneayea>as well as the exact commit that caused it
<paroneayea>I did some more searching and git-bisect wasn't being precise
<paroneayea>more info in-email.
<ryanwatkins>Hi guys, I am trying to configure a guile library from source on GuixSD, any idea how to solve the error 'No Guile development packages were found'?
***Piece_Maker is now known as Acou_Bass
<Apteryx>ryanwatkins: Do you mean your are running the autotools configure script? (./configure) and it doesn't find guile?
<Apteryx>If this guile library has already been packaged, you can simply do "guix environment your_guile_library". It'll leave you in a (temporary) environment where all the package dependencies are installed.
<rekado_>paroneayea: thanks, I’ll take a look
<ryanwatkins>Apteryx: that sounds good but the library is not yet a guix package it seems
<ryanwatkins>Apteryx: I just cloned down the library repo and tried to do a configure
<ryanwatkins>Apteryx: in any case, when I perform guix environment guile, it still claims I have no dev guile package
<ryanwatkins>Apteryx: nvm, I noobed out. Dev guile is guile-next :D
<ryanwatkins>Apteryx: okay; now I am getting failed to create path for auto-compiled file ... etc, any ideas?
<catonano_>I' ve run into this effort to package Guix on Debian https://github.com/detrout/debian-guix
<azazel>hi all
<amz3>Someone added gnu guix to http://guildhall.hypermove.net/
<amz3>:D
<azazel>what's the reason the latest python package is still 3.5.2 when there is 3.6? It's simply lack of resources to packetize it or there is something else? and how can i have/make a package for 3.6?
<gnu_guix>UPDATE MINETEST TO 0.4.15
<adfeno>gnu_guix: It already is.
<ng0>also ALLCAPS ARE NOT LOOKING FRIENDLY IN TEXT
<adfeno>Please login as root in your system, do guix pull, then guix package -u.
<gnu_guix>ACTION is running guix pull.
<adfeno>Then, do the same as your normal user (login, guix pull, guix package -u)
<adfeno>This is covered in the manuals of course, but it's also a good idea to remember: Every user has its own profile.
<adfeno>So every user must do: guix pull; guix package -u
<azazel>i repeat my question i've written before, maybe now there is someone that knows the answer
<adfeno>in order to update recipes, and also to upgrade existing installed packages.
<adfeno>azazel: Indeed, go ahead :)
<azazel>what's the reason the latest python package is still 3.5.2 when there is 3.6? It's simply lack of resources to packetize it or there is something else? and how can i have/make a package for 3.6?
<ng0>too many dependencies
<ng0>one moment
<ng0>packages which cause a huge set of packages (400+ or something) to be rebuild are worked on in features branches and then merged into master
<ng0>for example in core-updates
<azazel>as an example in debian python3.6 is in experimental but not in sid because of release freeze
<azazel>ng0: are you writing to me?
<ng0>yes
<ng0>core-updates is due to be merged into master soon
<sneek>Understood.
<ng0>I'm not sure wether there is 3.6 python in there
<ng0>now how do I make sneek forget that
<ng0>I hope i didn't delete the core-updates fact
<ng0>sneek: what is core-updates
<sneek>Last time I checked Core-updates is fontconfig, eudev and cups-minimal FTBFS
<ng0>weird bot
<azazel>ng0: so if i wish to check if there is such a feature branch and then use it (i immagine you are referring to a git branch?) what should i do?
<catonano_>azazel: to check whether it exists or not, just refer to the official repo
<ng0>I think this started the wrong way. It's not really recommended to run a system from "core-updates" unless you know you want to help and fix issues in there
<ng0>last I know a python related branch was jus tmerged into master
<ng0>the branches are build by hydra/cuirass (continous integration systems) which then serve the binary substitutes later on
<ng0>as there is no concept of channels (yet) in guix, the default is "master"
<azazel>catonano_: i'm looking into http://git.savannah.gnu.org/cgit/guix.git but it's unclear to me how can i use another branch then
<ng0>if python-3.6 recipe is not in master, you will have to check wether it's in any other branch, use that and ru nyour system from a git checkout or contirbute to bump it
<ng0>I
<ng0>I don't have much time to explain small details, but someone else can fill you in
<catonano_>azazel: ng0 is being very exaustive about this. if you really want to, you can clone the repo locally, checkout to your branch, build it (it' s gonan be though). Then you can use it with ./pre-inst-env guix blah blah...
<catonano_>azazel: I would wait
<ng0>if it isn't documented well enough how to run a system from a branch, it should be fixed.
<azazel>also, i've found some errors in the docs
<azazel>here https://www.gnu.org/software/guix/manual/html_node/Emacs-Initial-Setup.html#Emacs-Initial-Setup
<ng0>the online documentation is not synced often enough with master
<azazel>it misses the required installation of emacs-guix package, which instead I've found on the info docs
<ng0>regarding your python question, I think now that python-updates was merged into master, I think you could simply work on an python-3.6 update and this will be used in next core-updates or python-updates .. or just ask on the mailinglist as not everyone uses irc
<ng0>"guix refresh --list-dependent python" is this right now:
<ng0>Building the following 934 packages would ensure 2413 dependent packages are rebuilt:
<azazel>well, its my second day with guix and guile so i think it will take me some more time to familiarize with the architecture and the tools :-) i was hoping start a replacement of my actual dev environment (built around docker) with something developed with guix, but now i'm wondering what to do....
<ng0>I think section 8 (contributing) of the handbook should give some info, otherwise feel free to ask anything
<azazel>thanks ng0 , I'll look into it
<ng0>azazel: for guile, I'd recommend "teach yourself scheme in fixnum days" and "pamphlet against R" as two introductions which cover basics
<azazel>ng0: thanks! mmm... "phamplet" seems so 19 century :-)
<azazel>s/19/19th/
<catonano>youtube footages work in Icecat but not in Web
<catonano>Can I do anything to make them work in Web too ?
<adfeno>Hm...
<adfeno>It could be that Web (epiphany) has to know how to open video/webm MIME type (the .webm file format). These use the WebM container.
<catonano>adfeno: so how do I instruuct it to deal with the video/webm mime type ?
<adfeno>catonano: That's an interesting question...
<adfeno>I'll search for this now.
<adfeno>catonano: I think I found a solution.
<adfeno>I'll test now.
<catonano>adfeno: thanks !
<adfeno>catonano: I'm about to test my solution now. I got the packages installed, now I just need to find a good video and see what else must be done.
<catonano>adfeno: ok, here's a good video https://www.youtube.com/watch?v=Ozipf13jRr4&t=23s
<adfeno>OK, I got something working.
<adfeno>Tested 3 videos so far
<adfeno>Including your suggestion.
<adfeno>However, one must note that, together with the vidoes comes the annoying ads.
<adfeno>I have tested here, and even though the ad blocker is enabled, the YT ads continue to be displayed.
<adfeno>catonano: To solve the playback issue, you must install gst-plugins-bad, and as an optional, install gst-plugins-good. The last one is optional because I, myself, have decided to install it, but various websites suggest only "-bad" to be needed.
<adfeno>Of course, I'm talking about Guix packages.
<adfeno>After the install, watchout for recomendations made by the Guix post-install process.
<catonano>adfeno: thank you very much.
<adfeno>It'll probably tell you that you need "such and such" variables in your profile.
<adfeno>Please follow such recomendations and re-login in your user session.
<adfeno>catonano: You're welcome :)
<jmd>I get an error building vtk. Does anyone else have that problem?
<jmd>Never mind. My bad.
<quiliro>catonano: how did you solve the video problem in Browser?
<Apteryx>Hi. Trying to run "reconfigure" failed at downloading "guile-lib-0.2.3". Many mirrors were tried, and in the end it downloaded from centervenu.com and failed the SHA256
<Apteryx>s/centervenu.com/www.centervenus.com
<catonano>quiliro: I installed gst-plugins-bad but that didn't resolve. I also installed gst-plugin-libva or something nut I didn't verify yet. I was readign something
<catonano>that didn't solve. Not resolve
<catonano>bah
<adfeno>catonano: As I said: try installing gst-plugins-good
<catonano>adfeno: ah I was confused. I remembered "bad". Ok, then, sorry
<adfeno>And also, if you did change your user's .profile, make sure that you have restarted your session.
<adfeno>catonano: No, you were in the right track.
<adfeno>Both -bad and -good.
<catonano>ah
<catonano>ok
<catonano>installing right now
<quiliro>WebM VP8 i think is the problem
<quiliro>i have both -good and -bad gst-plugins
<quiliro>but Web will not reproduce videos
<quiliro>and iceweasel will not reproduce vimeo.com
<quiliro>videos
<catonano>ah
<adfeno>quiliro: Have you restarted user session?
<adfeno>Also, follow what Guix says when it finishes installing -bad and -good.
<adfeno>It'll probably tell you that you need variables in your user .profile.
<adfeno>It'll tell you how to add these.
<catonano>adfeno: quiliro yes !! It's working !
<catonano>it works !!
<quiliro>i did not add variables in the user profile
<quiliro>and i installed those packages long ago
<quiliro>many restarts ago
<quiliro>catonano: how did you do it?
<catonano>quiliro: I installe gst-plugins-bad and gst-plugins-good AND gst-libav amd libav itself
<catonano>also, I set thhose env vars in .bashrc
<catonano>then I rebooted (I can't simply logout form Gnome)
<catonano>that made it
<Apteryx>Oh, the URL of guile-lib 0.2.3 changed. Now it's under old/ subfolder. Maybe we should update it to 0.2.5.
<quiliro>libav does not exist
<catonano>quiliro: just a minute
<catonano>quiliro: yes, I meant libva, sorry
<catonano>I read that rekado had to install it in order to work with the osdem videos
<quiliro>how can i check what version of a package is installed?
<adfeno>quiliro: guix package -I
<adfeno>guix package -I [Package name]
***joachifm_ is now known as joachifm
<quiliro>i have not installed: gst-libva libva
<catonano>too bad a simple video overheated the laptop :-/
<adfeno>catonano: Even using mpv to watch youtube videos (no ads! :D ) overheats somehow.
<catonano>adfeno: well, good to kknow
<catonano>how often do you get your thermal grease renewed, people ?
<adfeno>I'll probably uninstall -bad and -good and remove the variables from my .profile, I'll keep using IceCat to browse YouTube, and passing the video URLs to mpv when I want to watch the videos.
<catonano>adfeno: how do you manage to pass youtube videos to mpv ?
<adfeno>catonano: For unemployed poor people like me, I'm lucky if I can get it to be cleared once a year.
<adfeno>catonano: Manually :)
<catonano>adfeno: ok to both :-)
<adfeno>Copy the URL, and do: mpv "[URL]"
<adfeno>without braces.
<catonano>adfeno: ah, I see. Note taken. Thanks !
<lfam>azazel: The reason that Python is not updated yet is lack of human energy and build farm resources. I have a working update of Python 2, and the Python 3 update should not take very long for me to make a patch for.
<quiliro>adfeno: perhaps you can learn to do it yourself
<quiliro>i used white toothpaste instead of thermal grease once
<catonano>quiliro: did it work ? :-
<adfeno>Oh...
<catonano>:-)
<quiliro>it will do the job but i think thermal paste is not expensive
<quiliro>catonano: it did the job but was not the best
<azazel>lfam: thanks for answering my question, but won't be possible to have just the definitions for some packages? definitions and substitutes must always appear "in tandem" in the distro? Also, why not preparing a substitute for py3.6 without electing it the default python-3 implementation, postponing it for later when the package is tested? debian does that and it seems a good policy to me
<lfam>azazel: What you suggest is possible. The main limitation for that action is human energy
<lfam>Help wanted :)
<lfam>I'm currently re-testing the Python 2 update and then I will send it to the mailing list
<adfeno>I wish I could have done my computer repair course two or four years later than I did. As a result, I'm average desktop computer hardware repair person. But I don't know a thing on how to repair notebook hardware (or how to open it).
<lfam>azazel: I will say that I'm not willing to personally do the work to create multiple Python 3 packages. We have to maintain some patches on the Python 3 source code, and it's very tedious to maintain multiple versions of them.
<adfeno>There could be "python3-next"?
<azazel>ah, as a side-note, i do not really know how dependency specification works for guix, but i can easily immagine that it is as much as powerful the debian's one
<quiliro>adfeno: use old machines to practice
<lfam>azazel: It's totally possible. We just need "someone" to do it :)
<quiliro>adfeno: it is even easier than desktop once you get the hang of it
<lfam>I can do it today, after I dig in to another build failure for a few minutes
<adfeno>quiliro: Hm.... Good to know :)
<quiliro>adfeno: all you have to do is learn how to disassemble and be careful not to damage the parts
<lfam>azazel: In Guix, the answer to "why isn't this thing done yet" is usually "because nobody did it yet" :)
<azazel>lfam: oh, i would be gadly contribute, but i must say i never hacked with python source code
<lfam>azazel: The first step is to set up a Guix development environment, which is explained in the Guix manual, section Contributing
<azazel>lfam: it was what i thought... it happens also with the packages (python packages) i maintain ;-)
<lfam>I *would* like to try to update our Python packages more quickly. They do fix security issues in each release, but they are rarely publicized. But the limitations I mentioned earlier are real :)
<catonano>azazel: just out o curiosity: which python packages do you mantain ?
<lfam>Urgh, the version of flex on core-updates is going to cause lots of problems: https://github.com/westes/flex/issues/162
<azazel>lfam: I plan to install the full dev env... I see that in the package definition some tests are left out... what's the rationale on that? Incompatibility with some strange property of the guix distribution system?
<lfam>azazel: In particular, which tests?
<azazel>catonano: https://github.com/azazel75
<catonano>azazel: thanks !
<azazel>lfam: i was reading here http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/python.scm#n158
<lfam>azazel: In that comment, the tests marked as failed are disabled by one of the patches named here: http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/python.scm#n131
<lfam>azazel: The "skipped" tests are skipped by the Python build process itself. I don't know why. Presumably it can detect that some property of the build environment is not suited for running those tests.
<lfam>For example, I'd bet that things like test_macostools and test_winsound are specific to other platforms besides GNU / Linux
<azazel>i'm trying to familiriarize with the "definition format" and having read that the python-3 definition inherits from the python2.7 one i'm wondering if that applies too
<lfam>The Python 3 packages have their own set of patches.
<azazel>lfam: oh, ok sorry, my bas
<azazel>ops bad
<lfam>No problem :)
<lfam>You can see that those package definitions have their own (source) field, and the patches typically are applied at that level, when building the source
<azazel>i also tried to import the definition using "guix import gnu python3.5" but the command failed trying to access some ftp directory
<azazel>it was a naive try to have te source without cloning all the repo
<azazel>ops... "guix import gnu python@3.5""
<lfam>`guix import` won't provide the Guix package definition that we use. Those importers are intended to provide the very start of what could become a Guix package definition.
<lfam>For a package as complex as the Python interpreter, the importer is basically useless.
<azazel>but i'll will instead do the right thing
<lfam>I have an almost complete Python 3.6 update patch in my Git tree. Of course you're welcome to try it yourself, but I'll probably be submitting this one for review soon.
<azazel>yes I then understood that... and also that for example when i develop a python app in a virtual environment it installs tens of packages that will probably don't exist in guix and i'm wondering if should instead think to develop a more mixed (guix and pip) approach to develop app's recipes (that's not a limitation of guix in particular, debian has it in a much more "vast" way but it's one of the reason why docker comes handy)
<lfam>Well... `guix import pypi` could make it easy to create Guix packages for those tens of packages. Most Python package definitions are trivial.
<azazel>but docker is braindead,i'm quite good at it but it feels like don quixote with the windmills
<lfam>Heh, you're among like-minded people
<adfeno>azazel: We are likeminded then :)
<adfeno>That tower is so hugea and so "isolated" that it's even difficult to upgrade stuff.
<lfam>Does anyone know if it's possible to disable the "acknowledgement" email from guix-patches?
<azazel>and then if I have a an environment (or profile, i don't know yet) containing definitions coming from pypi, fixed here and there, it would be possible to have a local "in office" cache of the substitutes ?
<efraim>i'm still trying to find an easier method (that doesn't involve emacs) than download mbox, mutt -f mbox; rm mbox
<lfam>efraim: Why do you need to download the mbox?
<azazel>lfam: thanks for all your answers
<gnu_guix>What is What is OSError: [Errno 30] Read-only file system: '/gnu/store/[path]' in Python?
<lfam>gnu_guix: It means that some path in /gnu/store cannot be modified
<gnu_guix>Can I fix it?
<lfam>Which is expected. /gnu/store is immutable and can only be modified by the guix-daemon
<gnu_guix>I need to install something with pip.
<lfam>You can fix the behaviour of the code that printed the error to not try to modify /gnu/store
<adfeno>gnu_guix: Make sure that software which tries to write there writes to other place instead.
<adfeno>This also applies to configuration files, these should not be expected to be found inside the store.
<adfeno>(the issue on openning configuration files is sometimes tricky to find out in the first place, but once you spot it, it becomes like the saving one)
<gnu_guix>How can I fix pip installation path?
<adfeno>The issue with "Read-only /gnu/store/..." usually happens because other projects assume that the same place where things are installed are also the place where some configuration file must be found, this can be often signalled by reading the source files and looking for lines with $PREFIX $prefix $DESTDIR and $destdir variables (the $ is for calling shell variables, please change it accordingly).
<adfeno>If I recall correctly, Guix doesn't use DESTDIR nor any variation of this.
<gnu_guix>Fix pip path!
<gnu_guix>FIX IT
<jmd>adfeno: I would be suprised if that is the case.
<adfeno>gnu_guix: in which way you installed pip?
<gnu_guix>guix package -i python-pip
<adfeno>jmd: I recall seeing a messagei n the mailing list archives to that effect (saying that DESTDIR isn't used).
<gnu_guix>adfeno
<adfeno>Although I should rephrase it some something better: DESTDIR is set to same as PREFIX, or unset.
<adfeno>gnunet_bot: Hm...
<adfeno>After you installed it, didn't Guix tell you that "you probably need 'such and such' environment variables"?
<gnu_guix>I installed it with Git. Only Git variable.
<gnu_guix>export GIT_EXEC_PATH="/home/username/.guix-profile/libexec/git-core${GIT_EXEC_PATH:+:}$GIT_EXEC_PATH"
***kelsoo1 is now known as kelsoo
<adfeno>gnu_guix: Oh, you are using the Guix environment setup script?
<gnu_guix>What is the Guix environment setup script? I'm using GuixSD.
<adfeno>Oh ok. Don't worry...
<adfeno>I guess I jumped into conclusions :)
<adfeno>Well... Unless there is a bug on python-pip package, I don't think pip needs a fix in its path.
<adfeno>I'll test it once I come back from my important errands.
<adfeno>As for the "Read-only" OSError, it's a good idea to install strace and do:
<gnu_guix>My commands: pip install pytmx
<gnu_guix>pip install neteria
<gnu_guix>With errors
<gnu_guix> https://tuxemon.org/ubuntu-install.html (first command was changed for Guix)
<adfeno>strace -o "Log file.txt" "[command that resulted in error]"
<adfeno>And in another terminal, do: less "Log file.txt"
<adfeno>Hm....
<adfeno>So the pip installation path for the packages available through pip is broken, not the pip installation path itself.
<adfeno>Hm....
<adfeno>I'll see what can be done.
<adfeno>I'll come back after an hour to deal with this issue.
<gnu_guix>I'm AWAY.
<gnu_guix>AWAY is an IRC command.
<gnu_guix>(in this case)
<paroneayea><gnu_guix> FIX IT
<paroneayea>gnu_guix: be nice :)
<paroneayea>everyone here is volunteering their time
<azazel>lfam: are you working with the new python packages in a branch of the main guix repo?
<lfam>azazel: I have a local branch that forks off the master branch
<lfam>I sent an update for Python 2. That one is trivial: http://lists.gnu.org/archive/html/guix-patches/2017-03/msg00094.html
<lfam>Now I'm porting the Python 3.5 patches to 3.6
<azazel>lfam: i see
<efraim>lfam: thats the patch I got when I tried updating python 2.7.12 to 2.7.13, but i only tried building python2, not other programs with it
<lfam>efraim: I built some packages with it the last time I was working on this (~1 month ago). I think it works fine
<gnu_guix>adfeno
<gnu_guix>3 minutes left
<lfam>efraim: I want to update the interpreters and some core python packages like pytest on a python-updates branch
<efraim>now that the python-tests branch was merged?
<adfeno>I'm back! :)
<adfeno>gnu_guix: Will test python-pip now.
<lfam>efraim: Yes, that was a pre-condition for any further Python work, in my opinion
<azazel>mmm the contributing guide doesn't seem to specify how/if should i setup an environment to play/work with package definitions, or I'm missing something?
<efraim>sounds good. I just assumed core-updates, a new "update python" branch also works for me
<lfam>azazel: Basically, make your changes and then use the changed Guix with the 'pre-inst-env' script mentioned in the section "Running Guix Before It Is Installed"
<lfam>That script only appears after you build Guix from the Git checkout the first time
<lfam>efraim: What do you mean you assumed core-updates?
<azazel>so building Guix from source is a necessary precondition
<lfam>Yes
<lfam>Well, you can use your own package defintions via the GUIX_PACKAGE_PATH environment variable, but I don't recommend it if you intend to get your work into GNU Guix
<lfam>It's easier to start your work in our Git tree if you intend to have it merged
<efraim>lfam: core-updates is basically frozen, I thought it was time to build it and fix build errors
<efraim>sometimes I work on packages in my GUIX_PACKAGE_PATH, and then when I'm ready I copy them over one by one
<lfam>efraim: Yes, I really want to finish core-updates so we can deploy the chunked-references bug fix
<mekeor>what if i set GUIX_PACKAGE_PATH to be my local git clone of the guix repository?
<adfeno>mekeor: Then you'll have duplicated package definitions?
<mekeor>yes, but i could use `guix package -i emacs` to install my own modification of th emacs package definition in my clone of guix repository?
<quiliro>i have a problem with claws when attaching a file
<quiliro>El fichero «tetrapolis.ods» contenía caracteres inválidos para
<quiliro>la codificación actual, la inserción puede ser incorrecta.
<quiliro>the translations is:
<quiliro>The file «tetrapolis.ods» contained invalid characters for the current configuration, the insertion could be incorrect.
<catonano>mekeor: you don't need to set GUIX_PACKAGE_PATH to a newly checked out folder. In the checked out folder you can do ./pre-inst-env guix package -i my-version-of-emacs
<gnu_guix>The biggest netsplit.
<adfeno>quiliro: Hm...
<mekeor>try, but i wouldn't need the "cd path/to/guix; ./pre-inst-env " part
<mekeor>*true
<adfeno>quiliro: That message can be becaouse of the mail client thinking that you have one character encoding, while you are actually using another.
<gnu_guix>Can you fix my problem with pip now?
<adfeno>gnu_guix: Indeed. I can reproduce the problem. Now I'll see if there is a way to fix this.
<adfeno>quiliro: I'll also investigate it to see what I can find.
<efraim>mekeor: I have a custom x265 package here: https://gitlab.com/Efraim/my-guix/blob/master/dfsg/main/x265.scm
<adfeno>gnu_guix: About pip packages installation: make the following text file "$HOME/.pip/pip.conf", and add this inside:
<adfeno>[global]
<adfeno>target=Any_place_you_want
<gnu_guix>EOF?
<adfeno>gnu_guix: Also, if I recall correctly, Guix does provide pyasn and rsa (some of the dependencies to run neteria).
<adfeno>gnu_guix: yes, EOF. And you must replace "Any_place_you_want" accordingly.
<gnu_guix>[Connection]
<gnu_guix>bash: python: command not found
<gnu_guix>Error if using python3 to run tuxemon.py
<adfeno>Did you really install python through Guix?
<adfeno>gnu_guix: Just to make sure: Did you install python through Guix?
<gnu_guix>Yes.
<gnu_guix>Upgrade?
<adfeno>By doing: guix package -i python
<gnu_guix>3.5.2 → 3.5.2
<gnu_guix>Is it REALLY upgrade?
<gnu_guix>*an upgrade
<adfeno>gnu_guix: one thing at a time.
<gnu_guix>Trying this
<mekeor>do i have the source code of emacs on my file system when i installed emacs using guix?
<adfeno>Sent to quiliro: About not being able to attach .ods file: Try "Attach" instead of "Insert". "Insert" is for plain text files (or similar to that), and it doesn't create attachments.
<adfeno>mekeor: It depends if you allowed package substitutes from some substitutes provider, and if Guix indeed found substitutes for all the parts of emacs.
<adfeno>gnu_guix: Do you still have the problem with `python` command not being found?
<gnu_guix>How to install Python 2 on Guix?
<gnu_guix>Yes.
<lfam>mekeor: Use `guix package --source emacs`
<lfam>mekeor: I'm sorry, that was incorrect
<lfam>mekeor: Use `guix build --source emacs`
<mekeor>adfeno: i know for sure there was no substitute. so, where can i find the code?
<adfeno>mekeor: lfam just answered.
<adfeno>And gnu_guix is still not registerd with NickServ....
<adfeno>sneek later tell gnu_guix To install Python 2 do: guix package -i python2
<sneek>Got it.
<adfeno>Thanks :)
<lfam>adfeno: That's incorrect
<adfeno>lfam: Oh... is that?
<lfam>Instead, `guix package -i python@2`
<mekeor>lfam: after `guix build --source emacs`, where can in find the code?
<lfam>mekeor: That command returns the location of the file.
<lfam>You can do `tar xf $(guix build --source emacs)`
<mekeor>it's still compressed, right?
<adfeno>lfam: Thanks! :)
<adfeno>sneek forget later tell gnu_guix To install Python 2 do: guix package -i python2
<sneek>Got it.
<adfeno>I hope he forgot it :)
<gnu_guix>guix package: error: python2: unknown package
<sneek>gnu_guix, you have 2 messages.
<sneek>gnu_guix, adfeno says: To install Python 2 do: guix package -i python2
<sneek>gnu_guix, adfeno says: To install Python 2 do: guix package -i python2
<adfeno>Oh...
<adfeno>gnu_guix: A correction: it's python@2
<gnu_guix>Can I install both 2 and 3?
<adfeno>guix package -i python@2
<adfeno>Can he?
<mekeor>yes
<gnu_guix>The following package will be downgraded:
<mekeor>there is a package python-wrapper, too, which makes the `python` binary point to `python3`. otherwise there are only python2 and python3 binaries
<mekeor>hmmm. maybe i was wrong
<mekeor>i just tried something like "package -i python@2 python --dry-run" which imho should install both versions
<mekeor>i wonder if it works within a manifest
<mekeor>i wonder if it would actually work but the output of the command was just confusing: http://sprunge.us/JVWW
<adfeno>mekeor: python-wrapper is to use python3 as python, not to select which one to use.
<mekeor>that's what i meant, too
<adfeno>mekeor: Indeed.
<adfeno>I guess that once he installs python@2, that should provide the python binary.
<gnu_guix>ImportError: No module named pytmx.util_pygame
<adfeno>Hm....
<gnu_guix>Also No handlers could be found for logger "core.components.rumble"
<lfam>gnu_guix: It's not very helpful to copy and paste isolated error messages into the channel. If you are trying to get help, it will be more effective to give a complete statement of what you are trying to do, and to then put the full output of the failing command somewhere like paste.lisp.org.
<quiliro>i don't understand...isn't it possible for guix to install version 2 and version 3 of python?
<quiliro>at the same time i mean
<adfeno>quiliro: It is.
<adfeno>quiliro: Also, did you get the message I sent about Attach and Insert?
<quiliro>adfeno: no
<quiliro>i did not get the message
<adfeno>quiliro: check with MemoServ (do: /msg MemoServ help)
<quiliro>adfeno: list responds: MemoServ: (notice) You are not logged in.
<quiliro>with /msg MemoServ list
<adfeno>quiliro: You must login with: /msg NickServ identify [Your passphrase]
<adfeno>Some irc clients do this automatically, but some others dont.
<quiliro>oh!
<quiliro>thanks
<quiliro>it is weird
<adfeno>quiliro: You're welcome :)
<quiliro>i though i was logged in
<quiliro>i like it separate insert from attach
<quiliro>how to configure claws-mail to not go to the newest messages on opening a folder
<quiliro>?
<lfam>quiliro: You should ask the claws-mail community
<adfeno>lfam: +1
<quiliro>lfam: no one has answered
<quiliro>but sorry
<adfeno>Hm...
<adfeno>Perhaps their mailing list is more appropriate.
<quiliro>since the channel is quiet, i thought it would be good
<quiliro>to ask here
<adfeno>quiliro: Indeed. I also used to do the same. But I found out that not everyone uses the same software I use.
<adfeno>Or, that the right people weren't in the right time.
<adfeno>So I'm now more used to ask for support on mailing lists or forums instead of IRC.
<adfeno>Because both have greater reach.