IRC channel logs

2017-02-18.log

back to list of logs

<jmi2k>I can't build a rust project. It fails to compile some crates with: erro: failed to build archive: No such file or directory. I've just tested it in an Arch Linux VM and it works, so it's something on my system. Anyone knows what could it be?
<jmi2k>s/erro/error/
<emyles>lfam, sirgazil, amz3: I have the same problem as in that bug report (bug=25775), on amd64, prob haven't upgraded since 0.10
<lfam>emyles: I'm guessing there's some incompatibility between the old daemon and the current Guix code that your user is using
<lfam>emyles: Maybe you could try `guix pull`-ing an older commit, from before the problem started, and then updating root's packages.
<lfam>It's not that obvious how to use `guix pull` to get older commits. See the later version of the manual: https://git.savannah.gnu.org/cgit/guix.git/tree/doc/guix.texi#n2345
<lfam>I mean, the latest version
<emyles>lfam, okay I'll try that, thanks
<Guest51825>Newbie question: running `guix pull` as root updates the package list used by `guix system reconfigure` right? As opposed to running `guix pull` as an unprivileged user
<lfam>Guest51825: Correct
<lfam>Guest51825: `guix pull` is per-user.
<Guest51825>thanks lfam
<Guest51825>yay, I'd somehow managed to cause a kernel panic on boot, but starting up in the previous configuration, then running `guix system roll-back` got me back on track!
<Guest51825>another newbie question: is `sudo guix package install=foo` equivalent to running `sudo guix system reconfigure [config file including package foo]`?
<clacke[m]>guix package install affects one user only, even when root runs it
<Guest51825>clacke: so would `sudo guix package --install=xf86-input-joystick` do what I expect and give joystick drivers to everyone?
<Guest51825>(I think the answer is no)
<clacke[m]>only to root ... and X wouldn't find it I think
<Guest51825>thanks clacke
<clacke[m]>welcome to the sometimes bewildering world of guix :-D
<Guest51825>hehe
<Apteryx>OrangeShark, sirgazil: thanks for the guile-csv pointer!
<Guest51825>what's in9mh91axx22lgr2q70gsm6md0q6iag5-luckystrike-1.5.6.tar.gz that I'm seeing when running `guix package upgrade`? I'm assuming it's not a package itself, as it's not listed in the package list.
<[df]>a data file for red eclipse apparently: http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/games.scm#n2227
<jmi2k_>I can't build a rust project. It fails to compile some crates with: error: failed to build archive: No such file or directory. I've just tested it in an Arch Linux VM and it works, so it's something on my system. Anyone knows what could it be?
<janneke>jmi2k_: i don't know anything about rust...could it be that the compiler expect files to be installed in /usr or /usr/local and that you miss som *PATH setting?
<Guest51825>thanks [df]
<janneke>anyway, find which file is missing and follow the trail from there
<gnu_guix>Can I install KDE on GuixSD?
<jmi2k_>janneke: The problem is that I can't get rustc to tell me more information than that. I had the problem with cargo build. Then, I ran it with --verbose flag so I could see what failed exactly, and copied the command that failed. It gives the same error, but I checked *all* the files the command contains and they are all present. I'm starting to use rust, but I can't do it in GuixSD, and I was expecting someone who already uses it to give
<jmi2k_>me more information.
<janneke>jmi2k_: sure
<janneke>gnu_guix: it wasn't ready in 0.12, quite some progress was made but i don't know the current status
<phant0mas>janneke: thanks for sharing your notes :)
<janneke>phant0mas: hopefully it helps making entry easier
<janneke>they can use some cleaning-up, review
<catonano_>rant: I tried to install GuixSD again and this time the dhcp doesn' t give me an ip address. It did work last time !! grrrr
<janneke>catonano_: boo! -1 for computers
<catonano_>I don' t understand. The desktop computer (which I' m typing from right now) is connected to the same access point. The mobile phone too
<rekado_>catonano_: how do you try to obtain an IP address?
<rekado_>catonano_: are you running dhclient manually? Are there more than one instance of dhclient running (check the output of "pgrep -fa dhclient")?
<catonano_>rekado_: I read command lines on the desktop pc monitor and I type them in the laptop
<catonano_>there might be more than one instance running. Let me check
<catonano_>there are 6 lines in the output. Are they 6 instances ?
<janneke>catonano_: `ps -C dhclient' should only show one line
<catonano_>If they were several instances, I pkilled them all anyway
<rekado_>catonano_: I have exactly one process for dhclient. If you have 6 then something's wrong.
<catonano_>I tried again starting from 0 instances
<catonano_>"No DHCPOFFERS received.
<catonano_>No working leases in persistend database - sleeping
<catonano_>the instance is still alive
<catonano_>this is the pesky router from the Telco
<catonano_>they are terrible
<emyles>sneek: later tell lfram: I couldn't fix my problem yesterday ( https://gnunet.org/bot/log/guix/2017-02-17#T1296008 ) but while re-installing noticed that I had a static systemd service file, instead of a link, so it would always use the old daemon. Thanks for your help though.
<sneek>Will do.
<emyles>sneek: botsnack
<sneek>:)
<catonano_>could I use a static ip and get around the dhcp ?
<janneke>catonano_: depending on [the settings of] your router, sure
<catonano_>janneke: I was looking at the router admin screen, when I asked. But then I realized that the network interface won' t come up. ip a reports, among other things, state: down. ifconfig reports: no carrier. Last time I managed to ping gnu.org. I swear !
<catonano_>ok, I need some meditation now
<janneke>catonano_: _/|\\_
<erliphant>Hi - I've been trying to build a package with a recipe that points to source in a secure repository. This is tricky due to keys + ssh etc etc. I asked on guix-devel about this but haven't had a response yet. Has anybody managed to do this?
<erliphant>Is this something that we can ever imaging guix supporting or is it something that goes against the "ethos" of the guix project?
<rekado_>erliphant: it's tricky.
<rekado_>erliphant: you could either add the secrets to the package itself
<rekado_>or you could download the sources manually and then point guix to the location of the downloaded sources via a file:// URL.
<rekado_>I don't see any other way of doing this.
<erliphant>@rekado - that's interesting. Will that file:// url be available inside the jail when building starts?
<rekado_>is this for personal use only? It's not software you want to add to Guix upstream, right?
<erliphant>@rekado - for the moment it's personal but I would contribute it if I could
<rekado_>erliphant: the sources will aways be available at build time.
<rekado_>it doesn't matter where they are downloaded from. You can use file:// or http:// or ftp:// et.
<rekado_>etc*
<erliphant>@rekado - that makes sense. I could dynamically create a package object with "inherit" perhaps. And just override the file://location
<rekado_>when you want to add it to Guix proper you'd have to make sure that people can actually fetch the sources automatically (including hydra).
<rekado_>erliphant: you lost me :)
<rekado_>there's no need to work with "inherit" unless you want to create package variants.
<rekado_>ACTION has to leave for a few hours
<erliphant>@rekado - ok - so I can just change the source field in the package object
<janneke>erliphant: sure
<erliphant>@rekado + @janneke - thanks
<erliphant>By the way I just wanted to say that I think guix is really impressive and thanks to everyone who works and contributes to it. My scheme isn't great at the moment but I'd love to help out in some way in the future.
***emyles is now known as lfram
<lfram>sneek?
<sneek>lfram, you have 2 messages.
<sneek>lfram, emyles says: thanks, will try setting TMPDIR
<sneek>lfram, emyles says: I couldn't fix my problem yesterday ( https://gnunet.org/bot/log/guix/2017-02-17#T1296008 ) but while re-installing noticed that I had a static systemd service file, instead of a link, so it would always use the old daemon. Thanks for your help though.
<lfram>lfam: ↑
***lfram is now known as emyles
<emyles>lfam: I got your nick wrong
<emyles>twice
<lfam>emyles: Ah, so the service file started a program like '/gnu/store/...-guix-daemon' instead of '/var/guix/profiles/per-user/root/...'
<lfam>?
<emyles>From memory, I think it was using something like ExecStart=/var/guix/profiles/per-user/myles/xyz-guix-0.10 TMPDIR=/home/myles/tmp/scratch but when it was trying to 'guix pull' it couldn't upgrade the guix-0.10 because the systemd service file wasn't a link to ~root/.guix-profile/lib/systemd/system/guix-daemon.service and was instead a standalone file in /etc/systemd/system/
<lfam>emyles: I use a "standalone" service file too. It works fine since the path in '/var/guix/profiles/per-user/root/...' is a symlink to the current version of the guix-daemon in root's profile.
<lfam>It's really recommended to use root's guix-daemon instead of an unprivileged user's guix-daemon, but that's probably another issue
<lfam>Specifically, my service file includes this line:
<lfam>ExecStart=/var/guix/profiles/per-user/root/guix-profile/bin/guix-daemon
<lfam>But, if you were actually using myles's guix-daemon, and myles's Guix installation was broken, then switching to use root's guix-daemon would help you avoid myles's broken Guix so that you could upgrade
<lfam>It sounds like a lot of people are having the same issue that you are, but I still haven't been able to reproduce it
<slyfox>'guix environment' has a neat --container option. when guix needs to build package locally does it automatically use container support?
<lfam>slyfox: Building packages in a controlled and isolated environment is one of the main parts of how Guix treats package building as a function: https://www.gnu.org/software/guix/manual/html_node/Build-Environment-Setup.html
<slyfox>oh, it's already in chroot
<lfam>If you're interested, there are two papers that explain the functional packaging idea and implementation concisely:
<lfam>Nix: A Safe and Policy-Free System for Software Deployment, by Eelco Dolstra et al
<slyfox>i have basic understanding of the idea and description
<lfam>Functional Package Management with Guix, by Ludovic Courtes
<slyfox>my question is more about the differences in build environment of 'guix environment --container' versus 'guix build' call
<slyfox>say, --container does network isolation by default. does 'guix build' do it?
<lfam>Yes, of course :)
<lfam>The only things that can come over the network are "fixed-output derivations". Those are things like source code tarballs that we have already determined the hash of.
<lfam>But, they are downloaded via a separate mechanism anyways
<slyfox>right, it's not directly related to build process itself
<slyfox>seems to isolate properly: http://dpaste.com/0V5P7WA.txt cool!
<lfam>slyfox: Thanks for checking :) Please let us know about the bugs you might find!
<slyfox>a silly user question. that system* failed and yet derivation built successfully. i hoped build would crash with exception. is there equivalent function (or a checking predicate) that does that?
<lfam>slyfox: Try (zero? (system* ...))
<lfam>You didn't check the return value of the (system* ...) procedure
<slyfox>yay, that works!
***jonsger1 is now known as jonsger
<planglois>Hello everyone! I have a series of patches to package the Clementine music player that'd like to contribute, but it seems my email didn't go through to the guix-patches list :-(
<planglois>I generated the patches with git-format --cover-letter, and just sent the cover letter, hoping I'd get a bug number assigned, as per the manual
<catonano_>does a cons* procedure extist that takes several arguments to append to a list ?
<catonano_>catonano_: yes, it does exist
<catonano_>thw wi fi card decided to come back on line. But now the build of guix 0.12.0 fails :-/
<catonano_>this is frustrating :-/
<paroneayea>planglois: did you get an error?
<planglois>paroneayea: hi! Nope, I had CC'd myself and received the email back in my inbox but I can't see it in debbugs.gnu.org
<planglois>maybe my email got stuck in a spam filter?
<planglois>oh wait a minut
<planglois>just received an ack!
<planglois>it just took time I guess :-)
<paroneayea>planglois: yeah it takes time :)
<paroneayea>glad it went through!
<planglois>all sent now :-)
***jonsger1 is now known as jonsger
<jonsger>no idea how to give my guixsd in qemu internet :(
<jeeshmee>Howdy First time here and almost first time on irc Have installed guix binary on new trisquel OS - new as in testing - Flidas Trisquel 8. Using Hexchat installed via guix package so guix is mostly working. Right now I am trying to figure out why I get get the warning cannot install locale "Invalid argument' message
<alezost>jeeshmee: look at https://www.gnu.org/software/guix/manual/html_node/Application-Setup.html#Locales-1
<janneke>jonsger: have you looked at node `Running GuixSD in a Virtual Machine?' -- https://www.gnu.org/software/guix/manual/html_node/Running-GuixSD-in-a-VM.html
<jeeshmee>and this line in .bashrc : export GUIX_LOCPATH="$HOME/.guix-profile/lib/locale"
<jeeshmee>Actually I have both glibc-locales and glibc-utf8-locales installed both 2.24
***espectalll[m] is now known as espectalll
<jeeshmee>I'll try this change - export GUIX_LOCPATH="$HOME/.guix-profile/lib/locale/2.24" in .bashrc
<adfeno>jeeshmee: Hi, what's up?
<adfeno>Are you by chance having problems with GUIX_LOCPATH?
<jeeshmee>I guess so.
<adfeno>Hmm.... It doesn't get applied to your copy of Guix?
<adfeno>(prints a warning)
<jonsger>janneke: I basically use the command which is described there
<jeeshmee>Yeah warning failed to install Invalid argument
<jeeshmee>warning: failed to install locale: Invalid argument
<adfeno>jeeshmee: Put the following in your ".profile" file (inside your home):
<adfeno>export GUIX_LOCPATH="${GUIX_PROFILE}/lib/locale"
<janneke>jonsger: okay...so what do you observe?
<adfeno>janneke: Wrong nick?
<adfeno>Oh... sorry, anothe conversation. :D
<janneke>adfeno: :-)
<jeeshmee>guix pull still gives that error, maybe I have to log out and back in? It's mate DE by the way.
<adfeno>jeeshmee: Yes you must, restart session.
<adfeno>No need to reboot computer.
<adfeno>Just login again.
<jeeshmee>OK Gracias ADFENO will log out and back and see what transpires. Thx
<jonsger>janneke: http://sprunge.us/AZOW don't know how to get more information
<gsmyli_tr8_>Still getting 'warning: failed to install locale: Invalid argument'
<adfeno>Hm....
<adfeno>Is there other lines around this one?
<adfeno>For example, is there a line which has "LANG" or "LC_ALL"?
<janneke>jonsger: you only bring eth0 up?
<janneke>it needs to get an ip address, eg using `dhclient eth0'
<gsmyli_tr8_>In .bashrc?
<gsmyli_tr8_>Here is what I have there:
<gsmyli_tr8_>LANG="en_US.utf8"
<gsmyli_tr8_>export LANG
<gsmyli_tr8_>export INFOPATH="/home/gsmyli_tr8/.guix-profile/share/info${INFOPATH:+:}$INFOPATH"
<gsmyli_tr8_>export PATH="$HOME/.guix-profile/bin:$HOME/.guix-profile/sbin:${PATH}"
<gsmyli_tr8_>export GUIX_LOCPATH="${GUIX_PROFILE}/lib/locale"
<adfeno>Try LANG="en_US.UTF-8"
<gsmyli_tr8_>OK, maybe if I just do systemctl stop guix-daemon and then restart it will work instaed of logging in and out.
<adfeno>Not exactly...
<adfeno>The issue isn't guix-daemon per see.
<gsmyli_tr8_>OK
***jonsger1 is now known as jonsger
<gsmyli_tr8_>Well still the same warning:
<gsmyli_tr8_>fetching path `/gnu/store/lqhbbv6ssnz4n9vmvbizhd0212xha3rl-guile-ssh-0.10.2'...
<gsmyli_tr8_>warning: failed to install locale: Invalid argument
<gsmyli_tr8_>It doesn't seem to hurt anything though.
<adfeno>Strange, because it doesn't show which invalid argument it is
<gsmyli_tr8_>No, it doesn't. Does there happen to be a verbose way to invoke a guix command?
<ng0>--verbosity=LEVEL or what it was
<ng0>see --help of 'guix subcommand'
<ng0>yes, --verbosity= it was
<gsmyli_tr8_>Looking here
<gsmyli_tr8_>GNU_Guix_Reference_Manual.html#Locale-Data-Compatibility-Considerations
<gsmyli_tr8_>maybe this is what I need:
<gsmyli_tr8_>(use-package-modules base)
<gsmyli_tr8_>(operating-system
<gsmyli_tr8_> ;; …
<gsmyli_tr8_> (locale-libcs (list glibc-2.21 (canonical-package glibc))))
<gsmyli_tr8_>My guix locale is 2.24
<gsmyli_tr8_>but, /run/current-system/locale doesn't exist in Trisquel8
***jonsger1 is now known as jonsger
<adfeno>Hm....
<ng0>wrt pykka: "the package has an extensive testsuite" no shit sherlock... one test runs so long I fear it hangs. this is after updating to the git version. I will wait and comment
<alezost>gsmyli_tr8_: I think you also need to set GUIX_LOCPATH in your guix-daemon systemd service
<ng0>what's not documented, or I did not see it so far, is how the guix daemon can make use of a local proxy (socks5, etc), it's just assumed that the line which explains it is selfexplanatory which it isn't.
<jeeshmee>OK I'm not that versed in systemd how?
<alezost>gsmyli_tr8_: check /etc/systemd/system/guix-daemon.service or whatever it is called; it should contain contain "Environment=GUIX_LOCPATH=/path/to/locale" line
<jeeshmee>OK. Will take a look.
<adfeno>Oh indeed... Trisquel 8 does make use of systemd.
<alezost>gsmyli_tr8_: make sure "/path/to/locale" exists; I think it is "/root/.guix-profile/lib/locale" by default but I recall you installed locales in your user profile
<adfeno>I'm not affected yet because I use Trisquel 7, but this is also good to be aware of.
<ng0>this testsuite is longer than longcat :/
<jeeshmee>alezost: What has is:
<jeeshmee>Environment=GUIX_LOCPATH=/root/.guix-profile/lib/locale
<alezost>jeeshmee: yes, exactly what I said; did you install locales there?
<thomassgn>hi, does anyone use or know about the iwlwifi driver?
<jeeshmee>alezost: in /root there is a symlink to /var/guix/profiles/per-user/root/guix-profile
<adfeno>jeeshmee: And, what happens if you do:
<alezost>jeeshmee: does "/root/.guix-profile/lib/locale" exist?
<adfeno>sudo --login; guix package -I
<ng0>is there a normal timeout in minutes/seconds/hours/days for tests in the python build system?
<jeeshmee>alezost: does "/root/.guix-profile/lib/locale" exist?
<jeeshmee>No
<jeeshmee>.guix-profile is just a symlink
<jeeshmee>to /var/guix/profiles/per-user/root/guix-profiles
<alezost>jeeshmee: so you can either modify guix-daemon.service to point to your user locale dir, or to install locales to the root profile
<jeeshmee>OK prefer to have local user good.
<alezost>so change the service to: Environment=GUIX_LOCPATH=/home/<you>/.guix-profile/lib/locale
<alezost>(make sure "/home/<you>/.guix-profile/lib/locale" exists)
<jeeshmee>exit
<jeeshmee>Sorry, wrong focus
<jeeshmee>That's just the same as root, /home/gsmyli_tr8/.guix-profile is a symlink
<jeeshmee>it points to /var/guix/profiles/per-user/gsmyli_tr8
<jeeshmee>which contains a guix-profile directory
<jeeshmee>which contains bin etc include lib libexec manifest share var
<alezost>why did you tell it? I didn't ask about "/home/<you>/.guix-profile/"; I just asked to make sure that "/home/<you>/.guix-profile/lib/locale" exists :-)
<jeeshmee>.guix-profile exists
<jeeshmee>but not .guix-profile/lib/locale
<jeeshmee>I find locale here: /var/guix/profiles/per-user/gsmyli_tr8/guix-profile/lib
<jeeshmee>So I am thinking th symlink in my home directory is wrong.
<alezost>does "/gnu/store/hyi7svs0ds79wrcg5l0nr36zzjikqj7i-glibc-locales-2.24/lib/locale" exist?
<jeeshmee>Yes /gnu/store/hyi7svs0ds79wrcg5l0nr36zzjikqj7i-glibc-locales-2.24
<alezost>does the output of "guix package -I" contain glibc-locales?
<jeeshmee>Yes, what I just posted was from that command but I also notice that same /gnu/store/randomstring does not exist in my user in /var/guix/profiles/per-user/gsmyli_tr8 directory
<alezost>I don't understand how this could happen as by default "guix package ..." command uses "/var/guix/profiles/per-user/gsmyli_tr8/guix-profile"
<alezost>is there glibc-locales if you run it like this: "guix package -p /var/guix/profiles/per-user/gsmyli_tr8/guix-profile -I" ?
<jeeshmee>Yes that command yields:
<jeeshmee>Sure is a chain of links
<alezost>ok, could you check that "/gnu/store/hyi7svs0ds79wrcg5l0nr36zzjikqj7i-glibc-locales-2.24/lib/locale" exist
<alezost>and then "/var/guix/profiles/per-user/gsmyli_tr8/guix-profile/lib/locale" once more
<jeeshmee>Home .guix-profile points to /var/guix etc guix-profile which points to guix-profile number 38 in the same directory which points to /gnu/store/store/5x9lksia7j38xhwwc193rsr1sjbirc9j
<jeeshmee>Actually, /gnu/store/5x9lksia7j38xhwwc193rsr1sjbirc9j-profile is the end of the trail.
<alezost>no, no, please just check those 2 files. glibc-locales is installed, so "lib/locale" should exist in the profile if it exist in "glibc-locales" dir
<jeeshmee>and locale is located in /gnu/store/5x9lksia7j38xhwwc193rsr1sjbirc9j-profile/lib
<jeeshmee>Sorry, one file: /gnu/store/5x9lksia7j38xhwwc193rsr1sjbirc9j-profile/lib is a yes. Which other file?
<alezost>no that not the one!
<alezost>1. "/gnu/store/hyi7svs0ds79wrcg5l0nr36zzjikqj7i-glibc-locales-2.24/lib/locale"
<alezost>2. "/var/guix/profiles/per-user/gsmyli_tr8/guix-profile/lib/locale"
<adfeno>jeeshmee: Do:
<alezost>look at the output of "file /gnu/store/hyi7svs0ds79wrcg5l0nr36zzjikqj7i-glibc-locales-2.24/lib/locale" and "file /var/guix/profiles/per-user/gsmyli_tr8/guix-profile/lib/locale"
<adfeno>ls "/gnu/store/hyi7svs0ds79wrcg5l0nr36zzjikqj7i-glibc-locales-2.24/lib/locale"
<jeeshmee>adfeno: /gnu/store/hyi7svs0ds79wrcg5l0nr36zzjikqj7i-glibc-locales-2.24/lib/locale: directory
<alezost>jeeshmee: and now "file /var/guix/profiles/per-user/gsmyli_tr8/guix-profile/lib/locale"
<jeeshmee>Is a directory
<alezost>so it exists!!! you lied! :-)
<jeeshmee>Did I?
<jeeshmee>Was not intentional.
<adfeno>jeeshmee: Don't worry, it was just a misunderstanding. :)
<jeeshmee>Welcome to the misunderstanding zone
<alezost>[00:17]<jeeshmee> .guix-profile exists
<alezost>[00:17]<jeeshmee> but not .guix-profile/lib/locale
<jeeshmee>I believe it is radiating further and further from me head.
<alezost>so now I don't understand what is the problem?
<adfeno>First, I would actually recommend that he does install glibc-locales to the root user's Guix profile.
<adfeno>If I recall correctly, this would make things easier.
<jeeshmee>Its just when I use guix package -i or guix pull I get get the "warning: failed to install locale: Invalid argument'
<jeeshmee>It still installs and pulls etc so guix works. I have to go through other steps to get packages to my main menu and I don't know if that is related.
<jeeshmee>First, I would actually recommend that he does install glibc-locales to the root user's Guix profile.
<jeeshmee>OK Will do that.
<alezost>jeeshmee: as I told 50 minutes ago, you can either install locales as root (what adfeno also suggests), or modify the service with "Environment=GUIX_LOCPATH=/home/<user>/.guix-profile/lib/locale"; then you told that that locale dir does not exist and we lost all that time on finding out that it exists; I think it's enough chatting for me for today, sorry
<adfeno>Hi lxo :)
<jeeshmee>Hey, OK I changed the ENVIRONMENT LOC_PATH in the systemd/system/guix-daemon.service to point to my regular user profile/lib/locale.
<jeeshmee>Will see if it works Thanks, adfeno and alezost.