IRC channel logs

2017-01-22.log

back to list of logs

<Apteryx>ng0: Right, the problem is that this would need some system configured smtp server which I haven't done, I believe. All my emails are handled from inside Gnus with its own smtp.
<ng0>no idea
<Apteryx>I think I can execute a shell command from inside Gnus and pipe the output directly to the mail I'm tying. I'm a bit worried about that Gnus might linewrap it though.
<ng0>"git send-email --help"
<Apteryx>ng0: Will check it, thanks.
<Apteryx>Strange, my git doesn't have a 'send-email' command.
<ng0>oh. out:email
<ng0>or something
<ng0>guix package -i git:send-email
<ng0>i think
<ng0>but you can read the docs online
<ng0>to check if and how it'll work
<jin>on guix master, i run 'make' then display error message: http://paste.lisp.org/display/337136
<ng0>I think I will prefix the "need comments/help" emails now with DRAFT/RFC in my send script
<Apteryx>ng0: Right :) It's in the git:send-email output. Thanks.
<ng0>that should make it easier for people who need this in their filter
<emyles>How can I find out which package owns a file?
<civodul>jin: you need to run "rm gnu/system.go", see https://lists.gnu.org/archive/html/guix-devel/2017-01/msg01400.html
<emyles>sorry, stupid question...
***Apteryx_ is now known as Apteryx
<Apteryx>Yikes. Hard freeze.
<Apteryx>Probably my RAM just filled up while building IceCat... With IceCat running too.
<enoeht> hey I was trying to build icecat as well did you run into the issue of the configure script saying gstreamer wasn't installed?
<Apteryx>enoeht: I didn't get far enough it seems!
<Apteryx>Hmm, I ran the gc today, and now when I do "guix environment guix" and try to build the git checkout, it says: "./pre-inst-env: line 71: /gnu/store/77cs63vpqnwmrrrb7i684dym842ijavp-profile/bin/guile: No such file or directory".
<Apteryx>Shouldn't "guix environment guix" take care of pulling guile in the (environment) profile?
<Apteryx>OK I guess I had to re-run ./bootstrap && ./configure --localstatedir=/var
<iyzsong>Yes, the environment command always brings a current guile, and the one you last time used (which configrued into 'scripts/guix') had been collected by gc.
<Apteryx>I see! Thanks for the explanation.
<Apteryx>When using "guix build", is the guix-daemon operating in a "profile" built the same way a "guix environment" would?
<Apteryx>If not, what are the differences, and why are those necessary?
<Apteryx>I'm interesting in making Python always able to find "$HOME/.guix-profile", or "$BUILD/.guix-profile", if such a thing exists? There is no $HOME set when in build mode.
<jmd>Apteryx: When building $HOME is set to /homeless-shelter (which does not exist)
<Apteryx>When a package has python & python libraries as inputs, how does it finds it? What kind of profile is built?
<jmd>No profile.
<jmd>The inputs are declared in the package recipie.
<jmd>... and typically the recipe will have a line similar to (python (assoc-ref inputs "python") if it needs to refer to the python directory.
<Apteryx>OK, this I can understand. But supposing the build process runs a Python script which requires a library, this library would need to be made available in the PYTHONPATH. There's no easy way to plug in absolute store locations in source Python scripts as dependencies.
<Apteryx>So the answer must lie in the Python package (native-search-paths).
<jmd>Hey! you're talking about Python. So of course there is no easy way!
<Apteryx>Ha! I think on easy way to make it fit the functional model. Must be a scheme from Guido ;)
<jmd>I think some packages have a --python= option in their configure script.
<Apteryx>*no
<jmd>Have a look at the recipe for wicd for example
<Apteryx>This would probably just indicate the Python binary location.
<jmd>Right.
<Apteryx>The interesting thing about Guix is that the Python libraries are all over the place in /gnu/store and *something* usually takes care of creating links to those under ~/.guix-profile/lib/python2.7/site-packages.
<Apteryx>and add this dir to PYTHONPATH so that the executable (Python) can find those extra libraries.
<jmd>Yes. But the profiles don't exist in the build namespace.
<jmd>You can always do (setenv "PYTHONPATH" "...") if that helps.
<jmd>I'm afraid I'm completely ignorant about python.
<Apteryx>jmd: At least now I have one thing to dig more (how Python libraries are made visible in profile-less build environments)
<Apteryx>*made visible to the Python binary.
<Apteryx>So you helped me! Thanks.
<jmd>np. Sorry I couldn't be more explicit.
<clacke[m]>I guess most python packages have wrapper scripts to their */bin scripts that add their dependencies to the front of their PYTHONPATH?
<thomasd>hi #guix
<thomasd>I'm in the middle of the installation procedure, but getting an error running "herd stat cow-store /mnt"
<thomasd>*herd start ...
<jmd>thomasd: Have you mounted /mnt ?
<thomasd>yes,
<jmd>Hmm. and what was the error?
<thomasd>I believe I followed instructions exactly, except that I enabled swap before mounting root at /mnt
<thomasd>the error was "in procedure mount: mount "./rw-store" on "/gnu/store": invalid argument
<thomasd>upon repeating, I get "In procedure rmdir: Device or resource busy"
<jmd>Yes. You cannot enable cow-store twice.
<thomasd>perhaps the best is to just reboot and see if it succeeds this time.
<jmd>That sounds like a plan.
<thomasd>grrr. same result :)
<thomasd>should I run guix pull before or after this point?
<jmi2k>I'm writing a recipe, and I need to import a package built with Lua 5.2. I use package-input-rewriting, but when I set LUA_CPATH, I have to use /gnu/store/.../lib/lua/5.3 instead of 5.2. How can I deal with that? Using 5.3 doesn't looks right.
<cbaines>I've seen packages pull out the version of an input from the record, and use that to create paths
<cbaines>so, could you use something like (package-version lua), and then use that to create the correct path?
<jmi2k>cbaines: That's what I'm doing now. It works, but I think if I'm using Lua 5.2, the path should be Lua 5.2.
<thomasd>well, lets just proceed with the installation and see if it works :)
<jmi2k>cbaines: can I get package-version from an input, instead of a package? So if I change the input, it changes the path as well.
<cbaines>jmi2k, some inputs are packages :)
<cbaines>I'll try to dig out an example
<cbaines>This looks to be doing something http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/lua.scm#n390
<cbaines>Although, the call to package-version is unquoted, so rewriting the inputs won't work
<jmi2k>cbaines: yes, I submitted this package :) and that's exactly the problem I have. I'm still getting used to writing Guix recipes...
<cbaines>Looking at other packages as well, this seems to be an awkward issue
<cbaines>If a version is used, the information comes from the module, but the package always comes from the input, so there can be a disparity between the two
<jmi2k>Yes, it's not a big problem, but it's confusing. Well, at least things work!
<thomasd>I'm almost at the end of the installation procedure, but grub is complaining it won't install on /dev/sda ("this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.")
<thomasd>is this a known issue?
<thomasd>could it be related to the fact the first partition on that disk is an EFI system?
<iyzsong>thomasd: yeah, the defaut grub is BIOS-based (i386-pc), which need a 'BIOS Boot Partition' to work with GPT. see https://www.gnu.org/software/grub/manual/html_node/BIOS-installation.html#BIOS-installation
<thomasd>ah, if only I hadn't shut down my machine yet :)
<thomasd>well ok, next time then
<jmd>iyzsong: Maybe this should be documented under Limitations?
<iyzsong>jmd: agree, I'll try send a patch for it.
<ng0>rekado: I don't understand. I understood https://mskalick.fedorapeople.org/mozjs38/mozjs38.spec and what they set as environment variables.. I never did rpm before, but I assumed it did this. What else should I set then?
<ng0>ah, "-D" hm
<ng0>as we have no Makefile at all, just add those to the configure?
<thomasd>iyzsong: thanks for the hint, by the way. I think I'll manage next time (unfortunately no more time for that today)
<thomasd>(is parted available on the installation image?)
<iyzsong>thomasd: yes parted is available, and cfdisk can be used to create a BIOS boot partition too.
<ng0>I'll try as configue flags
<thomasd>ah, I was using cfdisk but didn't see how to set up the boot stuff. Too bad I'll have to re-build the system now :)
<ng0>and like I guessed they are not accepted by configure by this stupid rc0 release.
<ng0>what other options do I have for setting something like -DMOZJS_MAJOR_VERSION=38 ?
<ng0>#:make-flags even where there is no Makefile being used?
<ng0>apparently nope. why couldn't they release this with full autotools available.
<rekado>ng0: I don’t have time to investigate this for you, but I see that the tarball contains a directory src/js; that contains a Makefile template and a configure template.
<ng0>and neither configure nor make takes this. I'll look for a way, maybe I have to substitute/patch this in
<rekado>and the README says to build only src/js
<ng0>but thanks for pointing out to me that I had a misunderstanding with what I should set
<ng0>that's exactly what I do
<rekado>configure scripts are not used to define CPP values
<GNUnymous_IRC>Hello.
<GNUnymous_IRC>Can GuixSD be used on desktop?
<GNUnymous_IRC>Can GUI be installed?
<rekado>GNUnymous_IRC: yes to both questions.
<adfeno>Hi GNUnymous_IRC: The other day, I saw your message about notebook backlight and Trisquel.
<adfeno>I might be able to help.
<adfeno>If you want to, lets talk at #trisquel about this.
<jlicht>hi guix!
<adfeno>Hi jlicht :)
<janneke>hi jlicht!
<jlicht>I packaged libtorrent for guix, but it seems we already have a libtorrent, although it is a totally different library :O
<jlicht> http://www.rasterbar.com/products/libtorrent/ is the one I need
<jlicht>should I just add a suffix to the package name to differentiate these two libraries?
<janneke>jlicht: well, if their name is identical, suffixing or prefixing one or both is the only option i see
<jlicht>libtorrent-rasterbar it is then ;-)
<janneke>:-)
<myglc2>hi guix!
<myglc2>Anyone familiar with how GuixSD boots?
<myglc2>Anyone familiar with how GuixSD boots?
<jlicht>would a guix version of NixOps be a nice idea for a GSoC student?
<jmd`>jlicht: What is NixOps ?
<jlicht>tldr: a tool for deploying NixOS system. See https://nixos.org/nixops/
<jlicht>so it adds a way to provision systems in a way that meshes well with the Nix language and tools
<efraim>Probably. Last year gsoc planning started after fosdem
<jlicht>efraim: Ah, cool. I might also join in Brussels for a bit
<Apteryx>ArneBab: Connection woes?
***ShalokShalom_ is now known as ShalokShalom
<Apteryx>ArneBab: Thanks to you I've found this: http://dev.weechat.org/post/2008/10/25/Smart-IRC-join-part-quit-message-filter :D
<Apteryx>If using weechat I think all you really have to do more by default is this: "/filter add irc_smart * irc_smart_filter *".
<pareidolia>civodul: I am interested in the current state of Nix-Guix interoperability. Is there a resource you can point me to?
<buenouanq>Anyone here able to successfully install guixsd on a macbook yet?
<buenouanq>I'm going to try again right now.
<civodul>pareidolia: no material on this i'm afraid
<civodul>basically the format for derivations is the same
<civodul>the protocol between clients (the 'guix' or 'nix-*' commands) and the build daemon is mostly the same, but with a few differences
<civodul>the default store name is different, meaning that you can't get substitutes from the other distro
<civodul>now, you can also use separate stores and separate daemons
<pareidolia>civodul: Theoretically I can use Nix to instantiate derivations for e.g. Chromium by talking to the Guix daemon right?
<civodul>pareidolia: yes, but that's only in theory, as i suggested above :-)
<emyles>Is is possible to change 'cmake ../source' to 'cmake ../somewhere/else' in a package definition?
<adfeno>emyles: Is this "cmake ../source" writen in a file inside the source being packaged?
<mekeor>why does the patch for xmonad 0.12 (in guix-devel mailinglist) not get any response/reaction/acceptance? :(