IRC channel logs

2016-09-30.log

back to list of logs

<ZombieChicken>First post to the mailing list is moderated, right?
<ZombieChicken>help-guix@gnu.org, I mean
<efraim>No, just has a long delay
<ZombieChicken>Long delay is right. it's been at least an hour
<demotri>Within a package build, I want to define an envirenment variable. Is there something like (setenv "OpenCV_ROOT_DIR" ,opencv)?
<demotri>For the protocol: It's built in in Guile: (setenv "MY-INPUT" (assoc-ref inputs "my-input"))
<civodul>Hello Guix!
***malthe_ is now known as malthe
<civodul>with little work, we could generalize the thing that makes the Guix binary tarball
<civodul>and have a general 'guix pack PACKAGE...' command that would create such a tarball for any given package set
<civodul>eventually we could extend it, like 'guix pack --format=docker PACKAGE...'
<civodul>thoughts?
<wingo>yes!
<civodul>positive feedback, good :-)
<wingo>dunno if --format=docker is sufficient tho :)
<civodul>yeah, i haven't really thought about that one, just making it up
<rekado>is there a way to run a shell script in a snippet?
<rekado>shogun now comes with a script to remove its non-free stuff, and I'd rather use that than maintain our custom code.
<rekado>we have really serious problems with our Haskell packages.
<rekado>as they are they are hardly maintainable.
<rekado>many inputs are not declared.
<rekado>does anyone feel responsible for the haskell packages and would like to work on fixing this?
<rekado>almost every package needs to be checked to ensure that all inputs are in fact declared.
<civodul>rekado: re shell script, yes, it's possible; in fact the snippet can be a gexp, so you can arrange to add bash in there
<civodul>rekado: re haskell, are you saying that our packages lack inputs?
<rekado>yes
<civodul>do they fail to build, or do they fail at run time?
<rekado>haskell binaries include references to their inputs
<rekado>although inputs were not declared they were available at build time due to propagation
<civodul>so inputs are declared, but not in the right place, right?
<rekado>now when I update packages I see GHC complaining about potential conflicts because package X depends on an older version of, say, bytestrings.
<civodul>that is, inputs happen to be there because they were propagated from elsewhere
<rekado>correct
<civodul>i see
<rekado>this means that for every package I now have to manually check the inputs.
<civodul>bah
<rekado>I've been at this for two days already
<rekado>just trying to add a new package
<rekado>it's terrible
<civodul>stop here and improve 'guix refresh' :-)
<civodul>i wonder how we ended up in this situation
<rekado>first thing I'll do is change all "propagated-inputs" with "inputs"
<civodul>all these packages were created by 'guix import'
<rekado>then improve guix refresh to also do an import
<civodul>ok
<civodul>the importer suppossedly fills in 'inputs' correctly, so that's weird
<rekado>maybe the problematic packages were created by an older version of the importer?
<rekado>on some problematic packages the importer fails, e.g. streaming-commons
<rekado>the importer doesn't know the token "IF"
<civodul>uh
<civodul>anyway, i think having 'guix refresh' check the inputs would be awesome
<janneke>who is supposed to merge the latest mingw patch set, i would guess mark_weaver (last big review) or wingo (many earlier reviews)?
<civodul>hey janneke!
<janneke>ACTION is getting a bit nervous, it has been sitting in ready-to-merge-to-master for 5 weeks
<civodul>janneke: good point, i dropped the ball and feel guilty now!
<janneke>hey civodul, read your slides --> great! looking forward to the video
<civodul>the slides are all alike so it doesn't tell much without the speech on it ;-)
<civodul>mark_weaver: your thoughts on the MinGW patches?
<janneke>civodul: even better, i already enjoyed the slides
<civodul>:-)
<janneke>mark showed me how to make the patch set not to trigger rebuilds and i worked that into the last iteration
<civodul>ok
<civodul>janneke: to be sure, what's the date of the latest iteration?
<civodul>if we don't hear from mark_weaver, i'll apply it
<civodul>taylan: thanks for the Guile 2.2 patch, BTW!
<janneke>civodul: https://lists.gnu.org/archive/html/guix-devel/2016-08/msg01223.html
<janneke>civodul: v10 series, one minor remark by alex that i sent a single patch update on
<janneke>civodul: yay, thank you!
<taylan>civodul: my pleasure :)
<rekado>civodul: I'm trying to use a gexp for a snippet. But how do I make packages available there?
<rekado>Just using #$bash-minimal isn't enough
<rekado>it says the variable is undefined even though I added (gnu packages bash) to the list of modules
***[0xAA] is now known as XSalsaTequila
<civodul>rekado: it follows the normal scoping rule, so you need to have a use-modules (gnu packages bash) or similar
<civodul>and then it Should Work™
<civodul>that sounds a little hand-wavy i'm afraid :-)
<rekado>hmm, it's fine when I don't try to use bash or coreutils.
<rekado>something from the same module is okay
<rekado>the error looks again like a loop
<civodul>do you have something that you could copy/paste?
<rekado> http://paste.lisp.org/display/327445
<rekado>this is the snippet and the errors I get when building the package.
<rekado>when I replace "bash-minimal" with "randomjungle" from the same module there are no errors.
<civodul>rekado: the use-modules form must be outside the gexp
<civodul>so that 'bash-minimal' is visible on the "host side"
<civodul>#$ is like unquote in spirit
<rekado>yes, I understand that.
<rekado>I have (gnu packages bash) in the (define-module ...) expression and also in the list of modules
<rekado>so it's available everywhere, no?
<civodul>yes
<civodul>hmm
<civodul>where is this snippet?
<civodul>in which module?
<rekado>it's in the definition of shogun in machine-learning.scm
<civodul>ok
<rekado>ACTION goes afk for a few mins
<civodul>i can reproduce it
<civodul>the problem is that snippets are "eager"
<civodul>so here we refer to 'bash-minimal' at the top level, which doesn't work because of circular dependencies
<civodul>an obvious fix would be to make 'snippet' a "thunked" field of <origin>
<civodul>that's reasonable
<bavier>I didn't realize we are so optimistic for 1.0 :)
<civodul>of course we're optimistic! :-)
<civodul>did that sound this optimistic actually?
<bavier>no, I think I was just surprised by the specific timeframe that was quoted in a recent email
<bavier>and I think I'm feeling guilty about hacking on some other projects recently
<rekado>to me it was a timely reminder to finish all the WIP stuff like recursive importers.
<davexunit>what's this about 1.0?
<davexunit>ACTION is out of touch, goes to read mailing list archives
<bavier>davexunit: yeah, 1.0
<rekado>IIRC it was a reply to an email to help-guix
<davexunit>ah okay
<rekado>I'm currently rebuilding Pandoc after replacing all "propagated-inputs" with "inputs". So far this seems to work. Maybe propagation really isn't needed for Haskell.
<rekado>as a welcome side effect I expect the closure size for ghc-pandoc to be much smaller than befor.
<rekado>*before
<civodul>i'm happy if that reply of mine gives people an incentive to hack more :-)
<bavier>rekado: see my email response to your question
<rekado>bavier: aha, excellent!
<bavier>:)
<civodul>ACTION tries the Bash upgrade in core-updates
<janneke>xb
<df_>reminds me of http://www-cs-faculty.stanford.edu/~uno/boss.html
<emas>Hi, can someone give me an example of a static-networking-service declaration?
<emas>or not