IRC channel logs

2016-09-25.log

back to list of logs

***Steap_ is now known as Steap
<lfam>Can anyone help me get started building the GuixSD website in guix-artwork.git
<lfam>?
<lfam>My load path includes '/home/leo/guix-artwork/website/www'
<lfam>I try (use-modules (www)) but the module is not found
<jmd`>There's a way of finding out the filename of a gexp. Can anyone remind me how to do it?
***jluttine_ is now known as jluttine
<quigonjinn>What's the appropriate way of starting user services in guixsd? Using 'shepherd -c <file>' is working, but how should that be done on user login?
<jmd>quigonjinn: I thought herd start <service> was the way.
<jmd>Services aren't usually started on a per user basis, although I suppose they could be.
<jmd>.. in which case ~/.bash_login and ~/.bash_logout could be used.
<quigonjinn>jmd: Maybe it's wrong to start ona per user basis, but isn't for example 'emacs --daemon' supposed to be started like so?
<quigonjinn>herd status as user has no socket to connect to, unless i run shepherd as a user as well
<jmd>So what's wrong with putting emacs --daemon in your .bash_login if that's what you want?
<jmd>But your idea of starting a local shepherd is interesting. I suspect however some services would fail because they write to global state files.
<quigonjinn>nothing wrong I guess, i'm just trying to migrate my stuff in shepherd. Like emacs daemon, scheduling offlineimap etc
<quigonjinn>i had been using systemd for those
<rekado>I updated our Epiphany package to 3.22.0. It’s probably best to upgrade your browsers.
***[0xAA] is now known as Zer0Pings
<jmd>Has anyone tried packaging torbrowser?
<Zer0Pings>jmd: why would someone do that
<Zer0Pings>one is meant to run Tor Browser himself without trusting his distro
<jmd>... so you just have to trust the torbrowser package.
<jmd>Guix, is meant to ensure that one can trust everything that is packaged.
<jmd>If one ran an unpackaged torbrowser on guix (assuming that was possible) then that would defeat the purpose of having a trusted distro.
<ng0>jmd: search the guix-devel archives of this year, last 5 months for torbrowser. We discussed it, I never started it.
<ng0>specifically the last thread of ludovic and myself.
<ng0>fun question: is our downloader capable of using the gopher format for sources?
<amz3>when I launch a guile program on ubuntu+guix I have this error 'guile: warning: failed to install locale'
<amz3>how can I fix it?
<amz3>especially now 'setlocale' calls fails
<amz3>which my program can't run
<rekado>amz3: have you installed glibc-locales and set GUIX_LOCPATH?
<amz3>no
<iyzsong>ng0: hi, my emails missed your reply about gforth. yeah, it works. about module file, it was told GNU packages prefered in their own (maybe I'm wrong).
<amz3>hydra is quite fast nowdays
<ng0>ok, thanks
<ng0>I'll send the patch within the next days
<iyzsong>for colorforth? TIA :-)
<amz3>rekado: what value should take GUIX_LOCPATH?
<ng0>yes, the gforth->forth renaming and adding colorforth afterwards back to it. I'm doing a bit work on the inox patches today
<iyzsong>ok
<ng0>following the gnuzilla list it seems like they are stuck on discussions.
<amz3>anyway guile stil fails
<ng0>in bash.scm , what is the effect of ... in the syntax rules?
<iyzsong>amz3: the version of glibc used by guile and glibc-locales have to be matched.
<ng0>it's difficult to search for an explanation on '...' using search engines, you know :)
<amz3>ng0: this is a guile syntax
<ng0>which section of the guile documentation would give me an explanagtion?
<amz3>ng0: it means something like "copy the previous pattern"
<ng0>oh, nice.
<amz3>ng0: in this case is means that (seqno hash) is repeat a certain number of time
<amz3>ng0: https://www.gnu.org/software/guile/manual/html_node/Syntax-Rules.html#Patterns
<ng0>thanks
<amz3>"..." is kind of magic syntax
<amz3>IMO
<amz3>I always wondering how it works
<rekado>amz3: GUIX_LOCPATH would be set to ~/.guix-profile/lib/locale (assuming you installed glibc-locales, guile, and the other packages into the default profile)
<amz3>rekado: thx!!! but there still an issue GUIX_LOCPATH is not reported by 'guix package --search-paths', is it ok?
<iyzsong>i wonder too, why glib-locales clear the native-search-paths it inhert (GUIX_LOCPATH). maybe we should add it.
<ng0>I assume that nix-base32 originated at Nix? There's a discussion about how they will solve whatever distributed system they are discussing to move content to and their hash incompability.
<ng0>I think i should pause at some point and read the papers.
<ng0>on deadlines.. with inox I get why specific dates are a bad idea. I'm working on this and it's getting somewhere but it's slow.
<ng0>and dates are not what I meant yesterday.
<ng0>how does (define %patch-series-4.3 interact with the fetching of the patches? I'm trying to recycle this for inox
<ng0>as they use names and not numbers it's not very forward.
<efraim>ng0: I'd look to see how its used further on in the code. That part is more like the patches themselves are factored out
<ng0>hm, ok
<ng0>I think my error is further up.
<ng0> https://ptpb.pw/y2qe.scm I have to look at more scheme and try more to figure out why it breaks like this.
***abbe_ is now known as abbe
<adfeno>Hi all! :)
<adfeno>When using "snippet" inside "origin", should I do `substitute* [file name]` to replace absolute paths to those corresponding to inputs" (or "outputs", whichever is needed)?
<adfeno>Or should I keep such path modifications to build phases?
<adfeno>I mean: to modify standard build phases
<adfeno>My understanding is that these paths must be changed by modifying phases.
<adfeno>Otherwise, doing things like archiving the package would make it not usable for the person receiving it.
<iyzsong>yes, you're right!
<adfeno>(since he would have to deal with finding which paths belong to guix)
<adfeno>Now, next question is: What about using "snippet" for other file modifications (using `substitute*`, of course)? That is, those changes that don't involve fixing paths?
<ng0>I know it's used for deletion of parts either substituted by guix provided ones or content we can't ship
<adfeno>It's because I have file that references to another one inside the same directory (that is, with relative path)...
<adfeno>... and that file being referenced is deleted by my recipe.
<adfeno>s/deleted/removed/
<ng0>you could create a symlink?
<ng0>i'm not sure if i understand you
<adfeno>E.g.:
<adfeno>Directory named "win32", being referenced by file "MANIFEST.in".
<adfeno>File "MANIFEST.in" is also making references to other files.
<adfeno>Directory "win32" seems to have only non-source files.
***malthe_ is now known as malthe
<ng0>the size of chromium is one factor which makes try and error so incredible long. I hope this is finished before end of this year
<ng0>there's like 1 or 2 minutes of scrolling shebangs etc after unpack
<lfam>Pythonistas, can you comment on Ivan's patch for quickswitch-i3, which uses an upstream pull request as a patch?
<lfam>upstream pull request: <https://github.com/proxypoke/quickswitch-for-i3/pull/24>
<lfam>guix-devel patch: http://lists.gnu.org/archive/html/guix-devel/2016-09/msg01626.html
<lfam>The pull request is not merged, but there has been on work on quickswitch-i3 since 2014; I think it's abandonded
<lfam>There has been *no* work
<ng0>so i discovered this metabug.. and it lead me to fedora chromium, which could look like a better starting point.
<ng0> https://bugs.chromium.org/p/chromium/issues/detail?id=28287
<ng0>I'll look into this.
<ng0>what have I gotten myself into... so I think the way until a full system-everything inox/chromium will be long, but we can have some result hopefully this year.
<ng0> http://spot.livejournal.com/312320.html somehow related, fedora on chromium packaging.
<retroj>to do a full system upgrade, does it involve doing 'guix pull; guix package -u' with all user accounts and as root as well?
<ng0>also a reconfoigure.
<ng0>*reconfigure
<retroj>does the order matter?
<ng0>parts like the kernel will not be upgraded by the user profile updates.
<lfam>ng0: That's a really good rant. Thanks for sharing :)
<lfam>retroj: The order does not matter as far as I can tell
<retroj>thank you
<ng0>what mess have I walked in. and why am I so fascinated by solving mess.
<ng0>really... my priorities are at gnunet... maybe I do some basic work on this to produce a basic inox, and others can improve on that.
<ng0>feels like i'm packaging an OS inside an OS. OS'ception.
<ng0>*wizzard of OS
<lime_>time to do another guixsd install, any major progress to report?
<ngz>I'm trying to write package which is just and HTML page with a bunch of javascript files. However, when I call xdg-open on the HTML file, I get NS_ERROR_DOM_BAD_URI. At first I though it was related to some cross-domain AJAX limitation, but, looking at the console, it looks more like a JS issue. Unfortunately, I don't know jack about JS. I have the package definition and a simple recipe to reproduce the error. Would there be anyone with
<ngz>a little knowledge about these things and some spare time to look at it ?
<JamesRichardson>Is there a recommended/best practice/how to anywhere that describe how to setup a mcron job that will rotate log files? Specifically syslog files at the moment.
<janneke>JamesRichardson: yes, I'm working on a patch
<janneke>I have log rotation working for quite some time now
<janneke>here's the most recent version, that will hopefully be merged: https://lists.gnu.org/archive/html/guix-devel/2016-09/msg01751.html
<JamesRichardson>thanks.
<retroj>i'm interested in packaging the gui library agar <http://libagar.org/>. which would be the most appropriate file in gnu/packages for it?
***Igel is now known as sig3l
***sig3l is now known as Igel