IRC channel logs

2016-08-14.log

back to list of logs

<balduin>@OrangeShark: according to your link cmake will first look if APR_INLUCDE_DIR is specified in the CMAKE variable cache. Which can be specified with -D <var>:<type>=<value>. but I have no idea how to set it correctly
<balduin>I do not think it is: -DCMAKE_varname
<OrangeShark>balduin: maybe "-DAPR_INCLUDE_DIR="?
<balduin>@OrangeShark: yes, thanks that was the successful hint :-)
<balduin>Found APR: /gnu/store/cbbxwx7y3zl8863lsd7my721j8nyrd7r-apr-1.5.2/lib/libapr-1.so
<OrangeShark>great, now you need to do the rest of the inputs :P
<daviid>guix web page installation requirement still list GNU Guile, version 2.0.7 or later; I thought it required the latest stable
<daviid>on this page I can't read any reason why it could not be installed on a mac, but if some one could confirm it would be cool, I know nothing about mac ...
<balduin>how can I determine the hash value of an git commit (git-fetch method)?
<lfam>balduin: Clone the git repo, check out the commit you want to use, and then remove the .git directory. Finally, exit the Git repo and run `guix hash --recursive` on it
<jlicht>balduin: I have a script I make use of quite often:
<jlicht> http://paste.lisp.org/submit
<jlicht> *http://paste.lisp.org/display/323081
<jlicht>as always, buyer beware etc ;-)
<balduin>@jlicht: thanks :-)
<lfam>jlicht: I recommend not running that `rm -rf` if the previous commands fail. So, you could chain the commands together with &&, for example
<lfam>Just a suggestion inspired by your "watch out" comment :)
<jlicht>As a lazy person, I usually ad set -e to the top of those kinds of scripts
<lfam>Oh yeah, that works. 'set -u' is another nice one
<daviid>anyone about my Guix on Mac quizz?
<lfam>daviid: Can you rephrase the question? I don't understand
<daviid>lfam: as anyone or mre generally speaking is it possiblew to install Guix on MascOS
<daviid>* MacOS
<lfam>daviid: I don't think it's currently possible. At least, I haven't heard of anybody trying it.
<daviid>lfam: ok thanks
<sankey>i'm trying to understand how guix challenge works
<sankey>what if, .e.g, there is a bug in the hello@1.2.3 package definition that gets fixed in a later commit to guix
<sankey>but that does not bump the version
<sankey>wouldn't the hash become different?
<sankey>in that case, guix challens should complain because the locally build hello@1.2.3 now differs from the substitute-provided hello@1.2.3
<sankey>or do we just assume that guix challenge requires guix pull beforehand?
<sankey>OH i'm conflating the output hash with the hash of the definition
<lfam>sankey: The hash that uniquely names items in /gnu/store is roughly a hash of all the inputs to the package. Whereas `guix challenge` checks the hash of the content of the package itself.
<sankey>lfam: thanks for the clarification, that matches my guess
<ksjogo>Hi everyone, I installed GuixSD in addition to Ubuntu and Windows on my machine. Ubuntu Grub is running fine and I kept it for the moment, so I use (re)configure with --no-grub and add the GuixSD grub.cfg to Ubuntus. The problem then is, that GuixSD will not write the updated cfg after reconfigure. I can reconfigure without --no-grub, but that will stop due to pointing to a partition instead of a disk.
<ksjogo>Is there a way to configure reconfigure to write the grub.cfg but not attempt to write grub somewhere.
***Piece_Maker is now known as Acou_Bass
***Piece_Maker is now known as Acou_Bass
***fkz is now known as Guest79115
<rekado>very weird: when connecting to a bluetooth audio device with bluetoothctl my keyboard layout is reset to qwerty.
<rekado>I’ve been thinking about adding a service to start setxkbmap, but I’d like to ensure that the layout isn’t reset
<rekado>another big update with lots of rebuilds: fftw. Should this be pushed to core-updates?
<dhamidi>hello!
<dhamidi>a question about (uri (git-reference ...)): how do calculate the right hash for a git-reference? For regular URLs `guix download` does the trick
<rekado>dhamidi: I think you can use “guix hash” on the directory after deleting the .git directory.
<rekado>there seems to be a problem with the cunit substitute. I get this error:
<rekado>@ substituter-failed /gnu/store/4y4lmi3cakn50fm0w16aszay8qakj40d-cunit-2.1-3 0 hash mismatch in downloaded path `/gnu/store/4y4lmi3cakn50fm0w16aszay8qakj40d-cunit-2.1-3': expected 1165aeb07d7c4f2061984c51b7c8f24122b9ee6eaf8b02cacbea25ffba009fcd, got 47d6f4b30e28596999e1b79912e024aecda6605e5425454f349903de84f51d49
<dhamidi>rekado: thanks, I'm trying that now
<dhamidi>also, when using autotools, should configure, Makefile.in, aclocal.m4 be committed to the repository?
<rekado>dhamidi: no.
<rekado>dhamidi: they will be part of the release tarball that you can generate with “make dist”
<dhamidi>ok, then that means calculating the hash for a git-reference should be done when those files are not present, correct?
<ng0>is there a quick git fix for when you discover that you just wrote https instead of http in 14 new perl modules? I don't know how to go back in git history to change tiny details and move on to the next commit without breaking the other commits. which commands should i read into?
<ng0>metacpan.org has https in search, cpan.org doesn't have it -.-
<rekado>ng0: git rebase -i commit^
<rekado>you will be shown a list of commits which you can then mark for editing.
<ng0>interesting. thanks
<rekado>as you “git rebase --continue” git stops at each marked commit; there you can do your changes and run “git commit --amend”
<rekado>dhamidi: I don’t understand. When a git checkout doesn’t contain them, then they shouldn’t be there when you compute the hash.
<fps>i wonder how i can make a job specification for cuirass to build all of master
<fps> (#:arguments (subset . "hello"))
<fps>this seems to make it build only the hello package from master..
<dhamidi>I was working from within the git repository, with a the guix package definition in $REPOSITORY/guix.scm, hence the confusion
<dhamidi>I'll do a proper write-up of what I'm trying to achieve later, maybe that helps
<ng0>import cpan * would be great to not have to package 15 dependencies for one dependency of a package you work on.
<ng0>but reviewing most of cpan will take ages.
<ng0>so.. meh.
<ng0> 171,144 Perl modules currently. that will only take about a year to review or someone really dedicated with no sleep and lots of time.
<lfam>rekado: core-updates sounds like the place for your fftw update
<janneke>ng0: is there a popularity-contest thing for perl modules?
<ng0>hu?
<ng0>i just packaged surfraw and it needed 14 perl modules.
<rekado>lfam: okay, will push it to core-updates.
***lashdu is now known as drtan
<janneke>ng0 http://popcon.debian.org/
<janneke>i could imagine that with 200 packages you cover 80% of usage
<sankey>how do i get a text listing of all inputs for a package?
<sankey>sort of like guix graph, but a flat list (the full dependency closure) in plaintext
<pmikkelsen>phant0mas: You are the one working on the hurd port as a GSoC project, right?
<rekado>sankey: you can do this with a Scheme script.
<rekado>sankey: do you want to get the full list of dependencies down to the bootstrap binaries?
<philsnow>I was reading https://www.gnu.org/software/guix/manual/guix.html#Substitutes and it says "HTTPS is recommended because communications are encrypted; conversely, using HTTP makes all communications visible to an eavesdropper, who could use the information gathered to determine, for instance, whether your system has unpatched security vulnerabilities."
<philsnow>but it also says "When using HTTPS, the server’s X.509 certificate is not validated (in other words, the server is not authenticated), contrary to what HTTPS clients such as Web browsers usually do. This is because Guix authenticates substitute information itself, as explained above, which is what we care about (whereas X.509 certificates are about authenticating bindings between domain names and public keys.)"
<philsnow>it's cheap to verify x509, and doing so prevents an active MITM from eavesdropping. is there another reason for not verifying x509 ?
<philsnow>the most common reason i've seen is that then you have to depend on what certificate bundle is installed, but I think you can bootstrap to a known-good cert bundle + curl binary with just gpg-signed packages over http, and then switch to all-https with verification
<philsnow>and that would not leak much information, especially if that's what the standard bootstrap does
<lfam>ACTION works on Perl update for core-updates
<lfam>There are some changes in Perl to make it easier to build Perl software reproducibly