IRC channel logs

2016-07-12.log

back to list of logs

<lfam>Can we inherit parts of #:phases? I'm looking at go-1.4 and go-1.5, and there are a lot of repeated custom phases.
<bavier`>ACTION continues to be a bit in the woods with monads
<efraim>for modifying inherited phases you're looking at substitute-keyword-arguments
<lfam>efraim: Thanks, I'll grep for it
<rekado>hmm, libvirt wants to write to sysconfdir and localstatedir
<rekado>localstatedir should be /var, but at installation time libvirt will try to create directories there
<toothbrush0>Hello Guix!
<efraim>hi!
<efraim>substitute or patch out the install time directory creation i guess
<dysfun>so am i to understand that guix has no facilities for partitioning from within the configuration?
<alezost>dysfun: right, you need to do partitioning yourself
<sneek>Welcome back alezost, you have 2 messages.
<sneek>alezost, Gamayun says: the kernel panic seems to have been an issue with partitions. Redid partition tables and filesystem, and it appears all sorted now. :)
<sneek>alezost, lfam says: This is a bit paranoid, but the remote server could detect the signature of the Guix downloader and serve something different. And, I think it's worth being a little paranoid since we are making packages for others to use.
<dysfun>alezost: right, well my use case is building virtual machines for deving guix. i want to automate the building of the base images. how do you recommend doing that/
<alezost>dysfun: I don't have any recommendations :-)
<alezost>this question is outside Guix (at least currently)
<dysfun>well i was looking into scripting it with guile last night, but there are way fewer libraries than i expected
<alezost>yes, Guile is not so popular as Python :-(
<dysfun>well i picked up guile many years ago but it wasn't a great implementation back then
<dysfun>at least with python, there is only one implementation to worry about
<civodul>Hello Guix!
<efraim>hi!
<efraim> https://github.com/chrissimpkins/naked/blob/master/setup.py#L46 python-naked requires ... naked?
<efraim>any suggestions on how to deal with that?
<catonano>does the gnu-build-system provides the autotools as implicit inputs ?
<efraim>no
<catonano>ok thanks
<sturm>So have I got this right - sharing your build/downloaded packages between machines is as easy as `guix publish`? Wow!
<civodul>yup!
<civodul>efraim: weird
<sturm>I notice that some packages listed on the package website don't seem to be available, eg. "chromium-bs". Is this because I'm running Guix SD version 0.10.0 and they're not part of that version, or is it some other reason?
<vlegoll>Hello, I'm trying to package some software for guix, but don't know how to build the one I defined in a .scm file, I probably should put this file somewhere but the documentation does not really tell me where it is : I've tried with GUIX_PACKAGE_PATH=$GUIX_PACKAGE_PATH:. but that does not work (even if I put the scm in the ./gnu/packages subfolder).
<alezost>sturm: that's because your Guix is not fresh enough; after "guix pull" such packages should become available for you
<alezost>vlegoll: if you are going to contribute it to Guix, see https://www.gnu.org/software/guix/manual/html_node/Contributing.html#Contributing
<alezost>if it's a package for your own use, you need to set GUIX_PACKAGE_PATH to let's say "/home/<me>/guix-packages", and there you can put your "my-packages.scm" file, and it should define (my-packages) module
<alezost>vlegoll: please ask if it's not clear :-)
<alezost>vlegoll: btw if you think https://www.gnu.org/software/guix/manual/html_node/Package-Modules.html#Package-Modules is unclear, please drop a message to guix-devel@gnu.org
<vlegoll>Thanks I'll see if that helps, but I was already trying to follow that doc
<alezost>vlegoll: all is needed is keeping the right directory in GUIX_PACKAGE_PATH and the right module in a package file. BTW there may be an error in the package file; if you paste it somewhere, I can look at it
<vlegoll>no I think it's the right module / right directory problem, I was misled by the hello example...
<alezost>ok, what dir do you put in GUIX_PACKAGE_PATH and what .scm file it is and what "(define-module (...)" it is?
<vlegoll>I've made it to work, now I've got to find a way to build different than the default, because there's no configure script...
<alezost>what does "different than the default" mean? You can delete configure phase: grep for "(delete 'configure)" in ".../gnu/packages" directory
<vlegoll>yeah that will probably do it, I'll also need to apply local patches to the source tree...
<sturm>alezost: thanks!
<alezost>sturm: no problem :-)
<vlegoll>alezost: thanks, I fond the two in one single grep ;-)
<alezost>vlegoll: you can put your patches to "dir-with-your-guix-packages/patches"
<vlegoll>is there a way to avoid "updating list of substitutes from" at each guix command ?
<jlicht>Hello Guix!
<jlicht>servers seem to be quite slow today
<alezost>vlegoll: "updating list of substitutes from ..." means it fetches some info from hydra; you can use --no-substitutes option but you will build things locally with it
<vlegoll>Does it really need to fetch something each time ?
<efraim>i think my subsitute* in a cmake-build-system had a race condition "cant lstat file" error with a changedir phase
<efraim>no, that's not it
<vlegoll>alezost: I think I misunderstood you on patch file location: http://pastebin.com/w5Stcqt0
<vlegoll>that is with "(patches (search-patches "sinit-build-fix.patch"))" in the .scm's (source (origin))
<civodul>jlicht: which server in particulra?
<efraim>i haven't figured out how to add patches to packages stored in my GUIX_PACKAGE_PATH
<alezost>vlegoll: oh, I've looked at the code: it appeared that you need to put patches right in the /home/vince/guix-packages
<vlegoll>OK thanks
<alezost>vlegoll: btw please don't use pastebin.com (it blocks tor users), better anything else, e.g. http://paste.lisp.org
<vlegoll>OK, I did a quick ddg search for "pastebin gnu.org" which did not find anything useful... I'll bookmark this one
<jlicht>civodul: http://hydra.gnu.org/nix-cache-info seems to take a lot of time for me
<civodul>jlicht: i suggest using --substitute-urls=https://mirror.hydra.gnu.org as a workaround
<vlegoll>does "guix build" pass CC env var ? I don't see it in /tmp/guix-build-sinit-1.0.drv-0/environment-variables ?
<alezost>vlegoll: no, you need to set it, grep for "CC=gcc" in the packages dir
<vlegoll>thanks again, but that's strange, I had "CC ?= gcc" in the makefile, yet it failed to build telling me it couldn't execute 'cc', which led me to think it did. And I fixed it by changing the "?=" into a simple "="...
<vlegoll>Thanks a lot for the newbie-helping, hope to be able to help myself soon... heading home, bye
<bavier`>I want to search a file for a regexp. Does Guix or Guile offer something straightforward for that?
<bavier`>Maybe I'll just loop over lines and regexp-exec each one
<paroneayea>bavier`: https://www.gnu.org/software/guile/docs/docs-1.6/guile-ref/Regexp-Functions.html#Regexp%20Functions
<paroneayea>you can also use irregex (packaged in guix) if you want a more scheme'y api (but it's slower)
<jmd>bavier`: Guix packages grep. So you can use that.
<civodul>wip-gexp-imported-modules merged! \\o/
<efraim> yay!
<civodul>hydra.gnu.org seems to be offline
<civodul>FSF syadmins are aware and working on it
<Gamayun>:)
<roelj>civodul: Is it a DNS issue then?
<roelj>Or is hydra actually hosted by the FSF sysadmins?
<civodul>roelj: it is hosted by the FSF
<civodul>it's not a DNS issue, the machine is really down
<civodul>they don't have an ETA yet but they'll let us know
<roelj>civodul: Wow, I always thought that hydra.gnu.org was hosted elsewhere..
<roelj>civodul: Time to set up the new hardware? :D
<civodul>roelj: that's in the works indeed :-)
<civodul>we received the new server last week