IRC channel logs

2016-05-08.log

back to list of logs

<roelj>kyamashita: Ok. Then I don't know what's wrong in your situation.. :)
<kyamashita>Thanks.
<kyamashita>I'll smack my keyboard for a while until I discover something interesting. :)
<kyamashita>ACTION is away
<kyamashita>my /var/guix/gcroots file is a symlink to /mnt/var/guix/profiles. Is this supposed to happen?
<lfam>kyamashita: For me, /var/guix/gcroots/profiles -> /mnt/var/guix/profiles
<kyamashita>lfam: What you wrote is what I meant.
<kyamashita>lfam: I guess this is normal. I'm trying to clear my Guix store a bit. I think I've found the culprit.
<lfam>I haven't had any trouble with :)
<lfam>Old profiles can be removed with `guix profile --delete-generations`. Then, you can reclaim the disk space with `guix gc`
<lfam>You can also remove profiles that are older than a certain date
<kyamashita>lfam: I think that's what I've been missing.
<lfam>`guix package --delete-generations=1m` will remove profiles older than 1 month
<lfam>Also see `guix gc --free-space`. No point it deleting more than you need to, especially when you are working on packages
<kristofer>lfam, would 1w work as well?
<lfam>Try it :)
<lfam>Or, read the code and then try it
<lfam>If you feel like augmenting the manual to describe the feature a little more fully, I think it would be welcomed. Right now I'd call it "lightly documented"
<kyamashita>Where does Guix look for *.desktop files? I want users to be able to install packages and launch them from the GNOME applications menu.
<robsyme>Hi all. Is there a clever way to track down the source of a stack overflow error like this:
<robsyme>ice-9/boot-9.scm:65:2: Throw to key `vm-error' with args `(vm-run "VM: Stack overflow" ())'.
<robsyme>This was from running 'guix environment -l package.scm'
<robsyme>Where package.scm is: https://gist.github.com/robsyme/2a3e1a0e9c839017f163b59deecbf299/d073942f5f660050687f0927d39ec5e455ccc1b8#file-package-scm
<rekado>robsyme: I don't know of a good way to debug this, but it looks like a dependency cycle.
<robsyme>rekado: Ok, thanks. I think I'll just manually trace back all the deps and look for loops.
<robsyme>rekado: Thanks :)
<calher>OMG, Guix has maim and Trisquel doesn't!
<calher>ACTION installs Guix on Trisquel
<calher> https://github.com/naelstrof/maim
***imr is now known as imr_
<calher>Sig fail: http://paste.debian.net/plain/682838
<efraim>verify the .sig file
<efraim>calher: ^
<calher>I feel so stupid.
<calher>ACTION facepalms.
<efraim>i've messed that up before
<calher>gpg: Good signature from "Ludovic Courtès <ludo@gnu.org>"
<calher>:D
<calher>I'm going to use Guix whenever there's no Trisquel package or PPA.
<efraim>i'm using guix on debian, using it for as many cli programs I can
<calher>And people who SSH into my PC can install what they like in their own profiles.
<efraim>and terminology, since debian's is stuck at 0.7.0
<calher>Oh yeah, I might use the Guix package if the default is old AF.
<calher>(And there's no PPA.)
<calher>I want a clear-cut way to remember: OK, which package manager did I use?
<calher>root@leela:/usr/local/share/info# guix archive --authorize < ~root/.guix-profile/share/guix/hydra.gnu.org.pub
<calher>warning: failed to install locale: Invalid argument
<calher>:(
<calher>:( I can't find maim: http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/xdisorg.scm#n416
<calher>or https://www.gnu.org/software/guix/packages/#maim
<calher>guix package -s maim does not show it
<calher>using guix on trisquel
<iyzsong>calher: I think you should run 'guix pull' to get the latest repository.
<calher>Oh, right.
<calher>ACTION does guix pull
<calher>iyzsong: Will my version of dmenu, installed by apt, see maim?
<iyzsong>yes, as far as `maim' is in the $PATH of dmenu.
<janneke>aaarghhh, why is configure so unimaginably broken?
<calher>How do I accesss the binaries in my profile on a host system?
<calher>export PATH="/home/cal/.guix-profile/bin
<calher>?
<fhmgufs>calher: That's right. Normally Guix shows the environment variables you need to define after each operation.
<fhmgufs>calher: If you want to have them defined automatically, just add ". $HOME/.guix-profile/etc/profile" to your .profile file.
<calher>. $HOME?
<calher>Huh?
<fhmgufs>calher: . means source and $HOME is defined to your home directory automatically.
<calher>fhmgufs: http://b.1339.cf/vnspivu.png
<calher>28 litres written.
<calher>fhmgufs: When is .profile reloaded? I started a new shell and tried to look for maim; still not found.
<fhmgufs>calher: For a maim? What's that?
<calher>fhmgufs: pkg
<fhmgufs>A new shell should have the profile reloaded.
<calher>That's what I thought, but I don't see maim show up still.
<fhmgufs>calher: Then run "source $HOME/.guix-profile/etc/profile" manually to test it.
<fhmgufs>If it's working then, it wasn't reloaded, if not, it's a different issues.
<calher>fhmgufs: That worked :D
<calher>fhmgufs: so, should i add "source $HOME/.guix-profile/etc/profile" to .profile or .bashrc?
<civodul>iyzsong, mark_weaver: hi! what's the status of gnome-updates? :-)
<sneek>civodul, you have 2 messages.
<sneek>civodul, efraim says: I was reading the manual for cloog and it says it is lgpl2.1+ unless built against polylib. since we build against isl the license should probably be changed
<sneek>civodul, efraim says: also http://isl.gforge.inria.fr/ says isl is MIT licensed, not lgpl2.1+ like we have listed
<civodul>efraim: if you're confident, please commit the changes, possibly with comments explaining the situation
<civodul>efraim: if in doubt, take it to the mailing list :-)
<fhmgufs>calher: I have it in my profile, but if you use Bash you can add it there too.
<calher>fhmgufs: :( I add source $HOME/.guix-profile/etc/profile to .profile but maim still does not appear
<fhmgufs>calher: Then add it to .bashrc, I don't know.
<cpjl>Hello, I’m trying to install zsh as the default shell on guix
<cpjl>and… I can’t get the prompt to be colorized
<cpjl>well, that’s a very small issue :)
<cpjl>but the weird thing is that from ssh and screen, the prompt is colorized
<calher>fhmgufs: weird; had to add to .bsahrc
<rekado>our importers should not print ugly backtraces when packages cannot be found upstream.
<rekado>usually that's because of a typo or other user error, so it would be nicer to catch this error than to print an ugly backtrace.
<kyamashita>I'm having an issue with packaging some calendar applications...
<kyamashita>Both orage and gnome-calendar suffer a segmentation fault when I run them.
<kyamashita>strace says that they cannot find a zone.tab file (it looks in directories appropriate for an FHS-compliant distro, not for GuixSD).
<kyamashita>gdb says something about
<kyamashita>gdb says something about "../sysdeps/x86_64/strlen.S"
<kyamashita>Also, GNOME is looking for backgrounds in my home directory rather than in my Pictures folder. I feel like this would be an easy fix.
<cpjl>the prompt thing I was talking about is probaly a rxvt-unicode bug
<calher>kyamashita: GNOME is annoying to do that.
<joshuaBPMan>Hello, I am trying to burn the guix installer image onto a cd. dd if=/path/to/guix.linux of=/dev/sr0 returns the following error: dd: failed to open /dev/sr0: read-only file system
<joshuaBPMan>I'm not sure why I'm getting this readonly error.
<cpjl>which does not find the terminfo entry
<joshuaBPMan>Anyone have any clues or relevent stackoverflow links?
<kyamashita>calher: I agree.
<kyamashita>joshuaBPMan: I do not believe that dd is the correct tool for the job.
<joshuaBPMan>the gnu guix documentation says to use dd for burning a usb stick. I just assumed that the same applied for a CD.
<cpjl> https://wiki.archlinux.org/index.php?title=Optical_disc_drive&redirect=no#Burning
<kyamashita>joshuaBPMan: Not quite.
<joshuaBPMan>I'll try brasero now and see if that works.
<cpjl>joshuaBPMan: you should have a look at the archlinux wiki
<kyamashita>joshuaBPMan: If you are looking for a commandline utility, you can use growisofs.
<kyamashita>joshuaBPMan: https://unix.stackexchange.com/questions/68426/how-to-burn-iso-image-to-dvd-using-dd-command
<joshuaBPMan>hmmm. Thanks kyamashita. I just tried with brasero, and it said that my dvd was not supported. I'm going to try another one.
<kyamashita>joshuaBPMan: What type of DVD are you using?
<joshuaBPMan>It is a "memorex" "DVD-R 16X 4.7GB 120min"
<joshuaBPMan>I'm really not sure what the problem is. I've used this machine, with these DVDs to burn stuff before.
<cpjl>DVD-R means read-only
<cpjl>I think
<joshuaBPMan>darn!
<cpjl>Read-write would be RW
<kyamashita>cpjl: Only if you've written to it before. DVD-R essentially means "one write".
<joshuaBPMan>kyamashita thanks for the tip.
<cpjl>I did non know tat
<cpjl>that
<joshuaBPMan>I'll have to find a DVD that i haven't used then.
<cpjl>Oh yes now I remember :) (it was a long time ago…)
<mark_weaver>civodul: I just asked hydra for a new evaluation of gnome-updates, and then I'll try updating my system to it.
<mark_weaver>it looks like there are still many new failures, but I'm going to avoid restarting those jobs until the evaluation is complete
<mark_weaver>(many of those new failures might be non-deterministic)
<joshuaBPMan>grr. I just tried 5 different clean DVDs. None worked. I'm going to try a usb stick.
<mark_weaver>joshuaBPMan: the guix installer is not an ISO image, so I'm not surprised that it doesn't work as a DVD
<mark_weaver>joshuaBPMan: was there something in the manual that suggested that it would work as a DVD?
<joshuaBPMan>mark_weaver: I just assumed that it would work on a DVD.
<DusXMT>"Assuming makes an ass out of you and me" :)
<joshuaBPMan>With respect sir, every other linux installer images that I'm aware of work on both DVDs and usbs.
<joshuaBPMan>I just assumed that it would work on a DVD. My mistake.
<joshuaBPMan>DusXMT: true dat.
<kyamashita>mark_weaver: Is creating a CD/DVD image a planned feature?
<mark_weaver>it would be a welcome feature. it only lacks someone to do the work.
<joshuaBPMan>GNU/Linux* installer images.
<kyamashita>joshuaBPMan: That's a fair assumption.
<joshuaBPMan>in case RMS is listening. :)
<mark_weaver>the normal disk image with GRUB has been working well enough that none of the existing developers seem motivated to work on creating an ISO
<mark_weaver>or in case anyone else is listening who believes in giving credit where it is due...
<DusXMT>And it was even argued several times that USB drives are more convenient for this purpose, and sometimes even neccessary, on machines which don't have a CD drive, like netbooks
<joshuaBPMan>Just to be clear, I'm not bashing the GNU guix people. I think they're awesome.
<kyamashita>joshuaBPMan: Yeah, I don't think anyone picked up that vibe.
<mark_weaver>joshuaBPMan: no worries, and fwiw, yours was an understandable assumption.
<joshuaBPMan>does anyone know of a way to graphically burn a usb stick? I've tried the dd way several times on 3 different sticks, and I keep not being able to get it right. I'm about to try on a new stick. haha
<joshuaBPMan>thanks mark_weaver
<DusXMT>joshuaBPMan: What kind of error do you get?
<DusXMT>What is the command you used in its full extent?
<joshuaBPMan>Well I typically get the dd if=/path/to/guix.linux of=/dev/sr0 returns the following
<joshuaBPMan> error: dd: failed to open /dev/sr0: read-only file system
<DusXMT>that's because /dev/sr0 is the CD drive
<joshuaBPMan>Sorry. I meant /dev/sdb
<DusXMT>joshuaBPMan: In that case, does it still report the 'read-only filesystem' error? And are you sure your USB stick is /dev/sdb? (did you check with dmesg after plugging it in?)
<mark_weaver>joshuaBPMan: what was the exact error message? (the one above clearly isn't the right message, since it included /dev/sr0)
<DusXMT>(if you have a card reader built into the case, that can take up the first couple of /dev/sdX devices)
<joshuaBPMan>dd: failed to open /dev/sdb: read-only file system
<joshuaBPMan>It was a couple of days ago that I ran into that error, but that was the error. I'll try to re run the command again in a little bit.
<DusXMT>joshuaBPMan: And be sure to check that it's the correct drive; just type dmesg after plugging it in and you'll see
<mark_weaver>joshuaBPMan: you're running this as root?
<joshuaBPMan>But right now I'm not able to mount the current usb stick that I have. It's telling me I can't mount it because of wrong fs type
<joshuaBPMan>and yes I am running this as root.
<mark_weaver>don't mount it
<DusXMT>joshuaBPMan: uhmmm. you're not supposed to mount it
<mark_weaver>the usb stick must not be mounted when you run dd
<joshuaBPMan>sudo dd if=/path/to/guix of=/dev/sdb
<mark_weaver>if it was mounted, that might explain the error
<joshuaBPMan>and I'm not mounting it. I'm mounting it now, because I have to get the picures on the current usb off before I burn the image onto it.
<DusXMT>And if you want to fix it, (restore the partition table, so that you can use it as a regular USB stick), you can use fdisk, there press "o", "p", a couple times enter, "w", and then mkfs.ext2 /dev/sdX1
<DusXMT>s/"p"/"n"/
<joshuaBPMan>hmmm. I'm not really sure what that means DusXMT, but I've gotta go, so I'll try to digest that information when I get back.
<DusXMT>ACTION thinks that people don't get warned enough that burning an image into a USB drive will wipe away the partition table :>
<kyamashita>ACTION agrees.
<mark_weaver>patches welcome
<kyamashita>So I found something interesting in the gnome-control-center source code...
<kyamashita>In panels/background/cc-background-chooser-dialog.c in lines 554-564.
<kyamashita> * directory in the string below when XDG_PICTURES_DIR is
<kyamashita> * undefined */
<kyamashita>"/* translators: "Home" is used in place of the Pictures
<kyamashita> * directory in the string below when XDG_PICTURES_DIR is
<kyamashita> * undefined */"
<kyamashita>That's slightly better.
<kyamashita>Whoa. There are actual lambda symbols in admin.scm???
<civodul>rekado: re #23421, you forgot the patch :-)
<civodul>or maybe i should give it a try
<wingo>i have an r6rs port question, if someone is interested (perhaps civodul or mark_weaver)
<wingo>currently it appears that if the port-conversion-strategy is 'error
<wingo>corresponding to an r6rs error-handling-mode of 'raise
<wingo>then if we are reading input in some encoding, and we encounter an invalid encoding
<wingo>that we raise the error *after* advancing the read pointer
<wingo>so if you call read-char again then you will continue decoding
<wingo>there is a comment in the source indicating that r6rs requires this behavior in https://docs.racket-lang.org/r6rs/r6rs-lib-std/r6rs-lib-Z-H-9.html#node_sec_8.2.4
<wingo>but i think that's incorrect
<wingo>that in the case of "raise", that actually we should not be advancing the read pointer
<wingo>see the documentation there for `(error-handling-mode ...)'
<wingo>if someone wants to verify my undestanding of that passage, input is welcome :)
<mark_weaver>ACTION looks
<civodul>ACTION -> #guile
<mark_weaver>yes, indeed!
<civodul>:-)
<wingo>haha
<wingo>sorry about that!
<janneke>ACTION phew!