IRC channel logs

2016-04-09.log

back to list of logs

<suitsmeveryfine>Yay! I've almost succeeded in making my first package for guix
<Jookia>woo!
<suitsmeveryfine>There is one thing that doesn't work: the config file complains about a missing dependency: lzo2, althought 'lzo' is available
<suitsmeveryfine>How do I define the inputs so that the package-to-be-installed knows that it's available?
<rain1>is this at runtime?
<suitsmeveryfine>n
<suitsmeveryfine>no, it's in the configure phase
<suitsmeveryfine>just one of the inputs that isn't accepted
<suitsmeveryfine>the program is written in C++
<suitsmeveryfine>Currently I need "./configure --without-liblzo2" in the package definition.
<mark_weaver>suitsmeveryfine: look in config.log to see what went wrong trying to detect it
<mark_weaver>after trying to build it with the -K option
<mark_weaver>(to keep the failed build directory, which will end up in /tmp/guix-*
<mark_weaver>)
<suitsmeveryfine>mark_weaver: I built it with this command: ./pre-inst-env guix build openttd --keep-failed
<mark_weaver>okay, then look in /tmp/guix-*/*/config.log
<mark_weaver>in there should be a test program that it tried to compile to detect the library, and a compile command to try building it, and probably some error message
<mark_weaver>search for the name of the library in there
<suitsmeveryfine>Nice. I'll need to modify the package defintion to remove the above option. I will then try again.
<mark_weaver>okay
<suitsmeveryfine>By the way: after sucessfully building the package I could only open it by finding the absolute path to the executable. Is this normal?
<suitsmeveryfine>mark_weaver: I found this:
<suitsmeveryfine>detecting lzo2
<suitsmeveryfine>trying /usr/include/lzo/lzo1x.h... no
<suitsmeveryfine>trying /usr/local/include/lzo/lzo1x.h... no
<suitsmeveryfine>trying /mingw/include/lzo/lzo1x.h... no
<suitsmeveryfine>trying /opt/local/include/lzo/lzo1x.h... no
<suitsmeveryfine>checking lzo2... not found
<mark_weaver>suitsmeveryfine: okay, that's the problem. is there a way to tell it where to find the headers?
<suitsmeveryfine>hmm, maybe I could send it which "lzo"?
<suitsmeveryfine>mark_weaver: I found the function (in config.lib) that looks for the libraries. It has this form:
<suitsmeveryfine>and a lot of more code that I should'n post here.
<suitsmeveryfine># $4 - header directory ()
<rain1>we should patch it to use pkg-config
<suitsmeveryfine>I added pkg-config as a native input
<suitsmeveryfine>most inputs are recognized
<suitsmeveryfine>but not "lzo"
<suitsmeveryfine>rain1: I think you may be right!
<suitsmeveryfine>In the `config.lib` file certain dependencies have [=\\"pkg-config xxxx"] while others don't, including lzo
<suitsmeveryfine>rain1: do you think you'd be able (and willing) to patch `config.lib` so that pkg-config is used for the 'lzo' package?
<rain1>no but you could ask the openttd people, maybe lzo does not even provide a pkg config .pc file though
<suitsmeveryfine>I just asked the question in their IRC channel
<suitsmeveryfine>rain1: maybe you are right and that's why pkg-config isn't used
<suitsmeveryfine>I guess that I could submit the packages with lzo disabled. The game is still playable, you just can't load old saved games.
<rain1>that sounds fine
<suitsmeveryfine>OK. I guess that I should just send an email with the package definition to the list
<suitsmeveryfine>thanks for you help
<fps>hi, this page tells me to extract the binary tarball in /tmp
<fps> https://www.gnu.org/software/guix/manual/html_node/Binary-Installation.html
<fps>is that correct? the paths lateron in the manual seem to indicate it was extracted in /
<fps>ah no, i suck :)
<jmd>I wouldn't recommend /tmp but you can unpack it there if you want.
<fps>jmd: i used /tmp/guix
<fps>just to keep clutter away from tmp
<fps>the location really doesn't matter :)
<jmd>You just need to be aware, that (on most systems) /tmp is emptied on reboot.
<fps>yeah, the installation instructions then go on to how to move the files to their expected locations
<fps>it's all good
<fps>using the guix binary (e.g. guix pull) i get quite a few:
<fps>warning: failed to install locale: Invalid argument
<fps>good job on making it much faster than on 0.9 :)
<jmd>What do I need to install to get guile bindings for gtk+ ?
***tschwing_ is now known as tschwinge
<janneke>phant0mas: see wip-hurd+mingw: ugly hack to get readline compiled (linking: todo)
<janneke>phant0mas: i think we need a kind='cross next to host/target
<janneke>ACTION rebuilds world again
<phant0mas>janneke: rebuilding world
<janneke>hey phant0mas ... still building here
<janneke>my latest patch is a real mess, as you can see
<janneke>i'm still struggling to understand guix's cross build system
<janneke>i added lots of stuff to print debugging info and hooks to possibly add a `cross' stage next to host/target
<suitsmeveryfine>Hi! I'd like to patch the source files of a package that doesn't understand that GNU's not Unix. From what I've understood from the manual it's most convenient to do it as a snippet.
<suitsmeveryfine>I'd like to modify all the text files in "src/lang" and replace the string ":Unix" with ":GNU". How is this done in Guile Scheme?
<suitsmeveryfine>(I'm looking at the reference manual right now but it's quite long.)
<janneke>a package that is sentient?
<fps>hmm, the configure script doesn't check for help2man, but errors out on missing help2man while insisting it's only a warning
<fps> https://pastee.org/eth3q
<suitsmeveryfine>jenneke: well, the upstream project doesn't use good language.
<janneke>good is a judgement, it depends on your perspective
<suitsmeveryfine>janneke: well, it's not correct in any case
<janneke>you may want to ask upstream why they use :Unix where you think it should be :GNU
<suitsmeveryfine>The program's exit dialog says: "Are you sure that you want to exit and return to Unix?"
<suitsmeveryfine>janneke: they use "Unix" for both the BSDs and GNU/Linux ports
<janneke>suitsmeveryfine: well, if the package builds on osx and windows too, :GNU could not be the best wording too?
<mthl>fps: help2man is no meant to be a build dependency when building from a tarball.
<suitsmeveryfine>janneke: yes, but I don't intend to modify those phrases.
<fps>mthl: i cloned the git repo, so it's not a tarball, but close enough :)
<fps>mthl: i suppose it's a bug in the build then?
<suitsmeveryfine>Besides, we're talking about patching software that goes into a GNU distro.
<fps>oh, and i just remembered that i could have just used guix environment guix to get all i need to build guix instead of hunting down deps in ubuntu
<janneke>although i have done it a lot, i still believe carrying diffs is evil
<janneke>possibly, sometimes, temporarily a necessary evil
<mthl>fps: what do you mean by "a bug in the build"?
<fps>mthl: the build errors out when help2man is missing
<fps>see my pastee
<mthl>fps: help2man is a "maintainer" dependency which is required when building from Git
<suitsmeveryfine>janneke: I prefer that this program says "return to GNU" rather than "return to Unix" when it's packages for GuixSD.
<suitsmeveryfine>*packaged
<fps>mthl: ok, then
<suitsmeveryfine>And it's a very simple patch, ...but I guess that I will need to learn Guile Scheme first.
<janneke>suitsmeveryfine: you may be looking for substitute*
<suitsmeveryfine>janneke: Yes, I saw that this was used in another place and tried this (which didn't work):
<janneke>suitsmeveryfine: "*.txt"! Where did you find that example?
<janneke>ACTION sees several cases of (find-files "...") as a first argument to substitute*
<suitsmeveryfine>janneke: it doesn't make any difference if I specify only one exact file
<suitsmeveryfine>"find-files"... nice
<janneke>why would you want to change :GNU into :Unix?
***Basstard1 is now known as Basstard`
<janneke>ACTION is just doing `git grep'...
<suitsmeveryfine>No, it should be the other way around
<suitsmeveryfine>I don't pretend to know this language.
<phant0mas>janneke: is realine failing for you, in the latest commit in your branch?
<janneke>phant0mas: not there yet
<phant0mas>I got i686-w64-mingw32-ld: cannot find -lncurses
<phant0mas>i686-w64-mingw32-ld: cannot find -ltermcap
<janneke>phant0mas: ah, that could be
<janneke>that would be "wonderful", it means getting past configure and compile
<janneke>only a "silly" link problem remains
<janneke>there should not be any -ltermcap
<janneke>i think
<janneke>previously, configure would stumble on a host's gnu-stubs32 include
<janneke>i meant to fix the -lncurses problem though, if i haven't that means another rebuild world.
<janneke>oh how i miss GUB's --no-depenencies
<phant0mas>from what I see in (gnu packages readline) "LDFLAGS=-Wl,-rpath -Wl," (assoc-ref %build-inputs "ncurses") "/lib" is passed to configure
<phant0mas>isn't this supposed to fix the above problem?
<phant0mas>hm..
<janneke>libncurses.dll lives in bin/
<janneke>it used to be libncurses6w.dll only, i attepmted a fix for that which i'm trying out "now" (the past 3hours)
<janneke>why do we have to rebuild everything if only mingw/hurd specific changes are needed?
<suitsmeveryfine>Yay! It works. Thank you janneke for pointing me in the right direction with "find-files"
<janneke>suitsmeveryfine: np
<suitsmeveryfine>Now I'm thinking about another modification: the DOS port contains non-free software that I guess need to be deleted. Maybe I should just remove all of the non-GNU OS ports since they will not be used in GuixSD. What do you think?
<phant0mas>janneke: if something changes deep in the dependency tree everything has to be built again
<phant0mas>:-(
<janneke>phant0mas: it would help if that could be prevented when creating a new target system
<phant0mas>janneke: you could do a trick using (if (current-target-system) ...) so your changes would be used only when cross building
<phant0mas>and you are sure it works, you remove the if
<phant0mas>and push the change
<janneke>trying that now :-)
<janneke>for the /lib vs /bin thing
<janneke>still, it seems that world rebuilds again
<paroneayea>hello, *!
<paroneayea>anyone running guix on a beaglebone here?
<paroneayea>I'm guessing "no" but
<paroneayea>I'm trying to figure out if possible
<paroneayea>I guess if we go uboot -> grub it might work?
<paroneayea> https://wiki.linaro.org/LEG/Engineering/Kernel/GRUBonUBOOT maybe?
<paroneayea>maybe I should stick to debian on it for now....
***Basstard1 is now known as Basstard`
<jmd>parabool: I sort of had it going on something similar some months ago.
<ng0>please don't let the MAME discussion become another "merge /usr" discussion, that is going on for like, idk almost a year now on gentoo-dev.. mame really starts to fill up my inbox :/
***Basstard1 is now known as Basstard`
<janneke>ng0: don't mention the war
<ng0>rule number one, sorry forgot it
<paroneayea>ng0: there's already a response from civodul on what the resolution is
<paroneayea>there's no reason for people to keep discussing it on guix-devel
<ng0>it might be gnu-linux-libre list, I was just complaining in general to myself.
<paroneayea>there's no way to boot guix from a cdrom presently, is there?
<alezost>I think no, since there is no iso image
<paroneayea>hm
<paroneayea>for some reason my 10 year old desktop seems incapable of booting from usb!
<Jookia>paroneayea: you might need to go in to the BIOS and change the boot order to use USB-HDD, or if the USB is inserted, check your HDD boot order to see if it adds the USB there
<ng0>or press either of f12, f8, f1 or any other key which could get boot selection prompt
<quiliro>hello
<quiliro>using guixsd now
<quiliro>happy!
<quiliro>i have spoken with a government agency that is willing to provide one or more vlades in exchange for libreoffice support
<quiliro>can we provide that?
<quiliro>s/vlades/blades/
<quiliro>not in donation but in their own premises
<mark_weaver>I don't see how we could use those
<mark_weaver>and I'm not sure what "libreoffice support" means exactly
<mark_weaver>what government agency?
<quiliro>can guix use that and can we provide support to migrate to libreoffice they need?
<quiliro>instituto ecuatoriano de propiedad intelectual
<mark_weaver>I don't think we're in a position to provide support for migrating to Libreoffice
<quiliro>mark_weaver: they need to support users when they have difficulties when changing from ms office
<ng0>libreoffice support sounds like user/tech support for the libreoffice infrastructure, which we can't do
<ng0>guix is no libreoffice support desk.
<ng0>i mean, it sounds like a big, time eating effort
<mark_weaver>yeah, I must agree
<quiliro>maybe with 1 hour of support per day would be enough
<paroneayea>Jookia: I was able to boot it via hitting F8 and entering the boot menu
<mark_weaver>I also don't think that we have sufficient expertise in libreoffice here.
<quiliro>ok then
<paroneayea>installing guixsd on my backup machine now!
<paroneayea>that'll mean two guixsd machines on my network
<paroneayea>(and hopefully will help me a little bit towards incentivizing managing remote guixsd machines!)
<ng0>it would be doable if the request was readable in text form and not just a very vague request in IM
<mark_weaver>expertise in MS office would probably also be needed, and we most definitely don't have that
<ng0>i stopped with it in 2008 or 9, so I only help with ms office when i have to when i am at the desk of someone. so i wouln't be in the position.
<mark_weaver>I think it's a good initiative, but we're not a good fit for that job.
<ng0>yep
<ng0>quiliro: maybe you know some org with the right contacts in the country?
<ng0>like FSFE, FSF,
<Jookia>why not the libreoffice community
<quiliro>libre FSFLA
<ng0>they should be able to network contacts better than us
<quiliro>but they will need enterprize grade support and not just come and go support
<quiliro>and i cannot pay
<quiliro>they cannot pay either because the economy is depressed and they have cuts
<quiliro>but they have extra blades
<quiliro>and i was thinking of using them for a libre distro
<ng0>sure, but i think your national FSF is more suited to find a solution for that, i have this impression with fsfe work here
<Acou_Bass>paroneayea: there is a boot CD available that essentially emulates a bios to enable USB booting on machines that dont natively support it... let me try and remember the name
<Acou_Bass>hmm
<Acou_Bass>i dunno how free it is acutally, i assumed it was
<Acou_Bass> https://www.plop.at/en/bootmanagers.html
<paroneayea>Acou_Bass: cool! thanks i did get it working, but I had been confused :)
<quiliro>why the web navigator not reproduce vp8 on youtube?
<quiliro>on xfce
<quiliro>it is called web
<quiliro>i suppose it is icecat
<quiliro>sudo guix package -i libreoffice
<quiliro>is correct?
<quiliro>i get
<quiliro>The following environment variable definitions may be needed: export PATH="/root/.guix-profile/bin"
<quiliro>at the end of the installation
<Acou_Bass>quiliro: dont run as sudo
<Acou_Bass>just guix package -i
<quiliro>Acou_Bass: i want all users to be able to use the program
<Acou_Bass>then youll need to add it to your desktop.scm ;P
<quiliro>Acou_Bass: will all users be able to use the program if i use sudo?
<quiliro>oh
<quiliro>ok
<quiliro>Acou_Bass: thank you
<quiliro>then guix system update /etc/destop.scm
<quiliro>right?
<quiliro>but guix pull
<quiliro>before that
<quiliro>right?
<kristofer>quiliro: you'd run guix system reconfigure..
<kristofer>although, any user on the system can install the libreoffice package into their profile
<quiliro>kristofer: what happens with the downloaded packages? will they be available to other users?
<kristofer>if the hashes match, I'd guess that profiles would share packages in the store
<suitsmeveryfine>Hi! I'm working on a package definition. I can build successfully but all the files are installed inside the store, including icons and the desktop file. It's possible to send options to the configure script where the "share", "icon" directories and others can be set. Which is the proper way to do this?
<Acou_Bass>quiliro: yep, sudo guix pull then sudo guix system reconfigure /etc/desktop.scm
<Acou_Bass>thats what id id to add firefox + libreoffice for all users
<Acou_Bass>(well, icecat, not firefox) :D
<suitsmeveryfine>For the package I use the GNU build system, but with "check" deleted and "configure" replaced with a minimal definition that uses the configure file in the sources.
<quiliro>si i change
<quiliro>(packages (cons* nss-certs
<quiliro>to
<quiliro>(packages (cons* nss-certs libreoffice icecat
<quiliro>???
<quiliro>s/si/so/
<slim_>hi
<quiliro>hi slim_
<slim_>hi quiliro, can I ask a noob question here?
<suitsmeveryfine>So, for example, what could I enter after `--icon-dir=`, `menu-dir=`, `--man-dir=`, etc.
<kristofer>slim_: don't be shy :)
<quiliro>slim_: I am a noob too...but might be able to help
<slim_>kristofer: so here it goes
<ajgrf>suitsmeveryfine: they *should* be installed in the store. it sounds like you already did it correctly, unless i misunderstood
<slim_>i can t manage to setup a french keyboard on gnome
<slim_>is there a package i can install?
<slim_>coming from a debian background
<slim_>in guixsd
<suitsmeveryfine>ajgrf: I don't think I've done it correctly because I can only start the program by executing the binary in the store, i.e. no typing the package name and no .desktop file shows up in GNOME.
<suitsmeveryfine>For other programs that I've installed, e.g. claws-mail and emacs, there are both icons and desktop files under ~/.guix-profile/
<kristofer>slim_: your system configuration should have (services (cons* (console-keymap-service "fr") (...) %desktop-services))
<ajgrf>so you have installed the package in your user profile?
<suitsmeveryfine>I built the program in a git checkout
<suitsmeveryfine>inside the guix environment
<slim_>kristofer: thqnks
<ajgrf>suitsmeveryfine: ok, so if you run `guix package -l` your new package should be listed. if it isn't there then we need to fix that first, because i wouldn't expect the desktop files to be found then
<quiliro>slim_: i have the same problem es_EC.utf8 does not exist
<suitsmeveryfine>ajgrf: it does not show up in the list
<ajgrf>suitsmeveryfine: ok, so that means you built the package but didn't install it yet
<quiliro>and loadkeys dvorak-es will not work either on the console
<suitsmeveryfine>ajgrf: but I get the error `unknown package` if I try to install using `guix package -i PACKAGE-NAME`
<ajgrf>suitsmeveryfine: what did you do to build it?
<suitsmeveryfine>./pre-inst-env guix build openttd --keep-failed
<suitsmeveryfine>and before that `make clean-recursive ; ./configure --localstatedir=/var ; make`
<ajgrf>so can you run `./pre-inst-env guix package -i openttd`?
<quiliro>is there a voip client in guix? cannot find it in https://www.gnu.org/software/guix/packages/
<suitsmeveryfine>ajgrf: interesting! I haven't tried that before. When I run that command I get a lot of errors
<suitsmeveryfine>I think it tries to build it again
<suitsmeveryfine>ajgrf: I'll spend som time to investigate this. I might come back in a while. Thanks for your unput
<suitsmeveryfine>*input
<ajgrf>suitsmeveryfine: as a temporary measure you can run `guix package -i /gnu/store/<hash>-opentdd-<version>`
<ajgrf>it's not the right way but you can try out your package for now like that
<suitsmeveryfine>good to know!
<ajgrf>and actually, if the errors you're seeing are all about collisions then it's safe to ignore them
<suitsmeveryfine>ajgrf: it looks like the errors are about certain dependencies that can't be built
<suitsmeveryfine>which is strange because I have no trouble running the program
<suitsmeveryfine>those errors only showed up when I ran the install command
<quiliro>i cannot find /usr/share/locale
<quiliro>to check which locales are available
<quiliro>and locale -a will not work
<quiliro>how can i configure es_EC.utf8 locale? it will not be set according to my desktop.scm file
<quiliro>i have put it ...but it will not be used
<quiliro>(locale "es_EC.utf8")
<quiliro>in (operating-system
<suitsmeveryfine>quiliro: I'm afraid that I can't help you. I had the same problem when I installed the OS
<Jookia>quiliro: did you try UTF-8 instead
<quiliro>how can i add packages in my scm?
<Jookia>i suggest reading the manual quickly
<suitsmeveryfine>quiliro: you can install packages later
<Jookia>you can find it using 'info guix'
<quiliro>(packages (cons* nss-certs libreoffice icecat
<quiliro>is that correct?
<suitsmeveryfine>quiliro: I think most people here would agree that it's better to get a working system first and then install more packages later. After you've rebooted you only need to run `guix pull` and then `guix package -i icecat`
<quiliro>i want all users to be able to use the packages
<suitsmeveryfine>I see
<quiliro>suitsmeveryfine: i have guixsd working
<quiliro>the commands you told me would not install it system-wide
<quiliro>only for the current user
<kristofer>quiliro: that's the idea behind guix I think.. it gives users control over the packages in the profile instead of a system administrator
<quiliro>kristofer: so you suggest i do not install these packages system-wide?
<Jookia>quiliro: well, it depends whether you want them to have them 'pre-installed' system-wide
<quiliro>this is a laptop computer
<quiliro>only i and another person will use it
<kristofer>quiliro: are there going to be multiple user profiles?
<quiliro>kristofer: just one profile
<quiliro>i will make multiple user profiles only for demonstration
<kristofer>quiliro: I'd just do a very basic desktop system configuration and install packages in my profile
<Jookia>quiliro: check the sample config in the manual, that's how to do it
<suitsmeveryfine>ajgrf: I've made som progress. The package now shows up when I run `guix package -l`. I still can't start it by entering the package name in a terminal, however, and the desktop file doesn't show up
<suitsmeveryfine>I just rebooted to see if that would help but it didn't.
<suitsmeveryfine>ajgrf: Do I need to reconfigure the system you think?
<quiliro>ok kristofer
<quiliro>Jookia: thats what i did
<Jookia>quiliro: does it work?
<quiliro>Jookia: yes\\
<Jookia>woo
<quiliro>Jookia: but i have not added extras
<Jookia>you mean stuff like libreoffice?
<quiliro>Jookia: it is a great feeling
<quiliro>Jookia: yes
<Jookia>try it and see if it works
<alezost>suitsmeveryfine: IIUC you built openttd and now want to check if it can be started, right?
<suitsmeveryfine>alezost: I built it, successfully installed it but I can only start it by running the executable in the store
<quiliro>if libreoffice will be used by all users, why should each user install it
<suitsmeveryfine>quiliro: the users might prefer different versions of libreoffice
<alezost>suitsmeveryfine: so after you installed is there a binary at ~/.guix-profile/bin ?
<suitsmeveryfine>alezost: no it's not
<alezost>how did you install it?
<suitsmeveryfine>as you suggested above, from the git checkout
<alezost>suitsmeveryfine: I didn't suggest anything :-)
<alezost>it was ajgrf probably
<suitsmeveryfine>yes, sorry
<suitsmeveryfine>I ran: ./pre-inst-env guix package -i openttd
<suitsmeveryfine>and it worked
<suitsmeveryfine>after this the packages shows up when I run `guix package -l`
<alezost>ok, is there a binary after building in /gnu/store/...-openttd.../bin?
<suitsmeveryfine>it's located here: /gnu/store/w7njlh3rm9a7zd9h8w91clvk8brfbz2k-openttd-1.6.0/games/openttd
<suitsmeveryfine>and I have no trouble starting it from there
<alezost>ah, so the problem is that it's not in "bin" but in "games"
<suitsmeveryfine>oh, I see
<alezost>suitsmeveryfine: you picked a really complex thing as a first package :-)
<quiliro>suitsmeveryfine: oh!
<quiliro>true
<suitsmeveryfine>alezost: yes, you're right; openttd is pretty complex
<suitsmeveryfine>But I've learned quite a bit
<Jookia>suitsmeveryfine: congrats on getting openttd running!
<quiliro>what is needed for html5 to work?
<suitsmeveryfine>thank you Jookia :)
<Jookia>quiliro: a web browser?
<alezost>suitsmeveryfine: so you have to figure out how to put the binary to the right directories (probably with flags to 'configure' script)
<quiliro>it will not view webm videos
<quiliro>in youtube
<Jookia>hmm, that's odd
<Jookia>it works for me?
<alezost>works for me as well
<suitsmeveryfine>Jookia: I even modified my package so that it says "return to GNU" instead of "return to Unix" in the exit dialog :)
<Jookia>suitsmeveryfine: heh, not sure if that's a good or justified idea but cool nevertheless
<suitsmeveryfine>Jookia: GNU's not Unix
<pizzaiolo>suitsmeveryfine: what?
<pizzaiolo>not unix?
<pizzaiolo>fuck
<suitsmeveryfine>Jookia: the modification is done in the package definition so it's transparent
<pizzaiolo>:P
<suitsmeveryfine>like this:
<Jookia>suitsmeveryfine: neato
<suitsmeveryfine>;; GNU's not Unix so let's modify the exit dialog. (substitute* (find-files "src/lang/" "\\\\.txt") ((":Unix") ":GNU"))))))
<Jookia>Interesting
<Jookia>but what if you're running Guix on BSD? ;)
<suitsmeveryfine>But there is no system but GNU...
<pizzaiolo>lol
<pizzaiolo>guix on windows imagine that
<suitsmeveryfine>alezost: you are right; there is a binary_dir="games" option
<Jookia>if openttd wants to install, generally set the prefix to the out path
<suitsmeveryfine>Currently it looks like this: " (string-append "--prefix=" out)
<suitsmeveryfine>I will try to add more flags
<suitsmeveryfine>Or do you suggest something else?
<Jookia>hmm
<Jookia>shouldn't the gnu build system be setting prefix automatically
<ajgrf>suitsmeveryfine: i think --binary-dir=bin would be the trick
<ajgrf>*do the trick
<suitsmeveryfine>Jookia: no I couldn't use the gnu build system unmodified
<suitsmeveryfine>again, it is a complex package
<Jookia>can i see? curious
<suitsmeveryfine> http://paste.lisp.org/display/312614#4
<suitsmeveryfine>I'd be happy for any criticism
<suitsmeveryfine>ajgrf: which is the stylistically best way to add a second flag in your opinion?
<Jookia>"The DOS port contains proprietary software"?
<ajgrf>suitsmeveryfine: you can use the #:configure-flags argument
<ajgrf>would be easier than what you're currently doing too
<ajgrf>something like:
<suitsmeveryfine>ajgrf: I couldn't get it to work when I tried it before
<Jookia>there's no other way to disable --enable-fast-install ?
<ajgrf>oh, what happened?
<suitsmeveryfine>Either syntax error or build failure
<suitsmeveryfine>Jookia: no I asked here in the chat but people told me that there isn't
<Jookia>ah, i see
<suitsmeveryfine>I tried to modify the build system by commenting out that line, but then the entire world wanted to rebuild itself :)
<alezost>suitsmeveryfine: please use "modify-phases" syntax instead of alist-delete and alist-replace
<alezost>also instead of deleting 'check' phase, I think you can disable tests by adding "#:tests? #f" to 'arguments'
<suitsmeveryfine>I also tried "#:tests? #f" but it didn't work
<suitsmeveryfine>OK, I'll try to use "modify-phases"
<suitsmeveryfine>Maybe "#:configure-flags" doesn't work because I override the "config" part of the gnu build system. Do you think so=
<suitsmeveryfine>?
<Jookia>yes
<quiliro>when using guix package -i as a user (not root) the packages download again
<suitsmeveryfine>Jookia: what's the cleanest way to add more options then in your opinion, if you look at the "(string-append "--prefix=" out)" part
<alezost>suitsmeveryfine: why do you use this "ftp.snt.utwente.nl" instead of the official url?
<Jookia>quiliro: what do you mean?
<Jookia>suitsmeveryfine: looks good to me if it works
<suitsmeveryfine>alezost: oh, the official URL has been unstable
<quiliro>that i installed as root libreoffice and now as another user and the packages are being redownloaded
<suitsmeveryfine>I guess that I should change the URL to the official one before submitting
<alezost>suitsmeveryfine: unstable? what do you mean?
<quiliro>Jookia: ^
<suitsmeveryfine>alezost: well, it's been unavailable
<Jookia>quiliro: are they running the same guix version
<suitsmeveryfine>and the official server just pointed to this other URL
<alezost>oh, ok
<suitsmeveryfine>Jookia: my problem is that when I try to add more flags they are interpreted as one option
<quiliro>Jookia: i didnt know they could run different versions on the same cpu and at the same time...can they?
<suitsmeveryfine>and so I get a build failure
<alezost>quiliro: perhaps you did "guix pull" as root but not as user, so it tries to install a different libreoffice
<Jookia>quiliro: yep
<quiliro>alezost: oh!
<Jookia>suitsmeveryfine: you gotta ad spaces
<Jookia>suitsmeveryfine: oh you might not have to
<suitsmeveryfine>I tried that
<Jookia>if there is a clue to be found, i don't have it
<Jookia>try display/printing the command line you're gonna run
<suitsmeveryfine>I understand. Maybe it was something else that I messed up at the same time. That's pretty likely
<quiliro>so always use guix pull and then guix package -i
<alezost>quiliro: well, always is probably too much :-) I would do it once in a couple of days maybe
<alezost>but actually I don't use "guix pull", instead I use guix from a git checkout
<suitsmeveryfine>maybe I need to add "(string-append "--prefix=" out)" twice?
<Jookia>how would that help
<suitsmeveryfine>Jookia: maybe it will be enough nag to make the program want to build
<Jookia>perhaps
<Jookia>is there not any useful error output
<suitsmeveryfine>yes, I'll check that soon
<suitsmeveryfine>I just need to clean up and rebuild every thime
<suitsmeveryfine>*time I make a change to the definition
<suitsmeveryfine>Jookia: I can't make i build any more after having changed into modofy-phases
<alezost>suitsmeveryfine: could you show how you changed to modify-phases?
<suitsmeveryfine> http://paste.lisp.org/display/312614#5
<alezost>suitsmeveryfine: it's correct, what error do you get?
<alezost>wait, you told that "#:tests #f" doesn't work, is that it? then remove 'check' as you did
<quiliro>suitsmeveryfine: son openttd is working in guix?
<suitsmeveryfine>alezost: I fixed a typo just before sending that paste. Now it seems to be building
<suitsmeveryfine>Haven't got to the check part yet. Let's see if it fails there
<alezost>suitsmeveryfine: ok, btw do you use emacs?
<suitsmeveryfine>alezost: yes
<suitsmeveryfine>Emacs is really great for working with these packages
<suitsmeveryfine>quiliro: I package openttd for GuixSD
<suitsmeveryfine>alexost: the build worked! Now I only need to add the second flag
<suitsmeveryfine>alezost
<alezost>suitsmeveryfine: indeed, I just see that the indentation of 'modify-phases' is not perfect. So I think you installed guix on top of some distro using binary install, right?
<suitsmeveryfine>that's right
<alezost>great! you are doing a good job
<suitsmeveryfine>THis is fun :)
<suitsmeveryfine>alezost: do you know how I can fix the indentation settings?
<quiliro>suitsmeveryfine: so i can jut guix pull && guix package -i openttd
<quiliro>?
<suitsmeveryfine>quiliro: not yet
<quiliro>s/jut/just
<quiliro>suitsmeveryfine: please tell me
<alezost>suitsmeveryfine: yes, do you use emacs installed with Guix?
<suitsmeveryfine>quiliro: when I'm done I will submit this for inclusion
<suitsmeveryfine>so you and everyone else can play OpenTTD
<quiliro>the browser's name in Gnome is web?
<suitsmeveryfine>alezost: what do you mean installed with guix?
<suitsmeveryfine>oh, I misunderstood you above: I'm using GuixSD
<alezost>I mean do you run emacs from ~/.guix-profile or from your distro (/usr/bin)
<suitsmeveryfine>the former
<alezost>suitsmeveryfine: on GuixSD? Could you check, do you have any "M-x guix-..." command available?
<suitsmeveryfine>yes, e.g. M-x guix-emacs-load-autoloads
<suitsmeveryfine>shall I run that?
<alezost>suitsmeveryfine: no. Actually you should also have indentation rules, let me think...
<suitsmeveryfine>Oh, there are some indentation rules but sometimes it all looks very different compared to the other package definitions
<alezost>is "M-x guix-devel-mode" avialable?
<suitsmeveryfine>no
<alezost>hm, interesting. It needs to be investigated if you don't mind :-) Could you look at "M-x find-library site-start". Does it contain "(require 'guix-emacs nil t)"?
<paroneayea>so I have a phase that does this:
<paroneayea> (substitute* '("driver/Makefile.in" "po/Makefile.in.in")
<paroneayea> (("@GTK_DATADIR@") "@datadir@")
<paroneayea> (("@PO_DATADIR@") "@datadir@"))
<paroneayea>but weirdly I'm getting
<paroneayea>In /gnu/store/vs75q74qsfr3h45vkbr559p5w6fn4mw2-module-import/guix/build/utils.scm:
<paroneayea> 549: 1 [with-atomic-file-replacement "driver/Makefile.in" ...]
<paroneayea>In unknown file:
<paroneayea> ?: 0 [mkstemp! "driver/Makefile.in.XXXXXX"]
<paroneayea>ERROR: In procedure mkstemp!: No such file or directory
<paroneayea>but the directory driver/ is there, and so is driver/Makefile.in ...
<suitsmeveryfine>alezost: is this good http://paste.lisp.org/display/312614#6
<alezost>suitsmeveryfine: no :-(
<suitsmeveryfine>I just used tab all over it
<alezost>suitsmeveryfine: the indentatio will be automatically solved once we find out why you don't have "guix-devel-mode". What about "site-start"?
<suitsmeveryfine>I don't see any site-start
<suitsmeveryfine>This community so damn helpful and friendly!
<suitsmeveryfine>I could sit here day and night
<suitsmeveryfine>:)
<alezost>suitsmeveryfine: do you mean after "M-x find-library RET site-start" it tells "can't find library"?
<suitsmeveryfine>it outputs: (require 'guix-emacs nil t)
<alezost>ok, good. Could you look at this "guix-emacs.el" (placed in the same directory where "site-start.el")?
<alezost>does 'guix-emacs-autoload-packages' function contains "/run/current-system/profile"?
<alezost>oh, I think you don't have 'guix-emacs-autoload-packages' there, right?
<suitsmeveryfine>no I don't
<suitsmeveryfine>I only installed plain Emacs
<suitsmeveryfine>The openttd installation worked great with the new flag
<suitsmeveryfine>It gets installed in 'bin' and the desktop file is properly configured
<alezost>great!
<alezost>ok, this looks like some previos build of emacs. Did you install it to user profile or globally (with system config)?
<suitsmeveryfine>hurray!
<suitsmeveryfine>alexost: to the user profile i think, using guix package -i
<alezost>when did you update it last time? I think after you update it, everything will be ok
<alezost>I mean indentation rules (and many other things actually)
<suitsmeveryfine>OK, cool. I actually ran a full system reconfiguration an hour ago
<suitsmeveryfine>I haven't rebooted since
<alezost>don't reboot!
<alezost>system reconfiguration doesn't update you user profile
<alezost>suitsmeveryfine: you can try "guix package -u emacs"
<alezost>suitsmeveryfine: I think currently you can't do "M-x guix-installed-packages", right? After updating emacs, try it; if it works then indentation rules should also work
<suitsmeveryfine>alezost: upgraded and restarted Emacs
<suitsmeveryfine>yes, you are right
<suitsmeveryfine>now a REPL started
<alezost>suitsmeveryfine: ok, now open your openttd file and try to reindent the package definition
<suitsmeveryfine>And the mode Scheme Guix Guile is being used
<alezost>yes, so it should work now :-)
<suitsmeveryfine> http://paste.lisp.org/display/312614#7
<suitsmeveryfine>This is what I get when I apply 'tab' on every row in the definition
<suitsmeveryfine>See what happened to the comment down at the inputs
<suitsmeveryfine>alezost: do you think it looks good otherwiser?
<suitsmeveryfine>*s
<alezost>yes, now modify-phases is indented correctly. btw no need to press tab on every line, you can reindent the whole (define-public ...) thing by "M-x beginning-of-defun" and "M-x indent-sexp" (I don't remember default bindings for these things)
<alezost>suitsmeveryfine: what line do you mean "down at the inputs"?
<suitsmeveryfine>;("lzo" ,lzo) Disabled for the time being
<alezost>this is because of a single ";". if you use ;; ("lzo"...) it will be ok
<paroneayea>oh
<paroneayea>figured it out
<paroneayea>forgot the (lambda) wrapper ;)
<quiliro>when opening http://calibre-ebook.com/demo
<paroneayea>YAY I have xscreensaver working!
<quiliro>i get unsupported video format
<alezost>there is also an incorrect indention of "#:foo" things (#:tests and #:phases should be at the same level) but it's an emacs bug. There is a workaround for this though
<alezost>suitsmeveryfine: ^^
<quiliro>html5: Unsupported video format. Try installing Adobe Flash.
<alezost>quiliro: there is no Adobe Flash on Guix!
<alezost>and will never be
<quiliro>alezost: i know
<quiliro>and i'm glad
<suitsmeveryfine>alexost: OK, how should I indent those things up there
<alezost>quiliro: actually I can view that video!
<quiliro>alezost: it is webm i am looking for
<alezost>quiliro: yes, I've just tried it and it works for me :-)
<quiliro>alezost: so...what is wrong
<quiliro>?
<alezost>quiliro: sorry, I don't know why it doesn't work for you. Do you use icecat?
<alezost>suitsmeveryfine: the workaround is by mark_weaver: http://www.netris.org/~mhw/scheme-indent-function.el
<quiliro>i suppose i just installed gnome
<quiliro>alezost: ^
<suitsmeveryfine>quiliro is using epiphany
<alezost>suitsmeveryfine: you can put it into your emacs config, and property lists should also be indented correctly
<alezost>quiliro: well, I can recommend to "guix package -i icecat" and try icecat then
<quiliro>suitsmeveryfine: how did you know when i didnt know
<quiliro>?
<suitsmeveryfine>quiliro: because I'm also using Gnome 3 on Guix SD
<suitsmeveryfine>epiphany = "Web"
<quiliro>suitsmeveryfine: how did you know web+epiphany?
<quiliro>suitsmeveryfine: how did you know web=epiphany?
<suitsmeveryfine>epiphany is the package name
<suitsmeveryfine>and the old name of the web browser
<quiliro> https://duckduckgo.com/l/?kh=-1&uddg=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FEpiphany_(web_browser)
<suitsmeveryfine>quiliro: hmm, I'm struggling to find the emacs config file :)
<quiliro> http://www.webupd8.org/2010/06/how-to-get-webm-support-in-epiphany-web.html
<suitsmeveryfine>never mind
<alezost>suitsmeveryfine: I've just checked the default keybindings: to reindent the current top-level definition (for example, (define-public openttd ...) expression), you can do "C-M-a" and "C-M-q" - don't press tab on each line!
<suitsmeveryfine>alezost: Nice! I'll need to save that in a text file
<alezost>suitsmeveryfine: re emacs config file: it is either "~/.emacs.d/init.el" or "~/.emacs". Have you never customized it?
<suitsmeveryfine>alezost: no, I've just selected a different theme from the graphical menu
<suitsmeveryfine>alezost: well, I've customized emacs on different install, but on GuixSD everything is in a different place :)
<suitsmeveryfine>everything hidden away in some dark store room
<alezost>suitsmeveryfine: no, your user config files are always placed somewhere in your home directory. It is the same as for any other distro
<suitsmeveryfine>Yes, I'm slowly starting to learn
<suitsmeveryfine>I'm very fond of guixsd
<alezost>I am too :-)
<alezost>suitsmeveryfine: so after all, did you fix those indentations (commented lzo line and #:phases under #:tests)?
<quiliro>installed gst-plugins-good -bad and -ugly
<quiliro>for webm to work
<quiliro>i will test now
<quiliro>oh and installed icecat too