IRC channel logs

2016-04-07.log

back to list of logs

<quiliro>git clone git.savannah.gnu.org/r/guix.git
<quiliro>right?
<quiliro>lfam: ^
<quiliro>git clone http://git.savannah.gnu.org/r/guix.git
<lfam>No, like this:
<lfam>git clone http://git.savannah.gnu.org/r/guix.git
<lfam>Oh, you got it ;)
<quiliro>lfam: downloaded 33MB
<quiliro>is it that small?
<bavier>quiliro: yes
<kristofer>quiliro: 'guix environment guix' will setup the build environment. you'll want to ./configure --localstatedir=/var && make
<lfam>Don't forget to ./bootstrap
<lfam>That comes before ./configure
<kristofer>right
<lfam>`guix environment guix --fallback -- ./bootstrap && ./configure --localstatedir=/var && make`
<quiliro>kristofer: where is the doc for that?
<lfam>It's documented here: https://www.gnu.org/software/guix/manual/guix.html#Building-from-Git
<kristofer>quiliro: read about "the perfect setup" in the manual I think
<kristofer>nope I'm mistaken
<bavier>quiliro: see if http://paste.lisp.org/+6P8M works for you
<kristofer>well I guess that's part of it
<bavier>quiliro: just add 'openfwwf-firmware' to the operating-system "firmware" field in your system configuration (section 7.2.2 in the manual)
<bavier>ACTION -> away
<anthk_>mmm a bug on bash? echo $((2**63))
<anthk_>-9223372036854775808
<anthk_>I tought bash had a 2^64-1 limit for calculations
<lfam>What's the double ** supposed to do?
<ringst>busybox sh does that too
<anthk_>potentiation
<ringst>And zsh
<ringst>If it's a bug, it's a bug in at least three shells that don't share code
<anthk_>power exponent
<anthk_>well, bc segfaults on any calc :|
<Jookia> python has it too and so does haskell
<anthk_>echo "2^64-1" | bc
<anthk_>Violación de segmento
<anthk_>segmentation fault
<anthk_>" bc --version" returns bc 1.06
<anthk_>do you have the same problem with bc?
<quiliro>almost 2 hours finished installation
<quiliro>but it has error
<lfam>What is the error?
<quiliro>failed to resolve partition "raiz"
<lfam>How did you set up the 'file-systems' part of desktop.scm?
<quiliro>i used sdb on config.scm
<lfam>Or config.scm
<lfam>Just 'sdb'?
<quiliro>but when removing the usb there is only one disk
<quiliro>i dont remember
<quiliro>now i remember
<quiliro>it asked label and device
<lfam>Here is what works for me: http://paste.lisp.org/+6P8P
<lfam>I made sure to set the label of the partition when creating the filesystem, like this: `mkfs.ext4 -L my-root /dev/sda1`
<quiliro>i did that too
<lfam>Of course, whether it's sda or sdb depends on your system
<quiliro>in fact the label is raiz
<quiliro>but i put sdb because it was sdb at the time
<quiliro>now te usb is removed and it is sda probably
<quiliro>how can i boot
<quiliro>to change this?
<lfam>Is the system still running or did you halt / reboot?
<quiliro>i rebooted
<quiliro>and got the guile prompt
<quiliro>scm-error
<lfam>I would reboot again from the USB, and then inspect the partitions of the computer to see if they match what is expected.
<quiliro>if i change desktop.scm to sda will it boot?
<quiliro>lfam: ^
<lfam>Well, you'll have to reconfigure the system to use the correct device and partition. If you can't boot the machine, we'll have to figure out how to do that from the Guile prompt
<quiliro>lfam: how do i reconfigure
<quiliro>i am rebooting now
<lfam>Normally you reconfigure like this: `guix system reconfigure path/to/desktop.scm`. But if you can't boot, it's complicated.
<quiliro>i thought i hhad to put sdb as it was recognized by the live usb
<lfam>I think it's possible to fix it from the Guile REPL, but I'm not sure how
<lfam>Did you boot from the USB to check what device and partitions exist? Do they match what is in desktop.scm?
<quiliro>yes
<quiliro>checkig
<quiliro>checking
<quiliro>there is no /etc/*.scm
<lfam>Did you put it there? It doesn't automatically get placed on the new system
<quiliro>yes, i copied it on /mnt/etc/desktop.scm
<quiliro>oops
<quiliro>found irçt
<quiliro>ok changed it to sdb
<quiliro>i mean to sda
<quiliro>but it is sdb in reality
<quiliro>now
<quiliro>when i remove the usb it is probably sda
<lfam>Okay, you still have to reconfigure the system. Just changing that file won't have any effect
<quiliro>lfam: do i type `guix system reconfigure mnt/etc/desktop.scm /mnt` ???
<lfam>I don't know if you can do that from the USB system
<lfam>Normally you do it from the system itself. In this case, that system isn't running.
<quiliro>it says i have not run guix pull
<lfam>That's probably not relevant right now
<quiliro>what should i do?
<quiliro>io am stuck and its night
<quiliro>please help
<quiliro>should i run guix system init /mnt/etc/desktop.scm /mnt
<quiliro>lfam: ^
<lfam>quiliro: I'm trying to find somebody with more experience than me
<quiliro>lfam: thks
<quiliro>like davexunit
<kristofer>quiliro: what does df -h say is mounted on /?
<quiliro>kristofer: it is the usb
<quiliro>kristofer: uninfs
<quiliro>kristofer: unionfs
<suitsmeveryfine>Hi! I'm trying to package a game for the first time but I can't make it work properly. Would any one here mind give me a hand?
<iyzsong>hi!
<suitsmeveryfine>Here is my definition: http://paste.lisp.org/display/312614#3
<suitsmeveryfine>II get "syntax error" when I try to run `make clean-recursive ; ./configure --localstatedir=/var ; make` from a guix git checkout.
<iyzsong>quiliro: you installed guixsd but the hard disk changed from 'sdb' to 'sda' right? maybe at grub, you can modify the commandline to use 'sda'.
<quiliro>iyzsong: good idea
<quiliro>i will test
<quiliro>iyzsong: it did not work
<quiliro>aparently it is a fstab problem
<quiliro>because it talks about mtab
<quiliro>there is no mtab or fstab!
<iyzsong>both mtab and fstab should be create during the boot, shound like they get the root wrong.
<quiliro>reissuing guix system init /mnt/etc/desktop.scm /mnt
<iyzsong>ok, if a clean install still don't work, please report to maillist list.
<quiliro>ok
<quiliro>why i cannot loadkeys dvorak-es ?
<quiliro>why is it downloading all the files over again
<quiliro>?
<quiliro>i have them downloaded and compiled already
<quiliro>why is it doing it again?
<iyzsong>the state is recorded in /var/guix, in the livecd, it's fresh. so it will download all again..
<quiliro>2 more hours
<davexunit>quiliro: run 'guix pull'
<davexunit>the version of guix that is installed is necessarily older than the one you used to install
<quiliro>davexunit: i suspend guix system init /mnt/etc/destop.scm /mnt ????
<quiliro>and run guix pull ???
<davexunit>wait you're reinstalling?
<davexunit>nvm
<davexunit>of course you have to download it all again
<davexunit>when you reinstall, it's all fresh
<quiliro>the system recognized sdb because the scm file specified sdb but when the usb was removed tjhe disk probably became sda
<quiliro>so it would not boot
<davexunit>use partition labels
<quiliro>it was using them
<iyzsong>suitsmeveryfine: it seems openttd using a customized configure script. but the error you get is from guix?
<davexunit>quiliro: not if you had that error
<quiliro>it asked device_and_ label
<quiliro>check default destop.scm
<quiliro>check default desktop.scm
<suitsmeveryfine>iyzong: I get the error from guix yes
<suitsmeveryfine>"gnu/packages/games.scm:1863:2: source expression failed to match any pattern in form"...
<iyzsong>yep, the (device "my-root") mean that you have a partition named "my-root".
<quiliro>davexunit: on grub-configuration
<suitsmeveryfine>iysong, sorry
<suitsmeveryfine>*iyzsong
<quiliro>iyzsong: i have(device "raiz")
<anthk_>so "root"
<quiliro>That is: on the file-systems section
<suitsmeveryfine>iyzsong: how do you see that the configure script is customized?
<iyzsong>suitsmeveryfine: I unpack and look at it :-)
<suitsmeveryfine>:O)
<quiliro>but on grub-configuration section (device "/dev/sda") now, (device "/dev/sdb") before
<iyzsong>suitsmeveryfine: and the source should be a 'origin' object.
<quiliro>i included (firmware "openfwwf-firmware")
<quiliro>but it wont run...i had to comment it
<iyzsong>that's confusing, I think what you did is right, when install the 'grub-configuration' should be '/dev/sdb', so that the bootloader will be installed.
<quiliro>but it will not recognize it when it changes to sda
<quiliro>iyzsong: but it will not recognize it when it changes to sda
<iyzsong>yes, if in the live usb, the hard disk is sdb, I think you should use usb. after boot from harddisk, do a reconfigure to change it to sda.
<iyzsong>s/use usb/use sdb/
<quiliro>iyzsong: i cannot boot
<quiliro>without usb
<quiliro>i am running guix system init
<quiliro>with desktop.scm configured on sda
<quiliro>because i used sdb before and it didnt boo
<quiliro>t
<quiliro>so i could not reconfigure
<quiliro>i had a guile prompt
<suitsmeveryfine>iyzsong: adding 'origin' removed several error messages but I'm still unable to run `make clean-recursive ; ./configure --localstatedir=/var ; make` without problems.
<suitsmeveryfine>If I remove the 'openttd' package definition entirely I don't get any errors so there must be something more wroing there, I just can't see it.
<iyzsong>quiliro: if you can boot it without usb (grub is installed on hard disk) but meet the prompt, the error maybe elsewhere.. what the traceback says?
<quiliro>iyzsong: how can i know? i rebooted with the usb
<suitsmeveryfine>I think I missed a ")" so I try again.
<iyzsong>quiliro: after do the install with 'sdb' as (grub-configuration (device .)) and the (device "raiz"), unplug the usb disk, and boot.
<quiliro>iyzsong: i did that already
<quiliro>let me check
<iyzsong>quiliro: did it boot to prompt or no grub menu show?
<quiliro>probably previously in the chat i copied the error
<quiliro>it booted to a guile prompt
<quiliro>after grub
<quiliro>the errror was ....failed to resolve partition "raiz"
<quiliro>iyzsong: ^
<iyzsong>ok, that's the problem..
<quiliro>how to solve it?
<iyzsong>can you check what's in '/dev/disk/by-label'?
<quiliro>should i suspend guix system init /mnt/etc/desktop.scm /mnt ???
<iyzsong>no
<quiliro>gnu-disk-image, int, raiz
<iyzsong>you can switch to another tty by 'ALT+F2' etc.
<quiliro>sda1, sdb2, sdb1 (respectively)
<quiliro>iyzsong: is that what you needed?
<iyzsong>ok, you are doing the system init now, and record the the previous error log.
<quiliro>remember i used sda in desktop.scm
<quiliro>are you sure i should continue?
<iyzsong>not sure, but please paste the current config.scm.
<quiliro>because it takes 2 hours for the full process
<quiliro>how can i do it?
<quiliro>iyzsong: ^
<iyzsong>well, not all need, both the 'device' for grub-configurtion and filesystems.
<iyzsong>I guess it's all right, but just want to be sure
<iyzsong>also, I suggest you use 'bare-bones.tmpl' and switch to 'desktop.tmpl' after install
<iyzsong>quiliro: we should first get it boot from hard disk.
<quiliro>ok
<quiliro>i suspend and use bare-bones.scm
<suitsmeveryfine>I can't make it work and give up for tonight.
<suitsmeveryfine>ciao
<iyzsong>quiliro: you can try change the 'title' to 'device and 'device' to "/dev/sda1" for "/", if after boot it still can't find raiz.
<quiliro>woops...used sda
<quiliro>iyzsong: should i correct and rerun?
<iyzsong>yes, it's safe.
<iyzsong>here you should set device for grub to "/dev/sdb" (if it's the harddisk) and device for "/" to "/dev/sda1", title for "/" to 'device .
<quiliro>iyzsong: ok...did that and reran guix ssytem init
<quiliro>please stay with
<quiliro>me until i can boot
<iyzsong>sure, I pray for it to work :-)
<quiliro>iyzsong: thank you for your help
<iyzsong>you're welcome. do the install finish?
<quiliro>iyzsong: not yet
<quiliro>iyzsong: it is a pre-success thank you...for your good energy and effort
<iyzsong>yep, hope this year we can make an installer for guixsd.
<quiliro>iyzsong: finished and rebooted with same error
<iyzsong>what's the error? did you change 'device' to '/dev/sda1'?
<iyzsong>the 'device' for the "/" filesystem.
<quiliro>ext2fs_check_if_mount: Cant check if filesystem is mounted due to missing mtab
<iyzsong>that's not an error, i see it every time.
<quiliro>fsck.ext4: No such file or directory while trying to open /dev/sda1
<quiliro>Possibly non-existent device?
<iyzsong>ok, in the prompt, maybe do 'ls /dev' to see what in there.
<quiliro>fsck.ext4 exited with code 8 on /dev/sda1: spawning bourne-like REPL
<quiliro>output is /dev
<quiliro>of ls /dev
<iyzsong>oh? try 'cd /dev', and then 'ls'
<quiliro>iyzsong: that is the same message i had before
<quiliro> spawning bourne-like REPL
<lfam>janneke: I just finished building gnome-tweak-tool. How do you recommend I test it? Put it in the system's global packages and reconfigure?
<iyzsong>yes, REPL is what you get when the booting fail.
<iyzsong>quiliro: sorry, but what I can think of now is to collect informations like what's in /dev, what's in /etc, and the output of 'dmesg', 'mount', etc.. so find what's wrong.
<quiliro>iyzsong: reboot with usb?
<iyzsong>not now, just try find it in the prompt.
<quiliro>cant
<quiliro>gives no info
<quiliro>just ls shows directories
<quiliro>iyzsong: ^
<iyzsong>quiliro: so /dev is empty?
<iyzsong>what's the output of 'ls /etc/'?
<quiliro>unknown location
<quiliro>warning: possibly unbound variable: ls
<quiliro>ERRROR: In proceedure ....
<quiliro>etc
<quiliro>etc
<iyzsong>ah, ok, you are in the scheme mode.. try '(getenv "PATH")'..
<quiliro>is there an image i can download to dd insto my disk?
<iyzsong>maybe you can try dd the usb disk, I'm not sure if it will work or not.
<quiliro>$3 = "/gnu/store/fci79...........-e2fsck-static-1.42.13/sbin"
<quiliro>should i do it now?
<quiliro>iyzsong: ^
<quiliro>how can i dd the usb by booting from it
<quiliro>using another?
<iyzsong>you can download the image to another usb, and dd it there.. but I shouldn't suggest this way, I'm not sure what will happend..
<quiliro>iyzsong: what should i do?
<iyzsong>quiliro: now I guess you didn't install to the right root..
<iyzsong>reboot into the usb, and mount it to check, and reinstall...
<quiliro>iyzsong: how can that be?
<iyzsong>I don't know.. if you are still at prompt, you can do ',bournish' and 'cd /dev' then 'ls'.
<quiliro>done
<quiliro>what do i do now
<iyzsong>quiliro: where are in? usb or the prompt?
<quiliro>prompt
<quiliro>iyzsong: prompt
<iyzsong>ok, first to switch the Bournish shell by ',bournish', then do 'cd /dev', and 'ls'. maybe 'ls sda1'.
<quiliro>no such file or directory
<iyzsong>'sda1: No such file or directory' right? what's the output of 'ls'?
<iyzsong>or it's "in procedure chdir: No such file or directory" ?
<quiliro>iyzsong: is a long list
<quiliro>but no sda1
<quiliro>cd works ok
<iyzsong>ok, try 'ls sdb', 'ls sda', 'ls hda'
<quiliro>no such file or directory
<quiliro>iyzsong: ^
<quiliro>with all three
<quiliro>there is tty0 and such
<iyzsong>quiliro: oops. 'cd /dev/disk/by-id/' and then 'ls'. does the output is empty?
<iyzsong>quiliro: also, please do 'cat /var/log/messages', as and report it (you can scoll it up using SHIFT+PageUP) to maillist..
<lfam>Is it possible to pass arguments to GRUB from the system configuration?
<iyzsong>lfam: we can add customized menu entries using 'menu-entries', but I think there is no way to pass arguments to the exist guixsd entries now.
<quiliro>iyzsong: there is no disk directory in dev
<iyzsong>quiliro: ok, as I expected.. there is something wrong with udev, how mush could you get from 'cat /var/log/messages'?
<quiliro>no such file or directory
<quiliro>no /var/
<iyzsong>oh.. I don't know how to do now :-(
<quiliro>just .cache,dev,gnu,init,proc,root,sys
<quiliro>on /
<iyzsong>quiliro: ok, do 'cat /init', let's see what's in ((.. "/" "ext4")) and '#:linux-modules'.
<quiliro>i shutdown
<quiliro>iyzsong: i am sorry
<quiliro>i will start again tomorrow
<iyzsong>quiliro: ok, no problem. sorry I don't help it :-(
<quiliro>iyzsong: you helped a lot
<iyzsong>quiliro: ok, good night!
<quiliro>now i know something bout guix
<quiliro>i can investigte more now
<quiliro>iyzsong: good night
<quiliro>thank you
<iyzsong>yes, it's still 'beta' :-)
<iyzsong>ACTION pushed 'gnome-updates' :-)
<efraim>do we have a program to take an image and display it as asciiart?
<efraim>`guix environment --ad-hoc figlet -- figlet < ~/gpl-3.0.txt` is suprisingly easy to read, but I should've passed it to less
<mark_weaver>efraim: the 'aalib' package can do that
<mark_weaver>efraim: also see 'libcaca' for a color version
<efraim>i'll look at those, sometimes I don't want to leave the terminal to see pictures in viewnior
<taylan>do I understand it right that for e.g. .xz items in the store, the substitute server does a (superfluous) bzip2 of it when serving it?
<mark_weaver>taylan: yes, I believe so
<mark_weaver>efraim: even mplayer can use those libraries to show movies on a text display
<mark_weaver>(although I haven't tried that in Guix)
<mark_weaver>I see that our mplayer package is not built with aalib or libcaca support, but our mpv has libcaca as an input
<efraim>i finally found it with mpv --vo=help, tells me mpv --vo=caca
<efraim>amusingly, watching the videos in asciiart takes more cpu power than just watching it
<phant0mas>davexunit: do you have the build log of the avr-gcc build?
<phant0mas>if you do ./pre-inst-env guix build avr-gcc --log-file you should find it
<phant0mas>search for avrxmega
<phant0mas>davexunit: and I found that I have a version of gcc-cross-avr which has the libs
<phant0mas>interesting
<phant0mas>how did I do that..
<suitsmeveryfine>Hi! I've packaged a game that I'm trying to build but get this error: "Unknown option --enable-fast-install". Any ideas about what I can do about it? I've simply used (build-system gnu-build-system) in the package definition.
<spudowiar>I was just wondering, does #!/usr/bin/env work in GuixSD?
<efraim>suitsmeveryfine: if it builds anyway then don't worry about it, if the error causes it to fail to build then you need to replace the configure phase
<efraim>spudowiar: we don't have /usr/bin/env in GuixSD
<spudowiar>efraim: that's what I thought, how would you use shebangs on GuixSD then?
<efraim>iirc /bin/sh works, but for the others they have to be patched I think
<efraim>i don't think we've come to a consensus what to do about it yet
<roelj>I have about 45 R packages I would like to add, which is about the entire dependency graph for a single R package I actually wanted. Should I send one mail to the list with 45 patches? Or should I split them in groups of related functionality? Or should I send 45 mails to the list? Or should I just keep them outside the guix master?
<efraim>there's a command line argument to patch it at run time but I don't have it written down
<spudowiar>efraim: ok
<efraim>I find 1 patch per email message easier to read, might as well send them all it in one go
<roelj>I think it'll be a kind of flood to the mailing list..
<suitsmeveryfine>efraim: the build fails so I can't ignore the warnings.
<suitsmeveryfine>efraim: Is it likely that I need to use an older version of GCC? The README says that it has been confirmed to compile with GCC v. 3.3 - 4.4, 4.6 - 4.8
<wingo>roelj: 1 patch per mail is better i think; lets reviewers process it in chunks and lets you know feedback per-patch
<roelj>wingo: Are you sure about that? It's 45 mails then.. :)
<wingo>it's happened before :)
<roelj>Cool
<wingo>git-send-email can do it for you, and readers can kill threads
<spudowiar>efraim: my current solution is to symlink `/usr/bin/env` to `/run/current-system/profile/bin/env`
<roelj>wingo: But then the mail only contains the patch. Is that OK?
<wingo>roelj: not a problem, the patches will be numbered and threaded by git-send-email
<roelj>Ok. Thanks :)
<wingo>and you can edit a "main" message
<wingo>see the git-send-email man page
<roelj>Do you have some pro tip for separating the chunks into commits as well? Most packages are in the same file..
<wingo>no real pro-tip there, besides using staging in magit
<wingo>but if the lines are all contiguous, magit might see it all as one hunk
<spudowiar>Also, how do I add globally-visible packages to my system?
<spudowiar>Do I copy config.scm, modify it and `guix system reconfigure`?
<wingo>spudowiar: yep
<spudowiar>thanks
<suitsmeveryfine>Hmm, downgrading GCC had no effect. I don't even know where "--enable-fast-install" is coming from; it's not in `configure` or any of the helpers.
<iyzsong>it's in the configure phase of the gnu-build-system, here you should replace it.
<suitsmeveryfine>iyzsong: I see. Should I do this by adding something like this: "(arguments `(#:configure-flags '("--xxxxxxxxxxxxxxxx"))"?
<efraim>(arguments (modify-phases %standard-phases (replace 'configure
<efraim>er, (arguments `(#:phases (modify...
<iyzsong>yes, the #:configure-flags is add to (not replace) the default flags.
<suitsmeveryfine>OK, so what whould be the full line to remove "--enable-fast-install"?
<iyzsong>suitsmeveryfine: just replace the 'configure phase, look the 'samba' package for example.
<iyzsong>wingo: thanks for the guide on 'edit-expression'! also I wonder if the byte position can be recorded in source-properties ..
<suitsmeveryfine>iyzsong: I'm looking at the 'samba' package but there are things added below "(replace 'configure".
<wingo>iyzsong: that would be possible but would require a change in Guile and (currently) an ftell() before every read
<wingo>so probably not a short-term thing
<spudowiar>wingo: should I not replace /etc/config.scm?
<wingo>spudowiar: i don't remember how that works :)
<iyzsong>oh, that sound too heavy :-
<wingo>i think i started using guixsd before it installed the config into /etc
<wingo>so i don't know how that works
<iyzsong>suitsmeveryfine: yes, you need call the 'configure' script using 'system*', and pass the desired flags.
<spudowiar>wingo: I guess I'll just read the source code
<spudowiar>wingo: AFAICT config.scm means nothing
<wingo>iyzsong: one more thing i forgot -- the argument to get-string-n isn't bytes
<iyzsong>there is no /etc/config.scm on my system. I put and manage my config.scm in /etc/guix.
<wingo>so probably to be correct you should use get-bytevector-n and then convert to a string
<suitsmeveryfine>iyzsong: these are the configure flags that were called automatically: "configure flags: ("CONFIG_SHELL=/gnu/store/b1yqjimbdh5bf9jnizd4h7yf110744j2-bash-4.3.42/bin/bash" "SHELL=/gnu/store/b1yqjimbdh5bf9jnizd4h7yf110744j2-bash-4.3.42/bin/bash" "--prefix=/gnu/store/yglqy6ahpljdfjskznjrbmw1sj1d2252-openttd-1.6.0" "--enable-fast-install" "--build=x86_64-unknown-linux-gnu")"
<suitsmeveryfine>So you're saying that I would need to add all of these except "--enable-fast-install".
<spudowiar>iyzsong: yeah, the installation says to create one but AFAICT, it's stored there just for reference
<spudowiar>The only thing is that it's made read only
<spudowiar>So I just `chmod 644 /etc/config.scm` :P
<iyzsong>ok :-)
<spudowiar>Anyway, I'm new to Lisp, so I might be on here quite often
<iyzsong>suitsmeveryfine: you can figure them out by run the 'configure' script manually in 'guix environment', etc.
<suitsmeveryfine>iyzsong: OK -- when I do this I get an output like this: "checking build system type... x86_64-unknown-linux-gnu [...] checking build cc... gcc [...] detecting SSE... found [...] configure: error: no video driver development files found"
<spudowiar>wingo: how do I list all herd services? I'm trying to restart sshd (lsh)
<suitsmeveryfine>Ah, I get a long list of flags after running `./configure --help`
<wingo>spudowiar: sudo herd status shepherd i think
<spudowiar>thanks wingo
<Jookia>anthk_: gloome's source code has sketchy voxel support that i think is taken from the nonfree BUILD engine
<ngz>Hello.
<ngz>I have a question about package creation. I wrote a new package definition in GUIX_PACKAGE_PATH and successfully installed it in the store. Now I'm trying to send a patch for inclusion. I pasted the definition in the appropriate module in /gnu/. How can I check if it is still correct (e.g., there is no missing use-module at the beginning of the module)?
<df_>compile it?
<roelj>ngz: Set GUIX_PACKAGE_PATH to "" (blank), then compile the Guix source with your new package definition. Then install it using Guix.
<ngz>df_: That's what I would like to do, but I don't know how. I'm not using the repository as my guix installation.
<ngz>roelj: How do you "compile the Guix source"?
<df_>well... do that? you can run your development version without messing up the rest of the system by using preinst-env
<roelj>ngz: For that you need to check out the Guix git repository, and then just autoreconf -i; ./configure; make
<jmd> http://www.gnu.org/software/guix/package-list.html is too large. It needs to be split up or made dynamic.
<df_>that's a good problem to have...
<jmd>But a bad problem to ignore.
<davexunit>it should stay static.
<davexunit>just needs pagination
<ngz>roelj: Thank you. Do I have to do this each time I pull from the git repository?
<davexunit>we cannot host dynamic web applications on gnu.org anyway
<roelj>ngz: Well, what I do is this: 1. 'git pull' to get the latest changes; 2. Add my package; 3. Test my changes; 4. Commit the changes; 5. Run 'git format-patch -1 --no-attach' to create a patch file; 6. E-mail the patch file to the mailing list.
<ngz>roelj: Actually, as I tried to explain, the third point is giving me headaches. I'm fine with the others, tho :)
<roelj>ngz: If you make a symbolic link in $HOME/.config/guix/latest that points to your Git repository directory, then you'll be able to test your changes.
<roelj>ngz: What is it, that you're exactly running into? If you are able to build and install the package once it's in the Guix repository checkout, it be fine for others too.
<ngz>roelj: Basically, I create a branch in my local repository and made the changes to a module. I cannot guix build my-new-package because it is not found. I had no pre-inst-env script before your help: ./configure created it.
<roelj>ngz: Aha, ok. And now with ./pre-inst-env you're able to test your changes?
<ngz>Now, I try ./pre-inst-env guix build my-package from the root of the repository, and I get a cannot connect to socket error.
<roelj>ngz: Is guix-daemon running?
<ngz>I assume, since I can, e.g., call guix package -i something
<roelj>Then it should be running, you could check with 'ps -A | grep guix-daemon'
<ngz>It is.
<roelj>Right. I never use pre-inst-env, so I cannot help you with that.
<df_>I'm guessing you need to run the daemon using pre-inst-env?
<ngz>Ah. That makes sense.
<efraim>I'm on my phone, what's the output of 'which guix'
<ngz>Well. sudo ./pre-inst-env guix-daemon --build-users-group=guixbuild freezes.
<df_>how do I build the website?
<ngz>efraim: $HOME/.guix-profile/bin/guix
<efraim>It doesn't auto daemonize, you have to call it with & at the end
<ngz>Ah. Oups. :)
<efraim>Did you run configure from the git repo recently?
<ngz>Ok, one step further: the group "guixbuild" does not exist.
<ngz>There should be one since I'm using the daemon already, albeit not from pre-inst-env
<davexunit>ngz: ./configure --localstatedir=/var
<davexunit>if you already have a guix system, you need to make sure your development environment is configured accordingly
<ngz>efraim: I ran ./configure a few minutes ago.
<ngz>davexunit: OK, trying that.
<ngz>Ah. Much better.
<roelj>Can I pass variables to override in a Makefile (like CFLAGS="...") to the build process when using the r-build-system?
<roelj>And if so, how?
<ngz>OK, I have one last point (hopefully) to solve. How can I remove a previous derivation from the store. guix package -r package doesn't remove the derivation. If I delete the previous generations and call "guix gc", it will probably remove too much.
<ngz>I took the "guix gc" route.
<roelj>ngz: Yes, guix gc --delete <store-path> will work when it has no references in any profile.
<ngz>Ah! I didn't know about the --delete <store-path> part.
<roelj>You can find out even more with guix gc --help :)
<ngz>To tell the truth, I did that, without being able to grok it. Now, it makes sense, indeed.
<ngz>OK. I sent the package to the dev list. Thank you for the help!
<roelj>Argh, how does (substitute* ...) work? I want to replace 'PKG_LIBS= ' with 'PKG_LIBS=something'. But I cannot seem to get it to do that.
<ngz>(substitute* file (("(PKG_LIBS=) " _ prefix) (string-append prefix "something")))
<taylan>roelj: (substitute* file-or-file-list ((regexp match-group ...) replacement) ...)
<wgreenhouse>lazy-guix-gmane™: which threads should I start reading about the status of uefi in guixsd, and the status of luks+lvm in guixsd?
<Jookia>wgreenhouse: luks+lvm patch discussion by me, and closest to uefi is adding platform support (which my coreboot work covers)
<Jookia>wgreenhouse: not really much discussion or implementation of it so not worth reading
<wgreenhouse>Jookia: thanks :)
<spudowiar> /quit
<roelj>I have this: (substitute* "src/Makevars" (("^PKG_LIBS= ") (string-append "PKG_LIBS=" (assoc-ref inputs "nlopt") "/lib/libnlopt.so")))
<taylan>roelj: hmm, looks fine to me...
<roelj>But when I look at the failed build output, I see it hasn't replaced it.
<anthk_>Jookia, about gloome, I think they replaced all non-libre code with a free one.
<Jookia>anthk_: are you sure? AFAIK there's no free voxel renderers for doom
<taylan>roelj: is there really a space after "PKG_LIBS="?
<roelj>taylan: Yes.
<roelj>Oh.. I see.. there's no 'configure' phase in r-build-system. The './configure' is run in the install phase..
<anthk_>Jookia, show me a link to that code on github
<anthk_>if exists, tell marrub it has code incompatible with the GPL
<Jookia>anthk_: is marrub on IRC? or is there a gloom channel?
<anthk_>Jookia, "All of the code from Doom has been relicensed from the Doom Software License to the GPL license, and all legally troubled code (such as the code taken from Ken Silverman's BUILD engine) have been either removed or rewritten and licensed to be GPL compatible."
<anthk_>Jookia, marrub on github
<Jookia>i don't use github
<anthk_> https://github.com/marrub--
<anthk_>altough prboom-plus is good enough for FreeDoom
<Jookia>yeah
<anthk_>gloome is just suited for most z-doom source PWADS, and sadly most of them have non-free ACS code
<Jookia>odamex is based on zdoom and is GPL compatible (no voxel code either)
<anthk_>prboom compatible PWADS are fine too
<roelj>What package provides "sh"?
<bavier>roelj: bash
<anthk_>btw I need a guix switch to show a delta from added packages and a guix pull
<anthk_>altough I could use diff -u
<Jookia>anthk_: know any doom ports with openal support?
<anthk_>Jookia, why do you need openal?
<anthk_>prboom-plus has different sound backends such as SDL, fluidsynth, timidity...
<Jookia>i don't NEED it, but it'd be nice to have hrtf support
<Jookia>just for fun
<anthk_>positional audio
<anthk_>somehow I knew it :P
<anthk_>but
<anthk_>vavoom has openal support I think
<Jookia>i think doomsday engine does too
<suitsmeveryfine>Is it possible, in the package definition, to use "modify-phases" to replace a particular configure option with an empty string? The thing is that I'd like to remove a particular option, "--enable-fast-install"
<bavier>suitsmeveryfine: have you tried putting "--disable-fast-install" in #:configure-flags?
<bavier>or is it a case of the configure script failing on unrecognized option?
<suitsmeveryfine>bavier: I haven't tried that no
<suitsmeveryfine>bavier: I'm completely new to making guix packages; this is my first.
<bavier>suitsmeveryfine: great. feel free to ask questions
<suitsmeveryfine>bavier: thanks a lot!
<suitsmeveryfine>bavier: oh, it is the case of an unrecognized option
<suitsmeveryfine>bavier: Now I get this: `sh-4.3.42/bin/bash" "--prefix=/gnu/store/iqzmdgbda69wd3wixv6gblw1sfhq7fpd-openttd-1.6.0" "--enable-fast-install" "--build=x86_64-unknown-linux-gnu" "--disable-fast-install") Unknown option --enable-fast-install`
<suitsmeveryfine>i.e. both `--enable-fast-install` and `--enable-fast-install`
<suitsmeveryfine>*disable
<bavier>suitsmeveryfine: in that case, you'll need to replace the configure phase
<bavier>there are other examples of this
<bavier>I can find one... just a sec
<suitsmeveryfine>bavier: yes, other people suggested this to me earlier. The trouble is that I don't know which options to add. That's why I asked earlier if there's a way to remove a particular option rather than defining all the options manually.
<alezost>suitsmeveryfine: why do you need to remove --enable-fast-install? Does it gives an error or just warning?
<suitsmeveryfine>it gives me an error
<suitsmeveryfine>and build failure
<bavier>suitsmeveryfine: I see, no there's no way to do that currently
<davexunit>replace the configure phase
<alezost>suitsmeveryfine: I think it's better to make a custom configure phase. If you grep for --enable-fast-install in "gnu/packages" dir, you'll find something
<suitsmeveryfine>davexunit: yes, but with what?
<davexunit>suitsmeveryfine: one that runs configure the way you need it
<davexunit>I'm not writing the package so I can't tell you what you need
<alezost>suitsmeveryfine: for example, look at 'flint' package
<davexunit>suitsmeveryfine: reading the source to guix/build/gnu-build-system.scm is a useful exercise. you'll see how each phase works
<zacts>hi guix
<rain1>darn I got a build error
<rain1>I was wondering how to get pcmanfm to be able to mount encrypted drives
<rain1>so I'm trying adding cryptsetup as a propagated input to random things
<rain1>wanted to add it to gtk but that tries to rebuild a really big number of packages on my system
<rain1>including webkit which fails to compile
<civodul>mark_weaver: hello!
<civodul>i think we should look at the graft changes you have in a branch one of these days
<civodul>WDYT? :-)
<rain1>I'm nto sure how to get an environment to build linux in?
<rain1>I tried this: guix environment --ad-hoc binutils --ad-hoc gcc --ad-hoc linux-libre-headers --ad-hoc ncurses
<rain1>but make menuconfig complains about not having ncurses
<rain1>/gnu/store/...-bash-4.3.42/bin/bash: /bin/pwd: No such file or directory
<rain1>this is a problem :/
<mark_weaver>civodul: sure! I mainly got stuck because I was trying to verify that the resulting grafts were good, and they weren't. but those problems seem to exist without my changes as well.
<mark_weaver>civodul: also, although I haven't yet filed a bug report for it, my attempt to eliminate duplicate grafts failed, because sometimes (but not always) a graft derivation includes extraneous inputs.
<civodul>oh, noted!
<civodul>i also need to look closely at the bug you reported before the release
<mthl>when building a package using the gnu build system is it normal to have:
<mthl>patch-shebang: ./reposurgeon: warning: no binary for interpreter `python' found in $PATH
<mthl>and python is declared as an input