IRC channel logs

2016-01-24.log

back to list of logs

<mark_weaver>Steap: sorry for missing your reply. what's the output of "grep _NS= /boot/config-4.2.0-1-amd64" ?
<mark_weaver> http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/build/linux-container.scm#n40
<mark_weaver> http://git.savannah.gnu.org/cgit/guix.git/tree/guix/scripts/environment.scm#n446
<mark_weaver>Steap: relevant code ^^
<mark_weaver>I'm not sure how you could see that error message when /proc/sys/kernel/unprivileged_userns_clone contains "1"
<petter>regarding installation, maybe we should have an example config set up for encrypted root, with mapped-devices etc.
<mark_weaver>unless perhaps /proc/sys/kernel/unprivileged_userns_clone is "0" from within containers, or something.
<mark_weaver>but that test appears to be run from outside the contain, so I don't know.
<mark_weaver>*container
<mark_weaver>Steap: can you try this: "./pre-inst-env guile", then within guile ",use (gnu build linux-container)" and "(unprivileged-user-namespace-supported?)" ?
<mark_weaver>petter: or maybe a commented-out section in our existing example configs?
<petter>yes.
<petter>because it's a bit cumbersome to have (mapped-devices ...) in the manual and ask people to insert it a not-random place
<petter>*at a
<mark_weaver>*nod*
<lfam>mark_weaver: That returns #f on my Debian. I have the same problem as Steap
<mark_weaver>lfam, Steap: how about this: ",use (ice-9 rdelim)" and then (call-with-input-file "/proc/sys/kernel/unprivileged_userns_clone" read-string)
<lfam>It returns "0\\n"
<lfam>That's a zero
<mark_weaver>lfam: but "cat /proc/sys/kernel/unprivileged_userns_clone" prints "1" ?
<mark_weaver>the newline at the end is another issue, though.
<lfam>Oh, it doesn't
<lfam>However, CONFIG_USER_NS=y
<mark_weaver>lfam: you may have a different problem than Steap. but the newline at the end might be Steap's problem.
<mark_weaver>that file doesn't even exist on my GuixSD i686 system
<mark_weaver>Steap: the fix might be to change the line containing "string=" in gnu/build/linux-container.scm to the following: (eqv? #\\1 (call-with-input-file userns-file read-char))
<mark_weaver>can you try it?
<mark_weaver>this is surprising though, that apparently on some systems the (magical) file contains a newline and on some others it does not.
<mark_weaver>lfam: you may need the above fix and also to write "1" to that file.
<lfam>Yes, I think setting that to 0 is a Debian default
<lfam>I'll try patching linux-container.scm
<mark_weaver>I have to go afk for a while. good luck!
<lfam>'eqv? #\\1' did not work but 'string? "1\\n"' did work
<lfam>But that's no good if the newline is not there on all systems
<lfam>I wonder if it's a Debian bug
<mark_weaver>lfam: you changed the 'read-string' to 'read-char' ?
<lfam>Like this: http://paste.lisp.org/+6JWB
<lfam>Oh, I understand. I'll change read-string
<lfam>Yes, your suggested change works
<mark_weaver>lfam: thanks for testing! I'll push a fix.
<Steap>mark_weaver: yeah, I tried with "1\\n" :p
<lfam>It's nice to chat with a serif font but it's a disaster for sharing code :p
<Steap>mark_weaver: yeah that works
<mark_weaver>I just pushed the fix
<mark_weaver>Steap: great, thanks!
<Stebalien>Is there any way to use xorg without SLiM (i.e. with xinit from a tty)?
<mark_weaver>apparently on davexunit's system it returns "1" without the newline. interesting.
<petter>lfam: hehe, yeah :)
<mark_weaver>Stebalien: not at present, sorry.
<lfam>I wonder what Debian version davexunit is on
<Stebalien>mark_weaver: Thanks. :(
<mark_weaver>Stebalien: I think there may have been a thread on guix-devel about this in the last couple of months. not sure where it ended.
<mark_weaver>I can't seem to find it right now. maybe I'm misremembering.
<Emas>is it normal for guix system init to download packages like gtk+ and python?
<lfam>Emas: It depends on the OS declaration you gave to `guix system init`. The list of packages you ask to include determines what gets downloaded.
<Emas>hmm, i haven't added any packages to %base-packages, except for tcpdump
<Jookia>Can Guix create a bootable USB?
<lfam>Jookia: Yes, check `guix gystem disk-image`. That is how the USB installer is created. https://www.gnu.org/software/guix/manual/guix.html#Invoking-guix-system
<lfam>Emas: I'm not sure, they might be pulled in by something in base packages.
<Jookia>Awesome
<lfam>Also grep the manual for install.scm
<lfam>Jookia: ^
***nckx|offline is now known as nckx
***nckx is now known as nckx|offline
<codemac>hm, guix now isn't producing derivations correctly?
<mark_weaver>codemac: what makes you say that?
<codemac>with nix-daemon, it complains about guile-bootstrap.drv not having the right output hash
<codemac>(sorry, was trying to type that follow up sentence quickly) guix works on my arch machine just fine, so I don't think it's a bug, but maybe a bug in my setup
<mark_weaver>what changed since it last worked? or did it never work on your nix-daemon setup?
<mark_weaver>also, an exact copy of the error message would be more helpful than a paraphrase.
<codemac>guix package: error: build failed: derivation ‘/nix/store/678j3bmn4kk3j4jxzkgazdcwapmbksh1-guile-bootstrap-2.0.drv’ has incorrect output ‘/gnu/store/d147rzxa7drpg8x8w4dcrpaq80v3fj11-guile-bootstrap-2.0’, should be ‘/nix/store/rzzifjycn6cqjvxw9fm0fi1646l37aas-guile-bootstrap-2.0’
<mark_weaver>the relevant thing is the /gnu/store vs /nix/store
<mark_weaver>your guix has probably been configured to build things for /gnu/store, but you're using a daemon that's configured to use /nix/store
<codemac>Oh dammit, thank you so much mark_weaver, the configure line was misspelled
<codemac>'--with-tore-dir=/nix/store'
<codemac>you've always been very helpful on this channel, I really appreciate it.
<mark_weaver>heh, you're welcome
<mark_weaver>note that by using a different store name, you won't be able to make use of binary substitutes from hydra
<mark_weaver>you'll need to build everything from source, which in the core bootstrap is a lot of stuff.
<mark_weaver>you might be happier running guix-daemon and nix-daemon side-by-side, each with their own stores.
<codemac>can I get away with hard linking /gnu to /nix?
<mark_weaver>I don't see any advantage to a shared store for this.
<mark_weaver>you can hard link directories
<mark_weaver>*cannot
<mark_weaver>there may be other problems as well, this is not something that many people have tried to do in recent years.
<mark_weaver>anyway, I have to go afk for the night. happy hacking!
<codemac>thanks! have a good night
<codemac>has anyone had any problems downloading from ftp://ftp.astron.com/pub/file/file-5.22.tar.gz ? I can't seem to successfully download it.
<DocPlatypus>I'll try
<DocPlatypus>"Error in server response, closing control connection."
<efraim>looks like their website is down
<codemac>Yeah, did guix download on a mirror of the tar ball somewhere else
<fps>Emas: that came up earlier, too. i think gtk+ is needed for some graphical tool to manipulate boot screen images. even if it's used noninteractively
<blackd0t_>hi i'm going to try installing Guix SD using bootable USB image. Will I be able to configure an WiFi connection with before I start installation process?
<jmd>Regarding build reproducibility: It has come to my attention that ar adds a timestamp even if -D has been passed. How does guix overcome this?
<petter>mark_weaver and others: here's current installation proposal, http://sprunge.us/JNCF Structure is changed from suggestion yesterday. Let me know if you have minor or major issues.
<petter>i'll be back in a few hours
<NiAsterisk>so about gnunet-gtk, glade has been updated now, but are all packages tested manually before they are pushed to hydra? or should I rewrite the gnunet-gtk package to get it published?
<jmd>NiAsterisk: So far as I'm aware, guix doesn't do a lot of manual testing. It would be too much.
<efraim>we generally trust everyone to test their own packages
<jmd>... and to provide a sufficient set of tests in "make check" or equivalent.
<NiAsterisk>okay. I was just curious, but I'll wait some more then
<efraim>I'm looking at upgrading pulseaudio to 8.0, and I'm confused why it wants Async DNS support
<efraim>i mean i understand with multi-device audio, but some of the optional inputs seem a bit much
<jubalh>Hello
<jmd>jubalh: Hi
<efraim>hi
<rekado>NiAsterisk: I have a gnunet-gtk package, but it segfaults...
<rekado>I brought this up on #gnunet but haven't gotten a response yet.
<rekado>I can send it to the list, but it needs debugging.
<NiAsterisk>ah, okay.. right, mine wasn't that complete, forgot that
<NiAsterisk>i might have questions about service composition and other things, but it's for something I am currently not working on. I try to take some notes and maybe ask at fosdem if there's time, or later on the mailinglist if I can't get it right. it's not really about services, but about further understanding the separation between guix and guixsd.
<jmd>Is there anything formal guix related happening at fosdem?
<NiAsterisk>although it would be best to just send it to the ML when I have thought through what I want to achieve and have remaining questions about how to do it.
<rekado>jmd: https://fosdem.org/2016/schedule/track/gnu_guile/
<NiAsterisk>ACTION wouldn't have time/energy for informal things
<NiAsterisk>4AM train to belgium, 9PM bus back to germany
<efraim>oh fun
<NiAsterisk>sounds like a lovely day, right? :D
<efraim>at least yours is a day trip, I can't go this year, but I'm looking at ~$500 for roundtrip flights and 3 nights in a hotel
<NiAsterisk>ouch
<NiAsterisk>lucky me, I live relative close to the border
<efraim>I'm just happy I could have a direct flight with times that work, trips out of Israel are sometimes hit or miss
<NiAsterisk>oh
<NiAsterisk>does brussel have public wifi? I only accidentaly drove to brussel one time when I picked some wrong directions to netherlands (too many highways, wouldn't now years later)
<civodul>Hey Guix!
<civodul>mark_weaver: hope everything is fine re the snow storm
<hillerod>hi, what's the preferred solution to quickly install software that has not been packaged (configure, make, make install)?
<hillerod>Inside a container with another distro perhaps?
<a_e>Package it :-)
<a_e>If it is really just the standard triplet of things to do, it is also easily packaged.
<a_e>And then everyone profits from it.
<civodul>hillerod: indeed, for configure && make && make install, https://www.gnu.org/software/guix/manual/html_node/Defining-Packages.html should have all the details
<hillerod>ok
<hillerod>thanks
<efraim>gnu-build-system is always my first guess
<civodul>lfam: finally replied to your doc patch, which had fallen through the cracks!
<Steap>civodul: you have to go to https://fosdem.org/2016/schedule/event/pypy/
<Steap>It's about "paying the bills" for Free Software
<Steap>ie getting money for new machines and salaries :)
<civodul>Steap: i've seen that one yes, looks interesting
<civodul>despite my disagreement on "Open Source is just a better way to write software" ;-)
<Steap>civodul: yeah, you should focus on the "I'm getting money to work on cool shit instead of wasting my life in a stupid office" part :p
<rekado>well, maybe "open sources" really is just a better way to write software. That's why we don't call it "open source".
<mthl>civodul: A first version of the '@' version separator is coming soon!
<sneek>Sneeky bot running on Guile version 2.0.11 using bobot++ 2.3.0-darcs
<rekado>'@' version
<rekado>hmm.
<mthl>rekado: I am tired :)
<mthl>I meant the first version of my patches regarding the use of '@' for delimiting package names and versions is coming
<civodul>Steap: yeah, esp. since i'm getting tired of doing pointless stuff to pay the bills when there's so much "relevant" work to do
<civodul>mthl: cool!
<civodul>rekado: skeptical about the "guile@1.8" thing?
<NiAsterisk>Steap: the "how do i pay my bills" talk?
<civodul>meanwhile, Guix shows up at the oh-so-corporate http://community.redhat.com/events/
<Steap>NiAsterisk: yes
<rekado>oh, no, I just wonder why sneek replied
<rekado>I tried to reproduce this.
<Steap>civodul: you know more about Red Hat than I do
<rekado>no comment on '@' versions implied.
<NiAsterisk>i had this on my bookmark list to maybe attend
<Steap>civodul: I haven't submitted my talk to Devconf, maybe I should have :)
<rekado>I think David should be removed as a speaker from this talk: https://fosdem.org/2016/schedule/event/guixmodules/
<lfam>sneek
<sneek>Its been said that sneek is a good boy
<efraim>sneek: botsnack
<sneek>:)
<paroneayea>oops
<lfam>version
<lfam>Does anyone know how to generate the "all-in-one" HTML manual like the one at [0]? `make doc/guix.html` gives each section in its own file. [0] https://www.gnu.org/software/guix/manual/guix.html
***nckx|offline is now known as nckx
<daviid>hello guix folks! I have 2 [unimportant] comments about the manual [html version]: (a) in the table of content, each entry has a dot preceeding the number, I think in the toc, the dot should removed; (b) all tables are left align with no indent at all, it would be a lot nicer to indent them like the 'code' snipsets are, imo.
<daviid>forgot to mention as well that all tables have an empty column in the middle, I wonder why. again, nothing important but I thought I'd share ...
<suitsmeveryfine>mark_weaver: ping
<efraim>I think I've figured out gst-plugins-good, but I've made the mistake of building one of the webkits and its taking forever now
<suitsmeveryfine>mark_weaver: I managed to fix my trackpad issue in a very simple way
<suitsmeveryfine>I Xfce I went into Session and upstart and ticked the empty box before "At-SPI D-Bus Bus"
<suitsmeveryfine>or checkbox to speak US English
<petter>suitsmeveryfine: Stallman is on tour in Sweden if you're interested, https://www.fsf.org/events/aggregator
<suitsmeveryfine>petter: Yes I know. Unfortunately I live quite a bit from where he'll be going
<suitsmeveryfine>and I have an infant that needs taking care of
<suitsmeveryfine>But if I went then maybe I could get my computer signed :)
<petter>ah, ok. I'll be going to Stockholm tomorrow to watch his talk
<suitsmeveryfine>you are!
<suitsmeveryfine>What time is it tomorrow?
<petter>18:00
<lfam>Does anyone know why the @copying stanza of the manual has explicit line breaks after some of copyright statements? http://git.savannah.gnu.org/cgit/guix.git/tree/doc/guix.texi
<lfam>And, should I add one for taylan when I add one for myself?
<lfam>Or, perhaps Taylan left it off because he or she was the last author, and the last author does not need to declare the line break? In which case I would add one after taylan's line, and not one for myself
<civodul>lfam: "makeinfo --html guix.texi" should do it
<civodul>lfam: i think the line breaks are actually necessary; you can tell the difference by looking at guix.pdf
<lfam>So my previous contribution to the manual broke it :( Oops!
<civodul>heh, np :-)
<lfam>$ man guix-system: guix - manual page for guix system (GNU Guix) 0.9.1
<lfam>0.9.1!
<suitsmeveryfine>I'm trying to edit the Xorg configuration file but I believe that the suggested way is not the right one
<suitsmeveryfine>I opened the file ~/.guix-profile/share/X11/xorg.conf.d$ nano 50-synaptics.conf
<suitsmeveryfine>And at the top it says that I shouldn't edit it directly but rename and move it to /etc/X11/xorg.conf.d
<NiAsterisk>you should never edit things in ~/.guix-profile/ iirc
<lfam>Yes, ~/.guix-profile contains symlinks to /gnu/store, which is immutable
<lfam>Perhaps the best option would be to make the change in your OS declaration and reconfigure
<lfam>But perhaps making the change in /etc would work too, I'm not sure
<suitsmeveryfine>can so many things be configured in the OS declaration?
<suitsmeveryfine>I'm not exactly sure what I'm doing but I like to make synclient work
<lfam>I don't have much experience with GuixSD yet, so I can't tell you exactly how to make that change in the OS declaration. But the goal is to have a totally declarative system.
<suitsmeveryfine>I see. Yes, that would be awesome of course
<lfam>I believe that xorg is a GuixSD service, so I would look into how that service is configured.
<lfam>In the meantime you could make the change in /etc and see if it survives a reconfigure
<suitsmeveryfine>I see. Well, to get basic touchpad functionality working in Xfce I enabled a service called AT-SPI Bus D-Bus Bus
<lfam>What a name
<suitsmeveryfine>yes, pretty strange. The service is not native of Xfce
<suitsmeveryfine>so I'm not sure where it's coming from
<NiAsterisk>you managed to install guixsd on the macbook now?
<suitsmeveryfine>yes, I'm typing from it right now
<NiAsterisk>cool
<suitsmeveryfine>Full disk encryption also
<lfam>Who needs a mouse pointer anyways ;)
<NiAsterisk>oh, nice.
<suitsmeveryfine>I had to enable two decryption modules and three keyboard-related modules in initramfs to make it work
<suitsmeveryfine>I like to use the keyboard as much as possible, but it's nice to be able to use the touchpad too sometimes.
<lfam>I know, I'm kidding ;) I am using a real mouse right now
<suitsmeveryfine>I'd also like to make brightness and volume control work
<suitsmeveryfine>GuixSD is so different though so I don't get much help from Internet forums
<lfam>You are blazing the trail
<suitsmeveryfine>I suppose so!
<suitsmeveryfine>Yes, everything I manage to fix will be documented of course
<NiAsterisk>If I would have tried to use guixsd with dialup internet as my first distro like I tried with gentoo in '99, it would've been equal to gentoo back then from the do it yourself to get help status. you basically need to hack it yourself or be online to get feedback and help^^ but it's easier to hack :)
<lfam>And you can't really break it once the first boot succeeds
<suitsmeveryfine>that's a relief
<lfam>And most first boots are not as difficult as yours ;) And hopefully nobody will ever have to do what you did again
<NiAsterisk>oh, yeah :D although you can't break gentoo either (these days)
<lfam>Oh yeah?
<suitsmeveryfine>yes, hopefully
<NiAsterisk>and if suitsmeveryfine documents it and publishes it, people with equal issues will solve their problems faster :)
<suitsmeveryfine>Yes, I will publish this, but where?
<lfam>The FDE and libreboot instructions will go in the manual for sure.
<suitsmeveryfine>Should I send an email to the guix list perhaps?
<suitsmeveryfine>There I could explain what issues I have solved and those that remain on the macbook2,1
<NiAsterisk>lfam: sort of.. i mean the only thing where I really broke gentoo was when I did a thing which removed a package from the build chain (i wanted guile 2.0+).. this was broken even with booting from gentoo-minimal into it to repair it. there are rare chances of breaking it. but this is not gentoo focused, so offtopic :)
<lfam>NiAsterisk: I was wondering... does Gentoo protect against a failed libc upgrade? I know that if this fails on Debian you are basically screwed
<lfam>suitsmeveryfine: Yes, sending it to guix-devel is the next step. I would break it up into topics (FDE, libreboot, issues with your hardware, etc) and present it for feedback. Then, we can all think about what should change in the Guix codebase, what should go in the manual, etc. Perhaps mark_weaver has some notes to contribute as well. These are all things that should be integrated somehow, IMO..
<NiAsterisk>idk, i used it for about a year on 4 computers and getting back to something different took off some stress. it was fun though and I learned some things, about hardened-gentoo, etc. iirc if a build fails it does not get installed, and you could also somehow switch back to an older version of the package. there's also a legion of people working on stuff (but some dust collecting packages too)
<suitsmeveryfine>Ifam: OK, I'll send one email but a well-structured one
<lfam>Perhaps the libreboot stuff should CC francis7 or a libreboot list. I'm not sure.
<lfam>It's an "L"fam :)
<suitsmeveryfine>Ifam: yes, I can CC the libreboot list
<francis7>yes, please CC the libreboot list
<suitsmeveryfine>hi francis :)
<suitsmeveryfine>francis7: the devel list or normal list?
<petter>suitsmeveryfine: have you done any more work on the installation guide?
<suitsmeveryfine>no, not really
<suitsmeveryfine>I can if you want
<lfam>What guide is that?
<petter>i have. I'm basically waiting for mark to come on and discuss it with him
<suitsmeveryfine>Install GuixSD with full disk encryption incl. boot
<suitsmeveryfine>ah, good petter
<petter>this is the current draft, http://sprunge.us/JNCF
<lfam>It would be good to integrate that into the Guix manual when it's ready
<petter>lfam: yes, this is what i want also
<suitsmeveryfine>I also don't know how to enable the loaded keymap in the operating system
<suitsmeveryfine>even if I selected a different locale in the installer I got the US keyboard layout
<petter>i changed keyboard layout in Xfce
<NiAsterisk>(services (cons* (bla bla) (console-keymap-service "de") %desktop-services)) I use for pre-xorg layout
<NiAsterisk>the other thing... maybe somehow integrate the "setxkbmap $lang" into some part of a future systemconfig
<francis7>suitsmeveryfine, -dev
<suitsmeveryfine>petter: I also did that, but first I accidentally logged into ratpoison and didn't know how to get out!
<petter>hehe
<NiAsterisk>is there a way out of ratpoison? I use it due to the lack of awesome-wm currently, and I just do sudo halt to "log out"
<petter>yeah, i've ended in there as well. But i've removed it since, so it's not an issue anymore
<suitsmeveryfine>NiAsterisk: If you have a different keyboard than the US one it's not so easy to enter the correct commands. For example I couldn't find the ´?´ key.
<suitsmeveryfine>petter: I have a few suggestions to your draft. How should I send the proposed changes?
<NiAsterisk>it takes some time, but after many many many many installs and even remote install with no option for DE layout I know qwerty for the most parts on qwertz now
<petter>suitsmeveryfine: maybe just talk about it here, or make a new version
<NiAsterisk>? is on <shift>+<-/_> here
<suitsmeveryfine>Well, maybe it's possible to find the correct keys but it's annoying
<NiAsterisk>yes.
<NiAsterisk>reasons why I never switched to neo2 layout, bad habbits and all the world uses qwert{y,z}
<NiAsterisk>regarding: finding keys
<petter>suitsmeveryfine: i'll be going to bed now, and i'll be away for a couple of days. Hope to see your suggestions when i get back :)
<civodul>mark_weaver: seems like core-updates is almost mergeable no?
<suitsmeveryfine>petter: you don't want to have this published before you come back=
<suitsmeveryfine>?
<petter>That's fine by me. But i'm interested to see what you have in mind.
<suitsmeveryfine>Oh, I was mainly thinking of style and grammar stuff
<suitsmeveryfine>If you want I can polish it a bit, listen to what mark and others have to say and then push it to libreboot
<petter>Ah, ok. I've been mostly focusing on structure and getting all the steps
<suitsmeveryfine>Yes, I think this could be worked on more, but that doesn't exclude publishing now
<petter>I found it a bit tricky to get readability vs. maintainability ratio ok
<suitsmeveryfine>since improvement can always be done
<petter>sure
<suitsmeveryfine>yes, it's not not always easy to get the balance right, but if it's going to be published on libreboot.org one can always compare it with the other guides
<petter>this draft is intended as a GuixSD installation manual proposal
<suitsmeveryfine>OK. One other thing that I think is missing is the part about adding modules to initramfs
<petter>Already numbered with chapters to fit right in
<suitsmeveryfine>OK, I like the idea of getting it into the officual GuixSD manual
<suitsmeveryfine>I guess there is no rish
<petter>I'm not sure that belongs there though, mark added the modules you needed, and the next user with the same computer shouldn't face the issues you had
<suitsmeveryfine>*rush
<suitsmeveryfine>petter: did he really add all of them?
<petter>not sure, i interpreted it as that was what he wanted
<petter>i'm more confident he would add the crypto modules, less with the keyboard modules
<suitsmeveryfine>that's how I interpreted it
<suitsmeveryfine>look: I'll send an email to the guix list about all the macbook2,1 specific issues and we can finish up the full disk-guide when you come back
<petter>ok
<suitsmeveryfine>Do you run GuixSD on an x200?
<petter>Yes
<suitsmeveryfine>Does it work fine or do you have any device-specific issues?
<petter>Runs very fine, no problems :)
<suitsmeveryfine>Sound good. I've never used an x200 actually, but I'm sure it's a nice machine
<suitsmeveryfine>I wish you a pleasant trip to Stockholm!
<petter>one thing i miss though is to run virtual machines
<petter>it doesn't have hardware virtualization
<petter>Thank you!
<suitsmeveryfine>at least you don't need to do graphics rendering on the CPU like with the c201
<petter>oh, is it noticable?
<suitsmeveryfine>don't know actually; I never managed to start X!
<petter>*noticeable
<suitsmeveryfine>it can render the terminal graphics very quickly though
<petter>i see
<petter>Well. Me tired. To bed. Now. Bye!
<suitsmeveryfine>bye
<lfam>So the `khal` package installs an executable Python wrapper to the `vdirsyncer` package's main executable. What in the world?
<lfam>I wonder if that is an issue with our package or with upstream?
<lfam>The wrapper is an "EASY-INSTALL-ENTRY-SCRIPT". Does anyone know how the creation of such scripts is controlled?
<lfam>I don't even think you can run vdirsyncer from within khal so it makes no sense for khal to even know about it
<CompanionCube>lfam, https://pythonhosted.org/setuptools/easy_install.html?