IRC channel logs

2015-11-07.log

back to list of logs

***tapas is now known as fps
<detrout>oh. is there a new home for guix-web? gitorious disappeared and google didn't find it
<codemac>hmm guile-irregex doesn't export irregex-fold/chunked
<codemac>but looks like an upstream issue :/
<MrProlong>yo! I've successfully built the guix website locally! can anyone help me figure out how to serve it up?
<piyo>hello, where is RSA key 0x090B11993D9AEBB5 ? gpg --verify guix-binary-0.9.0.x86_64-linux.tar.xz.sig
<piyo>I looked at this https://www.gnu.org/software/guix/manual/html_node/Binary-Installation.html#Binary-Installation for guidance
<davexunit>piyo: that key is for ludo@gnu.org
<piyo>sorry for the noise, key lookup problem on my end
<FlibberTGibbet>hi, just booted a guix installation and have a scheme@(guile-user) prompt... have i made a mistake or can i get a root login from there?
<karhunguixi>Gxsdnewb, i just thought of something, but your GuixSD grub.cfg paste is expired. If i remember correctly you have cryptomount there... I don't (in my Libreboot setup).
<karhunguixi>I don't what happens if you decrypt a partition twice, but i think it could be worth a shot NOT doing that.
<karhunguixi>*know
<lfam>Hooray, with substitutes available for 0.9.0, I have successfully installed Guix on Debian on my armv7 board :)
<lfam>The whole experience has made me question of the value of these underpowered boards, though. If they can't successfully compile large software programs without becoming unstable, are they any good for software freedom?
<lfam>Well, there are a few more things to try before I give up on the board: replace the sunxi kernel (forked from 3.4) with mainline Linux, and test some of the hardware components
<rekado>detrout: the code for guix-web is here: https://git.dthompson.us/guix-web.git
<detrout>rekado: thank you
<Gxsdnewb>good morning guix!
<Xe>i'm getting my machine to log me out every time i install a package in guix
<alezost>Xe: did you maybe by accident add your user to 'guixbuild' group?
<Xe>you're not supposed to?
<alezost>no, you shouldn't do it
<Xe>fixed that
<Xe>let's see if it logs me out again
<Xe>still happening
<Xe>even if I do it as root
<Xe>do I need to do a full reboot?
<alezost>at first try to restart guix-daemon
<alezost>if it will not help, then I would reboot
<alezost>but double check 'groups' (for root as well)
<Xe>ah
<Xe>i hadn't made the user farm
<Xe>alezost: that seems to have done it, thanks
<alezost>you are welcome :)
<Xe>is it sane to use guix for configuration management on a not-guix system?
<alezost>"configuration management"? what do you mean?
<Xe>like the role that cfengine would play
<alezost>sorry, I have no idea what 'cfengine' is
<rekado>hmm, I installed microscheme, avrdude, gcc-cross-sans-libc-avr, and avr-libc, but the linking step fails with this error:
<rekado>avr-ld: cannot open linker script file ldscripts/avr5.xn: No such file or directory
<Xe>alezost: it's something you can use to make sure configurations across a large number of servers are consistent
<rekado>this linker script file is part of the cross-binutils for avr, which is a native input to avr-libc.
<alezost>Xe: I have no experience in such things, but I would say that guix is suitable for it
<rekado>has anyone managed to use the avr gcc compiler on GuixSD?
<Xe>alezost: where can I define my own packages?
<rekado>Xe: you can define own packages anywhere and add the path to GUIX_PACKAGE_PATH
<Xe>okay better question
<Xe>where are docs on how to make a package
<phant0mas>rekado: when I packaged it I remember being able to link
<phant0mas>and somebody reported the same problem before and I didn't have time to look into it
<phant0mas>I think it's about time I fix it
<alezost>Xe: it is described in the manual: see (info "(guix) Packaging Guidelines") and (info "(guix) Defining Packages")
<alezost>Xe: also IMHO the most useful thing is to look at the package recipes in the guix source (.../gnu/packages/*.scm)
<fps>wow, git is 80 megs or more?
<fps>in nixos it's 25megs
<fps>102 megs.. hmm
<alezost>yeah, I always ask myself: "damn, why is it so huge"?
<fps>hmm -vga qlx makes the resolution and the graphical console work, but screen updates are a little broken.. ugh.. can't win :)
<fps>[qemu-kvm]
<fps>oh i think i know why the grapical console mode doesn't work with -vga std
<fps>where in the distri do i find the requested mode?
<fps>and where does the guix package defiitions live in the installed fs?
<fps>oh found it /gnu/store/....guix-latest/lalala
<fps>so there's a gfxterm module
<fps>hmm
<fps>for some reason modinfo tells me nothing about it
<fps>oh that's because modprobe just silently fails when the module doesn't exist
<fps>hrmpfs
<fps>is that expected?
<fps>ok, this tells me something about how to setup modes:
<fps> https://www.gnu.org/software/guix/manual/html_node/X-Window.html#X-Window
<fps>but i'm a little lost on how to use it in my system config..
<Gxsdnewb>civodul: bonjour! i am trying to follow your instructions on the mailing list: http://lists.gnu.org/archive/html/bug-guix/2014-11/msg00057.html
<Gxsdnewb>but in REPL after entering the third line with (system* ... it returns ERROR: In procedure string-append:
<Gxsdnewb>Wrong type (expecting string): #f
<fps>hmm, is modify-services the procedure i'm looking for
<fps>?
<fps>if i eventually want to get a different list of resolutions for x to use? e.g. ((1024 768) (640 480))
<karhunguixi>Gxsdnewb, do you run cryptomount twice, in Libreboot and again when starting GuixSD?
<Gxsdnewb>i am having the same error as the parent poster, where cryptsetup is not found and it fails at fsck with the same errors
<Gxsdnewb>karhunguixi: i deleted cryptomount inthe guixsd grub.cfg
<fps>i was just gonna ask if cryptsetup is not found. what does (cs) give you?
<karhunguixi>ok
<fps>just poking around though :)
<fps>Gxsdnewb: i just tried it on my installed system and i get back a response
<fps>scheme@(guile-user) [2]> (use-modules (srfi srfi-1) (ice-9 ftw))
<fps>scheme@(guile-user) [2]> (find (lambda (file) (string-contains file "cryptsetup")) (scandir "/gnu/store"))
<fps>$4 = "57fkly6slcqsy5ciwn5sxq2q8jq36d1n-cryptsetup-1.6.1.tar.bz2.drv"
<Gxsdnewb>fps: hmm, you have the drv for downloading the tarball, but i just have the installed package dir which it does not return
<Gxsdnewb>fps: is your / encrypted?
<fps>Gxsdnewb: nah. was just wondering if that function in general worked at all
<Gxsdnewb>i was wondering how it is supposed to search my root fs if it cannot even decrypt it, which is why civodul's suggestion confused me
<fps>i was just wondering at what time you should get a repl. mabe you need to get cryptsetup on a ramdisk or something? no idea :(
<fps>oops
<fps>*initrd
<Gxsdnewb>yes i was considering this, but dont know how to do it.
<fps>i thought grub could had support for accessing an encrypted root directly?
<fps>i'm totally out of my league here though..
<fps>how's the initrd built in guixsd?
<fps>oh linux-initrd.scm.. hmm
<fps>Gxsdnewb: there's helper-packages in linux-initrd.scm
<fps> ;; Packages to be copied on the initrd.
<fps>maybe you can add cryptsetup there?
<fps>(define* (expression->initrd exp
<fps> "Return a derivation that builds a Linux initrd (a gzipped cpio archive)
<fps>containing GUILE and that evaluates EXP, a G-expression, upon booting. All
<fps>the derivations referenced by EXP are automatically copied to the initrd.
<fps>bbiab..
<Gxsdnewb>thank you for the tip fps, i am looking at linux-initrd.scm now. but i have a hard time believing i need to edit this when karhunguixi had no problems decrypting root
<Gxsdnewb>karhunguixij: can you paste the output of cryptsetup luksDump /dev/sda1?
<karhunguixi>Gxsdnewb, i could do a fresh install on another partition tomorrow or monday, to see if i run into the same issues you are or not.
<karhunguixi>Gxsdnewb, http://sprunge.us/MNWj
<Gxsdnewb>i wonder if you using sha1 vs. me using sha512 has anything to do with it
<karhunguixi>hmm
<ennoausberlin>Hello. Is there a way to upgrade from 0.8.3 to 0.9 ?
<fps>what else to read to understand how to apply #resolutions from here https://www.gnu.org/software/guix/manual/html_node/X-Window.html#X-Window
<fps>#:resolutions
<fps>ok, judging from the ML posts about it that doens't seem to be such a simple task
<fps>yay, xrandr to the rescue
<fps>xrandr -s 1280x720
<fps>sets the resoution correctly..
<fps>xorg reports 128x768 as supported but then it scrolls vertically ;)
<fps>*1280
<fps>ok, i got sed in my build input
<fps> https://pastee.org/jrpnr
<fps>can i just add the sed call to replace the paths in the install script to the builder commands?
<fps>hmm, can i somehow see what the builder does?
<fps>guix package -L src/guix-non-free/ -i renoise-demo --verbosity=3
<fps>this just tells me that the builder failed to produce the output path
<fps> https://pastee.org/dqghw
<fps>probably still wrong on many levels
<fps>ok, gone for a while..
***davi_ is now known as Guest30398
<efraim>I think most of the time `guix lint` fails for me on new packages is because I don't just copy a package and change the fields but I keep on typing everything myself
<efraim>last time it was (method url-fefch). I can't want to see what typo I made this time
<efraim>another time I had (define-pubic $name
<lfam>wingo: Does your guix on nix setup declare the guix build users in configuration.nix? If so, how did you do that? Do you have to manually specify each of the ten (or however many) users?
<kori>alright, I'm in preparation to install guixsd on another hdd, thought I'd check the IRC channel out
<sirgazil>ACTION succesfully installed Guix 0.9.0 in a foreign distribution
<lfam>kori: Welcome to #guix
<kori>thanks :) guix really interested me
<kori>well, nix already was very interesting, and I had heard of guix
<kori>the guile website redesign triggered an interesting phenomenon where anything guile-related became much more interesting to me
<sirgazil>\\o/
<kori>well... brb!
<sirgazil>That's the idea :)
<sirgazil>Hmm... Guile 2.0.11 appears twice in the packages list
<sirgazil> http://www.gnu.org/software/guix/packages/
<davexunit>sirgazil: we package multiple variants. guess we don't deduplicate in this particular case.
<lfam>davexunit: Did you ever finish defining all the packages for Let's Encrypt? If you have some of the work done I'd be happy to pick it up and keep going.
<davexunit>lfam: if I made a 'wip-letsencrypt' branch, you'll pick it up?
<lfam>davexunit: I'll do my best
<davexunit>the packages are messy right now, but I'll make a commit with the whole lot and push.
<davexunit>can be cleaned up later.
<lfam>That's fine. My packages are usually messy while they are in progress, too
<davexunit>lfam: pushed as 'wip-lets-encrypt'
<davexunit>good luck!
<davexunit>and thanks for offering to look into it
<lfam>davexunit: Thanks for getting it started
<efraim>about `make check` in gnu-build-system, xfail is supposed to fail?
<davexunit>yes
<kori>alright, I couldn't figure this out
<efraim>ok, good. I was sure something was wrong
<kori>what is to be put under (device) under (file-systems) in the guix config?
<kori>the default being (device "root"), of course
<kori>oh
<kori>brb
<fps>guix lint doesn't have a -L option :(
<fps>should it?