IRC channel logs

2015-09-17.log

back to list of logs

<goglosh>halp
<goglosh>I put a gpt label on my disk
<goglosh>and the install threw a couple warnings
<goglosh>this GPT partition label contains no BIOS boot partition: embedding won't be possible.
<goglosh>Embedding is not possible, grub can only be installed in this setup by using blicklists which are unreliable and discouraged
<goglosh>then error: will not proceed with blocklists
<goglosh>and it exited with an error: failed to install GRUB on device /dev/SDA
<goglosh>everything else seems to have installed though, how can I put the boot in the first partition?
<karhunguixi>goglosh, read the GPT section here and see if it helps, https://www.gnu.org/software/grub/manual/html_node/BIOS-installation.html
<karhunguixi>i'm pretty sure you need a small partition of type 0xEF02
<goglosh>shit
<goglosh>fuck this
<xentrac>ACTION fucks it
<xentrac>uhoh. what did I just do?
<exio4>you don't want to know xentrac, really
<xentrac>:(
<Steap>This channel gets weird at night.
<exio4>Steap: all channels do
<Steap>hehe.
<civodul>Hello Guix!
<karhunguixi>Salut
<civodul>salut karhunguixi :-)
<sprang>hmmm, can't sleep... might as well talk about guix!
<sprang>does it seem reasonable to just silence the profile collision warnings?
<sprang>when I install something now I see about 30 lines of useful output, and then several hundred lines of collision warnings
<sprang>if they are harmless and there's no relevant action I can take to fix the warnings, I'm not sure I need to know about them :)
<sprang>maybe just a summary like "102 profile collisions resolved." and a log file somewhere?
<civodul>several hundred lines? ouch
<sprang>yeah, maybe I'm just in a weird state
<civodul>i see more like 20, which is already too much ;-)
<civodul>i think we need to find out which collisions are common and how we can address them
<sprang>I'm on an "guix ergonomics" kick :)
<civodul>as discussed at https://lists.gnu.org/archive/html/guix-devel/2015-09/msg00213.html
<civodul>and your effort on ergonomics is welcome! :-)
<sprang>that's good :)
<civodul>speaking of which, you may be a good candidate to work on adding colors to the CLIs ;-)
<sprang>I played with (term ansi-color) a bit
<civodul>ah, see? :-)
<sprang>I tried using that module in a guix file and it guix wasn't happy about it... is there something special I need to do to use that module?
<sprang>I didn't investigate very hard at the time
<civodul>sprang: i'd need to see exactly how Guix showed its unhappiness ;-)
<civodul>but otherwise it should work
<civodul>in practice, i think we'll probably import that module and call it (guix ansi-colors)
<sprang>ok, I'll try it again
<civodul>ACTION pushes a bunch of Emacs packages
<sprang>hmm, I'm not seeing the problem now, maybe I just screwed up my import.
<sprang>oh fancy, green progress bar :)
<sprang>hmmm, the elapsed time seems to have disappeared from "guix download"
<sprang>ah, I didn't realize string-pad can clip the input
<sprang>civodul: the string-pad-middle procedure now guarantees that the resulting string is len columns long... original implementation would allow overflow
<sprang>wdyt?
<sprang>also, the download filename is a pretty long string again (for "guix download" case). looks like passing "#:abbreviation basename" to progress-proc in build/download.scm restores the previous behavior
<sprang>not sure if that breaks anything else
<civodul>sprang: unfortunately, colors probably cannot be used in (guix build download)
<civodul>ah right, overflow may be necessary
<sprang>adding colors complicates string length computation, at the very least :)
<civodul>arf, sorry for breaking things!
<civodul>heh
<civodul>i was thinking mostly of the output of 'guix package' and 'guix build'
<civodul>not that of things that go through the daemon
<sprang>no problem, it's all helping me learn by doing :)
<sprang>I can play around with it more tomorrow
<sprang>it's 3am here, not sure when I'll decide it's worth trying to go back to sleep. don't want to get too involved at the moment
<sprang>why do you say that (guix build download) can't use colors?
<sprang>civodul ^
<sprang>also, I'm not clear on why some guix code shouldn't use other guix code. what should I read?
<civodul>the output of (guix build download) goes through the daemon, except when running 'guix download'
<civodul>for the distinction between "build" and non-build modules, see http://www.gnu.org/software/guix/manual/html_node/G_002dExpressions.html about "code strata"
<civodul>ACTION goes for lunch
<sprang>ok, I will read through that
<Steap>So, I have python-pbr defined in openstack.scm, which uses python.scm
<Steap>and I'd like to define a package in python.scm that uses python-pbr
<Steap>so there is a circular dependency
<Steap>I took a look at flex/xorg, but cannot figure out how to avoir a stack overflow
<Steap>any idea ?
<paulo>hello :)
<civodul>hello, paulo
<civodul>Steap: the problem is not a stack overflow, is it?
<civodul>isn't it more like "unbound variable"?
<Steap>hum
<Steap>let me compile that again
<Steap>well, when I try to build the package in python.scm that uses python-pbr, I get a stack overflow
<civodul>ah ok, so it's just a circular dependency
<civodul>nothing to do with which file is used
<civodul>so the solution is to find out where the cycle is and to break it :-)
<Steap>oh
<rekado_>sprang: thank you for the UI improvements! The text UI is so much cleaner now, I really like it.
<civodul>sprang: as you wrote earlier, 'guix download mirror://gnu/ed/ed-1.10.tar.gz' has the file name overwrite the progress bar
<civodul>s/gz/lz/
<civodul>maybe i broke that yesterday
<davexunit>ACTION is not sure how to handle a situation on the mailing list
<Steap>civodul: how can I fix this "possibly unbound variable" error you were talking about ?
<civodul>Steap: is it unbound in practice?
<civodul>i would need more details :-)
<civodul>davexunit: which one?
<rekado_>I find I'm more involved in reviews than before, but I'm still working on a way to follow up on all emails. Any suggestions?
<civodul>i'm not very good at that
<rekado_>I'm now trying out org-capture to link emails to my org mode file, lest I forget about them.
<civodul>i just leave messages that i plan to address as unread
<davexunit>that's what I do
<civodul>yeah, that's pretty good
<davexunit>and when I see that someone else takes up the torch on a thread, I archive it.
<civodul>i do that for non-trivial tasks, not too much for review
<rekado_>before that I just flagged emails, but that got mixed up with stuff I wanted to keep for reference only.
<rekado_>email is hard.
<civodul>definitely!
<davexunit>civodul: things are getting a bit tense regarding pjotr and our high standards for patches.
<davexunit>rekado jumped in on the thread and was much more diplomatic than I could be.
<davexunit>er, I think it's rekado_ today ;)
<rekado_>(heh, sorry about the changing names. Still using IRC via browser at work, because ports are still closed.)
<rekado_>davexunit: I think it's not a very big problem. I think the problem is that git rebase isn't very convenient going back and forth. He said he's okay with sending out one polished patch in the end.
<davexunit>rekado_: okay
<davexunit>guess I misread then.
<rekado_>what he sends to the ML initially wouldn't need to be in the usual patch format if that's easier for some reason, as long as the final thing we get is a patch we could just apply.
<davexunit>he was threatening to just keep a fork and stop submitting.
<davexunit>which I wanted to avoid but at the same time I don't accept lowering standards.
<rekado_>I chose not to read this sentence ;)
<rekado_>if it's a technical barrier (which I chose to assume) then I think it's fine to lower it for the initial discussion about a new package.
<davexunit>sure, I think that's fine.
<rekado_>I just wouldn't be comfortable to be told to pick up the patch and make the effort to polish it up myself. That's feels too much like work.
<rekado_>s/That's/That/
<Steap>rekado_: isn't that what happens in most projects ?
<davexunit>Steap: not sure what part you are referring to
<Steap>davexunit: being told to polish your own patch
<davexunit>oh, yeah.
<davexunit>that's totally normal.
<davexunit>guess some people really don't like non-GitHub workflows, though.
<rekado_>there really isn't that much of a difference between email and Github workflows. You can work in a branch and stack commit after commit, but before sending it out for review you squash the commits.
<Steap>don't people rework their patches on Github ?
<rekado_>even many Github workflows require squashing commits.
<Steap>The only difference is that not using github is easier
<davexunit>Steap: yes, with the added grossness of having to force push to a remote git branch
<davexunit>I prefer the separation of version control system from patch review.
<davexunit>hopefully someone will get a chance to take a look at qemu's patches tool
<davexunit>civodul kindly packaged it already
<civodul>davexunit: right, i noticed Pjotr is a bit sloppy at times
<davexunit>I've received very broken patches multiple times
***frob is now known as Guest33164
<bavier1>I appreciate guix's high patch standards
<davexunit>me too.
<davexunit>I've become much more disciplined in how I write code as a result.
<bavier1>in some cases it might be "easier" to just grab a patch, fix it, and push. But then we're not communicating those standards to contributors
<davexunit>yeah.
<bavier1>davexunit: same here
<davexunit>the first few patches take awhile to establish the requirements and workflow with the contributor, but after that things seem to become smooth.
<davexunit>we've all been through that. ludo pointed out all the little things that are minor, but still important for a nice patch.
<civodul>ACTION is pissed off by the so-called neutrality of WP -> https://en.wikipedia.org/wiki/Talk:Linux#What_is_Linux.3F
<civodul>i discovered that WP has a very clear stance on these topics
<civodul>see https://en.wikipedia.org/wiki/Talk:Linux/Name#Position_by_Benjamin_Mako_Hill for instance
<civodul>that's "fine", except that that stance is never made explicit
<civodul>damn it
<civodul>davexunit: re patches, you've been very patient
<civodul>i think we have to be patient with newcomers
<civodul>but at some point, it's reasonable to expect more work from the submitter
<davexunit>thanks
<davexunit>civodul: that discussion page is quite the time sink
<sneek>Understood.
<civodul>yeah, i fell into the trap ;-)
<davexunit>lol what did I do to trick sneek?
<civodul>"foo is bar"
<civodul>or "the foo page is bar"
<civodul>hmm, dunno
<davexunit>I was told at some point, some odd sequence of characters tricks sneek.
<davexunit>just can't remember.
<davexunit>sneek: what is quite?
<davexunit>hmm
<civodul>sneek: what is the discussion page?
<civodul>hmm hmmm
<davexunit>:)
<taylanub>what is civodul: that discussion page
<taylanub>sneek: what is civodul: that discussion page
<sneek>I've heard civodul: that discussion page is quite the time sink
<taylanub>:)
<davexunit>hahaha
<taylanub>not a very smart parsing it does there :P
<civodul>uh
<sprang>rekado_: glad you like the UI changes! seemed like a good area to get my feet wet as a contributor
<davexunit>I like the changes a lot, too. feels more polished.
<mthl>me too.
<mthl>sprang: Maybe you can try to improve 'guix package --list-generations' next :) ?
<davexunit>use emacs ;)
<mthl>Yeah but I sympathize with our beloved Vim users :)
<davexunit>I'll pray for them ;)
<sprang>I'm fixing stuff up as it annoys me :)
<davexunit>much appreciated
<sprang>right now I'm annoyed by profile collision warnings... totally dominates my output
<davexunit>we all are.
<davexunit>we need to design a way to either avoid these collisions altogether or selectively suppress ones that are harmless
<davexunit>there's a thread on the mailing list about it
<sprang>I saw that thread
<sprang>in --list-generations is the hash prefix still useful to people if it's truncated to the first 6 digits or so?
<sprang>most of the problems with the output are due to the really long computery filenames
<davexunit>no, it's not useful.
<davexunit>we need the full store path
<davexunit>we have an emacs mode to hide them, but the full text is still really there so you can operate on those file names
<mthl>sprang: I think it's fine to truncate it, but what would be really neat is to show a sort of diff between generations instead of displaying all their contents
<mthl>and to have them aligned by column :)
<sprang>what's the use case for looking at and comparing generations? I think this might be the first time I've tried that particular command
<mthl>if you want to roll back after some update
<davexunit>and seeing which ones you want to delete so things can be gc'd
<civodul>oh! https://chicagolug.org/meetings/2015-09-30.html
<Steap>These Red Hat folks are so nice.
<davexunit>awesome!
<civodul>Steap: yeah, next time it'll be in their Bordeaux offices, right? ;-)
<Steap>civodul: I can hardly fit in the Bordeaux offices :D
<civodul>heh :-)
<Steap>I'm working on having them buy me a mansion so I can have optimal working conditions
<Steap>Do we have a nice illustration somewhere for the "symlink forest" ?
<civodul>in some of the older talks, i think
<civodul>and on rekado's or davexunit's blog, IIRC
<rekado>Steap: a greatly simplified illustration of symlinks in profiles is here: http://elephly.net/downies/poster-v3.pdf
<rekado>SVG sources are here: http://elephly.net/downies/poster.svg
<Steap>thx
***ander_ is now known as anthk_