IRC channel logs

2015-05-30.log

back to list of logs

<ewemoa>davexunit, iyzsong: updated fluxbox inputs and have it working as an option when logging in via slim: https://pastee.org/y6en6
<davexunit>ewemoa: nice!
<davexunit>ewemoa: the snippet can be improved a bit. use 'call-with-output-file' instead of explicitly opening and closing the file.
<davexunit>then, use a multi-line string instead of many display and newline calls.
<ewemoa>davexunit: thanks, will try to incorporate
<davexunit>hmm, our iproute2 package doesn't build a libnetlink shared library
<luxury>hello #guix
<luxury>this would be the part where I share my installation success story
<luxury>except that I haven't been able to boot into the new system
<luxury>the dreaded "waiting for partition 'root' to appear"
<luxury>like it can't even see the disk that that partition's on
<alezost>luxury: perhaps you miss some kernel module to recognize your HDD, for example I need to use "sata_nv" in my operating system declaration
<sneek>alezost, you have 1 message.
<sneek>alezost, alezost says: foo
<alezost>pardon for that ^^^ :-)
<alezost>luxury: something like this: http://paste.debian.net/188877
<alezost>I had the same "waiting for partition ..." message loop when my system was configured without "sata_nv" module
<luxury>alezost: interesting, hadn't even considered that
<alezost>luxury: I used "lsmod" on my other system installed on this computer ("Arch Linux") to find out what modules might miss
<luxury>alezost: let me give that a try; I'll report back in a bit (and thanks)
<paroneayea>hi #guix
*davexunit feels like he almost sort of has guix running in a container
<luxury>yesss, finally able to boot into my newly minted GuixSD installation
<luxury>not really "mine" yet -- just copied the bare-bones config --
<luxury>but I'm counting this as a pretty significant cliffside foothold
<luxury>alezost: you were exactly right, thank you thank you thank you
<luxury>not only was I missing a kernel module, it was, in fact, sata_nv!
<alezost>luxury: great :-)
<paroneayea>davexunit: ooh
<paroneayea>hello, *
<luxury>hey paroneayea
*paroneayea is packaging guile-dbi
<davexunit>woo!
<luxury>is that sort of the SXML for binary databases?
<davexunit>not really
<paroneayea>it's very minimal
<davexunit>there's no s-expression representation of database queries
<paroneayea>I'd love to have an sexp representation
<paroneayea>but that doesn't exist yet
<davexunit>it's a very difficult task
<davexunit>I tried and failed, and after I read that many other failed, too. :)
<paroneayea>davexunit: :)
<davexunit>there are many SQL implementations, and each has their own rules.
<davexunit>what operators are supported? which are infix? which are postfix? which are prefix?
<luxury>heh, it's withering just to think about
<davexunit>you have to know lots of context to get it right
<paroneayea>I'd probably try to mime sqlalchemy core's interface
<paroneayea>if I were to do it
<davexunit>but that's a much higher level then what we're talking about.
<paroneayea>davexunit: no there's two layers to sqlalchemy
<paroneayea>a "core" layer, which is very close to actual sql
<paroneayea>and an ORM built on top of that
<davexunit>oh okay
<paroneayea>the core is independent of the ORM
<paroneayea> http://sqlalchemy.readthedocs.org/en/rel_1_0/core/tutorial.html core
<paroneayea> http://sqlalchemy.readthedocs.org/en/rel_1_0/orm/tutorial.html ORM
<paroneayea>I think that layered approach makes a lot of sense
<davexunit>sure
<davexunit>then I could not use the ORM layer ;)
<paroneayea>yep
<paroneayea>and not saying that sqlalchemy should *exactly* be the basis
<paroneayea>but they seem to have a good breakdown of the primitives
<davexunit>activerecord would be another place to look
<davexunit>arel in particular
<paroneayea>I'm not really sure what to do about database usage for the project I'm working on for now
<paroneayea>see #guile for me hemming and haw'ing about it
<paroneayea>but
<paroneayea>for now I'm going to package various options
<paroneayea>so I can test them out
<paroneayea>it might be kind of fun to see how far I could get *without* a relational db and just using gdbm
<paroneayea>but that also seems a little bit insane
<paroneayea>like, getting the N latest post of something
<paroneayea>I'd have to index that *somewhere*
<luxury>however you go, good luck
<luxury>I'm a couple of reconfigures away from being able to comfortably package anything
<luxury>hope to connect again soon (and next time not from a sys-rescue live CD that doesn't recognize my mouse)
<luxury>cheers all
<rekado>I'm confused about libbdf. There's a library "withershins" that I packaged, which uses libbdf. When I then build software using "withershins" it complains at link time about "undefined reference to `bfd_init'" and the like.
<rekado>Is libbfd really offered by the binutils package?
<rftower>hello.how to make iso file by guix image?
<davexunit>ah, this silly ol' page is on the front page of HN
<davexunit> http://harmful.cat-v.org/software/dynamic-linking/
<needway>who to install guix in vBox?
<paroneayea>guix: package: command not found
<paroneayea>uh
<paroneayea>what is going on here
<paroneayea>guix gc --help works
<paroneayea>but guix package --help says no package command
<paroneayea>clearly something is wrong
<paroneayea>I've done a make distclean and a rebuild
<paroneayea>I haven't had this problem before o_O
<paroneayea>hm
<paroneayea>it does a catch of misc-error
<paroneayea>something is happening but it isn't clear to me what
<paroneayea>ah
<paroneayea>it had to do with my package definition
<paroneayea>I see, it's catching a misc-error, which seems like it can be anything
<paroneayea>"the diaper pattern" is no good
<phant0mas>sneek: later tell civodul I found what the problem was, patched gcc-4.8, waiting for the build to finish and I will report back.
<sneek>Okay.
<paroneayea>okay, that's curious
<paroneayea>trying to package guile-dbi
<paroneayea>but it's trying to install to guile's own /gnu/store entry
<paroneayea>/gnu/store/nnjnqr747xzvfkbf8vj7gassaak35g24-coreutils-8.23/bin/mkdir: cannot create directory ‘/gnu/store/5cqm1pk28agrc5yys99c6ng8i9ki5chg-guile-2.0.11/share/guile/site’: Permission denied
<davexunit>paroneayea: you'll need to set the installation prefix
<davexunit>though I don't know how guile-dbi's build system actually works