IRC channel logs

2015-05-07.log

back to list of logs

<davexunit>icecat is great and all, but it's using the firefox LTS release that is outdated for web development. might be good to package Abrowser for this purpose.
<mark_weaver>yeah, abrowser is the one to look at, but we'll have to stay on top of security updates as well
<davexunit>yeah
<davexunit>if I do this, I'll subscribe to whatever mailing list firefox security patches are posted on.
<civodul>davexunit & mark_weaver: thanks for the mesa-nouveau branch, it's a good idea
<mark_weaver>civodul: btw, I ran "make check" on MIPS current guix master, and it passed all tests. so, maybe it's a non-deterministic failure, or maybe it only fails within the build environment, or maybe it has to do with the rather older software in the profile where I build guix from git.
<mark_weaver>for now, I've restarted the failed build on hydra
<civodul>mark_weaver: noted your message re the guix build failure on MIPS
<civodul>sorry i was testing a daemon upgrade and there's apparently a kill(2) call in there that is not under control :-)
*civodul -> zZz
<mark_weaver>bah, sqlite needs a security update, and that will entail on the order of 2000 rebuilds :-(
<mark_weaver>I guess I should move "fix grafts" higher up on my TODO list
<davexunit>ouch
<mark_weaver>and, it's another upstream that doesn't sign packages :-(
<davexunit>hmm why doesn't bridge-utils include /sbin/brctl
<davexunit>when I build it by hand it installs it...
*davexunit prepares openvpn patch
<mark_weaver>maybe something missing from the build environment
<davexunit>a-ha, the build actually fails, but the build process still returns 0
<davexunit>:/
<davexunit>ugh, I just can't figure out what's missing.
<davexunit>/gnu/store/kw6vqh4w6mmji6cq1dlb0hv55qrc7bsz-linux-libre-headers-3.14.37/include/linux/if_bridge.h:184:20: error: field ‘ip6’ has incomplete type
<davexunit> struct in6_addr ip6;
<davexunit>in6_addr is defined in another head file in linux-libre-headers
<paroneayea>o/
<vmlinuz88>Question: Will Guix run on FreeBSD? Or does it require the Linux kernel?
<cmhobbs>i can't give you a definitive answer but i don't believe the package manager portion requires the linux kernel
<cmhobbs>someone more informed may tell you different
<mark_weaver>vmlinuz88: Guix will not currently run on FreeBSD.
<mark_weaver>Guix does not use anything from the host system except for the kernel. it starts with its own bootstrap binaries, and builds up the system from those.
<mark_weaver>those bootstrap binaries are compiled to run on Linux (the kernel) only.
<mark_weaver>in theory, Guix could be ported to run on the FreeBSD kernel, but note that we would still use a full GNU userland on top, including GNU libc.
<vmlinuz88>mark_weaver Ah, I see. That makes sense, thank you.
<mark_weaver>np!
<Kolt>Hey
<Kolt>Can I ask here about the GuixSD?
<Kolt>What should I do with my config.scm if my system has different partitions?
<Sleep_Walker> https://www.gnu.org/software/guix/manual/guix.html#File-Systems
<rekado_>I would like to avoid using "make install" but I also want to have a system-wide installation of guix, the same for all users.
<rekado_>I wonder how to do this.
<rekado_>Maybe a shared profile whose bin output appears first in the PATH...?
<civodul>Hello Guix!
<vmlinuz88>Hello civodul :)
<bavier>is it worth patching <package>-config type files to avoid propagating inputs?
<civodul>bavier: do you have an example?
<davexunit>civodul: I saw your commit for the site export. it's going to need a bit of extra work because sxml->xml doesn't do the right thing for all HTML tags.
<davexunit>if I have time I'll post a patch
<mthl>i would like some advices regarding how to work with www module
<mthl>how do you do to quickly load a module which have other module dependencies?
<mthl>I would like to "C-x C-e" (define-module ...) and that everything gets loaded
<civodul>davexunit: ok!
<civodul>mthl: i just added /path/to/guix-artwork/website to geiser-guile-load-path in ~/.emacs
<mthl>civodul: and then you C-c C-z and ",use (www)" ?
<vmlinuz88>I would like to get involved in Google's Summer of Code with the Guix project, but I'm not sure where to start.
<rekado->I evaluated this: (setq geiser-guile-load-path '("~/dev/guix/")) but I still cannot use M-. to jump to definitions of package values. Is something else needed to make this work?
<rekado->Oh, apparently I actually have to load all these modules before I can jump around. :-/
<mthl>you mean in the REPL?
<mthl>M-. is a shortcut for `geiser-edit-symbol-at-point' but modules are accessed by `geiser-edit-module-at-point'
<mthl>there is no keybind for `geiser-edit-module-at-point'
<vmlinuz88>hmm, apparently it's too late to register for GSoC. I'd still like to help out with Guix development. I'm learning Scheme, but I would rather the learning process involve a more hands-on activity. I'm thinking I could study guix api and source code and figure out how it all fits together as a whole.
<mark_weaver>vmlinuz88: the best way to start would be to install Guix (and maybe GuixSD), build Guix from its git repository, and add packages for things you miss that we don't yet have.
<phant0mas>there is a problem with netbpm
<phant0mas>svn: E170000: Unrecognized URL scheme for 'http://svn.code.sf.net/p/netpbm/code/advanced'
<vmlinuz88>mark_weaver That sounds good. I have guix installed on Fedora 21, and I'm running GuixSD in a vm. I will look for packages to add :)
<rekado->mthl: I mean in a Scheme buffer with geiser REPL in the background.
<rekado->it seems that I have to first load all modules with ,use or by evaluating the first define-module expression before I can point at anything and jump to its definition.
<rekado->I assumed that I could jump to *any* definition as long as it is in the guile load path.
<davexunit>the code most be loaded into your guile environment
<davexunit>otherwise there's no way for geiser to know anything
<davexunit>because the symbol is likely undefined otherwise
<phant0mas>when I try http://paste.lisp.org/display/147941 so the --build=i686-pc-gnu will be passed when not cross-compiling I get http://paste.lisp.org/display/147943
<phant0mas>guix/build-system/gnu.scm:274:0: In procedure gnu-build:
<phant0mas>guix/build-system/gnu.scm:274:0: Error while printing exception.
<phant0mas>did the same in base.scm and it works, why not in hurd.scm ? am I missing a module?
<rekado->phant0mas: could this be due to a dependency cycle?
<phant0mas>don't think so, I am probably missing something
<phant0mas>it will work with just #:configure-flags '("--build=i686-pc-gnu")
<vmlinuz88>mark_weaver when writing the package definition, how would I know what modules to use? The package I want to define is the fortune-mod package from debian. I have the source files for fortune-mod and I know the url for them.
<vmlinuz88>I imagine it wouldn't be a very complex package definition
<rekado->vmlinuz88: we usually just look around at what modules already exist. If one fits well we use it for the new package definition, otherwise we ask here where to place it :)
<mthl>rekado: I think the question was about "#:use-module: blabla" not where to write the definition
<mthl>vmlinuz88: am I correct?
<vmlinuz88>mthl Yes
<vmlinuz88>Is there a reference or something that describes all modules?
<vmlinuz88>like what does 'guix packages' include?
<mthl>you have to look in the "gnu/packages" directory each file correspond to a module
<vmlinuz88>mthl Ahh, okay cool.
<vmlinuz88>I see now, so the gnu and guix subdirs under guix/ correspond to module categories, and the modules are listed in those subdirs
<mthl>to be more correct it's (module sub-module sub-sub-module...)
<vmlinuz88>okay
<mark_weaver>vmlinuz88: all packages are in gnu/packages/*.scm
<vmlinuz88>I see. So the modules I should implement by "#:use-module..." would be dependencies of the package I'm defining?
<mark_weaver>yes, although a few others are also needed. however, hopefully your new package will fit naturally in some existing file.
<mthl>you have to include the package modules containing the definition of the dependencies + guix specific modules containing the procedures and macros you use
<mark_weaver>you will also need (guix licenses) (guix packages) (guix download) and usually (guix build-system gnu)
<mthl>vmlinuz88: you can start adding fortune-mod definition in gnu/packages/games.scm
<mthl>vmlinuz88: as Debian stows it in section games
<vmlinuz88>Alright
<phant0mas>hey mark_weaver could you have a look on this error http://paste.lisp.org/display/147943 ?
<phant0mas>the addition of (if (%current-target-system) '() '(#:configure-flags '("--build=i686-pc-gnu"))) is causing it.
<phant0mas> http://paste.lisp.org/display/147941
<mark_weaver>phant0mas: replace that expression with this: #:configure-flags (if (%current-target-system) '() '("--build=i686-pc-gnu))
<mark_weaver>well, the more minimal change would be to put ",@" in front of that expression, but then (%current-target-system) would be evaluated at a different time, and I'm not sure it would wrk.
<mark_weaver>but my first suggestion is more typical of what we do in practice
<phant0mas>mark_weaver: in base.scm in findutils the first version is used and it works
<phant0mas>and with your suggestion I get "ERROR: Unbound variable: %current-target-system"
<phant0mas>I will go with ,@
<phant0mas>but why does in work in the findutils case and not in mine?
<mark_weaver>phant0mas: in the findutils case, that expression is the entire 'arguments' field value.
<mark_weaver>whereas you were trying to stick it in the middle of another arguments list
<phant0mas>aaah
<phant0mas>now I get it, ok, thank you Mark :-)
<mark_weaver>np!
<mark_weaver>I'm very much looking forward to running GuixSD Hurd :)
<mark_weaver>I recently migrated my main machine from a Libreboot X60 to a Libreboot X200, and my X60 is destined to run Hurd when it's Guixified :)
<fchmmr>mark_weaver, I don't know whether hurd will work with libreboot, I haven't tested it.
<fchmmr>I don't think anyone else has, either. YMMV
<mark_weaver>*nod*
<mark_weaver>I'd be surprised if it matters.
<mark_weaver>Hurd can be booted by GRUB
<fchmmr>I probably won't be using hurd for at least another decade, if not more
<fchmmr>I'm happy enough with GNU/Linux since around 2005
<phant0mas>Guixified, love this word :-)
<fchmmr>guixed?
<vmlinuz88>mark_weaver, for the (build-system gnu-build-system) part, the manual says I could delete phases from the build procedure with #:phases (alist-delete 'configure %standard-phases), since fortune-mod does not require the configure phase. So in the context of the package definition, where do I put the #:phases... line?
<vmlinuz88>it is an argument to (build-system gnu-build-system)?
<mark_weaver>vmlinuz88: in general, I recommend grepping for similar things in gnu/packages/*.scm
<vmlinuz88>okay, will do
<mark_weaver>if there's no configure phase, you'll probably have to pass some arguments to make
<mark_weaver>vmlinuz88: dosfstools may be a helpful example, in gnu/packages/disk.scm
<mark_weaver>that also shows our new 'modify-phases' syntax which is a bit nicer
<vmlinuz88>I'll take a look.
<mark_weaver> http://git.savannah.gnu.org/cgit/guix.git/commit/?id=dd4a86207ef7be22faa825cc828dff3f82aabf2e
<rekado->I have a question about commit message format.
<civodul>sure
<rekado->I want to commit the new Ardour 4 package, but I want to name it "ardour" and rename the previous "ardour" to "ardour-3".
<rekado->How do I explain this in the commit message?
<rekado->I also want to add a comment about this revision.cc snippet to both "ardour" and "ardour-3". Does this have to be mentioned separately?
<civodul>* foo.scm (ardour): Rename to...\\n (ardour-3): ... this; change 'name' accordingly.
<civodul>something like that
<rekado->so, should this be a separate commit?
<rekado->because the value of "ardour" would be newly added.
<civodul>it's fine to have a single commit that adds v4 and renames v3 IMO
<rekado->should the message not also state that "ardour" is a new value? Or is your example message above sufficient?
<civodul>yes, i would also add "(ardour): New variable." after that
<rekado->ok, great. Thank you.
<civodul>as long as we understand that it's a rename + new version, that's fine
<civodul>Xfce looks quite ugly, it seems that it fails to find some but not all of its icons
<civodul>iyzsong: any idea what's wrong with Xfce's icons?
<civodul>it has a correct XDG_DATA_DIRS it seems
<mark_weaver>the default panel layout is ugly, but it can be customized to look quite a bit better
<mark_weaver>(but not as nice as GNOME, of course)
<mark_weaver>I don't know who thinks that fat bottom panel is a good idea, but it's easily removed :)
<rekado->release between 13th and 16th sounds good! I'll give a talk about Guix in Berlin on the 15th.
<civodul>aah good!
<civodul>rekado-: we should announce your talk, send us the details! :-)
<civodul>mark_weaver: but here (in a VM) it's not just ugly: icons are missing
<rekado->I guess I should begin preparing then ... :)
<civodul>heh :-)
<mark_weaver>civodul: most of the icons are present for me
<mark_weaver>I wonder what's the difference.
<mark_weaver>for example, in the first level of the applications menu, all of the icons are present except for the "Mail Reader" entry
<civodul>hmm, weird
<mark_weaver>civodul: are you using the 'xfce' meta-package? is it in your system profile?
<civodul>yes, like in the %desktop-services patch i posted
<mark_weaver>I also have 'dconf' in my user profile. not sure if that's relevant
<mark_weaver>actually, as I recall I had to add that to enable me to modify settings in gnome-terminal
<mark_weaver>it's possible that one of the other packages in my user-level profile is propagating something that's helping XFCE find its icons
<mark_weaver>e.g. gnome-terminal
<mark_weaver>civodul: btw, I never did get name resolution of *.local names working on my system, nor printing, but we can talk about that another time.
*mark_weaver test builds linux-libre-4.0.2