IRC channel logs

2014-09-04.log

back to list of logs

<davexunit>I'm working on auto-generating some package definitions by using the whole code-is-data thing and creating an sexp using quasiquote and pretty printing it.
<mark_weaver>sounds like the right approach to me!
<davexunit>however, I want to actually output quasiquote and unquote...
<davexunit>like (inputs `(("foo" ,foo)))
<davexunit>I guess it just works, though... wasn't expecting that.
<mark_weaver>quasiquotes can be nested
<mark_weaver>it gets slightly tricky when you need to unquote something that's within multiple nested quasiquotes
<mark_weaver>not too bad, but takes a bit of getting used to.
<davexunit>ah, yeah that sounds tricky.
<davexunit>hopefully I won't run into that for this
*tadni_ has like 3 different emails link to me in Guix... I really should write a patch that just updates it to one.
<davexunit>hmm, the sha256 of a bytevector containing the contents of a file is different than the output of 'guix hash <file>'
<davexunit>gah, and doing the same operation with a string port yields yet another hash
<davexunit>I just don't get it :/
<davexunit>the bytevector is the same length as the file on disk.
<davexunit>why different hashes?
*davexunit has an almost functioning pypi2guix script
<tadni_>davexunit: Neat!
<davexunit>still can't figure out the hash issue, if I could get that working I think my script is ready to roll...
<Steap_>davexunit: oh, pypi2guix ?
<Steap_>Nice, I was also planning on working on that
<Steap_>using the JSON data from pypi
<Steap_>davexunit: would you care to share your script so that I can try it, see if I can get it working ?
*Steap_ will just go to sleep for now
<davexunit>I can send it, yeah
<davexunit>be warned, it requires guile-json and guile-curl (for now)
<davexunit> http://paste.lisp.org/display/143602
<Steap_>yep
<davexunit>right now it's hardcoded for "oauthlib"
<Steap_>yeah
<Steap_>OK, that looks like a lot of code
<Steap_>I thought it would be shorter :/
<Steap_>I think one thing to add is the Python2 definition
<Steap_>would be nice to figure out this hash issue
<Steap_>Just a quick idea I had
<Steap_>I don't think we should have a Pypi specific script
<Steap_>Instead we should have an "auto-packager"
<Steap_>that would support writing most of a package definition and updating an existing package for PyPI, perl, GNU software
<Steap_>So we'd have a unified CLI for all packages, and it would be easy to add new "kinds" of packages
<Steap_>but that looks like a good start, I'll have to try that tomorrow
<davexunit>Steap_: I classify this as a "quick hack" to solve my immediate need of automating the process of creating python packages somewhat.
<davexunit>found the problem!
<davexunit>I was using base32 format, not nix-base32 format!
<davexunit>hehe this works pretty well
<civodul>Hello Guix!
<phant0mas>hey civodul, working on the fixme
<phant0mas>and I just checked the slides from ghm :-D
<phant0mas>proud to see my name in there :-D
<civodul>howdy phant0mas!
<civodul>heheh :-)
<civodul>i wish it could help improve the libc situation
<phant0mas>let's hope so
<civodul>it won't be easy :-/
<phant0mas>especially when only a handful of people work on the hurd :-/
<Tsyesika>good morning!
<civodul>phant0mas: a handful of people can sometimes make a difference
<civodul>but yeah
***civodul changes topic to 'GNU Guix --- http://gnu.org/s/guix/ --- guix.el merged: https://savannah.gnu.org/forum/forum.php?forum_id=8081'
***DusXMT_ is now known as DusXMT
<Svetlana>right! the 20s delay worked and I got into the installer bash prompt, but I'm missing free wifi firmware (and I would still have a nonfree bios, probably, after I do all that)
<Svetlana>I'll now go and figure out how & where to best purchase the free wifi thing that's in the 'ryf' list as time goes
<civodul>Svetlana: good to hear that progress has been made :-)
<civodul>my laptop has an Intel wifi chip, so i end up using plain old wired networking currently
<civodul>been planning to buy an Atheros wifi dongle though
<Svetlana>unfortunately I find people a bit too hard to deal with lately, especially landlord, so I'm not very excited about possibilities of wired internet here
<Svetlana>unrelated thing: I don't know whether my cpu is 32bit or 64bit
<davexunit>I flashed a hacked version of the proprietary BIOS for my thinkpad x220 that removed the whitelist for pci-e wifi chips. now I use an atheros chip from thinkpenguin instead of intel.
<DusXMT>Svetlana: do "cat /proc/cpuinfo"
<Svetlana>'lm' is in there
<Svetlana>in flags
<Svetlana>but windows insists it's a 32bit cpu for some reason which leaves me surprised
<davexunit>sizeof(int) :)
<Svetlana>checking
<Svetlana>wait, where do i put that? looks like c
<DusXMT>davexunit: actually, int is 4 bytes wide even on amd64
<davexunit>DusXMT: damn.
<davexunit>Svetlana: (use-modules (system foreign)) (sizeof int)
<DusXMT>I think long is 8 bytes wide, but I'm not 100% sure (it-s 4 bytes on x86)
<davexunit>not that it matters anymore.
<Svetlana>yep it returns 4
<DusXMT>Svetlana: in /proc/cpuinfo, what is the address size?
<DusXMT>And model name (perhaps we can look it up on the internet?)
<Svetlana>family 6 model 23 stepping 6
<DusXMT>Svetlana: yyup, that's 64-bit
<Svetlana>riight, I'll go stab windows a bit more then for peace of mind
<DusXMT>You might have had w32 installed, and it was reporting the architecture it was built for
<davexunit>so, I wrote a working, hacky script that takes metadata from pypi.python.org and generates a guix package: http://paste.lisp.org/display/143606
<Svetlana>DusXMT: 'windows' 'built' (lol). I'll not bother you tho, it's an issue on another side.
<Svetlana>see you a few days later. peace.
<civodul>davexunit: i agree, (system foreign) is more user-friendly than /proc/cpuinfo
<civodul>:-)
<davexunit>:)
<bavier>davexunit: does pypi not encode information about package dependencies?
<davexunit>bavier: nope
<bavier>:(
<davexunit>I have to add those manually, but it's not too bad.
<davexunit>I usually also have to edit the license and synopsis/description
<davexunit>pypi package descriptions are in RsT format
<davexunit>and synopses usually don't meet the constraints for guix
<bavier>yeah, I noticed that a while back when doing some python packages
<bavier>I wonder if setup.py could be explored to fill in some blanks
<davexunit>the script has still been super useful, I can quickly generate the boilerplate, complete with the correct source tarball and hash!
<bavier>ah yes, that is useful
<davexunit>bavier: that would be an excellent extension.
<davexunit>that would involve extracting the tarball, which I haven't done here.
<bavier>right
<davexunit>once we go that route, we can inspect the license file too to make a better guess. :)
<davexunit>I think this will be useful enough to other packagers, so I'm going to create a repo for it soon and see if anyone wants to jump in and make it more robust. :)
<bavier>sounds like a great idea
<davexunit>I'd also like to remove the guile-curl dependency and replace with guile-gnutls, but I haven't gotten there yet.
<davexunit>guile-curl got me off the ground quickly.
<leth>i wish there was a way to fix alwas regarding how to make a mashine readable and yet legaly conformed way of licensing a body of work which is a program.
<davexunit>in a perfect world...
<leth>in a brave new world...
<davexunit>it was pretty easy to write this script, the hardest part was generating the (source ...) form.
<davexunit>does anyone know if hydra can be used as a general-purpose CI system, or is it intended for building nix/guix packages only?
<Steap_>davexunit: civodul used to run a hydra instance at his work, to test some C code
<Steap_>so it's general purpose
<davexunit>Steap_: cool, good to know.
<Steap_>but I think you might end up writing some Nix anyway :)
<davexunit>I wonder how it stands up to jenkins or travis
<davexunit>I have too many projects, but the idea of writing a hydra-like system in guile is tempting.
<Tsyesika>afternoon :)
<davexunit>hey Tsyesika
<Tsyesika>:)
<jxself>No... morning. :)
<Tsyesika>:P
*Tsyesika looks at her clock
<davexunit>time zone, shmime zone
<jxself>07:43 hours
<Tsyesika>UTC is obviously the correc timezone :o
<Tsyesika>:p
<jxself>Nah, DST.... davexunit standard time. :)
<davexunit>It's 3:14 somewhere, man.
<Tsyesika>is it?
<jxself>According to DST. :)
<davexunit>Tsyesika: do not question DST! It is absolute!
<civodul>davexunit: the pipy2guix thing looks cool
<Tsyesika>oh did you finish it?
<Tsyesika>link?
<civodul> http://paste.lisp.org/display/143606
*civodul is lagging
<davexunit>I wouldn't say "finished", but it doesn't crash and makes decently usable output :)
<davexunit>thanks civodul
<Tsyesika>hm i'm gunna look at this later i need to finish up working
<davexunit>beware, I didn't comment a damn thing.
<Tsyesika>does this make it easier to package my software ;)
<Tsyesika>hopefully this evening i will find time to play with guix
<Tsyesika>might even throw it on my thinkpad rather than a vm
<Tsyesika>oh i did have a question now i come to think of it! I'm wondering when you're defining your system config file and the user section, if you specify say zsh rather than bash will it be able to pull in that package if it's not installed? I presume not but that'd be really awesome
<davexunit>Tsyesika: I'm not sure if it does that *yet*, but I know it's possible.
<davexunit>civodul wrote a really cool thing call "g-expressions"
<Tsyesika>hm
<DusXMT>Tsyesika: you could add zsh to the system packages, and then edit /etc/passwd to make it your shell
<davexunit>so you could add this "gexp" that contains zsh, and when guix builds the derivation, the zsh package will be included as an input.
<Tsyesika>sure but i'm just wondering if it'd possible to make it so that it does it automatically
<davexunit>I don't really know how they work, so my explanation is at least partly wrong.
<davexunit>but I think it's possible for it to happen automatically.
<Tsyesika>I'm wondering if maybe packages could list what files they provide so the zsh package might be able to list it provides /bin/zsh or whereever and then guix package manager do a check to see which packages provides that shell
<davexunit>(string-append (which "zsh") "/bin/zsh")
<davexunit>or rather, just (which "zsh")
<Tsyesika>well that would only work if zsh was already there
<Tsyesika>right?
<davexunit>I think that's where gexps come in
<Tsyesika>what you'd want is packages in their definition to list a bunch of files provided or them to maybe come with a seporate manifest file or something so that you could query guix to ask what package provides a certain file or in this case executable (/bin/zsh) and it could query that and install it as part of the transaction?
<davexunit>I don't think it's necessary at all.
<Tsyesika>oh?
<davexunit>I just can't give you the right answer right now :)
<Tsyesika>i'm not sure how else it'd know what provides zsh without that?
<davexunit>it's not about knowing what provides the zsh binary, because you as the programmer know that the 'zsh' package has it. many packages *could* provide /bin/zsh, but you need to explicitly refer to the one you want.
<Tsyesika>i think i was more wanting an eligant solution than having to manage packages to get my config to work
<Tsyesika>so rather than adding zsh to a list of packages i want installing and then defining the user i want let guix figure some of that out
<Tsyesika>davexunit: and installing something based on a "what provides" works yum/dnf has such a feature
<Tsyesika>yum install /bin/zsh
<Tsyesika>:P
<davexunit>I think that's where gexps come in, when you reference a package in a gexp, that package is automatically added to the inputs of the "derivation". the derivation in this case builds an operating system.
<Tsyesika>i think i need to look at gexps more but i suspect it won't do what i want as i don't think guix packages currently have enough info to do that
<Tsyesika>davexunit: maybe if i specify a package rather than a path but it'd then have to derive the path from the package somehow
<davexunit>I'm sure that they *should* have that info, and either way I think you can get what you want.
<davexunit>it would be a lot easier to demonstrate if I knew the code to write :D
<Tsyesika>davexunit: another example of this might be me saying i want openssh-server/sshd enabled and i don't want to have to touch a package list or have to care if it's installed nor should i have to care about adding it or removing it from the init system
<Tsyesika>okay :P second question then :P
<Tsyesika>i read this morning about err
<Tsyesika>dang what's the name
<Tsyesika>substitutes that's it
<Tsyesika>i was wondering if you could enable multiple at once as the documentation encurrages you to setup own build farm if possible, not saying i definitly will but just wondering how it might work if you want to maybe enable two?
<Ulrar>I was wondering, is it possible to install packages from source instead of binary ?
<DusXMT>Ulrar: just pass --no-substitutes to the command
<alezost>Ulrar: it is described in manual: (info "(guix) Substitutes")
<Ulrar>Oh yeah, missed that. Great, thanks :)
<paroneayea>hey Tsyesika :)
<Tsyesika>hey paroneayea :)
<Tsyesika>also not the right channel but woo the tests all pass now :P
<paroneayea>yay!
<DusXMT>Tsyesika: Tests of what?
<Tsyesika>mediagoblin
<DusXMT>Amazing
<Tsyesika>indeed
<Tsyesika>sorry i was just being lazy to switch windows to gmg channel xD
<davexunit>Ulrar: guix is a source-based distro. getting binary substitutes is just a nice optimization. :)
<davexunit>paroneayea: oh, is the test suite failing in the 0.7.1 release?
<davexunit>or rather 0.7.0-docfix
<Ulrar>davexunit: Well that's what I thought the first time I read about it, but I couldn't figure out how
<Ulrar>I like compiling my things
<davexunit>guix builds from source by default. you have to explicitly authorize a build farm for fetching substitutes.
<paroneayea>davexunit: it wasn't earlier... let me look
<DusXMT>Ulrar: unfortunately, with Guix, there's no real advantage to building your own things, other than that you don't have to put your trust into a build farm
<Ulrar>DusXMT: You mean there is nothing like gentoo use flags, I guess ?
<davexunit>paroneayea: now I know to disable the test suite in my 'mediagoblin' package. :)
<DusXMT>Ulrar: nope. In fact, the point of guix is to have reproducible builds
<davexunit>Ulrar: are use flags for toggling configure flags?
<Ulrar>davexunit: Yes
<davexunit>so, you can definitely do that in guix, but they way you would do it is by creating a new package that inherits from another and specifying the configure flags that you want.
<davexunit>the way*
<Ulrar>DusXMT: Well I suppose that if you were to put the flags in the config it'd reproduce the same thing, no ?
<davexunit>guix packages are *exact* recipes from producing a binary. to re-configure, you need to make a new package, which is very easy to do in guix.
<Ulrar>davexunit: That's what I was thinking, that's fine by me
<DusXMT>My point was: disabling substitutes won't help you with that
<davexunit>DusXMT: I think this was a separate concern.
<Ulrar>yes. Anyway, I'll try it out soon, sounds great
<Ulrar>thanks for the answers :)
<paroneayea>davexunit: tests seem to be passing here
<davexunit>paroneayea: okay cool. I will expect them to pass, then. :)
<davexunit>I'm going to have a massive patch set for guix when I finish this.
<paroneayea>:)
<davexunit>Ulrar: it would be fun to write a little procedure that takes a package plus a list of configure flag strings and returns a new package that is the exact same but with different flags.
<davexunit>(package-with-use-flags foo '("--install-gentoo"))
<Ulrar>davexunit: That's a good idea. If I like guix I might try to write some packages, I always liked lisp, I guess I would like scheme
<davexunit>Ulrar: I hope you will like guix and scheme. :)
<Tsyesika>davexunit: there are two which don't pass on 2.6 btw
<Tsyesika>they are nothing to worry about
<davexunit>I'll be using 2.7
<Tsyesika>cool :)
<tadni_>Tsyesika: If you're an Emacs user, I can give you a config.scm to get ratpoison, conkeror, and emacs working -- if you plan on putting Guix/GNU on a dedicated box. :^P
<Tsyesika>oh cool, yeah if you can show me that, ratposion isn't my wm of choice but :P
<Tsyesika>sure!
<Tsyesika>i'm sure i can modify it
<davexunit>we're a bit limited on vm choice right now :)
<davexunit>Tsyesika: do you use a DE like gnome or a lightweight WM?
<Tsyesika>wm :)
<davexunit>which one?
<Tsyesika>i usually use bspwm
<Tsyesika>probs have to package it
<Tsyesika>which is fine :)
<tadni_>Tsyesika: I mean, it's trivial to switch to guile-wm -- but it's been problematic to me.
<davexunit>tadni_: it's not ready for prime time yet.
<tadni_>davexunit: Well obviously, but I was hoping it'd crash a bit less and tiling would not limit itself to the upper 4th of the screen. :^P
<Tsyesika>i'll see xD tadni_ not even got it booted yet :P gotta try and find time
<tadni_>Tsyesika: Here it is, if you have some time. http://paste.lisp.org/+32T3
<Ulrar>Ho yeah, there is no xmonad package. So I guess that would be step one
<tadni_>Oh darn, sans those GGGG in-front of (gnu packages admin)!
<tadni_>Ulrar: Yeah, really know haskell things are packaged yet that I'm aware of.
<cantstanya>is there a list of things people want packaged or that people are trying to package (with issues)?
<davexunit>tadni_: tiling shouldn't be that broken. it works for me pretty well. also I recommend compiling from master.
<cantstanya>s/things/software/
<tadni_>Oh, those ggggs are only in my local buffer, nevermind. Good.
<davexunit>cantstanya: not that I know of. how about I create a place for that right now?
<davexunit>I'll create a page on libreplanet.org's wiki.
<Ulrar>That'd be great
<cantstanya>:^]
<tadni_>davexunit: Well, not a ton of motivation to compile it locally right now. Maybe when/if it gets multi-key maps and a mode-line like Stumpwm. Right now, even if I can get guile-wm tiling to work proper, what I'll end up with it just bassically ratpoison. :^P
<tadni_>It's not like I have the hacking skills currently to be able to contribute anything of worth to guile-wm anyways either... :^I
<cantstanya>also is there anyone using guix to manage local packages under ~/ in another OS such as OS X or FreeBSD?
<davexunit>cantstanya: not that I know of, though it should work.
<tadni_>cantstanya: Don't use another OS, butk other unix-like OSes should in theory work.
<Tsyesika>i should try it under haiku and OS X :P
<cantstanya>I might try it with the latter then. I was contemplating nix, but I've finished htdp a few months ago, starting sicp, and I like scheme.
<Tsyesika>i wonder if guile works on haiku
<jxself>Nothing work on Haiki :)
<jxself>er works
<tadni_>Aren't they porting to the Linux kernel, or something?
<Tsyesika>no
<Tsyesika>they have their own kernel and aren't planning on changing it
<Tsyesika>and haiku is awesome :)
<davexunit>it's crude, but here it is: http://libreplanet.org/wiki/Group:Guix/Wishlist
<tadni_>Tsyesika: http://www.osnews.com/comments/27907
<Tsyesika>hm i should find a package list
<tadni_>davexunit: Neat! We could maybe have a "status" system at some point to to denote if someone is working on it.
<cantstanya>I hope this doesn't start a debate, but would it be frowned upon to package spl and zfs (ZoL)?
<Tsyesika>tadni_: i haven't been part of that decision and it is very recent so i could be wrong but i don't think they're going to switch
<cantstanya>Tsyesika: http://www.gnu.org/software/guix/package-list.html I was looking here
<tadni_>cantstanya: That's not a problem, the more foss the better -- just don't expect them to be defaults over GNU software though.
<cantstanya>Yeah understood
<cantstanya>I'd just like the option to be out there
<tadni_>cantstanya: More than fair.
<cantstanya>;^]
<Tsyesika>tadni_: the haiku philosophy is completely different than what you find over in the BSD/linux world
<Tsyesika>anwyays :P now to go through this list and see what i want :P
<Tsyesika>davexunit: i can add stuff to this list right?
<cantstanya>I have three things I want to package, maybe someone may beat me to it :^]
<tadni_>Tsyesika: Yeah, just make a FSF account. You don't have to be a paid member, be aware.
<Tsyesika>i'm a member so i got an account :)
<Tsyesika>i think my vhost has fsf member on
*tadni_ thinks it's about time to renew his FSF membership, now that he thinks about it.
<Tsyesika>don't you have it like direct debit?
<tadni_>Tsyesika: I probably should, but no.
<Tsyesika>heh quite a few packages here
<tadni_>Okay, upgraded with the packages I plan to work on eventually. Hopefully by the end of the month.
<davexunit>Tsyesika: yes indeed
<davexunit>it's a wiki, after all. :)
<Tsyesika>i was actually meaning already packaged :P
<Tsyesika>oh feh, that's a good one
<Tsyesika>damn i have to manually merge this
<tadni_>Tsyesika: I added the last 4. Those are practically all I'm missing, to get my Fedora install.
<Tsyesika>there we go
<tadni_>Oh yeah, probably should add Wicd. Still not sure if that's not the best way to go for networking though. :^P
<Tsyesika>nah just use network manager and nmcli
<Tsyesika>:)
<tadni_>Tsyesika: Isn't NetworkManager systemd dependent?
<Tsyesika>oh
<Tsyesika>yeah it probably is
<Tsyesika>i like systemd
<Tsyesika>:P
<davexunit>systemd is not an option for us.
<Tsyesika>yeah i'm aware
<davexunit>oh okay
<Tsyesika>you might have issues with gnome
<davexunit>yup
<Tsyesika>i think gentoo has problems having gnome too
<davexunit>we're anticipating that.
<Tsyesika>what did debian decide on?
<Tsyesika>"stick with sysvinit"
<Tsyesika>:p
<davexunit>systemd
<Tsyesika>sigh i thought of a package but i forgot
<Tsyesika>okay i remembered and added :)
<tadni_>Is pump.io the same as gnu social now?
<Tsyesika>no
<Tsyesika>gnu social is what status.net was
<Tsyesika>pump.io is a completely different network and piece of software
<davexunit>new protocol, new server software, new clients
<tadni_>Ah.
<Tsyesika>tadni_: i like it
<Tsyesika>but i'm bias i wrote the python library for it and my day job is writing a pump.io complient federation API into GNU MediaGoblin
<davexunit>Tsyesika: you're doing great work :)
<tadni_>Tsyesika: Ah, that was you-- neat!
<Tsyesika>davexunit: thanks
<Tsyesika>tadni_: glad i no longer write closed source code for 8 hours of my day ^_^
<davexunit>Tsyesika: heh, I'm in the same boat.
<tadni_>Tsyesika: :^)
*tadni_ could probably strucure this wiki a bit for networked stuff, desktop stuff, etc.
<tadni_>Also just added Krita and Mypaint to the list.
<Tsyesika>oh yeh mypaint :D
<davexunit>tadni_: yeah, grouping them would be good if the list grows a lot
<davexunit>organize as necessary :)
<Tsyesika>oh tadni_ while you're re-arranging can you add 'click (python module)
<Tsyesika>'
<tadni_>Tsyesika: Yeah.
<Tsyesika>thanks :)
<Tsyesika>right! finished work i gunna go grab my thinkpad and throw guix on it!
<Tsyesika>or spend the rest of the evening looking for my usb stick, who knows xD
<tadni_>... Well, I did all that and it reset and I lost it...
<davexunit>back button? no?
<tadni_>davexunit: Nope, just gone.
<davexunit>damn.
<tadni_>It wasn't that much work... but still a pain.
<tadni_>I'm going to do it in sections now, instead all at once.
<jxself>Hmmm. So that's what happened.
<tadni_>I wish wiki had live editing, so you can see what other contributors are dong ...
<jxself>Yes. I was surprised when I clicked suvmit and I was like "Huh?!"
<tadni_>jxself: Okay, done editing for the most part.
<tadni_>Need to figure out why these headers aren't working though.
<davexunit>tadni_: use === foo ===
<tadni_>davexunit: Ah.
<tadni_>Ty!
<davexunit>np
<tadni_>Adding an office section.
<tadni_>Nearly 30 packages.
<davexunit>:)
<davexunit>I'm glad that so many of you have taken interest
<tadni_>I wish the FSD could show one all the entries at once, not just 500 at a time.
<davexunit>that sounds taxing on our server
<tadni_>davexunit: Not default to it, but have an option.
<davexunit>ah
<davexunit>I wish there was a JSON API for the FSD
<davexunit>using the semanticmediawiki data for each entry
*tadni_ needs to get in on the next fsd hackathon, there are quite a few packages missing on this list thusfar.
<davexunit>tadni_: join in tomorrow!
<davexunit>it's really easy to participate and doesn't take much time.
<davexunit>I won't be working tomorrow, but I'll be on IRC and will probably join in briefly.
<tadni_>davexunit: Oh there's one tomorrow? What time?
<davexunit>1PM eastern time
<davexunit>the meetings happen every friday
<davexunit>hop on #fsf
<tadni_>That's 2 in central, right?
<Tsyesika>i need to add some of my projects to the FSD
<davexunit>2 or 3, yeah.
<tadni_>I should be home from classes then. :^)
<davexunit>yay, the more the merrier
<Tsyesika>when is this IRC meeting?
<davexunit>it's a special "davexunit's birthday" edition :)
<davexunit>Tsyesika: 1PM eastern time in #fsf
<tadni_>davexunit: Oh neat, how old?
<Tsyesika>hm i think that makes it er
<Tsyesika>6pm my time?
<davexunit>tadni_: 24
<tadni_>davexunit: Oh, fun, fun -- you edge me out by only two years or-so.
<Tsyesika>3 years difference between me and davexunit
<davexunit>both younger, I'm guessing?
<Tsyesika>i am
<tadni_>davexunit: Nearing 22, yup.
<Tsyesika>i'm 22 in decemeber though so it's more like 2 and a little bit
<Tsyesika>:p
<Tsyesika>i'd prefer to think of it as 3 years :P
<tadni_>Tsyesika: I'm mid-november.
<civodul>happy birthday, young davexunit! :-)
<Tsyesika>i presume FSD i put the user level to deploy it (if it's a webapp) rather than to use a deployed one?
<davexunit>heh, thanks civodul!
<davexunit>tomorrow I will be spending the whole day hacking on guix, I think.
<Tsyesika>awesome way to spend ones birthday :P
<tadni_>Okay, think I have all the suggested packages that are too in the fsd linked.
<civodul>awesome way to spend *any* day ;-)
<civodul>davexunit: but your birthday is today, right?
<jxself>Happy birthday davexunit!
<davexunit>civodul: tomorrow, but thanks!
<davexunit>tadni_: thanks for that. when I'm done upgrading libreplanet.org to the latest mediawiki, we'll be able to do cool things like "interwiki links"
<jxself>Oh, pre-birthdays can be fun too.
<Tsyesika>sigh i think i never add anything to FSD because i can't describe stuff
<tadni_>davexunit: Oh, neat.
<tadni_>Tsyesika: I believe in you. :^)
<Tsyesika>:P i wouldn't xD
<tadni_>Tsyesika: I mean 80% is describing what the actual package does and the other 20% is marketing -- a general rule I use.
<Tsyesika>it's difficult especially when it's "short description"
<tadni_>Tsyesika: What package?
<Tsyesika>inboxen a project i co-founded
<Tsyesika>basically you make a bunch of unique email addresses so giving a website an email address doesn't also give them your identity
<tadni_>This? https://inboxen.org/
<civodul>tadni_: for descriptions in Guix i try to go down to 0% marketing
<Tsyesika>yep
<Tsyesika>tadni_: hopefully soon we'll have a "Deploy" button next to "Join"
<tadni_>civodul: I was speaking more-so of a general rule. Yeah, for technical descriptions -- not the best thing.
<davexunit>then why is the guile synopsis "the best damn scheme implementation ever"?
<Tsyesika>because it's true ;)
<tadni_>davexunit: That actually true?
<davexunit>and the description is "P.S. racket sux"
<tadni_>Isn't that*
<Tsyesika>xD
<Tsyesika>pfttt racket :P
<Tsyesika>(i don't know i haven't used either much really)
<civodul>davexunit: of course there are exceptions to that rule ;-)
<tadni_>Stumpwm's FSD seems to follow that 80% 20% rule.
<tadni_>Uses that "The Emacs of WMs" line.
<Tsyesika>tadni_: think of a good description then ;P
<Tsyesika>problem with inboxen i tend to have to explain a lot of background behind so that it makes sense xD
<tadni_>Tsyesika: The huh page is decent.
<Tsyesika>probs because i didn't write it :P
<tadni_>:^P
<Tsyesika>but yeah it's the short description i'm really struggling with
<Tsyesika>sum it up in a sentence
<Tsyesika>"email privacy protection dealio"
<Tsyesika>xD
<tadni_>Tsyesika: You need just one sentence? Try two or three, it's still short enough for the average person to read and get a lot more out of it.
<tadni_>One sentence descriptions, more likely than not, tend to be marketing orriented.
<Tsyesika>tadni_: it's just something to throw in "Short description (required):"
<davexunit>"sekret internet mails"
<tadni_>"Email service that provides protection, via virtual inboxes"?
<Tsyesika>yep that'll do
<Tsyesika>thanks tadni_
<tadni_>I mean, I don't know. I'm not good at brevity when it comes to technical descriptions. I don't think most people are.
<Tsyesika>:P it's far better than i could do
<tadni_>Tsyesika: Different strokes for differnt folks. Different skills for different pills.
<Tsyesika>okay cool submitted
<tadni_>Does FSD enteries need to be approved?
<tadni_>Do*
<davexunit>tadni_: yes, an admin will approve them shortly.
<davexunit>definitely by the FSD meeting tomorrow
*tadni_ plans on adding Krita and Mypaint, at least tomorrow.
<tadni_>Not sure what all else. I need to catch up on some HW tomorrow, for the week.
<tadni_>Professors need to set harder deadlines, this "you have a week before all these are due" is far too liberal for me. All it ends up with is "you have 5 assignments to do tonight." :^I
<phant0mas>tadni_: story of my life...
<tadni_>phant0mas: It's early enough in the semester for me to correct this ... I just need to find the motivation to do so. I think it's a pretty common thing though.
<tadni_>Schools need to get better with general pyschology though.
<tadni_>Oh well.,
<davexunit>Tsyesika, tadni_: the FSD meeting is actually from 2pm to 5pm EDT (19:00 to 22:00 UTC)
<davexunit>I thought it started at 1, my bad.
<tadni_>So 3 or 4 here, okay. Should be clear to attend, assuming I do an assignment or two to get caught up in said mentioned class prior.
<Tsyesika>long meeting thing
<Tsyesika>i might be around for an hour
<Tsyesika>tadni_: i'll add PyPump and p too :)
<Tsyesika>well maybe p once PyPump 0.6
<Tsyesika>then we can package p for guix
<tadni_>P?
<davexunit>that sounds great!
<DusXMT>For some reason, my network doesn't automatically get started by dmd, I have to issue `deco start networking'
<Tsyesika> https://github.com/xray7224/p tadni_
<davexunit>DusXMT: did you configure to start on boot?
<tadni_>Tsyesika: Ah.
<DusXMT>davexunit: I'm not sure, how does one do that?
<DusXMT>I just added the service to my config.scm
<tadni_>DusXMT: (static-networking-service "lo" "127.0.0.1" #:provision '(loopback) ?
<Tsyesika>I'm wondering if we should see if guix can go on https://www.gnu.org/distros/free-distros.html now it's an OS as well as a package manager?
<tadni_>Tsyesika: Once it hit stable, yeah, I don't think currently it's a good idea when it's still problematic in some areas of day to day use.
<tadni_>A notable one being networking wirelessly.
<Tsyesika>yeah probably a good point :P
<tadni_>Swap is another one.
<DusXMT>tadni_: no, I configured the interface "eth0", http://pastebin.com/9kEKqsBt
<civodul>tadni_: this specific example is due to the lack of free driver
<civodul>Tsyesika: the FSDG-compliance is under evaluation at the FSF, i think
<civodul>so it could be listed there, eventually
<civodul>one criterion for being listed is that it must stand alone
<tadni_>DusXMT: Looks like it should work, hrm.
<DusXMT>tadni_: it works after I invoke `deco start networking'
<DusXMT>Is there some specific thing I need to do to make it start by default?
<DusXMT>As it's rather inconvenient to have to log in as root each time I reboot the computer and start the network, dmd would do that on its own ideally
<civodul>DusXMT: if you use 'static-networking-service' i think it should be started by default, no?
<DusXMT>civodul: I'd imagine so.
<DusXMT>Perhaps if there are more of them, ie. also for the loopback interface, dmd only starts that, but this assumption may be wrong.
<civodul>DusXMT: so you do use static-networking-service, right?
<DusXMT>civodul: Yup, see the pastebin I sent
<DusXMT> http://pastebin.com/9kEKqsBt
*civodul grumbles something about pastebin.com being inaccessible over Tor
<civodul>DusXMT: yes, that should work, so there's a bug
<civodul>maybe it tries to start it before the ethernet device has been detected or something
<DusXMT>sorry, I should probably switch to a different paste site, it's just that it's not that bad once you have adblock and request policy
<davexunit>DusXMT: paste.lisp.org
<tadni_>DusXMT: Yeah, for anythying Lisp -- paste.lisp.org is great.
<DusXMT>civodul: in dmd's log file, all it states is that `Service Networking could not be started'
<DusXMT>So it is possibly a timeout issue
<DusXMT>tadni_: and thanks for the paste site :)
<tadni_>Well davexunit suggested it first, I just shared the seniment. But yw.
<DusXMT>you're right... should pay more attention
<tadni_>It's fine. :^P
<davexunit>no worries
<davexunit>time to head home. later everyone.
<DusXMT>g'bye davexunit
<tadni_>davexunit: Peace. o/
<Ulrar>So vmware doesn't see my usb stick, that's great
<civodul>Ulrar: try qemu, it's software that respects your freedom
<Ulrar>yeah, but I never really used it. I guess it's time to figure out how that works
<DusXMT>Ulrar: kinda like this: qemu-system-arch -hdX image.{qcow2,img} -m MEGS [--enable-kvm]
<DusXMT>if your system supports kvm, use it
<Ulrar>kvm being a kernel module, I guess ?
<DusXMT>yup, literally `Kernel Virtual Machine', only works on some (though most modern) CPUs, though
<DusXMT>basically, it allows for hardware accelleration
<Ulrar>Ha yeah, I understand
<Ulrar>CONFIG_HAVE_KVM=y
<Ulrar># CONFIG_KVM is not set
<Ulrar>Well, I guess I'll just enable it quickly
<jxself>I guess you're not using the Guix kernel? Because it comes with KVM configured already.
<jxself>CONFIG_KVM=m and etc.
<Ulrar>I'm on gentoo right now, I'm trying to make a guix VM to try it out
<civodul>good night/day!