IRC channel logs

2014-08-09.log

back to list of logs

<tadni`>Okay, got it.
*tadni` needs to remember how to make a patch.
<jxself>git format-patch -sn HEAD^
<tadni`>jxself: Prefix it with a git commit?
<jxself>Yes.
<tadni`>Pulling a clean guix.
<tadni`>Hm, it's stalling at 18%.
<tadni`>Just a VERY slow connection.
<tadni`>jxself: Hm, I can't find the file it's exporting.
<tadni`>Doesn't seem to generate one.
<tadni`>Tried "git format-patch HEAD" too.
<tadni`>got it.
<tadni`>Patch sent. :^)
<tadni`>First in a LONG while. Like 6 months, I think.
<tadni`>RISCi_ATOM: o/
<RISCi_ATOM>tadni`: o/
<tadni`>RISCi_ATOM: Whats up?
<RISCi_ATOM>tadni`: Unbricking a chromebook :\\
<RISCi_ATOM>Only got it so I can hack on coreboot.
<tadni`>RISCi_ATOM: Tried to root it?
<tadni`>Ah.
<tadni`>My old highschool just gave all their students chromebooks...
<RISCi_ATOM>:\\
<RISCi_ATOM>tadni` That is bad news.
<RISCi_ATOM>It is a way to control students :\\
<tadni`>RISCi_ATOM: Yeah, I doubt they're fine with allowing them to "root" the device...
<RISCi_ATOM>tadni`: It is more than that. Right now, I still have a long ways to go before I'll have built a working coreboot image from scratch.
<RISCi_ATOM>Sure, google did a lot to make it free'er, but not everything is documented or published.
<RISCi_ATOM>Some code / parts have been revoked
<RISCi_ATOM>I think that everyone should be able to control the device that they are using (with permission from the owner)
<RISCi_ATOM>But chrome[ium] os spies on users in various ways.
<tadni`>RISCi_ATOM: Yeah, I'm saying that the school doesn't provide a means to use said device in an alternative way is a jerk-move. That being said, I'm sure that was a reason they picked such devices.
<RISCi_ATOM>Ya
*tadni` needs to play with skibillo some more. I'm shocked Guix's manual isn't hacked in it.
<svetlana> http://www.gnu.org/software/guix/manual/html_node/System-Installation.html#Proceeding-with-the-Installation - what if I already have grub installed?
<tadni`>svetlana: mark_weaver got it working with a preinstalled grub, but I'm not sure how.
<tadni`>Sorry.
<svetlana>mark_weaver, hi.
<mark_weaver>greetings, svetlana!
<svetlana>mark_weaver, did you use wpa_sapplicant, and how do I do http://www.gnu.org/software/guix/manual/html_node/System-Installation.html#Proceeding-with-the-Installation if I already have grub installed?
<mark_weaver>I am running wpa_supplicant on my standalone guix system, yes, but currently I start it manually each time I boot the machine. I haven't yet made it into a dmd service.
<mark_weaver>as for grub, I see that there's a --no-grub option to guix system, but I haven't yet tried it. if it doesn't install a grub.cfg, that will make it difficult to boot into guix.
<mark_weaver>booting into guix requires passing several /gnu/store/xxxxx- things in the grub commands.
<mark_weaver>it looks like if you pass --no-grub, there is still a grub.cfg file, but it is buried somewhere in /gnu/store/
<svetlana>I don't know whether existing grub would pick it up there
<mark_weaver>definitely not.
<mark_weaver>for now, my recommendation would be to let guix install grub, and to add some grub menu items to your guix grub menu that load the grub.cfg file from your existing grub install.
<mark_weaver>or you could just do that manually. grub has a command 'configfile' that will load a grub.cfg file and use it.
<mark_weaver>so e.g. if your existing grub.cfg is on /dev/sda1 in /boot/grub/grub.cfg, then the command would be something like: configfile (ahci0,1)/boot/grub/grub.cfg
<mark_weaver>and that would load the menu from that file and present it.
<mark_weaver>hmm, looks like guix's grub configuration doesn't currently support adding 'configfile' commands to the menu.
<mark_weaver>well, I have another idea. instead of using /dev/sda as the device in the grub config, use /dev/sdaX where sdaX is the partition with guix.
<svetlana>I'm assuming that if guix itself would not work properly in some way, then I should be able to easily boot into my previous distro
<mark_weaver>that will essentially be a no-op, because it will install the boot blocks at the beginning of the partition.
<mark_weaver>however, the current guix grub configuration will be in /boot/grub/grub.cfg on the guix partition.
<mark_weaver>so you could add a menu item to your current grub config that loads the guix grub config.
<mark_weaver>(using the configfile command)
<mark_weaver>svetlana: yeah, even if you let guix install grub on /dev/sda, you'll still be able to get to your existing OS's grub menu using the configfile command. you type 'c' at the grub menu, then type "configfile (" and then tab will do tab completion on the set of available disk devices. on my system the disk devices are (ahci0,X) where X is the partition number, but on your system that ahci might be something else, dunno.
<mark_weaver>anyway, the tab completion really helps here. you can discover the set of disk partitions, and once you've found the partition, you can complete on the filenames in the filesystem.
<mark_weaver>but basically you'll want something like: configfile (ahci0,X)/boot/grub/grub.cfg
<svetlana>yup; what would you suggest me to read to configure wpa_sapplicant properly, and to start it?
<mark_weaver>svetlana: create a configuration file, which for typical WPA networks contains entries like this: network={ \\n ssid="MY-SSID" \\n key_mgmt=WPA-PSK \\n psk="MY-NETWORK-PASSWORD" \\n }
<mark_weaver>you'll need to load the 'ccm' and 'ctr' kernel modules. you can either do it manually with "modprobe ccm && modprobe ctr", or add it to the kernel modules loaded by the initrd.
<mark_weaver>then run "wpa_supplicant -i wlan0 -c /path/to/wpa_supplicant.conf -B"
<mark_weaver>and then "dhclient wlan0"
<mark_weaver>to load the modules from your initrd (admittedly, a bit of a hack), put the following in your os-config.scm:
<mark_weaver>(initrd (cut base-initrd <> #:extra-modules '("ccm.ko" "ctr.ko")))
<mark_weaver>you'll need to include the (srfi srfi-26) module in the 'use-modules' at the top, to get 'cut'.
<svetlana>what is initrd?
<mark_weaver>it's one of the fields of the 'operating-system' definition.
<mark_weaver>so it's a sibling of 'bootloader', 'users', 'packages', etc.
<mark_weaver>see the (GNU Distribution > System Configuration > Initial RAM Disk) section of the guix manual.
<svetlana>ok thanks
<mark_weaver>np!
<akamch>o/
<akamch>how do I go about fixing a broken Grub?
<akamch>(error: ELF header smaller than expected.)
<mark_weaver>sorry, I don't know, I've never seen that error message. maybe try #grub?
<mark_weaver>I guess I would boot into a rescue USB stick and ask it to reinstall grub.
<mark_weaver>for example, the debian installers include a rescue mode that makes it easy to reinstall grub for a debian system (or debian derivative)
<akamch>mark_weaver: thanks! I did just that, booted from the Debian CD
<mark_weaver>np!
<akamch>do you think it would be enough just to locate grub binary and use it?
<mark_weaver>sorry, I'm not an expert on grub.
<akamch>I tried "guix system reconfigure" on a chroot from rescue, but I guess it won't work on FHS-less system
<mark_weaver>the main issue with chroots is that you have to make sure that the chroot has the various special filesystems like /sys, /proc, and /dev
<akamch>yeah, that too
<mark_weaver>another approach would be to boot the Guix USB installer and run "guix system init" from it.
<mark_weaver>I think that's probably a more reliable approach
<mark_weaver>I'm running Guix on a gluglug X60 with libreboot, which has grub and a grub.cfg built-in to the ROM, so no matter what I do to the disk, I'll always have a working grub.
<mark_weaver>(even if I take the disk out completely :)
<akamch>wow! :)
<akamch>REALLY nice)
<mark_weaver>yeah :)
<akamch>and here I am, with a newish (circa 2011) Lenovo machine, it already has UEFI and all that stuff preventing me from booting the USB installer
<akamch>other than that "guix system init" would be perfect, I reckon
<mark_weaver>you could boot the USB stick from any working grub, if you had one.
<mark_weaver>just type 'c' from the grub menu to get a command prompt, and then type: configfile (usb0,0)/boot/grub/grub.cfg
<mark_weaver>and then select the first item from the menu
<svetlana>:D
<mark_weaver>there are GRUB rescue CDs around. https://www.gnu.org/software/grub/manual/html_node/Making-a-GRUB-bootable-CD_002dROM.html describes how to make one.
<akamch>mark_weaver: well, you've given me enough leads to experiment for now, thanks! :) one little question, I guess I messed things up after rebooting with Ctrl-Alt-Del; should I use "deco <something>" to reboot and shut down?
<akamch>Doesn't guix process three key combo correctly?
<mark_weaver>I'm not sure it does, but in my experience Guix is very robust against crashes.
<mark_weaver>I suspect you did something else.
<akamch>hmm, I've also noticed journal recovery after Ctrl-Alt-Dels, hence the question
<akamch>well, this I'll find out next after I fix my GRUB)
<mark_weaver>to shut down guix, use "reboot" or "halt.
<mark_weaver>"halt"
<akamch>will be sure to do that, I've read, these are aliases to deco on GNU Guix
<mark_weaver>well, I just tested it, and Ctrl-Alt-Del does indeed work in Guix :)
<akamch>umounts all the things properly?
<akamch>there might be more than one problem with my system, why not? :D
<mark_weaver>it unmounts things, yes. there are still some issues, e.g. /tmp is not cleared during boot, nor is /var/run, so things are sometimes left around that prevent daemons from starting up.
<mark_weaver>there's still lots to work on :)
<mark_weaver>well, it's just the dbus daemon and the X server that sometimes cannot start up.
<mark_weaver>I've never had a problem where I couldn't log into a text console, at least.
<mark_weaver>if I 'reconfigure' with a config that somehow results in an unusable system, I can always select an older config from the grub menu.
<mark_weaver>of course, if you bork your /etc/passwd, you're probably still screwed though.
<akamch>alt configs helped me too. Though I managed to trip grub up twice actually, on two machines.
<akamch>One small strange thing I noticed was Grub booting the second entry by default (old configurations). Is it by design?
<mark_weaver>I suspect it's a mistake, but we'd have to ask civodul.
<mark_weaver>I have a patch in my local guix tree to fix that, and will run it by civodul when he returns.
<mark_weaver>it can also be fixed in the operating-system configuration.
<mark_weaver>just add (default-entry 0) within the grub-configuration, as a sibling to 'device'.
<akamch>aha, thanks, good to know, that's undocumented in the manual
<mark_weaver>that's in gnu/system/grub.scm
<mark_weaver>you can also configure the 'timeout'
<akamch>It's a first time I see germ-free, hygiene-loving Tux with a toothbrush booting from the USB installer.
<mark_weaver>hehe :)
<akamch>Framebuffers on other machines were not up to the task.
<mark_weaver>nice!
<akamch>mark_weaver: and Mark, TIL I learned how to bypass UEFIs! Thanks!
<mark_weaver>what does it mean to bypass UEFIs? and what does TIL stand for?
<akamch>Today I Learned :) Sorry, too much reddit :|
<akamch>nicely done Super Grub2 Disk autodetects everything, I didn't even have to enter anything on the Grub command line
<mark_weaver>excellent
<akamch>by bypass (heh) I mean not being able to boot from MBR-lined USB image no matter how hard I tried
<akamch>Grub Disk allows it easily
<mark_weaver>I guess we'll need to add UEFI support
<mark_weaver>it's possible that when guix installs grub, it doesn't work on UEFI either.
<akamch>that would be useful in these times
<mark_weaver>also, UEFI machines will become increasingly common I guess.
<akamch>they surely will, thanks to Microsoft
<akamch>I tried making something up using https://wiki.ubuntu.com/USBStickUEFIHowto
<akamch>didn't succeed, but there's lot of useful knowledge
<mark_weaver>recent apple laptops use UEFI also, I think.
<mark_weaver>I installed Debian on a friend's UEFI-based MacBook a couple of years ago.
<mark_weaver>thanks for the link!
<akamch>mark_weaver: alas, it's nigh impossible to fix grub at the time being. This HDD was transplanted from an older ThinkPad R60 and this whole thing worked somehow for several days. Now I get typical EFI-related errors from grub-install ("source_dir doesn't exist." etc)
<akamch>mark_weaver: if you will need a tester for UEFI images, just say the word!
<janneke>is there an easy way to build only a minimal gcc-c cross compiler?
*janneke is getting cheesy watching endless gcc untar xzvf and build output
<janneke>or even a way to short-circuit, re-take a stage?
<janneke>set-cross-paths fails
<tadni>Hm, I might end up attempting to package netctl over wicd, seems more modern and light-weight on depends.
<tadni>Not sure if it's dependent on systemd though.
<akamch>tadni: netctl is slick, but systemd is listed as a hard dependency :/ https://www.archlinux.org/packages/core/any/netctl/
<svetlana>how do you define 'slick'?
<tadni>akamch: I mean, Wicd is like 4 python packages away ... which isn't horrible, just will take awhile. :^P
<akamch>:) overall I like Arch Linux's ways: make small, console, well-working and VERY WELL documented utilities
<akamch>I see :) Well, Wicd is certainly great either, I'm using it on all my laptops, be it -curses or -gtk kind.
<tadni>davexunit: o/
<davexunit>\\o
<svetlana>hi.
<tadni>davexunit: What's up?
<davexunit>hacking on my guix web interface a bit.
<tadni>davexunit: Oh neat!
<svetlana>guix has a web interface?
<davexunit>I'm writing one for fun
<davexunit> https://cdn.mediacru.sh/DYokShTQ-Lty.png
<akamch>looks great, is it all written in Guile?
<davexunit>I'm trying to make it "modern", so it's javascript heavy.
<davexunit>akamch: the server-side is guile, yes
<svetlana>ah yes, the wonderful packages.distroname.org websites which are so popular today. yes. you're adorable.
<davexunit>svetlana: well, actually. I would like this to be a functioning interface to installing/removing packages.
<svetlana><3
<akamch>cool! How would it be working? Something like "click download link for .deb in Firefox -> open in gdebi"?
<davexunit>s/to/for/
<davexunit>akamch: you would just click the "install package" button and it would be done.
<davexunit>maybe a little spinning loading indicator would come up and then a success message (or failure message)
<akamch>hoho :) Guix would instantly gain a lot of hipness)
<davexunit>yeah, the idea is to make it pretty "web 2.0" to appeal to people
<davexunit>and also I was just itching to use guile's web modules for something
<akamch>Dave, do you have it public? I'm new here and might have missed the link to code repo.
<davexunit> https://gitorious.org/guix-web/guix-web
<davexunit>akamch: ^
<akamch>thank you!
<davexunit>it's pretty hacky right now
<davexunit>this is the continuation of a 1 hour hack I did a few nights ago to see how easy something like this would be
<akamch>guess it't time to join #guile :)
<tadni>Hm, trying to figure out what is wrong with this module ...
<mark_weaver>janneke: I suspect you'll have to write some customized recipes for mingw. Guix currently targets only the GNU system.
<mark_weaver>janneke: you should really talk to civodul about this. alas, he's away until after GHM.
<mark_weaver>He's currently the only one with a deep enough knowledge of Guix to help sufficiently with what you're attempting to do.
<alezost>Excuse me, but what does "GHM" stand for? I looked at http://acronyms.thefreedictionary.com/GHM but nothing looks suitable for me.
<alezost>oops, sorry I've just realized: http://www.gnu.org/ghm/
*tadni will attempt to figure out certs for git, before the weekend is over.
<davexunit>there's an env var you can set to disable cert checking for now
<tadni>davexunit: Can you give me a hint or point me towards the direction where I could find such a thing?
<davexunit>GIT_SSL_NO_VERIFY=true
<tadni>davexunit: Thank!
<tadni>s
<davexunit>the better, harder, option is to copy your /etc/ssl from a debian install and set more env vars
<davexunit>ssl on guix will get better soon enough, mark is working on it.
<tadni>davexunit: Hm, didn't seem to take. :^/
*tadni looks on his Fedora box for /etc/ssl
<davexunit>tadni: did you set the variable right?
<davexunit>type "env" at your shell and see if the correct value is there
<tadni>Hm, yeah ... it's not listed with "env".
*tadni really needs to take a basic UNIX class...
<davexunit>export GIT_SSL_NO_VERIFY=true
<tadni>davexunit: Ah! Sorry for being such a pain. :^/
<davexunit>all good :)
<tadni>So, skribillo might be broken. It doesn't seem to want to use modules from guile-reader?
<janneke>how can i try to build a package ignoring its dependencies?
*janneke ran guix gc in an effort to recover from a broken /gnu/store/...
<janneke>and now my expensive gcc source tarball is gone :-(
<mark_weaver>janneke: did you delete things from /gnu/store ?
<mark_weaver>janneke: what do you mean by "ignoring its dependencies" ?
<mark_weaver>IMO, we really shouldn't be encouraging the use of GIT_SSL_NOVERIFY=true
<mark_weaver>(although admittedly, CAs are compromised anyway so I guess it's a wash)
<mark_weaver>(and I admit I've occasionally made similar recommendations)
<davexunit>mark_weaver: yeah, I know it's not great to recommend...
<tadni`>I can copy over my /etc/certs. My guile-reader broke somehow, so guix got borked and I just reinstalled GNU so it doesn't really matter now for me.
<tadni`>/etc/ssl/certs*
<waxysubs>tadni`: there's normally one large file that contains all the certs. on Debian, it's in /etc/ssl/certs/ca-certificates.crt
<mark_weaver>oops, I meant to type that here (waxysubs is my logger)
<mark_weaver>anyway, it imght be somewhere else.
<mark_weaver>but wherever that file is, you should set the SSL_CERT_FILE and GIT_SSL_CAINFO environment variables to point to it.
<mark_weaver>that should make SSL work, at least for git.
<tadni`>mark_weaver: Okay, thanks.
<mark_weaver>yw!