IRC channel logs

2014-08-07.log

back to list of logs

<mark_weaver>tadni: a few ideas: does your .xsession have a proper shebang at the top? did you chmod +x it?
<tadni>Also, do you just use wpa_supplicant for networking? I'm thinking of looking into packaging wicd.
<mark_weaver>also, support for ~/.xsession was added very shortly before the 0.7 release.
<mark_weaver>tadni: wicd would be a very welcome contribution.
<mark_weaver>right now, I just try wpa_supplicant directly.
<mark_weaver>s/try/run/
<tadni>mark_weaver: It looks like it's only a few python packages away, which is nice.o
<mark_weaver>it's pretty simple. just create a wpa_supplicant.conf with entries like this: network={ \\n ssid="mynetwork"
<tadni>What in-regards to the shebang?
<mark_weaver>key_mgmt=WPA-PSK
<mark_weaver>psk="mynetworkpassword"
<mark_weaver>}
<mark_weaver>and then run wpa_supplicant -i wlan0 -c wpa_supplicant.conf -B
<mark_weaver>and then dhclient wlan0
<mark_weaver>tadni: well, is the first line of the file "#!/bin/sh" ?
*mark_weaver goes afk for a while
<tadni>mark_weaver: Thanks for the info. o/
<mark_weaver>davexunit: I saw your web server module for guix. very elegant!
<mark_weaver>one issue: since the url-path could contain ".." components, it could be manipulated into accessing files outside of the root of the tree.
*tadni_ suspects hydra might be stalling, reinstalling on this testbox again (regained it from friend) and it's taking 20 minutes so far to "guix pull".
<mark_weaver>I've never used "guix pull", so I can't say how long it takes.
<tadni_>mark_weaver: It seems to vary, a lot.
<tadni_>"perf interrupt took too long" seems to be a pretty common message I've been getting since release.
<mark_weaver>hmm, I've never heard of that one
<mark_weaver>is that the precise error message? I'm searching the source code to find where it might be coming from.
<mark_weaver>no hits
<zacts>ok, I seem to be having problems dding my guix usb image.
<zacts>I'm following the guide
<tadni_>[515.440414] perf interrupt took too long (2503 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
<tadni_>zacts: Problem, how-so?
<mark_weaver>zacts: fwiw, I just did: xzcat gnu-usb-install-0.8.SYSTEM.xz > /dev/sdX
<mark_weaver>zacts: but yeah, more details please
<zacts>ok my device is /dev/sdb
<mark_weaver>zacts: one thing: it's important that the filesystem on the USB stick is not mounted when you copy to it.
<zacts>I did: root-# dd if=gnu-usb-install-0.7.i686 of=/dev/sdb
<mark_weaver>since modern DEs tend to auto-mount USB sticks, you may need to unmount
<tadni_>Also, it doesn't hurt to zero out the device beforehand.
<zacts>mark_weaver: I use i3wm, and it was unmounted
<zacts>umount -> "Device is not mounted"
<zacts>umount /dev/sdb that is
<mark_weaver>tadni_: there's no reason to do that, and it will take twice as long.
<zacts>let me try mark_weaver's xcat method
<zacts>xzcat*
<mark_weaver>zacts: well, /dev/sdb wouldn't be mounted. but /dev/sdbX might be.
<mark_weaver>(e.g. /dev/sdb1)
<zacts>/dev/sdb1 not found
<mark_weaver>zacts: what was the error message when you tried 'dd' ?
<zacts>no error message, it said it was successful
<zacts>I can even pastebin the exact results
<mark_weaver>zacts: okay, so what went wrong?
<tadni_>zacts: Does it not boot?
<zacts>when I rebooted and selected my usb drive in the bios on two different computers it couldn't boot from the USB
<mark_weaver>hmm
<oitofelix>Hello mark_weaver! Are you working on a standalone version of the mips64el port?
<tadni_>I'd 'dd if=/dev/zero of=/dev/sdb'
<tadni_>Then try again.
<mark_weaver>I confess I don't have a machine around that can boot USB sticks normally, so I did it a different way: using grub.
<davexunit>mark_weaver: thanks! I have since fixed that code to use a function out of the web module that should handle that case properly.
<mark_weaver>tadni_: that's a waste of time.
<tadni_>mark_weaver: It's fixed similar problems for me before. :^P
<davexunit>I've also started using pattern matching for describing routes. works great.
<mark_weaver>tadni_: hmm, okay. well, maybe I'm wrong.
<mark_weaver>davexunit: sounds good!
<oitofelix>mark_weaver: Sorry! Just saw your messages... :-P
<tadni_>Still pulling.
*jxself pulls back
<mark_weaver>zacts: if you have grub on the system already, then you should be able to boot the USB stick with the following grub command: configfile (usb0,0)/boot/grub/grub.cfg
<mark_weaver>and then select the first item from the menu that comes up after that.
<tadni_>jxself: :^)
<oitofelix>mark_weaver: So, the packaging of GNU Linux-Libre is the only step needed for a standalone version?
<zacts>ok, I'll try it out
<mark_weaver>oitofelix: well, the fact that 'qemu' isn't yet building on MIPS is another problem. things like 'grub' and the images are built using qemu.
<mark_weaver>and of course, there's not yet a working X server for MIPS in guix.
<mark_weaver>but I suppose you could consider that optional.
<zacts>you know I think I may have done if=./gnu-usb-install-0.7.i686 rather than if=gnu-usb...
<zacts>it's taking longer this time
<mark_weaver>zacts: the ./ shouldn't be a problem.
<zacts>odd
<zacts>I also did the /dev/zero thing before this..
<mark_weaver>another issue is that even after the command finishes, the usb drive might still be working. if it has an activity light on it, that helps.
<zacts>mine has no activity light
<mark_weaver>if not, I don't know how you can be sure it is finished.
<zacts>perhaps I'll wait a few minutes after this time
<tadni_>Wait 5 minutes? :^P
<oitofelix>mark_weaver: Yeah, I consider that optional. Are you the only one working on this? (Are you actually working on this?)
<mark_weaver>oitofelix: well, I got the MIPS port up and running, but at this point I've lost a lot of motivation for working on it, since Lemote is no longer producing machines that can run with 100% free software, it's not clear whether they will make another one that does, and now there's the X60 and the Novena on the horizon.
<mark_weaver>also, no one else seems to be willing to work on it with me.
<mark_weaver>I can certainly contribute a recipe for a kernel that works on the YeeLoong 8101B.
<mark_weaver>but I'm not sure I'll bother getting qemu and X working.
<zacts>somehow this time it worked! \\o/
<mark_weaver>zacts: yay! who knows, maybe tadni was right about the /dev/zero thing, although I can't imagine why that would have helped...
<zacts>let me install it, and then I may have lsh questions for you mark_weaver
<oitofelix>mark_weaver: Well, I'm getting a Lemote and it will be useful to me virtually for lifetime. I'm willing to work with you, if you are still interested. (If you are not, I'd have to start working alone, and that's much less fun ;-))
<mark_weaver>oitofelix: which Lemote are you getting?
*tadni_ wants a Novena but has nowhere near the moolah.
*jxself might be interested in a Novena once the graphics work is done and it's as good as the X60s, freedom-wise
<jxself>But no FSF-endorsed distro currently supports ARM.
<mark_weaver>jxself: my Novena board should arrive in November, and I plan on running Guix on it.
<tadni_>jxself: Also, I don't think the FPGA on the Arm board is Free?
<oitofelix>mark_weaver: That's a good question. I don't know exactly yet. (It's a gift and I didn't ask :-P)
<mark_weaver>compiling new configurations for the FPGA currently requires non-free software.
<mark_weaver>oitofelix: well, if you'd like to help, that would be most welcome, and I'd be glad to answer your questions and get you started.
<mark_weaver>on my YeeLoong, I'm running almost entirely from Guix-compiled packages. there are only a few missing pieces.
<oitofelix>mark_weaver: Well, I only know it's a Lemote YeeLoong.
<oitofelix>mark_weaver: Thank you very much! I'm excited to get started! :-D
<mark_weaver>:)
<oitofelix>mark_weaver: What's your base distribution?
<mark_weaver>one thing that really impressed me about the Guix USB installer, btw: although it doesn't come with wpa_supplicant, I was able to install wpa_supplicant within the installer, and then switch to wireless before completing the install.
<mark_weaver>oitofelix: on the YeeLoong, I used CLFS (Cross [GNU/]Linux From Scratch) to bootstrap my own N32-based system from scratch.
<mark_weaver>(although I made a number of modifications along the way)
<mark_weaver>but that was in 2011. the software I built was quite old. I finally refreshed it using Guix. at this point, I think the only thing I'm still running from the original system is the X server.
<mark_weaver>the X server required some patches for the YeeLoong that aren't suitable for upstream as-is.
<tadni_>Yeah, I'm going to just leave guix pull going... but I think I'm going to have to restart and try again tomorrow. :^P
<tadni_>Alpha-tier software is a blast. :^)
<mark_weaver>tadni_: if you plan to contribute to guix, then a better strategy is to avoid 'guix pull', and instead install the software you need to download the guix git repo and build that from source code.
<mark_weaver>that's what I did, and it worked well.
<tadni_>Yeah, I plan on it. That being said -- since I just got my secondary laptop back (lent to a fried for almost a week, when his died), I nuked GNU and now reinstalling it. And of course 0.7 really ships 0.6 so ... :^P
<mark_weaver>tadni_: well, the 'guix' that's installed by the USB installer is 0.7. however, if you do "guix package -i guix", then you get 0.6, that's true.
<mark_weaver>but there's really no reason to do that. guix 0.7 is already there.
<mark_weaver>I agree that it's a problem, but one that's easy to avoid.
<tadni_>Hm, that's odd. Why does it list only 0.6 packages then?
<mark_weaver>well, it lists guix 0.6 in the package list, yes.
<oitofelix>mark_weaver: I had my time of (GNU/)Linux from scratch. I built my own version in early 2012 and used it until mid 2013. Good time. A lot of work. Only then I could really understand the value of a distribution. :-)
<mark_weaver>but the other packages are the versions that are from guix 0.7
<mark_weaver>oitofelix: indeed, I spent stupid amounts of time on it :)
<oitofelix>mark_weaver: hahahaha me too. Zillions of packages building every day for several months until it get stable for me. :-P
<mark_weaver>especially on the yeeloong, which is a very slow machine. it took literally weeks to compile everything.
<mark_weaver>even for a basic system.
<tadni_>mark_weaver: Why are things like "wireless-tools" not present, then? :^P
<mark_weaver>tadni_: what is the output of "which guix" and "guix --version" ?
<mark_weaver>tadni_: hmm, maybe I'm wrong about this.
<oitofelix>mark_weaver: Yeah. But I'm used to slow machines. The best machine I ever had is this Intel Atom netbook. The past month I used almost exclusively a Jornada 728 whose GNU/Linux port I was working on (for myself). It's 12 years old: 64 Mb of RAM, StrongARM 1110 (206 Mhz).
<oitofelix>I even built X on it. :-P
<tadni_>Yeah, it says /run/current-system/profile/bin/guix and 0.7 respectively ... still doesn't display wireless-tools though.
<mark_weaver>I went as far as building GNOME 2.32 on my CLFS system on the Yeeloong.
<oitofelix>mark_weaver: Wow. That's a lot. It should be satisfactory system to use.
<mark_weaver>tadni_: well, I confess I don't know what's going on there. but I can tell you the path I took, which worked well.
<zacts>ok, it's almost installed
<mark_weaver>tadni_: I just used "guix package -i" to install all the packages I needed to download the guix git repo and build it from source code. then I ran "./pre-inst-env guix system reconfigure MYCONFIG.scm" to upgrade to the latest guix.
<mark_weaver>anyway, I have to go afk for a while.
<tadni_>Yeah, I'll probably end up doing that. Also, thanks, peace. o/
<mark_weaver>good luck!
<tadni_>Ty.
<zacts>darn it didn't install. I need to learn how to use gnu parted
<zacts>perhaps I'll use another distro to partition
<zacts>and then I'll reboot and try again
<tadni_>zacts: In parted, use mklabel and make a msdos disk label.
<zacts>I made a gpt disk label
<zacts>I'm going to use my slackware cd to make the proper partitions
<tadni_>Then use mkpart, set to ext4 and however big your alotted drive is.
<tadni_>zacts: Whatever works.
<tadni_>Parted isn't hard though, by any means.
<zacts>tadni_: yeah, I just am not used to it.
<zacts>I want to get this up and running soon
<mark_weaver>it's possible that some BIOSes don't understand GPT disk labels.
<mark_weaver>oh, well, I guess maybe that doesn't matter, now that I think on it.
<tadni_>mark_weaver: ... I think I may have figured it out, I forgot to authorize hydra... so I'm guessing it was building everything from source.
<zacts>mark_weaver: do you use lsh as your main ssh implementation? is it stable?
<zacts>I don't see much info on its mailing lists / homepage
<tadni_>I've never seen lsh used in the wild.
<zacts>I don't see a problem with using mosh + openssh for initial auth
<zacts>mosh is gplv3+ also..
<zacts>but eventually replacing openssh with lsh for initial auth could be an option, I guess.
<tadni_>Yup, auth was the missing piece.
<zacts>I wonder if mosh will reimplement openssh for initial auth eventually also..
<tadni_>Well that was dumb of me. :^P
<svetlana>did folks here get wifi working on this thing?
<svetlana>during install
<mark_weaver>tadni_: ah, glad to hear you figured it out! yeah, authorizing hydra should be more prominently mentioned in the installation section of the manual.
<mark_weaver>zacts: I don't actually use lsh. I only mentioned it because there's already an lsh-service (for dmd) included in guix.
<mark_weaver>but it would probably be easy to write an openssh service for dmd as well.
<mark_weaver>svetlana: yes, I got wifi working, but it took some tricks.
<mark_weaver>svetlana: let me know if you want to know details.
<svetlana>I'm using iwlwifi drivers and I'm not sure whether they're already packaged. yes, the more details the better, I'd take notes and use them later
<tadni_>Isn't iwlwifi firmware non-free?
<tadni_`>Okay, ratpoison on GNU! :^)
<tadni_`>Tomorrow, I'll try to figure out the git cert situation.
<mark_weaver>tadni_`: regarding SSL: we don't yet have a trust store in Guix, i.e. a set of certificate authorities to trust.
<mark_weaver>so currently you need to copy it from somewhere else, e.g. a debian system, a set environment variables to point to it.
<mark_weaver>among other things, that's needed to fetch the nix submodule in the guix git repo.
<davexunit>I now have a working web application that allows you to regex search guix packages by name. :)
<tadni_`>davexunit: Neat!
<tadni_`>mark_weaver: Hm, I wouldn't know where to start there ...
<tadni_`>Would that be in the directory I built on say mf Fedora install, or is it somewhere in the / directory?
<tadni_`>Meh, I'll look into it more tomorrow. Should really go to bed for the night. Peace all. o/
<janneke>is there a recipe or example page that i can follow?
<janneke>i find it very hard to get going with guix
<janneke>now i get
<janneke>guix package: error: build failed: unable to fork: Operation not permitted
<janneke>
<Steap>janneke: look at hello
<janneke>[1]12:19:18 janneke@drakenvlieg:~/vc/guix
<janneke>$ find . -name '*hello*'
<janneke>./gnu/packages/patches/automake-skip-amhello-tests.patch
<janneke>
<janneke>No `hello' in index
<janneke>Steap; thanks, where?
<janneke>ah, you mean `defining packages' in the manual
<Steap>janneke: gnu/packages/base.scm
<janneke>i am still fighting with getting a simple package build going
<Steap>yes, you should first be able to build one of the already packaged pieces of software
<janneke>i am trying
<janneke>guix package -i guile
<janneke>
<janneke>and get
<janneke>guix package: error: build failed: unable to fork: Operation not permitted
<Steap>did you run the daemon as root ?
<xisiqomelir>hello friends
<janneke>Steap: no as myself
<janneke>i don't want 10 silly accounts just to test drive a new software?
*janneke sent a mail to guile-user with his troubles
<Steap>janneke: the daemon is supposed to run as root :)
<tadni> /me decided to just package terminus, because it's a lot easier than figuring out how to set up a trivial build system.
<davexunit>prototype guix web interface: https://cdn.mediacru.sh/DYokShTQ-Lty.png
<jxself>Looks good.
<jxself>You can search by any of those columns I assume?
<jxself>Might also be nice if it had a feature similiar to http://packages.trisquel.info/ where you can do a "packages that contain files named like this" for cases where you know what you want, but not exactly what pacakge it's in.
<taylanub>Is Guile really "especially for extensions" anymore?..
<taylanub>(not to say it isn't very good for extensions, rather it can do some other things just as well!)
<akamch>has anyone experienced "ERROR: Unbound variable: mkdir-p" during guix system reconfigure?
<akamch> https://clbin.com/g05vd
<akamch>my configuration is straight from the manual