IRC channel logs

2014-06-13.log

back to list of logs

<jmd>How do I find the path of the /tmp dir where a package is built?
***civodul changes topic to 'GNU Guix --- http://gnu.org/s/guix/ --- 0.7 is in the works, help test the system! --- core-updates frozen real soon now'
<civodul>Hello Guix
<jmd>I want to substitute "$(command -pv)"
<jmd>How do I escape the $ ?
<civodul>in the pattern?
<civodul>"\\\\$(command -pv)" no?
<taylanub>escape from what exactly? where does that string appear?
<jmd>civodul: I tried that.
<jmd> (substitute* "testsuite/which/which-uses-default-path"
<jmd> (("$(command -pv xxx") (string-append (getcwd) "/xxx")))
<jmd>
<civodul>jmd: oh the parentheses need to be escaped as well
<civodul>(string-match "\\\\$\\\\([a-z]+\\\\)" "$(command)") => #t
<jmd>ok
<jmd>How should $(command) behave anyway in guix?
<civodul>what do you mean?
<civodul>as a Bash command?
<jmd>Well "command ls" is supposed to run /bin/ls (and disregard the value of PATH). Does that behaviour make sense in GUIX?
<civodul>s/GUIX/Guix/ :-)
<civodul>hmm
<civodul>jmd: it works fine
<civodul>'command' just guarantees that it's a command that's invoked, and not a shell function
<civodul>i've never used it
<jmd>But it is also guaranteed to ignore PATH
<civodul>no, i don't think so
<civodul> Runs COMMAND with ARGS suppressing shell function lookup, or display
<civodul> information about the specified COMMANDs. Can be used to invoke commands
<civodul> on disk when a function with the same name exists.
<civodul>(from 'help command')
<jmd>"the search for command is performed using a default value for PATH that is guaranteed to find all of the standard utilities"
<jmd>(when -p is given)
<civodul>ah, yes
<civodul>well -p doesn't work
<jmd>We need to hack bash to find out what Guix has installed.
<civodul>i'm not sure what we'd want -p to do
<civodul>perhaps set PATH to /run/current-system/profile/bin
<jmd>That could work.
<jmd>civodul: That directory does not exist
<civodul>it exists in the GNU system
<civodul>wb jmd
<civodul>my reply was: this directory exists in the GNU system
<jmd>Oh.
<jmd>But it does not exist in the guix build environment.
<civodul>ah no
<civodul>but there's nothing sensible we can do there
<civodul>not that i can think of, that is ;-)
<jmd>I suppose it depends on one's definition of "sensible".
<civodul>grrr emacs crash grmbl grmbl
<jmd>Right now I have a problem. guix build just hangs...
<civodul>i think that's because hydra is lost or something
<jmd>Seems to be working again..
<civodul>yup, just restarted the services...
<civodul>seems one of them leaks
<jmd>You had better patch it then.
<civodul>i would, but i have only two hands :-)
<jmd>how many HEADs does hydra have?
<civodul>:-)
<jmd>There needs to be some kind of heuristic to guess whether downloading a binary from hydra is likely to be quicker than downloading the source and building.
<civodul>it's rarely faster to do things locally
<civodul>because you at least need to download the source, which is bigger than the binary
<jmd>Usually, but not always.
<civodul>oh, BusyBox
<jmd>oh!
<civodul>looks like you had a great time getting the tests to work as expected ;-)
<civodul>nice that you worked on it
<jmd>The BB devs seem to have different ideas about software development to what I do.
<civodul>yeah it's definitely not GNU ;-)
<jmd>It should have been called GING
<civodul>:-)
<jmd>The ROADMAP seems to somewhat static recently.
<civodul>well, there are frequent upgraded roadmaps on the list no?
<civodul>maybe "frequent" isn't the right term
<civodul>but i mean, there are updates
<civodul>perhaps that's no clear enough, wdyt?
<jmd>why aren't they checked into git?
<civodul>i felt it was less convenient
<jmd>ok.
<civodul>but maybe it'd be better to update it actually
<civodul>or maybe we could use the bug tracker for that, with "wishlist" items
<jmd>As I understand the term, a "roadmap" is not the same as a list of wanted features, although it could include some of the more important ones.
<jmd>Anyway, presumably you are going to tell us about the plan for the next 12 months in August?
<civodul>yup!
<civodul>but everyone is welcome to contribute to the plan, of course ;-)
<civodul>for the coming weeks, the plan is https://lists.gnu.org/archive/html/guix-devel/2014-05/msg00110.html
***civodul changes topic to 'GNU Guix --- http://gnu.org/s/guix/ --- 0.7 is in the works: https://lists.gnu.org/archive/html/guix-devel/2014-05/msg00110.html --- core-updates frozen real soon now'
<civodul>jmd: had a chance to try 'guix system' & co.?
<jmd>Not yet.
<jmd>GUIX$ ./pre-inst-env guix services vm build-aux/hydra/demo-os.scm
<jmd>guix: services: command not found
<jmd>Try `guix --help' for more information.
<civodul>"guix services"?
<civodul>it's called "guix system"