IRC channel logs

2014-05-24.log

back to list of logs

<Denommus>whoa, perfect
<Denommus>another thing: sorry if that is too basic, but I still have little knowledge on it, but is Guix similar to other Linux package managers in that the package must be in some repository, or can I define how to build my dependencies (including where to fetch them from) locally?
<taylanub>Denommus: http://www.gnu.org/software/guix/manual/guix.html#Invoking-guix-package "--profile=profile | -p profile: Use profile instead of the user’s default profile."
<taylanub>Denommus: Guix "normally" compiles things locally as per the given recipe, but since Guix packages are 100% reproducible and identified by a hash, a build farm can produce precompiled packages which Guix can download and use as a substitute -- unsurprisingly these packages are called "substitutes" in Guix terminology
<Denommus>taylanub: ah, cool. Then it seems that Guix is just perfect for a development-level generic package manager (or whatever I should call this kind of package manager)
***Denommus` is now known as Denommus
<jmd>Is there something like substitute* but wich takes literals instead of regexps?
<bavier>jmd: by literal do mean a fixed string?
<jmd>bavier: yes
<bavier>substitute* should work fine with literals. see e.g. the sed package in base.scm
<jmd>???
<jmd>Then how does it know if I mean something literally?
<bavier>do you have an example of what you need?
<jmd>Well for example "foo (const char *, ...)"
<bavier>I see what you mean now
<bavier>for substitute* you would need to put in escapes
<jmd>Yeah. It gets painfull when there are a lot of * . and ()
<jmd>and of course " needs to be replaced with \\\\\\"
<bavier>yes, things get ugly fast
<bavier>perhaps we could have a substitute*/literal that performs the escaping before handing off to substitute*
<jmd>Is there a procedure which I can use to insert a line at the top of a file?
<jmd>How do I escape $ in a string?
<taylanub>jmd: $ doesn't have a special meaning in a Scheme string, do you mean a string whose contents have some special meaning? e.g. if you mean a regexp, then you'd need "foo\\\\$" to construct the regexp 'foo\\$' meaning you escape the regexp-meaning of $
<taylanub>jmd: as for editing files from Guile .. maybe look into its Elisp implementation! :P
<taylanub>hrm, possibly it doesn't have buffers yet, I can't figure out right now
<jmd>What sort of bandwidth should I expect to hydra?