IRC channel logs

2014-01-28.log

back to list of logs

<civodul>Hello Guix!
<mark_weaver>hi civodul!
<mark_weaver>I'm afraid that setting --localstatedir=/var is a disaster.
<mark_weaver>lots of builds are now failing, because they fail to create /var
<mark_weaver>I'm not sure how to deal with this. "make install" tends to want to create things in localstatedir.
<civodul>yeah i just noticed and reverted :-)
<civodul>actually i remember having to patch packages precisely because of that
<civodul>so i suppose we may have to keep doing it on a case-by-case basis
<civodul>oh, gdb release in 1 day, glibc release in 2 days
<civodul>howdy jmd!
<civodul>jmd: i pushed a "fix" that should solve the problem you had with downloading apr
<civodul>i think it's even a fix, without quotes
<civodul>yeah, let's call it this way
<jmd>Oh ok. Had the url moved, or did we have it wrong in the first place?
<civodul>they move thing eventually to archive.apache.org
<civodul>so i just added that URL to the 'apache' mirror list
<jmd>I see.
<jmd>I'm concerned that if an upstream moves their download site or rearranges it, it might take a long time before guix notices - 12 months later it could cause a lot of trouble finding it again...
<civodul>yes, but we have caches all around
<civodul>on hydra in particular
<jmd>It might not be a bad idea to have a process which pings the download sites periodically.
<sriharsha>jmd, openembedded also suffers from this issue of download sites going offline. If anyone is going to FOSDEM, please ask them how they cope with this...
<viric>whawt download sites?
<viric>their own?
<sriharsha>Is the example given in the section http://www.gnu.org/software/guix/manual/html_node/Using-the-Configuration-System.html obsolete?
<viric>ah, references. (I looked at the backlog)
<viric>hydra could include a torrent tracker
<sriharsha>for serving nar files?
<civodul>sriharsha: no it's not obsolete, why would it be?
<sriharsha>because I could not find lsh-service anywhere..
<civodul>aah, that's because it's actually forward-looking :-)
<viric>be it nar files, be it direct tarbals
<civodul>'lsh-service' is not implemented :-)
<civodul>sriharsha: but you can find pretty much all the rest under gnu/system
<sriharsha>you lost me.. but doesn;t it complain of a missing variable?
<civodul>the manual itself doesn't complain, no ;-)
<sriharsha>ah, I get it..
<sriharsha>:-)
<civodul>heh
<sriharsha>can you write an example of how a service configuration is handled? I want to add nginx
<sriharsha>I read this http://www.gnu.org/software/guix/manual/html_node/Defining-Services.html#Defining-Services
<civodul>right, that's the basic example
<civodul>lemme see
<sriharsha>but it doesn't specify how configuration for the service is handled..
<civodul>right
<civodul>look at 'syslog-service', for instance, in gnu/system/dmd.scm
<civodul>it produces a config file, and start syslogd to refer to that file
<civodul>*starts
<civodul>maybe that's a better example for the manual
<sriharsha>that's the one I am looking after, thanks!
<civodul>you're welcome :-)
<civodul>i'm really glad you're looking into this
<sriharsha>what does (package-file inetutils "libexec/syslogd")
<sriharsha>do?
<civodul>it returns the file name /.../...-inetutils/libexec/syslogd
<civodul>(there's a docstring for 'package-file' in monads.scm)
<sriharsha>thanks; actually, we are using guix for deploying gnunet experiments over wide variety of machines.. so, the quicker I learn this, the quicker we deploy.. besides, this is a fun and functional project :-()
<civodul>if you're not using Geiser, you really should ;-)
<civodul>sriharsha: beware, this part is work in progress!
<viric>what is geiser?
<civodul>at this stage, we can only instantiate VMs
<sriharsha>I am using Geiser, but it doesn't show me any doc or take be to the function definition
<civodul>viric: the knees bees! http://nongnu.org/geiser/
<civodul>Guix's IDE :-)
<viric>Ahhh
<viric>interesting
<civodul>sriharsha: try C-c C-k while visiting dmd.scm, and then C-c C-d d when the cursor is under 'package-file'
<civodul>should work
<viric>we need someone to shot a documentary, "Life in Guix"
<viric>that's a big ecosystem :)
<civodul>ahah :-)
<civodul>indeed, crazy big ecosystem :-)
<viric>nix hasn't geiser!
<civodul>yeah!
<viric>those nixers think only of kde
<civodul>a package manager with an IDE, can you imagine? :-)
<civodul>heheh
<sriharsha>civodul, it does work! I was used to gtags and was pressing M-. all the while
<civodul>sriharsha: ah that should work too :-)
<sriharsha>oh yeah, that's working too! So its just that I have to compile with Geiser first
<civodul>exactly, so it knows where it is
<RelayChatInfo>Info about IRC: http://p.pw/DLV See Wikipedia.org
<viric>?
<viric>irc spam?
<civodul>weird
<civodul>live tomorrow: TZ=Pacific/Kiritimati date
<jmd>So I want to have a few "private" packages which I'm not going to publish. Where is there recommended place to put them?
<viric>your own computer
<viric>Better don't pay attention to me.
<jmd>I meant in what directory?
<jmd>Is there a site-local or something?
<mark_weaver>set GUILE_LOAD_PATH, and arrange for the packages to be in <DIR>/gnu/packages/*.scm where DIR is a component of GUILE_LOAD_PATH.
<mark_weaver>alternatively, make a new local branch in 'git', and run ./pre-inst-env guix ... from your git checkout.
<jmd>ok. I'll try the GUILE_LOAD_PATH approach
<mark_weaver>the branch method is more powerful, because it also allows you to make local changes to existing packages.
<mark_weaver>and then git will automatically handle merging upstream changes into your local branch.
<jmd>git doesn't automatically merge branches you have to do it manually.
<jmd>Now if we were using aegis ...
<mark_weaver>well, most of the time it's automatic. occasionally there's a merge conflict, but in practice it works pretty well.
<jmd>But you have to manually instruct it "git merge master" or simular.
<mark_weaver>oh, sure, you have to ask it to do the merge.
<mark_weaver>personally, I wouldn't want it to be more automatic than that. because nothing short of A.I. could handle the merges correctly in all cases, and so I want to control when it happens, in case some fixups are needed.
<jmd>That is true. But I like aegis' approach where "branches" really are true branches. Not just parallel lines of development like in git.
<mark_weaver>I'll have to take a closer look at aegis at some point. but not today; I'm too overloaded with Guile work.
<mark_weaver>jmd: sorry, I'm not sure that the GUILE_LOAD_PATH approach will quite work correctly at present.
<jmd>ok
<mark_weaver>It could be made to work properly, but it seems that some code in Guix currently assumes that the packages will all be in just one component of the GUILE_LOAD_PATH
<jmd>civodul must have started his pilgrimmage early.
<mark_weaver>Specifically, 'package-files' in gnu/packages.scm only searches for packages in the first component of the load path that contains gnu/packages.csm.
<mark_weaver>*.scm.
<mark_weaver>that should really be fixed though. it should search for packages in all components of the load path.
<mark_weaver>IMO, anyway.
<mark_weaver>until that's fixed, I guess you'll need to use the git branch approach.
<jmd>ok thanks.
<mark_weaver>np!
<zerwas>sriharsha: do you make progress in packaging GNUnet in Guix?