IRC channel logs

2014-01-16.log

back to list of logs

<zerwas>guix download https://gnunet.org/sites/default/files/gnurl-7.34.0.tar.bz2
<zerwas>... throws a segfault for me.
<zerwas>guile-gnutls is installed. (before, it complained about a missing guile-gnutls)
<mark_weaver>zerwas: this is just a guess, but civodul pushed some patches to guile to fix a bug that sounds just like this.
<mark_weaver>apparently, if a web server sent more data than its Content-Length indicated, it would segfault.
<mark_weaver>See the top two patches in http://git.savannah.gnu.org/gitweb/?p=guile.git;a=shortlog;h=refs/heads/stable-2.0
<zerwas>Thanks, Mark. I'll try the latest git and see if it helps
<zerwas>I understand that Hydra/the distribution/Guix won't have proprietary packages (like graphics card drivers). But will it be possible to easily use a third party repository for binary packages?
<zerwas>Let me rephrase that: Is it possible to install a plain .scm file?
<davexunit>you can use additional repositories, yes.
<zerwas>So does Guix work with Guile git at all? ./configure says "configure: error: Package requirements (guile-2.0 >= 2.0.5) were not met:". Guile reports as 2.1
<davexunit>zerwas: have you installed some experimental version of guile?
<davexunit>there is no 2.1 release afaik
<zerwas>I did a git clone git://git.sv.gnu.org/guile.git
<mark_weaver>zerwas: you should use the stable-2.0 branch for now.
<zerwas>mark_weaver: and apply civodul's patches manually?
<mark_weaver>civodul's patches are only on the stable-2.0 branch.
<mark_weaver>(at some point they'll get merged into master)
<zerwas>D'oh. I didn't realize.
***daiki is now known as dueno
<civodul>Hello Guix!
<sriharsha>Hi!
*civodul stumbled upon http://www.ohloh.net/p/gnuguix
<civodul>"31 years of effort"
<civodul>efficient, no? :-)
<davexunit>very efficient.
<davexunit>ohloh statistics are interesting.
<sriharsha>civodul, any help with the bug report regarding guile build failure?
<sriharsha>civodul, I installed hydra server on a nixos. Now, if I install Guix, won't it conflict with the exisitng /nix store?
<civodul>sriharsha: what's the bug report?
<civodul>i'm at work now, so i don't look at everything
<sriharsha>ok, may be later then; here's the bug report: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=16463
<civodul>sriharsha: regarding cooperation with Nix, see the bottom of http://www.gnu.org/software/guix/manual/guix.html#Requirements
<civodul>strange
<civodul>i'll see that later today
<Steap> http://www.ohloh.net/p/gnuguix/estimated_cost
<Steap>We could sell Guix for $1.7*10^6
<zerwas>Hm. I'm running Guile from git, branch stable-2.0, but still run into a problem with this https URL: http://pastebin.com/raw.php?i=3XStrfD1
<Steap>zerwas: do you have gnutls installed ?
<zerwas>yes
<zerwas>Maybe I was missing a -dev package, I'll try again
<zerwas>Hm, still no success
<zerwas>sriharsha: Does this command work for you? guix download https://gnunet.org/sites/default/files/gnurl-7.34.0.tar.bz2
<sriharsha>I get the same error
<sriharsha>zerwas, ^
<civodul>zerwas, sriharsha: that's because the Guile 2.0 bindings of GnuTLS are not available on your machine
<civodul>try this: guile -c '(use-modules (gnutls))'
<civodul>i bet you'll get "no code for module" :-)
<zerwas>right
<sriharsha>yes
<civodul>some distros have guile-gnutls built for Guile 1.8, so it's not usable for us
<civodul>you could install it with "guix package -i gnutls" actually
<zerwas>guix to the rescue :). I'll try that
<civodul>alternatively, there's this nasty trick: write your gnurl recipe with the https (with a possibly random hash), and run "guix build gnurl" or "guix build --source gnurl"
<civodul>it'll Just Work, because it'll use the right GnuTLS in the build environment of the download process
<sriharsha>I am trying to build guix-0.5 with nix
<sriharsha>I have the following in all-packages.nix
<sriharsha>guix_0_5 = callPackage ../tools/package-management/guix/0.5.nix {
<sriharsha> libgcrypt = libgcrypt_1_6;
<sriharsha> };
<sriharsha>I changed the name to 'guix-0.5' in tools/package-management/guix/0.5.nix
<sriharsha>but when I try: nix-build pkgs/top-level/all-packages.nix -A guix_0_5
<sriharsha>guix-0.3 source is being used
<sriharsha>now it builds, the hash values was incorrect; seems like it reverted to older source
<sriharsha>yay! built guix-0.5 on nix! :)
<zerwas>\\o/
<civodul>sriharsha: good news :-)
<civodul>gtg
<sriharsha>can you commit the patch to nix repos?
<zerwas>thanks for your help, civo
<sriharsha>if I give it to you
<zerwas>... dul
<sriharsha>where are the guix package files installed?
<zerwas>sriharsha: mine are in /usr/local/share/guile/site/2.0/gnu/packages
<sriharsha>ok, so are you modifying that directory directly?
<sriharsha>for creating recipie for libgnurl
<zerwas>Yes, I appended this to gnunet.scm: http://pastebin.com/U2TH4FKc
<sriharsha>Can i change the compiler guix builder uses? I want to use distcc
<jmd>sriharsha: distcc isn't a compiler
<sriharsha>yes, but a wrapper, which I use to offload compiling tasks to remote machine
<jmd>Well I think it is possible to specify the builders to run remotely, but I'm not sure.
<jmd>I think the answer would have to be, that to do that you would have to set a variable in the gnu-build system, which would mean that absolutely EVERYTHING would be rebuilt with distcc
<zerwas>sriharsha: I forgot that we probably should use "./pre-inst-env guix build libgnurl" from the guix-0.5 source directory (instead of manipulating /usr/local/...)
<jmd>Also, you could not use distcc in its intended mode, since whilst building, you cannot access the network.
<sriharsha>ooh, right!
<sriharsha>phew, I am doomed with this compile times...
<zerwas>Running this command ends in "gnu/packages/gnunet.scm:139:11: In procedure module-lookup: Unbound variable: gss" though.
<jmd>Well I *think* it is possible to configure the nix-daemon with (say) 20 builders running on different machines.
<sriharsha>zerwas, if we use ./pre-inst-env, should we modify the package files in the guix distribution?
<zerwas>sriharsha: No, the one in the guix source directory
<sriharsha>ok, that's what I though
<sriharsha>s/though/thought
<sriharsha>jmd, that's interesting..
<sriharsha>so, I am able to build guix-0.5 without the daemon on nixos with my new recipe
<sriharsha>and I installed it with: nix-env --install /nix/store/w5lpa1hwbpdw50ks526mm30pj6idjxcq-guix-0.5
<sriharsha>how do I make searchable with "nix-env -qa" ?
<sriharsha>at present `nix-env -qa guix` results only one result: guix-0.3
<zerwas>Yay, I successfully built gnurl.
<sriharsha>\\o/
<zerwas>sriharsha: here's the gnunet.scm: http://pastebin.com/raw.php?i=xXETAtgy
<sriharsha>thanks!
<sriharsha>gtg now; its been a wonderful day. Later!
<zerwas>Later :)
<civodul>davexunit: i'm using Guile-WM!
<civodul>so don't be surprised if i suddently disappear ;-)
<davexunit>civodul: cool!
<davexunit>I've had to suddenly disappear a few times because of bugs.
<civodul>heheh :-)
<davexunit>do you have the latest code from master?
<civodul>nope :-)
<davexunit>it will save you from one particularly nasty bug.
<civodul>the root window resize?
<davexunit>yeah
<civodul>i haven't manage to resize windows so far
<davexunit>tread lightly, we need you. :P
<civodul>:-)
<civodul>normally you click on the decoration to resize, right?
<civodul>also, how to you kill a window?
<davexunit>tinywm has really basic move/resize
<davexunit>alt + left mouse to move
<davexunit>alt + right mouse to resize
<davexunit>I don't know how to kill a window, I always just use the method to kill the given application
<davexunit>usually C-q for gnome applications.
<civodul>ooooh
<civodul>C-x k for emacs apps :-)
<civodul>resizing is a crazy concept
*civodul comes from Ratpoison
<civodul>ok
*civodul goes for dinner
<davexunit>civodul: tiling support isn't built yet. soon!
<davexunit>ttyl
<davexunit>and by soon I mean whenever mark witmer writes it. I sent him an email yesterday asking him to stop by here sometime.
<zerwas>So is a successful "make check" necessary? I ask this because gnurl fails make check
<civodul>davexunit: ah ah, good :-)
<civodul>zerwas: it's usually a good idea, yes
<zerwas>civodul: ok, I'll see if this can be fixed
<civodul>keep in mind that the build environment has no network access, and no resolv.conf
<civodul>so if there are test referring to "localhost", they'll fail
<mark_weaver>is there a good reason not to include /etc/hosts with a localhost entry in the chroot?
<civodul>for some reason emacs is at 100% CPU since i'm using Guile-WM
<civodul>that's getting annoying
<civodul>mark_weaver: not really
<civodul>that could be fixed, indeed
<mark_weaver>it might easier to do that than to fix tests
<civodul>well, more productive i'd say ;-)
<davexunit>civodul: strange, I don't have that issue with guile-wm.
<mark_weaver>then again, with 31 years of effort so far, we're doing quite well, I'd say :)
<civodul>it could be a coincidence, but that's weird
<civodul>mark_weaver: right, we can have a rest :-)
<civodul>davexunit: i actually had a leftover emacs process from a previous X session, and that's the one that was spinning
<davexunit>mystery solved. :)
<civodul>that PEBKAC isn't really a mystery ;-)
<civodul>this thing seems to work fine!
<civodul>it's a bit distracting
<civodul>i need to refocus, somehow
<davexunit>it's a really good start for a very extensible wm.
<civodul>yeah, really nice
<civodul>connecting Geiser to the WM, woo!
<davexunit>personally, I think that there needs to be an abstraction layer between xcb and the wm logic moving forward.
*mark_weaver really needs to switch to guile-wm.
<civodul>yeah, that would be ideal
<davexunit>for ease of future development and porting to wayland.
<davexunit>it's made it really hard for me to add features that I expected to be simple.
<civodul>and to GDS (the Guile Display Server)
<civodul>oh
<davexunit>wait, is that a thing?
<civodul>a joke
<civodul>but who knows ;-)
<davexunit>that might be a case of NIH :P
<civodul>:-)
<davexunit>but I think a basic abstraction over an xwindow would go a long way. I wanted to write some code that would resize a window to cover the left or right half of the screen but I had to deal with all sorts of X protocol stuff so I punted.
<civodul>(set-cursor! 'boat) ; <- incredible
<civodul>ah right, that's annoying
<davexunit>I want a regular cursor. I don't know how to use the ones that gnome uses.
<civodul>but writing the right abstraction may be non trivial
<davexunit>yes.
<davexunit>but I think simple stuff like (set-window-size! window width height) would be easy enough.
<civodul>possibly
<davexunit>there's a fullscreen module that does window resizing.
<civodul>fullscreen.scm is not completely unreasonable
<civodul>a bit too verbose, granted, but not as scary as i expected
<davexunit>yeah, I just want to decouple the logic to resize an X window from setting the size to the root windows size.
<civodul>ok
<davexunit>I just haven't had time to dig in further and get it done.
<civodul>'with-replies' & co. is pretty cool
<civodul>maybe similar to what you have in guile-2d?
<davexunit>I don't think I have anything like that.
<davexunit>are you referring to the coroutine stuff?
<civodul>yes
<davexunit>I guess with-replies blocks and waits for a response or something.
<civodul>you use delimited continuations right?
<davexunit>yes.
<civodul>no i think it aborts and the continuation is scheduled for execution when all the replies are received
<civodul>nice stuff
<davexunit>oh really neat.
<davexunit>how is the continuation scheduled?
*davexunit needs to read the source more.
<civodul>i haven't dig far enough
<civodul>it's part of guile-xcb