IRC channel logs

2013-11-21.log

back to list of logs

<mark_weaver> http://www.r6rs.org/implementations.html
<mark_weaver>I guess 6 was the number at some point in the past, when R6RS was declared a failure because of the "small" number.
<civodul>ok
<civodul>there's both Ikarus and Vicare
<civodul>they should list Racket in addition to PLT Scheme ;-)
<mark_weaver>heh, yeah.
<mark_weaver>still, most popular languages today don't have anywhere that many implementations.
<civodul>agreed
<civodul>and i can't imagine R7 doing better
<civodul>or maybe with small there could be a few new one-person implementations
<davexunit>I'm making packages for some SDL extension libraries.
<davexunit>I'm missing one dependency for SDL_mixer that will take some time to package. SDL_mixer compiles with ogg, flac, and mp3 support, but lacks MIDI.
<davexunit>could the package be merged in without MIDI support until fluidsynth is packaged?
<gzg`>davexunit: Good job! Just saw that you got SDL when I pulled latest.
<davexunit>gzg`: thanks
<zacts>hi
*gzg` plans on getting Slim done by the end of Saturday, fyi -- at the latest.
<gzg`>Started a new trivial job as a dishwasher and trying to get my schedule framed around that.
<mark_weaver>davexunit: fwiw, I think the package should go in without MIDI support for now.
<mark_weaver>it's better to have it there. maybe put in a FIXME comment about adding MIDI support later.
<davexunit>okay, same thing for SDL_image, it has jpg, png, tiff, etc. but it's missing support for a format I've never heard of called webp
<gzg`>mark_weaver: Seems just as applicable, just be sure to leave a note stating as such.
<gzg`>davexunit: *
<davexunit>that's what I'm doing.
<gzg`>davexunit: Cool! I'm very excited to soon have guile-2d so easily available! :^)
<davexunit>packaged for guix before any other distribution. :P
<zacts>guile-2d looks way cool
<davexunit>I don't even know how to begin packaging for debian.
<davexunit>I should learn sometime.
<davexunit>zacts: thanks! it needs a lot of work, but it is cool in theory, at least. :)
<gzg`>Now I just need to get guile-scsh going and most of my major bases I need/want to cover, will all be in Guile (when Guilemacs hits trunk!)
<zacts>oh cool
<zacts>I remember scheme48 scsh
<zacts>how is guile-scsh different?
<zacts>(lots of new and interesting guile scheme projects in the brew that are new to me)
<davexunit>okay, patch for sdl-gfx, sdl-image, sdl-mixer, sdl-net, and sdl-ttf sent to the list.
<zacts>hello
<civodul>Hello Guix!
<zacts>hello civodul!
<zacts>I hope to contribute next week
<civodul>hey zacts
<civodul>good!
<gzg`>civodul: FYI, I'm hoping to have Slim done and the mailing list by the end of Saturday. A lot of stress, between school and a new dishwasher job , keeping me busy. 3 days off though...! :^P
<civodul>heh, ok
<zacts>oh, and if I make major contributions do I need to do fsf copyright assignment?
<zacts>and if so, how many times do I have to do that?
<mark_weaver>no copyright assignment needed for guix
<mark_weaver>guile requires copyright assignment, just once
<mark_weaver>(just once if you assign past and future contributions to guile, as is usually done)
<zacts>oh cool
<jmd>Most projects which require assignments allow the "just once" option.
<jmd>When it is anything other than "just once" that is normally at the request of the assigner.
<gzg`>Openal builds, working on Irrlicht.
<gzg`>civodul: o/
<gzg`>Irrlicht doesn't seem to have a static binary... :^/
<civodul>hey!
<civodul>Irrlicht?
<gzg`>civodul: 3d Game engine, which Minetest uses.
<civodul>oh, ok
<gzg`>civodul: I still need to figure out how to move slim.conf out of /etc/slim.conf and in it's appropriate spot -- but after that, it seems ready to patch upstream.
<civodul>what's the problem exactly with /etc/slim.conf?
<civodul>that "make install" tries to create it?
<civodul>or just that the binary embeds that file name?
<gzg`>civodul: I haven't checked into it yet, but I'd assume the latter -- because wouldn't guix probably spot the former?
<gzg`>The error in the log is to the extent of ''CMake Error at cmake_install.cmake:72 (FILE): file INSTALL cannot copy file "/tmp/nix-build-slim-1.3.3.drv-0/slim-1.3.3/slim.conf" to "/etc/slim.conf". ''
<gzg`>But that still seems pretty vague, to me at least.
<civodul>well it tries to write to /etc/slim.conf, which it cannot do
<civodul>so either there's a CMake flag similar to --sysconfdir, or that has to be patched
<civodul>another benefit of the functional approach: http://thread.gmane.org/gmane.comp.lib.glibc.user/2051 :-)
<gzg`>civodul: It appears there is not such a flag, from a quick search.
<civodul>ok, so 'substitute*' then
<gzg`>Okay, that can't be right ... ''(substitute* ("/etc/slim.conf" "slim.conf"))''.
<civodul>first you have to find which file needs to be modified
<civodul>so you can grep -r /etc/slim.conf in the source
<civodul>then you do: (substitute* the-file (("/etc/slim\\\\.conf" line) (string-append (assoc-ref %outputs "out") line)))
<gzg`>$ grep -r /etc/slim.conf README:/usr/etc/slim.conf is the main configuration file. slim.1:Global configuration is stored in the /etc/slim.conf file. See the comments
<civodul>gzg`: Nixpkgs just replaces "/etc" by "$out/etc" in CMakeLists.txt
<civodul>likewise for /lib
<civodul>(Nixpkgs is the cheat sheet ;-))
<civodul> https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/display-managers/slim/default.nix
<viric>people looking at nixpkgs to learn how to package things.
<viric>the world upside down :)
<gzg`>Now to remember how to use "phases". :^P
<civodul>viric: i look at it when in need of a kludge ;-)
<gzg`>Stuck here ... '(#:phases (alist-cons-before 'configure 'set-etc-and-lib-location (lambda _ (
<gzg`>Probably should've waited another day until I was rested...
<civodul>good start!
<civodul>the body should be like: (substitute* "CMakeLists.txt" (("/etc") (string-append (assoc-ref %outputs "out") "/etc")))
<gzg`> http://paste.lisp.org/display/140059
<gzg`>So close ... :^I
<viric>irrlicht? I sell supertuxkart
<viric>smell
<gzg`>viric: Also on my list.
<civodul>gzg`: there's an extra level of parenthesis: ((substitute* ... should be (substitute* ...
<gzg`> civodul: Yah, builds! I'm going to grab some dinner then try to remember how to upload a patch.
<gzg`>civodul: Like always, thanks for the help. :^)
<civodul>you're welcome :-)
<civodul>see HACKING for how to submit the patch
<civodul>and enjoy your meal ;-)