IRC channel logs

2013-09-23.log

back to list of logs

<youlysses>civodul: Okay, cool then I guess I'll try building something in a sec then. :^)
<civodul>ArneBab_: as long as i can apply it with 'git am', that's fine
<ArneBab_>civodul: I don’t know what git am does, but if it is like patch -p1 < patch.diff, then that should work.
<youlysses>Is top-level home directory fine to have gnu/ in, or should it be in a certian direct I'm missing?
<civodul>ArneBab_: 'git format-patch' patches include meta-data such as the author and a commit log
<civodul>youlysses: normally when you type 'make install' the modules get installed in a nice place
<civodul>while developing, you can leave them in the source tree, and use the ./pre-inst-env wrapper to test things
<civodul>there's detailed info in the 'HACKING' file
<youlysses>What's xorg-util-macros? Besides that -- I think I have all of Slim packaged? I need it for libXmu.
<civodul>libxmu is already packaged
<civodul>so did you manage to build Slim?
<youlysses>civodul: It's not listed in my avaliable-package list? Also no, not-yet.
<civodul>"guix package -A xmu" shows libxmu; isn't it the case for you?
<youlysses>civodul: Weird; yeah it does. Why wouldn't it show up in 'guix package --list-available' and a search through the same material do the same? :^P
<civodul>-A is --list-available, so it should show up :-)
<civodul>but note that the name is lower-case, and perhaps you were expecting "libXmu"
<ArneBab_>civodul: same for hg export. I don’t know whether they are completely compatible, though.
<youlysses>Ah, yeah maybe that's the case.
<civodul>ArneBab_: i don't want to know, i just want the patch ;-)
<youlysses>Okay, so it's "done" then -- I don't think I'm doing something right though in building. Right now I'm calling 'guix build freeglut"... in my ~/gnu/to-package/ directory. Here's the package thus-far: http://paste.lisp.org/+2ZC3
<civodul>youlysses: for the 'inputs' field, you used a quote instead of a backquote
<civodul>that is, it should be: `(("mesa" ,xorg))
<youlysses>Okay, corrected -- I'll be sure to make a not with the other packages.
<civodul>ok
<civodul>i'm going to bed, but again feel free to ask here or on the ml for help
<civodul>we're in different time zones it seems ;-_)
<youlysses>civodul: Yup, midwest US here. :^)
<civodul>heh
<civodul>good night/day!
<docmalloc_>hi ... I am trying to compile the latest git version of guix (again) and it fails with:
<docmalloc_>[apply-smob/1 #<boot-closure 8173e0 (_ _ _)> #t ...]
<docmalloc_> ?: 7 [apply-smob/1 #<catch-closure 8de4a0>]
<docmalloc_> ?: 6 [primitive-eval ((@ # %) (begin # # #))]
<docmalloc_>In /usr/bin/guild:
<docmalloc_> 59: 5 [main ("/usr/bin/guild" "compile" "-L" ...)]
<docmalloc_>In unknown file:
<docmalloc_> ?: 4 [apply-smob/1 #<boot-closure 949520 (_)> (scripts compile) #:ensure #f]
<docmalloc_> ?: 3 [primitive-load-path "scripts/compile" #f]
<docmalloc_>In scripts/compile.scm:
<docmalloc_> 31: 2 [#<procedure e8e200 ()>]
<docmalloc_>In unknown file:
<docmalloc_> ?: 1 [apply-smob/1 #<boot-closure 92d480 (_)> (scripts compile) ...]
<docmalloc_> ?: 0 [scm-error misc-error #f ...]
<docmalloc_>any idea?
<Steap>what version of Guile do you use ?
<docmalloc_>standard ubuntu 13.04 : guile (GNU Guile) 2.0.7
<Steap>Could you send a bug report ?
<docmalloc_>of course
<Steap>I think most of the Guix developers are at work (including myself) so we probably won't be able to take a look at this before about 10 hours :)
<docmalloc_>no worries ... i am at work too ... so I can continue with a different task :-D
<docmalloc_>do you need any additional information?
<Steap>you could attach config.log
<docmalloc_>aah ok ... tia!
<civodul>hey
<Steap>hey
<civodul>packages
<civodul>we need more of 'em!
<Steap>huhu
<Steap>After packaging gobject-introspection, I tried to make it work with Python 3
<Steap>which kept me away from Guix
<civodul>heh
<civodul>you could push it to core-updates BTW
<Steap>I think it might be a pain in the ass
<Steap>because core-updates was created before Andreas made changes to the Python stuff
<Steap>so if I push it, when we merge, it will use the default Python, ie Python3, instead of Python2 (as in core-updates)
<Steap>so it will break
<Steap>that's why I'd rather wait for you to merge core-updates
<Steap>and then push gobject-introspection before we release 0.4
<civodul>i merged master in core-updates yesterday
<Steap>oh
<Steap>Well, I'll have to test that
<Steap>Not sure I'll have time tonight though, gotta buy myself a new laptop and run :)
<civodul>heh :-)
<Steap>The guys at LDLC are quite nice, but they just can't tell you what Wifi card they're selling you, so you can't know whether you'll need a non-free firmware, should you become crazy and use a wireless network
<davexunit>I just purchased a freedom-friendly wireless chip from thinkpenguin. :)
<Steap>davexunit: is it a USB one ?
<civodul>davexunit: the FSF-approved one?
<davexunit>Steap: not the usb one.
<davexunit> https://www.thinkpenguin.com/gnu-linux/penguin-wireless-n-half-height-mini-pcie-card
<davexunit>this one %
<davexunit>s/%/^/
<davexunit>I had to flash a hacked BIOS to my new thinkpad so that it would work.
<jxself>Ah, to get around that wonderful anti-feature?
<davexunit>yup.
<Steap>uh ?
<Steap>You can't change your Wifi card without flashing your BIOS ?
<davexunit>Steap: thinkpads have DRM in the BIOS that only allows wireless chips that are in a whitelist.
<davexunit>it's really disappointing that it exists at all.
<jxself>Proprietary software in action.
<Steap>davexunit: why would Lenovo do that ?
<davexunit>I really really like my X220, otherwise.
<jxself>I've read that it's not exclusive to Lenovo, which is unfortunate.
<davexunit>I've heard that as well.
<davexunit>my old laptop fortunately came with an atheros chip that worked without issue.
<Steap>I do hope my Clevo won't have that kind of crap built-in
<davexunit>I got lucky with that since I wasn't really aware of free software when I bought it.
<Steap>5 years ago, I was happy to have a free driver, now I want a free firmware as well
<Steap>What will it be in 5 years ?
<jxself>Will computers that run free software even exist?
<davexunit>it's not looking great.