IRC channel logs

2013-09-03.log

back to list of logs

<civodul>oh oh!
***ae is now known as Guest80403
<Steap>Guest80403: you should definitely register a nick on Freenode :)
<civodul>hello Guest80403 :-)
<civodul>you're incognito
<Guest80403>Being the only one without a registered nick, I actually become cognito.
<civodul>heheh :-)
<civodul>anyway, you're welcome, Guest80403
<Guest80403>I am lost in the python build system in build-system/python.scm.
<Steap>Tell us more.
*civodul wouldn't like to get lost there
<Guest80403>There is a parameter #:python-version that is apparently not used.
<Guest80403>And a function default-python that looks for a package named python, as far as I understand it.
<civodul>#:python-version is not not-used, if i may
<civodul>it's passed to python-build-system.scm, which uses it
<Guest80403>Now I just implemented the wrapper package python-wrapper, that creates a link python->python3.
<civodul>great
<Guest80403>So we will need a way to state in a package that we want python2 (package python) or python3 (package python-wrapper).
<Guest80403>Should this be done via #:python-version?
<Guest80403>Or should we simply add an explicit input ,python or ,python-wrapper to each package?
<civodul>#:python-version is really a hack, just to build up the search path in python-build-system.scm
<civodul>to specify which python is to be used, there's #:python
<civodul>so the Python package shouldn't be an explicit input
<Guest80403>Could the path not be obtained via PYTHONPATH?
<civodul>the search path?
<Guest80403>The one with python2.7 and lib or modules or something like this.
<civodul>problem is: in 'wrap' (python-build-system.scm), we want to augment the search path, which is why we need to know #:python-version
<civodul>otherwise #:python-version wouldn't need to exist
<Guest80403>I think #:python-version should not be passed explicitly, and also not be taken from default-python, but from #:python.
<Guest80403>The input to wrap could then be #:python instead of #:python-version, and the three character version could be constructed there.
<Guest80403>Thus so far, I could include into my package definition a line (arguments `(#:python ,python-wrapper))?
<civodul>i agree that #:python-version should be extracted (somehow) from #:python
<civodul>but the #:python argument should not be needed usually
<civodul>just like #:guile is never used (except for bootstrap)
<civodul>so, 'default-python' could be changed to return 'python-wrapper'
<civodul>and then, it should be easy to write a procedure that takes a python package and return MAJOR.MINOR
<civodul>that MAJOR.MINOR can then be used as #:python-version
<Guest80403>Well, if #:python is not given, it contains the result of default-python, right?
<Guest80403>So we can extract the version from the actual value of #:python.
<Guest80403>Yes, I also concluded that default-python should return python-wrapper.
<civodul>yes, exactly
<Guest80403>But then for packages requiring python-2, we would need to write a line with "#:python ,python-2". So this is really symmetric, just the default changes from one to the other.
<civodul>yes
<civodul>and for those that support both, we can have a 'package-with-explicit-python' procedure
<civodul>(similar to 'package-with-explicit-inputs')
<civodul>which would allow packages to be 'adapated' to specifically one or the other Python
<Guest80403>Time to stop for today, before it becomes tomorrow. Good night!
<civodul>night!
<Steap>Debugging gobject-introspection test suite
<Steap>Now, that's gonna be nice
<civodul>heh
<civodul>ok, g'night/day!