IRC channel logs

2023-12-19.log

back to list of logs

<rekado>I’m resuming work on our Guixified platform for launching RStudio, and I noticed that the Guix parts have become extremely slow
<rekado>I have a list of packages, and I want to turn them into a derivation.
<rekado>that part takes several minutes
<rekado>“guix processes” shows me that the lock on “guix repl -t machine” is held by texlive-*.lock files
<rekado>there are lots of texlive-* packages in a collection so a new child process is spawned for each of these packages. Watching “guix processes” shows that each query is rather slow, but the sheer number of queries makes it unusable.
<rekado>this is the innocent-looking code I use to compute the derivation: https://elephly.net/paste/1703002595.scm.html
<rekado>is this an ill-informed choice of code?
<rekado>I wonder if that’s a regression in the inferior code…?
<rekado>huh, it downloads substitutes instead of returning the derivation
<rekado> https://elephly.net/paste/1703003150.manifest.html
<rekado>this is the code I evaluate with “guix repl -t machine < snippet.scm”
<rekado>and instead of returning the derivation it fetches all substitutes.