IRC channel logs

2023-10-12.log

back to list of logs

<rekado>“INFO: Build completed successfully, 2113 total actions”
<rekado>I’ll add this to guix-science tomorrow.
<efraim>:cheer:
<rekado> https://github.com/guix-science/guix-science/commit/0c7a35b86acdfb77b0d2c8bffd1b8dd8cf951fc3?diff=unified
<rekado>hmm, looks like the binary is corrupted
<rekado>will disable stripping and try again
<rekado>works
<rekado>I’m now trying to build jaxlib witih bazel from within Guix
<rekado>it’s problematic because jaxlib needs xla, which needs llvm, etc
<rekado>we end up manually rebuilding the DAG that Bazel’s BUILD and workspace files describe.
<rekado>there’s no general way to override locations either
<rekado>on can override “repositories” but these must contain Bazel-specific files
<rekado>so it’s not just a matter of pointing it at the source code; you actually need to copy the source and add these files
<civodul>so it needs a copy of the source of LLVM etc. in its own source tree?
<civodul>just gave a 15mn talk for the Software Sustainability group at the Netherlands eScience Center (RSEs)
<civodul>the talk came right after a talk/demo of Nix by a local
<civodul>(nice)
<civodul>twas a bit frustrating because i was the only one not physically present and didn’t get much feedback from the audience
<rekado>oh, good!
<rekado>after all these years I still find remote talks difficult
<civodul>yeah
<rekado>not having a connection to the audience is like being blindfolded
<rekado>(but on the other hand I’m very travel averse, so it’s a price I’m often willing to pay to avoid travel arrangements)
<civodul>the Nix talk went as far as showing NixOS VMs
<civodul>“just type ‘nix build .#fdsErdfsdf.dfds.lineNoise.vm’”
<civodul>the result is impressive of course, but i suspect the command is intimidating
<civodul>someone asked me which has the steepest learning curve
<civodul>to which i replied that we do our best to make Guix approachable, but that i’m biased :-)
<efraim>I don't believe building bazel honors parallel-job-count
<rekado>efraim: yeah, probably not
<rekado>civodul: I always found the nix command line to be very inaccessible
<rekado>once I understood that the nix files describe functions a lightbulb went on, but it fizzled out right away because it seems like too much of an implementation detail to warrant making it a first class user interface.
<civodul>yeah, my feeling
<civodul>that’s why we have first-class packages :-)
<civodul>rekado: we need a Cuirass upgrade to unbreak GitHub actions (among other uses), right?
<rekado>yes
<civodul>ok, i’ll do that today then
<rekado>thank you!
<efraim>/gnu/store/ckjxycb7fkq5v4ncwryg3y3k1fx4a948-bazel-6.3.2/bin/bazel: ELF 64-bit LSB executable, ARM aarch64, version 1 (GNU/Linux), dynamically linked, interpreter /gnu/store/a19xbynxc3sg25xpkwmx7g0mdl7g31hx-glibc-2.35/lib/ld-linux-aarch64.so.1, for GNU/Linux 2.6.32, not stripped took ~85 minutes
<civodul>wo0t!
<civodul>rekado: did you add web hooks for guix-science?
<civodul>to trigger guix.bordeaux.inria.fr
<civodul>apparently yes
<civodul>Cuirass on guix.bordeaux got stuck yesterday evening while fetching some repo
<civodul>something that never times out
<civodul>libgit2 doesn’t let you specify that it seems
<civodul> https://guix.bordeaux.inria.fr/eval/7102656?status=pending
<rekado>civodul: I did not add the hooks. Maybe PurpleSym did?
<civodul>yes, probably
<rekado>about Bazel again: nix generates a big tarball of all vendored dependencies according to the Bazel workspace: https://github.com/NixOS/nixpkgs/blob/master/pkgs/build-support/build-bazel-package/default.nix#L111
<rekado>I never understood how this works. They define derivations that have access to the internet and compute a hash of whatever results from that.
<rekado>I suppose they record the hash somewhere, so this is some kind of two-step process?
<rekado>is our computed-origin-method comparable to this?
<rekado>except that computed-origin-method cannot access the internet?