IRC channel logs

2023-07-12.log

back to list of logs

<rekado>PurpleSym: I just found that my fix exhibits the same problems on the cluster installation as npm does.
<rekado>maybe because of the use of stat
<PurpleSym>So, it does not build?
<PurpleSym>(reliably)
<rekado>builds fine on my laptop, but even with the patched npm it does not build on the cluster
<rekado>where the number of hardlinks is much greater
<rekado>I’m investigating
<rekado>I want to figure out if it’s already borked at the union-build step or only after
<rekado>already at the union-build step
<rekado>on the cluster I simply don’t get all the files
<rekado>I think it’s just a matter of not picking the right node package after all
<rekado>curiously, in a “guix time-machine” command “-L ~/foo” is ignored, so it doesn’t pick up my patched node variant
<rekado>phew
<rekado>at least it’s nothing new :)
<PurpleSym>Looking at js-panmirror, I’m not as shocked as I expected yesterday 😅
<PurpleSym>Can you say which problem --main-fields and --conditions solve? the .js/.cjs issue?
<rekado>they don’t solve those; we still get both files imported
<rekado>adding module to main-fields enables more tree shaking
<rekado>(it may not be necessary)
<rekado>I added the module condition to avoid the dual package hazard: “Another way of avoiding a dual package hazard is to use the bundler-specific module condition to direct bundlers to always load the ESM version of your package while letting node always fall back to the CommonJS version of your package”
<rekado>from https://esbuild.github.io/api/#how-conditions-work
<PurpleSym>Alright, let’s add a comment.
<PurpleSym>When all of this works in the end, we should be knighted.
<rekado>:)
<flypaper-ultimat>Knight in the order of entangling-a-mess?
<flypaper-ultimat>*untangling
<rekado>it’s two sides of the same order
<flypaper-ultimat>they give you the same badge, but the side you wear is flipped? ;)
<rekado>there are again differences between building node-prosemirror-dev-tools with the patched node and the unpatched. This time it’s the patched build that has missing files…
<rekado>the file appears in the wrong location
<rekado>ACTION patches npm and build it yet again
<PurpleSym>We don’t have a toml parser in Guix somewhere, do we…?
<rekado>in Guile? As part of Guix?
<rekado>doesn’t seem so. We only ever pick individual sub-strings from the toml files.
<PurpleSym>“In Guix” = somewhere in guix/build. But apparently it’s regular expressions only. Ohwell, new side quest.
<rekado>woo, finally built the new js-panmirror with a different patch to npm
<rekado>(patched node-tar instead of pacote)