IRC channel logs

2023-07-11.log

back to list of logs

<PurpleSym>rekado: I doubt createKey will be our last issue. Let’s just disable the visual editor. We have collectively wasted enough hours on it and it’s not that important.
<rekado>well, the visual editor is working
<rekado>(it’s just that hitting enter on the first line isn’t)
<rekado>it’s useful for people who want to quickly check if their markdown document looks all right
<PurpleSym>😕
<PurpleSym>Not convinced shipping a backtracing component is a good idea.
<rekado>:)
<rekado>you said you saw that you were “counting 10 inclusions of prosemirror-model” — where did you see that?
<rekado>I’d like to try one last time to fix this properly
<PurpleSym>grep '//' /gnu/store/7np4i7wqbsi9xxbj9b9mxzmk3qaa3wyx-rstudio-server-2023.06.0+421/www/js/panmirror/panmirror.js | sed -nre 's#.(/node_modules/.)#\1#gp' | sort | uniq -c
<PurpleSym>npm install would have to build a directory of all transitive dependencies.
<rekado>what I see in my version of panmirror.js is no repetitive inclusions; each file is mentioned only once
<PurpleSym>Okay, that’s a start. So the remaining issue is “Can not convert <> to a Fragment”?
<rekado>ah, sorry I’m too dense
<rekado>it doesn’t hoist dependencies, of course
<rekado>gotta flatten that node_modules tree
<rekado>(FWIW, the above sed command doesn’t work for me. Doesn’t act on the capture group.)
<PurpleSym>Uh, maybe the Matrix->IRC gateway broke it? Here it is with proper quotes: `grep '//' panmirror.js | sed -nre 's#.*(/node_modules/.*)#\1#gp' | sort | uniq -c`
<rekado>ah, missing asterisks
<rekado>deduped the node_modules and now there are no duplicate imports
<rekado>the file is also much smaller
<rekado>I still needed to patch createKey, though
<rekado>it’s no longer printing a backtrace; “Can not convert <> to a Fragment” is gone.
<rekado>I’ll clean this up a bit and push it to your branch
<PurpleSym>Hm, strange regarding createKey. Is its state still duplicated?
<rekado>yes
<rekado>ah, I think it’s harmless
<rekado>it’s because both // node_modules/prosemirror-state/dist/index.js and // node_modules/prosemirror-state/dist/index.cjs are imported
<rekado>I guess I could kick out one of them
<rekado>PurpleSym: pushed
<rekado>if you’re okay with this abomination, please squash and merge
<PurpleSym>I’ll take a look tomorrow.
<rekado>thank you!
<rekado>pushed a few R package updates: https://ci.guix.gnu.org/jobset/r-updates