IRC channel logs

2022-12-31.log

back to list of logs

<rekado>PurpleSym1: there’s a weird test failure in tests/crate.scm, and a few in tests/import-utils.scm that are complaining about the changed list of keyword arguments. Will address those in a new commit.
<rekado>and I’ll take care of this car/cadr vs values thing
<rekado>I use srfi-71 for that
<rekado>the crate error is due to the fact that version restrictions are now broken in the recursive importer
<PurpleSym1>Urgh, sorry. Should’ve checked ☹️
<rekado>no worries!
<rekado>same problem with the gem tests, which is good
<rekado>wouldn’t want to debug this purely based on the rust importer :)
<PurpleSym1>Didn’t know about SRFI-71. Looks like object unpacking in other languages.
<rekado>I think the problem is in recursive-import passing on “rest”, but not “version”.
<rekado>srfi-71 is really quite refreshing compared to let*-values or receive or call-with-values.
<PurpleSym1>From my understanding rest should contain every keyword argument.
<PurpleSym1>Even those “consumed” explicitly.
<rekado>right, the problem was that lookup-node was called with a version argument that didn’t get passed down. Instead the #:version from “rest” was passed.
<rekado>so inside lookup-node I’m cutting that one out and replace it with lookup-node’s version value.
<PurpleSym1>Oh, I see 🤦‍♂️
<PurpleSym1>Thanks for looking into that!
<rekado>I think commit a274a6a1acb99738f02de7b226e6a0d3883ec353 broke a bunch of things
<rekado>it also broke some tests
<rekado>I’m a little annoyed by these kind of wide-reaching changes.
<rekado>what good are these changes when they break all updaters?
<PurpleSym1>Hm, but it looks like it passed the review: https://issues.guix.gnu.org/57460
<rekado>ah, bleh
<rekado>didn’t find it when searching issues.
<rekado>ACTION sends a follow-up email
<PurpleSym1>I searched for author:hartmut, because I’d seen the issue, but couldn’t find it either.
<PurpleSym1>That being said, having something like “Closes: #12345” in the commit message to cross-reference the discussion would help.
<zimoun>hi!
<efraim>o/
<drakonis> https://blog.thalheim.io/2022/12/31/nix-ld-a-clean-solution-for-issues-with-pre-compiled-executables-on-nixos/
<drakonis>real neat
<drakonis> https://github.com/Mic92/nix-ld and https://github.com/Mic92/envfs
<nckx>Blursed.
<drakonis>it works quite nicely
<drakonis>have tried and i find it to work too well
<drakonis>so much that it solved the biggest issues with nixos for newcomers
<drakonis>also makes it easier to actually deal with things that do not mesh well with getting patched
<nckx>‘Things’ ☺
<nckx>That's all valid, it's just an alien world to me.
<drakonis>its very likely to reduce nix friction
<nckx>Something you might now: someone asked earlier if it's possible to guix-install.sh on NixOS. I don't know. E.g., I'd expect their /etc/systemd not to be writable, but maybe it is?
<nckx>s/writable/persistent/ — worse.