IRC channel logs

2022-09-28.log

back to list of logs

<rekado>it’s a good idea
<zimoun>hi!
<efraim>hello!
<PurpleSym>rekado: What do your scripts do right now?
<rekado>PurpleSym: they fetch the names of all CRAN packages, diff them with whatever R packages we already have, and then import a number of the missing packages recursively.
<rekado>hey, we (BIMSB bioinfo platform) are looking for Schemers who would like to get paid to do a few odd jobs for our platform.
<rekado>we use the shepherd as a container manager, so we’d like to pay someone to implement cgroups support and things like container migration via cgroups freeze.
<rekado>if you know someone who would like to do this (and who can issue an invoice so that we can pay them through the proper channels) please contact me
<PurpleSym>rekado: That’s exactly what I would have written. Can you share the scripts?
<rekado>PurpleSym: this is my CRAN script: https://elephly.net/paste/1664358867.scm.html
<rekado>I think it needs changing to “display” instead of “pretty-print”
<PurpleSym>Thanks!
<rekado>running a test import of 1000 missing packages
<rekado>to improve our descriptions it would be helpful if we could use wordnet. Overkill in an importer?
<PurpleSym>How would wordnet help?
<drakonis>rekado: i would learn more scheme to get paid for that
<drakonis>really though
<drakonis>what i wanted to ask about is getting a kanren implementation merged into guile
<rekado>PurpleSym: just to tell us what is likely a noun at the beginning of a sentence, or what sentences are likely fragments.
<rekado>we could also go all out and write guile-nlp first :)
<rekado>drakonis: one key thing I forgot to mention: applications would need to have some way of doing business in Germany, i.e. need a tax id and a website with an impress.
<drakonis>hmm, i'd have to set that up first
<drakonis>among other things that would detract from my current job
<drakonis>so yeah, i suppose not.
<rekado>:(
<rekado>I wonder if we could set up some sort of shell company for this purpose
<drakonis>though i want to get out of my current job and do something that makes me much happier
<drakonis>this is probably not a thing to be saying in a logged channel
<rekado>:)
<rekado>PurpleSym: my first test of the bulk importer points to a number of minor problems
<PurpleSym>rekado: I guess “using wordnet” is pretty much the same as “implementing guile-nlp”?
<rekado>unknown license strings (we need to split them at “|”), a handful of packages which depend on bioconductor things, and more worrying duplicate imports
<PurpleSym>I’m working on writing packages into module files that actually build and run right now.
<PurpleSym>(i.e. getting all the imports right)
<rekado>the “--style=specification” option can help with that
<PurpleSym>Hm, yeah, that could avoid all the s-expression matching.
<PurpleSym>I imagine that’s pretty expensive in terms of performance though.
<rekado>PurpleSym: elephly.net/downies/cran2.scm
<rekado>*https://
<rekado>this contains some garbage that I know cannot be added to Guix; an example is r-xlsxjars
<rekado>looking at the descriptions and synopses I should be able to add some more checks to beautify-description
<rekado>already improved the string->license code
<rekado>I manually threw out r-diagrammer and r-visnetwork, and everything that depends on them because of bundled minified JavaScript
<zimoun>rekado: about shell company, the “issue” that I know (maybe because I am French) is that many things are country-wide. I mean, if the company is based in say Germany and the employee is based in say France, the tax-dance is not straightforward… so the shell cannot be totoally empty. :-)
<zimoun>And the example is simple because the both country use the same currency.
<zimoun>Maybe a “bounty” thing backed by an already existing fiscal structure could help.
<zimoun>rekado: about wordnet, well maybe it could help to test first using well-known Python packages.
<zimoun>And if it is worth the effort, then implement something.
<zimoun>For instance, Julia is doing interesting things with their compiler to implement automatic differentiation and so on
<rekado>yes, the shell company thing falls apart quickly :-/
<rekado>the problem is that the MDC can only deal in terms of invoices and sales tax ids.
<rekado>bleh, so now I have these thousands of R packages… they’ll go stale.
<rekado>guess I’ll have to add them to Guix proper now.
<zimoun> Oh, neat!
<zimoun>Is it not easier to test these using a channel?
<rekado>I’m only half serious
<rekado>but I did spend some time on a few of the packages, so I prefer to just contribute them directly
<rekado>what do you think of finally changing the CRAN importer to return “license:”-prefixed license values?
<zimoun>I am often annoyed, so yeah it is a nice. :-)