IRC channel logs

2025-05-02.log

back to list of logs

<old>how about freeze
<ArneBab>ekaitz: I now wrote the section on nginx as a first step: https://www.draketo.de/software/bsi-grundschutz#CON.8.A5 — the section on caddy is already written, too, but not yet exported: https://hg.sr.ht/~arnebab/draketo/browse/software/bsi-grundschutz.org?rev=352d9f0fb26a#L213
<lechner>old / frozen-guile?
<lechner>actually, freeze is good, too. more of an action word
<lechner>besides, frozen is a strange movie, i think
<old>I would love a command: `guild freeze'
<old>applied on a path, it will bundle every modules into a executable
<mwette>old: that's a great idea
<lechner>old / yeah!
<lechner>Hi, are kernel constants like PTRACE_PEEKUSER available anywhere in Guile already?
<trannus_aran>Anyone got any tips on how to write a Makefile.am for a guile project? I know *a bit* of autotools for C projects, but sussing out the lowest common denominator from spritely, guix itself, and other projects is...tricky, to say the least O.o
<daviid>trannus_aran: as I already did suggest, copy the one from chickadee Or any projects you're looking at, learn from it and adapt for your project
<trannus_aran>Yeah, that's been the plan here, just curious if anyone had a write up, since they all differ quite a bit!
<daviid>the chickadee one is an excellent model to follow
<trannus_aran>Thx!
<trannus_aran>I'm just trying to trim out as much as possible from that project to end up at a kernel of an autotoolized, guix-packaged guile project
<old>lechner: nope and good luck with ptrace and the FFI lol
<old>I have lots of experience with ptrace if you have question tho
<old>Here be dragons (sys/user.h): https://paste.sr.ht/~old/7f20ef1777a03f8193b7e770566a4b12db0216b2
<sham1>Is there an up-to-date mirror of Guile's git repo? Because Savannah is under siege and half the time it doesn't respond with anything but a 502
<ArneBab>old: such a freeze command would be pretty neat.
<ArneBab>trannus_aran: I tried to build an autotools setup without Guix support in conf: https://hg.sr.ht/~arnebab/conf/browse/templates/guile/Makefile.am?rev=tip using https://hg.sr.ht/~arnebab/conf/browse/templates/guile/guile.am?rev=tip
<ArneBab>and a bit more in https://hg.sr.ht/~arnebab/conf/browse/templates/guile
<ArneBab>that’s a template which also takes a generic tail that’s used for all languages: https://hg.sr.ht/~arnebab/conf/browse/templates/lang--generic/Makefile.am.tail?rev=tip
<sham1>Ooh, Mercurial
<ArneBab>sham1: whenever I can take the choice, Mercurial is my choice.
<cow_2001>i wanna mechanise converting srfi html reference documents into skribilo, so i am writing this. got advice? https://codeberg.org/kakafarm-guix-stuff/guile-srfi-html-to-skribilo
<lechner>old / thanks! i'll be sure to take you up on your offer in due time
<n|Phreak>If I want to connect to a repl in my code I use (system repl server) right ?, then do I need to (make-tcp-server-socket #:localhost #:port=1234) ?
<n|Phreak>and then (run-server) ?
<trannus_aran>okay halfway through writing this, I think I have some improvements I could make
<trannus_aran>woah, what's with the triplicate messages? O.o
<trannus_aran>oh, client issue, nvm
<trannus_aran>anyway
<trannus_aran> https://gist.github.com/Pinjontall94/f87efa8731690b9b715556ddc5b0b430
<trannus_aran>WIP to deal with the autoconf stuff
<trannus_aran>(and honestly I'm gonna rewrite for sconfig/generate to just take a single nested alist that can exist in a version-controlled file alongside the others)
<trannus_aran>even if not executable, it's handy for me to keep this stuff in a single file so I can keep the autotools and guix package incantations straight in my head ;/
<daviid>trannus_aran: autotool chain files are generated by guile-hall, so you'd rather use that and contribute 'there' if you have improvment(s) to propose, my 2c
<trannus_aran>daviid: oh yeah, that's the plan! this is more like "notes for myself before I contribute to guile-hall"
<trannus_aran>big fan of "make something existing better" over "roll your own"
<daviid>though very unfortunately, guile-hall was recently made 'hard depending' on guix, which is not good - no one should have to install guix to use guile-hall, imo
<trannus_aran>Yeah, and that's kinda my issue with guix and the guile ecosystem as a whole imo
<trannus_aran>Guix is very cool, I use it preferentially myself, but trying to develop guile programs on platforms guix doesn't play nice with (basically any immutable distro, macos, etc.) is increasingly painful