IRC channel logs

2025-04-29.log

back to list of logs

<lechner>Hi, how may I turn off the "source file is newer than warnings" please. I already have --no-auto-compile
<lechner>Hi, is there a way to quote the sexpr that's in a variable without going through strings?
<lechner>I'd like to immunize it to a trip through eval
<ArneBab>lechner: maybe you could have a look at enter-three-witches for the shell helper: https://hg.sr.ht/~arnebab/dryads-sun/browse/enter.scm
<ArneBab>lechner: see https://lists.gnu.org/archive/html/guile-devel/2024-01/msg00007.html
<ArneBab>lechner: (similar to that)
<ArneBab>lechner: or rather this: https://lists.gnu.org/archive/html/guile-devel/2024-10/msg00023.html
<ArneBab>lechner: guile -I
<ArneBab>^ for the warnings
<lechner>ArneBab / thanks for mwette's patch to avoid the warnings. what are the prospects of it being merged, please?
<lechner>ArneBab / thanks for the three witches, too. that's a bit above my experience level I'm afraid
<rlb>I suspect we have a bug in srfi-64 -- my reading of the srfi-64 docs for test-runner-test-name suggests this should print "name: outer group" at the end, but it's still showing the test-assert name: https://paste.debian.net/hidden/9dfbff9f/
<rlb>"suggest"
<ArneBab>lechner: mwette’s patch is already merged ☺
<ArneBab>lechner: what enter-three-witches does is to quasiquote each of its lines. That way in reverses the role of content and variables:
<ArneBab>(define-syntax Speak (lambda (x) (with-ellipsis ::: (syntax-case x () ((_ (((name :::))) ((mod :::)) (word :::) line :::) #`(begin (say-name (quasiquote (name ::: mod :::))) ... ))))))
<ArneBab>say-lines is likely much too complex for the use-case, though: it processes words one-by-one while they are being read, so if they trigger side-effects (like speeding up or slowing down text) that happens only when it is displayed.
<wingo>ACTION resurfaces
<wingo>so, hi!
<sneek>Welcome back wingo, you have 1 message!
<sneek>wingo, old says: what's missing in this list https://wingolog.org/archives/2016/02/04/guile-compiler-tasks
<wingo>i have been in a gc hole
<wingo>finally coming back to guile, starting to see if whippet + guile is a winner or not
<wingo>work is on wip-whippet branch
<wingo>note, it is a major version bump, if you are playing around with it, you will probably want a separate checkout to avoid issues when switching back and forth between it and 3.0
<wingo>does anyone have a srfi-14 implementation in minimal scheme?
<optimal>wingo what do you mean by minimal scheme
<wingo>i mean something that doesn't use too many modules, that is minimal enough to use in guile's bootstrap
<optimal>the reference implementation is very minimal, but it's MIT licensed
<wingo>tx
<optimal>the only module it uses i think is srfi-9 records and even that is just to wrap strings in a disjoint type, you can just cut it out with some substitution regex through the code easily
<optimal>wingo if you give me around 20 minutes i can hack on the reference implementation to make it only rely on guile's core and remove the implementation abstractions
<wingo>well, the reference implementation probably isn't right for guile atm, because it uses mutable strings
<wingo>and it's ascii-only, etc.. anyway, is a good inspiration
<optimal>ah, okay then
<rlb>wingo: how do you think whippet relates to the utf8 branch, i.e. if it works out would I likely move the branch there, or might it obviate that work, or...?
<lechner>ArneBab / thanks!
<lechner>Hi, is there a programmatic way to turn (a b c) into `(,a ,b ,c) ?
<lechner>i guess i'm looking for the string, and there is no way to write a quasiquote without going through strings
<humm>lechner: Why strings? You can transform a list (a b c) to a list (quasiquote ((unquote a) (unquote b) (unquote c))).