IRC channel logs

2025-04-28.log

back to list of logs

<sneek>wb dsmith
<ArneBab>meaty: Guile also supports #! ... !# comments which are pretty useful to have a custom hashbang while still being plain Scheme.
<ArneBab>meaty: https://www.gnu.org/software/guile/manual/html_node/Block-Comments.html
<ArneBab>meaty: ah, sorry, no that isn’t the same thing. Those are block comments, not s-expression comments.
<dsmith>sneek, botsnack
<sneek>:)
<lechner>Hi, why does 'setsid' raise a non-continuable exception, please? How may I catch EPERM?
<lechner>Hi, what's a quasiquote, philosophically speaking? What if the entire language were quasiquoted like some REPLs? Would we still need 'values'?
<ieure>What REPLs quasiquote everything?
<ieure>And are you speaking of 'values' in the sense of Multiple Values? https://www.gnu.org/software/guile/manual/html_node/Multiple-Values.html
<ieure>Or in the plain sense, meaning data?
<lechner>well, i'm not sure i'm ready for a counter-question, but both the guile and the guix REPLs use unquote to access a meta-level of instructions. Yet, it doesn't have to be that way: If more things were quasiquoted, an eval is a comma away surrounded by data. i'm just wondering if that's an alternative universe---metaphorically speaking
<ieure>Are you talking about the REPL meta-commands like ,use?
<lechner>yes, but perhaps more generally
<ieure>REPL metacommands ape the syntax of quasiquoting, but the mechanism is different.
<ieure>Honestly not sure I understand your question.
<ieure>Lisp code is also a Lisp value, quasiquoting (meaning `(foo bar ,(+1 3)) etc) puts some values in other values.
<ieure>If you have no values, you have no programming language.
<lechner>ieure / okay, thanks! I guess what I was getting to, and what the Guile REPL just told me: "unquote: expression not valid outside of quasiquote" so it would be an alternative universe, except it doesn't exist.
<ieure>What did you eval to get that error?
<ieure> I guess it would have had to be something like: (+ 1 ,foo)
<lechner>yes, i wrote a shell integration helper for Guile programs so I'm exploring the boundary between strings and sexps
<lechner>quasiquote is the star
<ieure>lechner, Have you ever implemented a toy Lisp before?
<lechner>i have seen the five equations, if that's what you mean
<sham1>Quasiquote is just a way to create data structures that are made of *mostly* literal data, but with some more complex computation added in
<sham1>Not sure there's much more than that philosophically speaking