IRC channel logs

2025-04-24.log

back to list of logs

<lisbeths>how can I get wisp like python indentation in scheme
<lisbeths>I have to install this: https://www.gnu.org/software/guile/manual/html_node/SRFI_002d119.html
<lisbeths>I found the GitHub for it https://github.com/scheme-requests-for-implementation/srfi-119
<lisbeths>I tried this guile --language=wisp -x fastpyll.w which is from this guide https://www.gnu.org/software/guile/manual/guile.html#SRFI_002d119 but guile says no such language wisp
<old>lisbeths: Wisp is new in 3.0.10 (the next version of Guile)
<old>what distro are you on?
<old>any idea why the profiler is pointing at ice-9/popen.scm:183:0:reap-pipes
<old>Nobody is calling open-pipe in the program. I use spawn
<civodul>old: it’s called at every GC, due to its guardian IIRC
<civodul>which isn’t pretty
<old>right. But it seems that the profielr thinks this is the bottleneck
<old>but it's actually another hook
<old>I use fibers, and it seems that the real bottleneck after GC is blue/fibers/events.scm:165:2:pump-epoll-guardian
<old>(I've removed the reap-pipes hook)
<old>and I get the exact same usage but now in fibers hook
<civodul>old: interesting; i’m not sure how reliable this is
<civodul>i mean, it mostly shows that your program is creating garbage
<old>civodul: right. The next most hot procedure is bytevector->pointer. I've ported fibers to pure Guile so I can embedded it in a pure Guile project. I wonder if this is a symptom of generating garbage in the FFI
<old>anyway, does not seem like it's a bottleneck afterall
<civodul>old: Fibers to pure Guile? woow
<civodul>the FFI is often a source of garbage
<civodul>could be improved
<civodul>oh, Guile is failing in CI: https://ci.guix.gnu.org/build/10163970/log
<civodul>ports.test: keyword arguments for file openers
<old>civodul: I guess it's less performant and not compatible with Guile 2
<old>But I only want a async scheduler for calling external tasks for my build system
<old>so I don't really care
<civodul>ok
<civodul>interesting
<civodul>rlb: does the build failure above ring a bell? ↑
<ieure>Still wondering about #78004, anyone have an explanation of what's going on with that? Am I doing something wrong?
<old>ieure: what are you refering to?
<ieure>old, A bug I filed.
<ieure> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=78004
<rlb>sneek: later tell civodul, looks like there's also an rdelim.test failure a bit further down, and don't remember anything offhand.
<sneek>Got it.