IRC channel logs

2025-04-19.log

back to list of logs

<lechner>Hi, is there a libraries that offer wrappers for 'malloc' and 'free' as well as perhaps some convenience routines?
<old>lechner: no but feel free to use this (not tested): https://paste.sr.ht/~old/fb6e10968e6cf4ef15dd0b27dd97a4117bff2a84
<old>you might want to do some bookeeping to track the pointer and avoid leaking
<lechner>old / thanks!
<lechner>old / thanks for teaching me about ~:p !
<AwesomeAdam54321>Hi
<AwesomeAdam54321>Does anyone know how to use guile-irc? I wanted to try out the simple examples before studying a bot like sneek
<AwesomeAdam54321>Oh, I figured out what went wrong
<AwesomeAdam54321>Just do ',hi bot'
<McParen>write your own bot from scratch
<McParen>it is easier than you might think and a nice learning exercize
<old>who needs bot when we have sneek
<old>sneek: botsnack
<sneek>:)
<dsmith>sneek, botsnack
<sneek>:)
<dsmith>!uptime
<sneek>I've been faithfully serving for 3 months
<sneek>This system has been up 13 weeks, 49 minutes
<dsmith>sneek, sneek?
<sneek>sneek is a good bot
<old>sneek: what is guile?
<sneek>From what I understand, Guile is the language Guix is implemented in.
<old>sneek: what is Guix?
<sneek>Last time I checked guix is a functional package management tool for the GNU system
<old>sneek: What is GNU?
<sneek>Someone once said GNU is not Unix
<old>sneek: What is Unix?
<old>sneek: help
<trannus_aran>old: A cut down Multics, probably not a big deal
<trannus_aran>so like
<trannus_aran>when making a new guile project, how do you all handle the autotools files? I'm trying to chop down the files in the guix repo source as an example, but I'm not sure how to handle adding dependencies and such
<daviid>trannus_aran: guile-hall will create them for you, fwiw, otherwise copy the tree from a well dev projects, like chickadee (for example)
<trannus_aran>daviid: and just sorta sus out the differences between them w/r/t how guile lib dependencies are handled?
<daviid>trannus_aran: if the guile lib yu depend upon is well autotool chained, and has a foo.pc file, you can use PKG_CHECK_MODULES, i.e. PKG_CHECK_MODULES(G_GOLF, g-golf-1.0 >= 0.8.0) otherwise use the GUILE_MODULE_AVAILABLE macro (provided by guile.m4) - https://git.savannah.gnu.org/cgit/guile.git/tree/meta/guile.m4