IRC channel logs

2025-04-18.log

back to list of logs

<lechner>old / for what it's worth, I use leuven light.
<mwette>I'm not a fan of many decorations or long names. I'm pretty lazy when it comes to hammering out code. I also like to stick to lines < 80 chars. I work on a lot of code that has seemingly arbitrary line lengths: drives me nuts. Thank god for emacs M-Q working on comments.
<lechner>Hi, how may I make Emacs's xref-find-definitions for Guile?
<lechner>work for
<lechner>Hi, is there a hacky way to make a parameter available everywhere, along the likes of guile-extensions-path?
<lechner>Hi, how may I tell Emacs to ignore a scheme-indent-function formatting rule in the export list?
<old>lechner: re: xref-find-definitions Never made it work. I think it's legacy stuff. But maybe somebody know how to use it
<old>lechner: re: parameter everywhere, you can define your parameter in the `(guile)' module in your init file and it should be available everywhere I think
<old>something along like this: https://paste.sr.ht/~old/d3416a44a7a3980af0da5669c1a69076ca178c8d
<old>if you put this in your .guile in your home, you will have my-parameter available I think everywhere, but only if your init file is getting loaded
<old>actually it will work if you do that at the top of a script before using modules. But you will get warnings when compiling
<old>lechner: re: for scheme-indent-function, I guess you have a `define-something' in export that get badly indent? or something similar? I don't have an answer for that but maybe other have
<lechner>old / thank you for all those helpful replies!
<lechner>Hi, does print-exception behave differently sometimes? In one program it seems to print all parts of compound exceptions. In another, it prints only the constituent error exception
<lechner>In both cases, I made the compound exception with (make-exception (make-exception-with-message message) caught-eception)
<old>is it me, or instrument instructions like `instrument-entry' does a none atomic increment on shared counters?
<old>vm-engine.c:380 data->counter += SCM_JIT_COUNTER_ENTRY_INCREMENT;
<old>is the counter for JIT a VM local counter or is it a counter associated with a bytecode?
<old>if it can be incremented by many threads, it's wrong and must use at least volatile access to prevent weird things
<lechner>mwette / Hi, should cdata-set! be able to assign one boxed pointer type to another? I think I have to send the boxed "value" through cdata-ref in order to avoid <&compound-exception components: (#<&error> #<&origin origin: #f> #<&message message: "~A ~S"> #<&irritants irritants: ("cdata-set!: bad arg:" #<cdata pointer 0x7fb1268ee860>)> #<&exception-with-kind-and-args kind: misc-error args: (#f "~A ~S" ("cdata-set!: bad arg:"
<lechner>#<cdata pointer 0x7fb1268ee860>) #f)>)>
<mwette>lechner: check out ccast
<lechner>mwette / thanks, but don't the types in the last line match? The doc says that an assignment would follow (presumably without cdata-ref or ccast) https://bpa.st/H5WA
<lechner>also, CDATA can do some things C cannot, like my use of cdata* in response-array. or am i using it wrong?
<lechner>i love cdata, by the way!
<lechner>Hi, how may I use exception-accessor which calls procedures on single instances in the tail position, to assemble a list of those instances, please? That's probably a common Scheme trick
<ayys>Hi, I wrote this small guile library to generate url-safe slugs from a string. It is inspired and closely compatible with Django's slugify function. Can someone please review it? I am very new to Lisp programming, so it probably doesn't follow all the standard practices.
<ayys> https://github.com/ayys/slugify.scm/
<ayys>I write to write tests for it in the test-slugify.scm file, not sure if that is the standard place to put tests.
<lechner>ayys / looks good to me (but i'm a noobie)
<ayys>lechner, thanks!
<mwette> lechner: there is a lot there; I'd need to look at the source of pam_messages; maybe I can get back to it later when I have some time
<lechner>mwette / please don't worry about it. it works as is. should i file an issue on Savannah so can you look at it when you return working on Nyacc?
<lechner>return to
<mwette>lechner: That would be great.
<lechner>Hi, will an uncaught exception terminate an application that uses libguile from C?
<lechner>where is that code?
<old>exception can not cross the C world I think?
<old>I'm not sure/
<old>I don't use Guile in C
<lechner>Well, catching it in Guile and returning to Rust breaks Greetd!
<old>does calling anything from Rust outside of Rust itself is not considered unsafe and thus breaking Rust ?
<lechner>then Greetd shouldn't be using PAM
<lechner>it could just be my printing to (current-error-handler) when I catch the exception. i see "endpoint not connected"
<lechner>or maybe that's making your point
<old>I was making a joke about rust
<lechner>okay, i kind of got that
<lechner>because they are so very safe
<lechner>actually, my error was elsewhere
<lechner>my apologies