IRC channel logs

2025-04-02.log

back to list of logs

<apteryx>do we have something builtin to compute the cartesian product of two sets?
<apteryx>it would probably have been in srfi-1, but there's nothing cartesian product for sets defined there
<apteryx>the brute force way is: (append-map (lambda (p) (map (lambda (a) (cons a p)) addresses)) ports)
<old>ya the trivial implementation would be: (define (X A B) (append-map (lambda (a) (map (lambda (b) (cons a b)) B)) A))
<old>I don't see how you could make it better. cartesian product is a O(n * m) operation
<old>how do you make paredit understand reader extensions like #vu8 ?
<cpli>i would like to include a <style> tag with css in cpli.dev/www, but can't because sxml->xml transforms #\" into its xml-entity: &quot;.. is there anything i could do to mitigate that?
<cpli>source https://git.sr.ht/~cpli/www/tree/dev/item/www/index.scm read at your own sanity's risk
<humm>cpli: Is that a problem? May characters in <style/> not be corresponding entities?