IRC channel logs

2025-03-30.log

back to list of logs

<old>lilyp: I've tried lazy identifier. They only work for global variables I think
<old>Assume the following simple promise: (define (add-later x y) (delay (+ x y))
<old>Now you have: (define todo (add-later (add-later 1 2) (add-later 3 4))
<old>What I want, is that I just do: (pk todo) and get: ;; 10
<old>Instead I have to add tons of: (if (promise? x) (force x) x) everywhere
<lilyp>old: look at guix – transparent promise unpacking everywhere ;)
<janneke>sneek: later tell spk121: i know that the patchset that we worked on (1) produces the same .go objects for all 64bit platforms, 64bit mingw and gnu/linux-like 64bit alike; is that also the case for patchset (2)?
<sneek>Okay.
<janneke>sneek: botsnack!
<sneek>:)
<old>lilyp: you have an example?
<old>I can see that Guix seems to implementer getter for its structure and will force the promises
<lilyp>yes, those getters behave like any other getter, except they also force
<lilyp>I think you could use let-syntax if you wanted to bind identifiers locally