IRC channel logs

2025-03-22.log

back to list of logs

<euouae>Hello suppose I want to distribute a Guile program (not a library).
<euouae>What are some of the options? I'm thinking of installing a shell script that invokes guile on the installed .scm -- but I'm not sure if that's the right approach? Should I be invoking guile on the .go instead?
<euouae>Or should I use the #! tricks on top of the .scm file and install /that/ directly into /usr/bin (or wherever)
<euouae>I got gnome to log me out by blowing up the stack in guile somehow
<euouae>anyway, if anyone had an answer to my question I'd appreciate it
<euouae>I put my full question here, <https://lists.gnu.org/archive/html/guile-user/2025-03/msg00024.html> if anyone can help
<ArneBab_>euouae: I use the #!tricks with -e '(module)' ⇒ calls main, but for the installed program I strip the actual implementation, because that is installed in the regular site dir.
<euouae>ArneBab_: I don't quite follow what you said
<euouae>What do you mean by "strip" the implementation?
<euouae>If I have an app/myapp.scm, I probably want to compile it as myapp.go and then invoke it from some installed shell script in /usr/local/bin/myapp. I think that's what I want to do.
<euouae>I think the #! trick is bad because I don't quite follow how guile's .go cache works with stuff under /usr/local/bin.
<ArneBab_>I only leave the shell script part, leaving out the scheme
<euouae>ArneBab_: did my response come through? last message "Assuming I don't want..."
<sneek>Yey! dsmith is back!!
<dsmith>sneek, botsnack
<sneek>:)
<ArneBab_>sneek: later tell euouae: I did not see your response.
<sneek>Will do.
<ArneBab_>sneek: botsnack
<sneek>:)
<spk121>Is the make check of the test-suite/tests supposed to halt at the first FAIL? It didn't used to work that way.
<rlb>spk121: hmm, for a bit in main it now uses the non-deprecated automake test harness, so likely whatever that does, if I did it right. But here, changing a numbers.test test to fail e.g. an (exact? 0) to (not (exact? 0)) doesn't halt the tests immediately with "make -j5 check".
<rlb>On the plus side, it supports a lot more concurrency now (i.e. higher j levels can speed things up more).
<spk121>rlb: ok. Thanks for checking