IRC channel logs

2025-03-17.log

back to list of logs

<old>ArneBab: awesome!
<euouae>Hello, I'm trying to write a C++/guile project. How can I document the C++ side to produce texinfo "docstrings" for its functions
<lloda>euouae: Use scm_set_procedure_property_x after scm_c_define_gsubr
<lloda> https://www.gnu.org/software/guile/manual/html_node/Procedure-Properties.html#index-scm_005fset_005fprocedure_005fproperty_005fx
<jean0t>hello
<jean0t>hi
<jean0t>howdy
<jean0t>hallo
<jean0t>Hei
<jean0t>konnichiha
<jean0t>(write "hello people")
<jean0t>hello
<jean0t>guile doesnt have readline
<jean0t>in my implementatio
<jean0t>(use-modules (ice-9 readline)) returns nothing
<old>do you have guile-readline installed?
<jean0t>yes
<jean0t>apparently the readline was renamed to rdelim
<jean0t>no, no change
<jean0t>rdelim and readline both dont work
<jean0t>Ive installed all the devel libs avaiable in fedora
<jean0t>for guile
<rlb>I assume you're activating it?
<rlb> https://www.gnu.org/software/guile/manual/html_node/Loading-Readline-Support.html
<jean0t>i cant activate it
<jean0t>I tried using in the .guile and it didnt allow me to enter the repl due to error
<rlb>What error?
<jean0t>then i removed, entered the repl and tried to load ice-9 readline module
<jean0t>Backtrace:
<jean0t>In ice-9/boot-9.scm:
<jean0t> 1755:12 12 (with-exception-handler _ _ #:unwind? _ # _)
<jean0t>In unknown file:
<jean0t> 11 (apply-smob/0 #<thunk 7fcbc9810300>)
<jean0t>In ice-9/boot-9.scm:
<jean0t> 724:2 10 (call-with-prompt ("prompt") #<procedure 7fcbc6dad5e0 …> …)
<jean0t>In ice-9/eval.scm:
<jean0t> 619:8 9 (_ #(#(#<directory (guile-user) 7fcbc9813c80>)))
<jean0t>In unknown file:
<jean0t> 8 (primitive-load "/home/jean0t/.guile")
<jean0t>In ice-9/eval.scm:
<jean0t> 721:20 7 (primitive-eval (use-modules (ice-9 readline)))
<jean0t>In ice-9/psyntax.scm:
<jean0t> 1243:36 6 (expand-top-sequence (#<syntax:.guile:1:0 (use-module…>) …)
<jean0t> 1235:19 5 (parse _ (("placeholder" placeholder)) ((top) #(# # …)) …)
<jean0t> 259:10 4 (parse _ (("placeholder" placeholder)) (()) _ c&e (eval) …)
<jean0t>In ice-9/boot-9.scm:
<jean0t> 3955:20 3 (process-use-modules _)
<jean0t> 222:17 2 (map1 (((ice-9 readline))))
<jean0t> 3956:31 1 (_ ((ice-9 readline)))
<jean0t> 3352:6 0 (resolve-interface (ice-9 readline) #:select _ #:hide _ …)
<jean0t>ice-9/boot-9.scm:3352:6: In procedure resolve-interface:
<jean0t>no code for module (ice-9 readline)
<jean0t>and then:
<jean0t>(use-modules (ice-9 readline))
<jean0t>While compiling expression:
<jean0t>no code for module (ice-9 readline)
<jean0t>ok my bad
<jean0t>I solved it
<rlb>That sounds like you might not have it available in the %load-path, i.e. do you get the same thing for (use-modules (x y))?
<rlb>Oh, good.
<jean0t>I could use the rdelim
<jean0t>and other modules
<jean0t>but it was missing even after isntalling
<jean0t>then... I tried to install guile directly from guix
<jean0t>it showed me the commands to set the environment variables
<jean0t>I did and it worked just fine
<old>fedora is really not the best distro for Guile unfortunatelly
<rlb>Am I misreading? I'd think this is just a potential error rather than buffer overflow https://debbugs.gnu.org/bug=76907 -- though still a bug.
<rlb>i.e. in the call we pass in the result length, so getsockopt() *ought* to return an error code if it's too small.
<rlb>But I agree that we ought to have a timeval in the union since at least on linux, it looks like SIOCGSTAMP can be a timeval.