IRC channel logs

2025-03-14.log

back to list of logs

<old>is there a way to tell the compiler to not optimize too much a certain expression in a file
<lloda>i guess you can compile it explicitly and call the compiled procedure?
<old>lloda: I ended up using #:declarative #f to avoid the optimization I wanted from the compiler (inlining of local bindings)
<old>I'm actually surprise that #:declarative? #f suppress of inlining of binding that are not exported by the module
<old>I was expecting it to only work for exported bindings
<cow_2001>confusion will be my epitaph https://codeberg.org/kakafarm/random-files-and-notes/src/branch/master/2025-03-14-undefined-constant/example-03.scm
<cow_2001>i was trying to write down a most minimal example that yields an "undefined constant" error, but this one came up and i was very confused
<cow_2001>maybe i should write all these in a single org file
<cow_2001>literate programming style, except it only shows my scheme / guile illiteracy
<dsmith>illiterate programming?
<old>cow_2001: rare reference to King Crimson in the wild
<old>I suppose. Maybe the quote is from other text
<dsmith>old, Greg Lake specifically, I guess. (I remember it from ELP)
<old>yes it was sing by Greg Lake
<old>are procedure properties with #(()) only usable with defined and not lambda?