IRC channel logs

2025-03-11.log

back to list of logs

<dsmith>lechner, So your pam module has some kind of failure when called from a Guile script. What are the condidions where it works? From a C progam?
<dsmith>I'm wondering about how libguile is being initialzied.
<dsmith>ERROR: Wrong type to apply: "quote"
<dsmith>Does that mean "quote" as a string? As in ("quote" ...) ?
<dsmith>scheme@(guile-user)> ("quote" 123)
<dsmith>ice-9/boot-9.scm:1676:22: In procedure raise-exception:
<dsmith>Wrong type to apply: "quote"
<dsmith>lechner, ^^
<lechner>dsmith / it works from C (mingetty) and Rust (greetd) although the latter produces an "madvise: failed" message
<lechner>dsmith / i think that's unfortunately transitory
<lechner>dsmith / here is another https://bpa.st/MM5A
<lechner>it's a real stress test, i think. it goes from Guile->dlopen->libpam->dlopen->custom C module->libguile->Guile->dlopen->ELF modules
<lechner>i am pretty confident, however, that the error occurs in the lower Guile level
<lechner>the "quote" part was transitory
<dsmith>So something that really help be get to the bottom of a arm jit issue some years ago was disabling "address space randomization" or *something* like that,
<dsmith>Unil I disabled that, every run was different.
<dsmith>Can't remember the exact thing right now..
<rlb>dsmith: (just guessing) looks like it could be setarch -R?
<rlb>ACTION has never tried that
<dsmith>rlb, Thanks! That does look suspiciously like what I'm remembering.
<dsmith>lechner, Try running your program with that and see if you can get more consistent results
<dsmith>Looks like you can also set it inside gdb for the prog you are debugging.
<dsmith>set disable-randomizaiton {on,off}
<mwette>janus: Did you put a `(use-modules (srfi srfi-9))' in the file before the `(lalr-parser' part? (I don't use (system base lalr) fwiw.)
<dsmith>lechner, How are you init-ing libguile in the pam stuff?
<lechner>dsmith / yes, here https://codeberg.org/lechner/guile-pam/src/commit/3fa3bb3abff2ff57e12afb1fd5dbe54a1245529a/lib/c/pam_guile.c#L266
<lechner>dsmith / was your advice to disable address space layout randomization in the kernel?
<lechner>there is a Texinfo manual https://juix.org/guile-pam/
<dsmith>Just in the failing Guile process.
<lechner>thanks!
<lechner>a single C module replaces all others in the libpam stack but calls all others as needed via a Guile implementation of the stack. modules can also be written in Guile
<old>I have a hook on module-defined-hook. However, the module I get has unbound variables for its public interface
<old>any idea how I can get a hook when a module is loaded and its variables are bound?
<dsmith>lechner, The scheme_with_guile sure seems right.
<dsmith>Hmm. I wonder if disabling the JIT improves things.
<dsmith>Or if something is stomping on some stack somewhere
<old>hmm I manage to fix my problem
<old>but now I have another
<old>I'm using traps to do coverage with a better granularity then add-next-hook!
<old>however, it seems that if I try to instrument a procedure in a file that was loaded with `load-from-path' I only get instruction pointer from ice-9 eval
<jean0t>hi
<jean0t>I want to be a contributor to the project
<jean0t>what do I need to do outside of registering in the mail list
<jean0t>to be honest I am not familiar with shceme, but Ive been studying common lisp recently
<jean0t>hello penguing
<jean0t>u guys are alive?
<dsmith>Response times are usually measured in days...
<dsmith>lechner, And remember, absolutely NEVER let a SCM become all-bits-zero. Your life will become very unhappy..
<vbramselaar>Is there any alternative to using autotools for a Guile project?
<vbramselaar>Apart from that, I would love to use Guile as embedded language in a game with SDL2/C++ etc. But I'm just too scared of Windows compat :(
<vbramselaar>I did see that MSYS2 has it now, so that is interesting.
<mwette>vbramselaar: do you know about https://dthompson.us/projects/guile-sdl2.html
<old>vbramselaar: there is on going effort to make a build-system in Guile. However, I'm not sure who we will make it work on Windows
<vbramselaar>mwette: I know about guile-sdl2, the issue mainly is Windows (I know GNU dislikes Windows, rightfully so of course).
<vbramselaar>old: there is? Is there a project already?
<dthompson>vbramselaar: for guile it's moreso that very few developers actually use windows, so the windows build is lacking
<old>vbramselaar: I've started working on that with two other peoples yes. It's work in progress
<old>many ideas for it. like make it portable to distros where guile is not available
<dthompson>for those that care about guile and sdl stuff, sdl3 was recently released and I'm working on guile-sdl3.
<vbramselaar>dthompson: (windows part) Ah yes, that too.
<dthompson>not only is sdl3 way better than sdl2, guile-sdl3 is going to be better than guile-sdl2. :)
<vbramselaar>dthompson: ah cool I just wanted to ask about sdl3
<vbramselaar>dthompson: I'm hyped already :)
<dthompson>basically I need to write the manual and clean up a few things and then it will be good enough for a 0.1.0 release. the bindings will be far from complete but all the structure will be there to hopefully make it easy for others to fill in gaps.
<vbramselaar>old: that would be nice. I mean Autotools exists but I feel like a build system specifcally for the language is missing.
<dthompson>sometimes I think "I could write a build system" but that is pure hubris, ego at its most extreme
<old>I'm a the only one not being able to reach https://git.savannah.gnu.org/git/guile.git ?
<dthompson>not loading for me, either
<old>okay
<dthompson>savannah is in rough shape these days
<old>was it in any good shape at some point actually
<old>seems like a half-baked forge from the 2000s
<dthompson>I was trying to be generous but you are very correct
<old>other freesoftware forge like sourcehut and codeberg are way better in that respect
<dthompson>codeberg is great
<vbramselaar>why is savannah still used so much by GNU, but feels like that really updated?
<old>I'm mostly on sourcehut, but it seems like all the communities are moving toward codeberg
<vbramselaar>not really updated*
<old>might worth looking at it
<old>vbramselaar: ask stallman or the FSF idk
<vbramselaar>old: im interested with moving from Gitlab to either Sourcehut or Codeberg.
<vbramselaar>mainly sourcehut
<old>sourcehut works okay for now. at least for my use. But I'm still waiting for the beta version .. since 3 years
<vbramselaar>but I'm trying to figure out where to keep images (binary files) of my website instead of Git.
<vbramselaar>old: yhea I was following that news a bit and they had some setbacks it sounded like recently
<old>yeah. unfortunatelly, it seems that forges are poppular not only for hosting projects, but for DDOS
<old>and when you don't have the capital of M$, it can be difficult to invest protecting against DDOS
<old>I'm saying this, but Github actually has more downtime than sourcehut
<lechner>dsmith / thanks! what does it mean to stomp on the stack, please?
<lechner>Hi, what is the easiest way to read (and evaluate) all expressions on stdin, please?
<dsmith>lechner, overwriting. Think of those Japanese moves from the 60's where a guy in a lizard costume is smashing all the buildings
<lechner>okay, i didn't think that still happened to stacks in 2025
<df>oh, it does, it's just that godzilla has learned to be a bit more subtle (guy in a lizard constume, huh!)
<dsmith>Well, it *shouldn't*. But garbeled backtraces and weird values makes me suspcious.
<df>there is ongoing an arms race between ways to exploit it and ways to protect against the exploits which has now got extremely complex
<df>*an ongoing
<freakingpenguin>If I ever teach programming dress up as godzilla and smash the student's code, got it.
<df>freakingpenguin: I approve of this didactic approach
<lechner>Hi, what's a way to signal to 'read' on stdin that there is no more input, please? C-d does not work
<dsmith>lechner, When the read system call returns 0 bytes
<lechner>i'm not sure how to check for that here https://bpa.st/NWHQ
<old>lechner: check for eof
<old> https://paste.sr.ht/~old/23e474e782da88f83636915b5a028993426ec5a4
<lechner>old / thank you so much!
<rlb>sneek later tell civodul would it be plausible to mark the 00-repl-server.test inter-protocol test as unresolved for now or XFAIL?
<sneek>Got it.
<rlb>sneek later tell civodul built main 402e0dfa33f442ad238a0f82a332efa438538840 and ran make check on debian riscv64 (i.e. with the jit enabled), and there were no issues.
<sneek>Okay.
<cow_2001>these commits now make all tests pass. now i need to make the version that works on strings. https://codeberg.org/kakafarm/guile-bytevector-peg/compare/b5eb9~4..b5eb9